]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
- 4.2.1
[packages/zsh.git] / zsh.spec
index 4f243ef2cc655e48f93973fd521e11c34d0ad4ec..f66b42a4960933534133e166a16f10d92af2989a 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -12,23 +12,24 @@ Summary(ru):        
 Summary(tr):   Geliþmiþ bir BASH sürümü
 Summary(uk):   ëÏÍÁÎÄÎÉÊ ÐÒÏÃÅÓÏÒ (shell) ÓÈÏÖÉÊ ÎÁ ksh, ÁÌÅ Ú ÐÏËÒÁÝÅÎÎÑÍÉ
 Name:          zsh
-Version:       4.1.1
-Release:       8
+Version:       4.2.1
+Release:       1
 License:       BSD-like
 Group:         Applications/Shells
 URL:           http://www.zsh.org/
 Source0:       ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.bz2
-# Source0-md5: 48958b1a3fc86261a26eea40a4f7d4af
+# Source0-md5: b59ef34b8de288d5fd16f842451125c8
 Source1:       %{name}.1.pl
 Source2:       http://zsh.sunsite.dk/Guide/zshguide.pdf
 # Source2-md5: 0d80ba1ef39052c512cfabf368f3bf20
+Source3:       zprofile
+Source4:       zshrc
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-tinfo.patch
-Patch2:                %{name}-addons.patch
-Patch3:                %{name}-paths.patch
-Patch4:                %{name}-no_nis.patch
-Patch5:                %{name}-completions.patch
-Patch6:                %{name}-zle_misc.patch
+Patch1:                %{name}-addons.patch
+Patch2:                %{name}-paths.patch
+Patch3:                %{name}-completions.patch
+Patch4:                %{name}-nolibs.patch
+Patch5:                %{name}-broken_configure.patch
 BuildRequires: autoconf
 %{?with_static:BuildRequires:  glibc-static}
 BuildRequires: libcap-devel
@@ -38,11 +39,11 @@ BuildRequires:      pcre-devel
 BuildRequires: texinfo
 Requires(post,preun):  grep
 Requires(preun):       fileutils
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
-%define                specflags_ia32  "-fomit-frame-pointer"
+%define                specflags_ia32   -fomit-frame-pointer 
 
 %description
 zsh is an enhanced version of the Bourne shell with csh additions and
@@ -94,7 +95,8 @@ shell-
 Summary:       Files needed for advanced TAB-completion
 Summary(pl):   Pliki potrzebne dla zaawansowanej TAB-completion
 Group:         Applications/Shells
-Requires:      %{name} = %{version}
+Conflicts:     kdesdk-completions-zsh <= 3:3.2.3-2
+Requires:      %{name} = %{version}-%{release}
 
 %description completions
 This package contains files needed for advanced tab completion in zsh.
@@ -109,7 +111,7 @@ Summary(pl):        Zaawansowana pow
 Group:         Applications/Shells
 Requires(post,preun):  grep
 Requires(preun):       fileutils
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description static
 zsh is an enhanced version of the Bourne shell with csh additions and
@@ -123,7 +125,7 @@ skonsolidowana statycznie.
 %package guide
 Summary:       A User's Guide to the Z-Shell
 Summary(pl):   Podrêcznik U¿ytkownika Z-Shella
-Group:         Applications/Shells
+Group:         Documentation
 URL:           http://zsh.sunsite.dk/Guide/
 
 %description guide
@@ -140,13 +142,13 @@ Podr
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p0
 
 install %{SOURCE2} .
 
 %build
 cp -f /usr/share/automake/config.sub .
 %{__autoconf}
+CPPFLAGS="-I/usr/include/ncurses"
 
 %if %{with static}
 LDFLAGS="%{rpmldflags} -static"
@@ -160,7 +162,10 @@ LDFLAGS="%{rpmldflags}"
 %endif
 
 %configure \
-       --enable-maildir-support
+       ac_cv_have_dev_ptmx=yes \
+       --enable-maildir-support \
+       --enable-pcre \
+       --enable-cap
 %{__make}
 
 cd Doc
@@ -174,41 +179,12 @@ install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir},%{_bindir},%{_mandir}/pl/m
        DESTDIR=$RPM_BUILD_ROOT
 
 %{?with_static:install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}}
-install Doc/zsh.info*  $RPM_BUILD_ROOT%{_infodir}
-
-touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zlogin,zshenv}
-echo "setopt no_function_argzero" > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
-echo ". %{_sysconfdir}/profile" >> $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
-
-cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
-# System wide functions and aliases
-# Environment stuff goes in /etc/profile
-
-# Aliases:
-alias which=whence
-alias cd='builtin cd'
-alias precmd=' precmd'
-
-setopt histignorespace
-
-# Setup key bindings:
-bindkey -e >/dev/null 2>&1
-
-bindkey \`tput khome\` beginning-of-line >/dev/null 2>&1
-bindkey \`tput kend\` end-of-line >/dev/null 2>&1
-bindkey \`tput kich1\` quoted-insert >/dev/null 2>&1
-bindkey \`tput kdch1\` delete-char >/dev/null 2>&1
-bindkey \`tput kpp\` up-history >/dev/null 2>&1
-bindkey \`tput knp\` end-of-history >/dev/null 2>&1
-bindkey \`tput kcuu1\` history-beginning-search-backward >/dev/null 2>&1
-bindkey \`tput kcud1\` history-beginning-search-forward >/dev/null 2>&1
-
-case "$TERM" in
-       xterm*)
-               precmd () { print -Pn "\e]0;%n@%m: %~\a"i; }
-               ;;
-esac
-EOF
+install Doc/zsh.info* $RPM_BUILD_ROOT%{_infodir}
+
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogin,zlogout,zshenv}
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogin,zlogout,zprofile,zshenv,zshrc}.zwc
+install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
+install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
 
 rm -f Etc/Makefile*
 find Functions Util StartupFiles -name .distfiles -o -name .cvsignore | xargs rm -f
@@ -228,6 +204,9 @@ else
        grep -q '^%{_bindir}/zsh$' /etc/shells || echo "%{_bindir}/zsh" >> /etc/shells
 fi
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
+for i in zlogin zlogout zprofile zshenv zshrc; do
+       [ -f /etc/$i ] && zsh -c "zcompile /etc/$i"
+done
 
 %preun
 if [ "$1" = "0" ]; then
@@ -258,7 +237,8 @@ fi
 %defattr(644,root,root,755)
 %doc Etc/* README LICENCE ChangeLog META-FAQ Util StartupFiles
 %attr(755,root,root) %{_bindir}/zsh
-%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/*
+%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/*[!w]?
+%ghost %{_sysconfdir}/*.zwc
 %dir %{_libdir}/zsh
 %dir %{_libdir}/zsh/%{version}
 %dir %{_datadir}/zsh
This page took 0.760909 seconds and 4 git commands to generate.