]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
- zsh.static is now really static; rel 7
[packages/zsh.git] / zsh.spec
index 4a66bc2abd05afeb71d3966ab8ea147a91c908ed..b4f15f2e8fad61cf42054f730532208489696957 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -2,7 +2,7 @@
 # Conditional build:
 # _without_static      - without static version
 #
-Summary:       Enhanced bourne shell
+Summary:       Enhanced Bourne shell
 Summary(de):   Enhanced Bourne Shell
 Summary(es):   Shell bourne mejorada
 Summary(fr):   Bourne shell amélioré
@@ -13,7 +13,7 @@ Summary(tr):  Geli
 Summary(uk):   ëÏÍÁÎÄÎÉÊ ÐÒÏÃÅÓÏÒ (shell) ÓÈÏÖÉÊ ÎÁ ksh, ÁÌÅ Ú ÐÏËÒÁÝÅÎÎÑÍÉ
 Name:          zsh
 Version:       4.1.1
-Release:       3
+Release:       7
 License:       BSD-like
 Group:         Applications/Shells
 URL:           http://www.zsh.org/
@@ -36,8 +36,6 @@ BuildRequires:        ncurses-devel >= 5.1
 %{!?_without_static:BuildRequires:     ncurses-static}
 BuildRequires: pcre-devel
 BuildRequires: texinfo
-PreReq:                grep
-PreReq:                fileutils
 Requires(post,preun):  grep
 Requires(preun):       fileutils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -106,8 +104,8 @@ Ten pakiet zawiera pliki wymagane przez zsh dla zaawansowanej
 TAB-completion.
 
 %package static
-Summary:       Statically linked Enhanced bourne shell
-Summary(pl):   Zaawansowany bourne SHell - linkowany statycznie
+Summary:       Statically linked Enhanced Bourne shell
+Summary(pl):   Zaawansowana pow³oka Bourne'a - skonsolidowana statycznie
 Group:         Applications/Shells
 Requires(post,preun):  grep
 Requires(preun):       fileutils
@@ -119,8 +117,8 @@ most features of ksh, bash, and tcsh.
 
 %description static -l pl
 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
-wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
-linkowany.
+wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest wersja
+skonsolidowana statycznie.
 
 %package guide
 Summary:       A User's Guide to the Z-Shell
@@ -151,9 +149,12 @@ install %{SOURCE2} .
 
 %if %{!?_without_static:1}%{?_without_static:0}
 LDFLAGS="%{rpmldflags} -static"
-%configure
-%{__make}
+%configure \
+       --disable-dynamic
+%{__make} \
+       DLLDFLAGS=""
 mv -f Src/zsh Src/zsh.static
+%{__make} clean || :
 LDFLAGS="%{rpmldflags}"
 %endif
 
@@ -179,18 +180,33 @@ echo "setopt no_function_argzero" > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
 echo ". %{_sysconfdir}/profile" >> $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
 
 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
-PS1='[%%n@%%m %%~]%%(!.#.%%\\$) '
-bindkey -e >/dev/null 2>&1
+# System wide functions and aliases
+# Environment stuff goes in /etc/profile
+
+# Aliases:
 alias which=whence
+alias cd='builtin cd'
+alias precmd=' precmd'
+
+setopt histignorespace
+
+# Setup key bindings:
+bindkey -e >/dev/null 2>&1
 
-# xterm
 bindkey \`tput khome\` beginning-of-line >/dev/null 2>&1
 bindkey \`tput kend\` end-of-line >/dev/null 2>&1
+bindkey \`tput kich1\` quoted-insert >/dev/null 2>&1
 bindkey \`tput kdch1\` delete-char >/dev/null 2>&1
 bindkey \`tput kpp\` up-history >/dev/null 2>&1
 bindkey \`tput knp\` end-of-history >/dev/null 2>&1
 bindkey \`tput kcuu1\` history-beginning-search-backward >/dev/null 2>&1
 bindkey \`tput kcud1\` history-beginning-search-forward >/dev/null 2>&1
+
+case "$TERM" in
+       xterm*)
+               precmd () { print -Pn "\e]0;%n@%m: %~\a"i; }
+               ;;
+esac
 EOF
 
 rm -f Etc/Makefile*
This page took 0.113169 seconds and 4 git commands to generate.