]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
- *all* key binding and function is back to zshrc
[packages/zsh.git] / zsh.spec
index 47e69601e44cd38c7259985c6b5bff111f8904cf..8f36eec94496de75099bea617c0e464b69968605 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -13,7 +13,7 @@ Summary(tr):  Geli
 Summary(uk):   ëÏÍÁÎÄÎÉÊ ÐÒÏÃÅÓÏÒ (shell) ÓÈÏÖÉÊ ÎÁ ksh, ÁÌÅ Ú ÐÏËÒÁÝÅÎÎÑÍÉ
 Name:          zsh
 Version:       4.1.1
-Release:       3
+Release:       5
 License:       BSD-like
 Group:         Applications/Shells
 URL:           http://www.zsh.org/
@@ -177,11 +177,23 @@ echo "setopt no_function_argzero" > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
 echo ". %{_sysconfdir}/profile" >> $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
 
 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
-PS1='[%%n@%%m %%~]%%(!.#.%%\\$) '
-bindkey -e >/dev/null 2>&1
+# System wide functions and aliases
+# Environment stuff goes in /etc/profile
+
+# Aliases:
 alias which=whence
 
-# xterm
+# Setup key bindings:
+bindkey -e >/dev/null 2>&1
+bindkey "^[[1~" beginning-of-line >/dev/null 2>&1
+bindkey "^[[H" beginning-of-line >/dev/null 2>&1
+bindkey "^[[4~" end-of-line >/dev/null 2>&1
+bindkey "^[[F" end-of-line >/dev/null 2>&1
+bindkey "^[[3~" delete-char >/dev/null 2>&1
+bindkey "^[[5~" history-search-backward >/dev/null 2>&1
+bindkey "^[[6~" history-search-forward >/dev/null 2>&1
+
+# xterm:
 bindkey \`tput khome\` beginning-of-line >/dev/null 2>&1
 bindkey \`tput kend\` end-of-line >/dev/null 2>&1
 bindkey \`tput kdch1\` delete-char >/dev/null 2>&1
@@ -189,6 +201,18 @@ bindkey \`tput kpp\` up-history >/dev/null 2>&1
 bindkey \`tput knp\` end-of-history >/dev/null 2>&1
 bindkey \`tput kcuu1\` history-beginning-search-backward >/dev/null 2>&1
 bindkey \`tput kcud1\` history-beginning-search-forward >/dev/null 2>&1
+
+case "$TERM" in
+       aterm)
+               bindkey '^[[A' up-line-or-history >/dev/null 2>&1
+               bindkey '^[[B' down-line-or-history >/dev/null 2>&1
+               bindkey '^[[D' backward-char >/dev/null 2>&1
+               bindkey '^[[C' forward-char >/dev/null 2>&1
+               ;;
+       xterm*)
+               precmd () { print -Pn "\e]0;%n@%m: %~\a"i; }
+               ;;
+esac
 EOF
 
 rm -f Etc/Makefile*
This page took 0.056589 seconds and 4 git commands to generate.