]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
- release 3: adapterized and added using rpm new automation suit.
[packages/zsh.git] / zsh.spec
index 6053e8b180ce33a78ada1a2bdbcd371fb0183aee..59596274b6cadf9ef306f3fa3cd3fdd6a25b04df 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -1,83 +1,96 @@
-# $Revision: 1.5 $ $Date: 2000-03-28 16:55:29 $
+# $Revision: 1.20 $ $Date: 2000-10-02 23:10:51 $
 Summary:       Enhanced bourne shell
 Summary(de):   Enhanced Bourne Shell
 Summary(fr):   Bourne shell amélioré
 Summary(tr):   Geliþmiþ bir BASH sürümü
 Summary(pl):   Ulepszona pow³oka Bourne'a
 Name:          zsh
-Version:       3.1.6
+Version:       3.1.9
 Release:       3
-Copyright:     GPL
-Group:         Shells
-Group(pl):     Pow³oki
+License:       GPL
+Group:         Applications/Shells
+Group(de):     Applikationen/Shells
+Group(pl):     Aplikacje/Pow³oki
 Source0:       ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
-Patch0:                zsh-info.patch
-Patch1:                zsh-DESTDIR.patch
-Prereq:                /usr/sbin/fix-info-dir
+Patch0:                %{name}-info.patch
+Patch1:                %{name}-DESTDIR.patch
+Patch2:                %{name}-sys_capability.patch
+Patch3:                %{name}-cap_get_proc.patch
+Patch4:                %{name}-tinfo.patch
+Patch5:                %{name}-addons.patch
 Prereq:                grep
-Prereq:                gawk
-Prereq:                sed
-BuildRequires: ncurses-devel
+Prereq:                mawk
+BuildRequires: ncurses-devel >= 5.1
 BuildRequires: glibc-static
 BuildRequires: ncurses-static
-Buildroot:     /tmp/%{name}-%{version}-root
+BuildRequires: texinfo
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Obsoletes:     zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
 
 %define                _exec_prefix            /
 
 %description
-zsh is an enhanced version of the Bourne shell with csh additions and most
-features of ksh, bash, and tcsh.
+zsh is an enhanced version of the Bourne shell with csh additions and
+most features of ksh, bash, and tcsh.
 
 %description -l pl
 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
-wiêkszo¶æ cech pow³ok ksh, bash i tcsh.
+wiêkszo¶æ cech ksh, bash i tcsh.
 
 %package static
-Summary:       Statcly linked Enhanced bourne shell
-Summary(pl):   Statycznie linkowany Zaawansowany bourne shell
-Group:         Shells
-Group(pl):     Pow³oki
+Summary:       Statically linked Enhanced bourne shell
+Summary(pl):   Zaawansowany bourne SHell - linkowany statycznie
+Group:         Applications/Shells
+Group(de):     Applikationen/Shells
+Group(pl):     Aplikacje/Pow³oki
 Requires:      %{name} = %{version}
 
 %description static
-zsh is an enhanced version of the Bourne shell with csh additions and most
-features of ksh, bash, and tcsh.
+zsh is an enhanced version of the Bourne shell with csh additions and
+most features of ksh, bash, and tcsh.
 
 %description -l pl static
 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
-wiêkszo¶æ cech pow³ok ksh, bash i tcsh.
-
-W tym pakiecie jest statycznie linkowany zsh.
+wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
+linkowany.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 autoconf
-LDFLAGS="-static -s"; export LDFLAGS
+
 %configure
-make
+%{__make}
+mv -f Src/zsh Src/zsh.static
 
-mv zsh zsh.static
+%configure \
+       --enable-maildir-support
+%{__make}
 
-LDFLAGS="-s"; export LDFLAGS
-%configure
-make
+(cd Doc; makeinfo zsh.texi)
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-install zsh.static $RPM_BUILD_ROOT%{_bindir}
+install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}
 
-touch  $RPM_BUILD_ROOT/etc/{zlogout,zprofile,zshrc,zlogin,zshenv}
+install -d $RPM_BUILD_ROOT%{_infodir}
+install Doc/zsh.info* $RPM_BUILD_ROOT%{_infodir}
 
-rm Etc/Makefile*
-gzip -9nf $RPM_BUILD_ROOT{%{_mandir}/man1/*,%{_infodir}/*} \
-         Etc/* README ChangeLog META-FAQ
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zprofile,zshrc,zlogin,zshenv}
+
+rm -f Etc/Makefile*
+gzip -9nf Etc/* README ChangeLog META-FAQ
 
 %post
 if [ ! -f /etc/shells ]; then
@@ -88,15 +101,15 @@ else
        fi
 fi
 
-/usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
 
 %postun
 if [ "$1" = "0" ]; then
        grep -v /bin/zsh /etc/shells > /etc/shells.new
-       mv /etc/shells.new /etc/shells
+       mv -f /etc/shells.new /etc/shells
 fi
 
-/usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
 
 %post static
 if [ ! -f /etc/shells ]; then
@@ -105,11 +118,10 @@ else
        grep '^/bin/zsh.static$' /etc/shells > /dev/null || echo "/bin/zsh.static" >> /etc/shells
 fi
 
-
 %postun static
 if [ ! -x /bin/zsh.static ]; then
        grep -v '^/bin/zsh.static$' /etc/shells > /etc/shells.rpm
-       mv /etc/shells.rpm /etc/shells
+       mv -f /etc/shells.rpm /etc/shells
 fi
 
 %clean
@@ -118,13 +130,13 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc {META-FAQ,README,ChangeLog}.gz Etc/* Util Functions
+%doc %{_infodir}/zsh.info*
 %dir %{_libdir}/zsh/%{version}
-%config /etc/*
+%config %{_sysconfdir}/*
 
 %attr(755,root,root) %{_bindir}/zsh
 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
 %{_mandir}/man1/zsh*.1.gz
-%{_infodir}/*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.084815 seconds and 4 git commands to generate.