]> git.pld-linux.org Git - packages/zsh.git/blobdiff - zsh.spec
- similar fixes have been included in zsh-4.2.6
[packages/zsh.git] / zsh.spec
index 947b3aa1f74879f4a27febb3255f2fdc86dddf85..11d89fd0fa378ab4beed02a65d0377353f0f9163 100644 (file)
--- a/zsh.spec
+++ b/zsh.spec
@@ -1,9 +1,8 @@
-# $Revision: 1.59 $ $Date: 2002-11-21 00:29:55 $
 #
 # Conditional build:
-# _without_static      - without static version
+%bcond_without static  # without static version
 #
-Summary:       Enhanced bourne shell
+Summary:       Enhanced Bourne shell
 Summary(de):   Enhanced Bourne Shell
 Summary(es):   Shell bourne mejorada
 Summary(fr):   Bourne shell amélioré
@@ -13,31 +12,39 @@ Summary(ru):        
 Summary(tr):   Geliþmiþ bir BASH sürümü
 Summary(uk):   ëÏÍÁÎÄÎÉÊ ÐÒÏÃÅÓÏÒ (shell) ÓÈÏÖÉÊ ÎÁ ksh, ÁÌÅ Ú ÐÏËÒÁÝÅÎÎÑÍÉ
 Name:          zsh
-Version:       4.0.6
-Release:       3
+Version:       4.2.6
+Release:       1
 License:       BSD-like
 Group:         Applications/Shells
 URL:           http://www.zsh.org/
-Source0:       ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
+Source0:       ftp://ftp.zsh.org/pub/%{name}-%{version}.tar.bz2
+# Source0-md5: 2cefebf742c190cbc611baded825db64
 Source1:       %{name}.1.pl
 Source2:       http://zsh.sunsite.dk/Guide/zshguide.pdf
+# Source2-md5: 0d80ba1ef39052c512cfabf368f3bf20
+Source3:       zprofile
+Source4:       zshrc
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-tinfo.patch
-Patch2:                %{name}-addons.patch
-Patch3:                %{name}-paths.patch
-Patch4:                %{name}-no_nis.patch
-PreReq:                grep
-PreReq:                fileutils
+Patch1:                %{name}-addons.patch
+Patch2:                %{name}-paths.patch
+Patch3:                %{name}-completions.patch
+Patch4:                %{name}-nolibs.patch
+Patch5:                %{name}-broken_configure.patch
 BuildRequires: autoconf
+%{?with_static:BuildRequires:  glibc-static}
+BuildRequires: libcap-devel
 BuildRequires: ncurses-devel >= 5.1
+%{?with_static:BuildRequires:  ncurses-static}
+BuildRequires: pcre-devel
 BuildRequires: texinfo
-%{!?_without_static:BuildRequires:     glibc-static}
-%{!?_without_static:BuildRequires:     ncurses-static}
 Requires(post,preun):  grep
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Requires(preun):       fileutils
+Requires:      findutils
 Obsoletes:     zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _bindir         /bin
+%define                specflags_ia32   -fomit-frame-pointer 
 
 %description
 zsh is an enhanced version of the Bourne shell with csh additions and
@@ -89,7 +96,8 @@ shell-
 Summary:       Files needed for advanced TAB-completion
 Summary(pl):   Pliki potrzebne dla zaawansowanej TAB-completion
 Group:         Applications/Shells
-Requires:      %{name} = %{version}
+Conflicts:     kdesdk-completions-zsh <= 3:3.2.3-2
+Requires:      %{name} = %{version}-%{release}
 
 %description completions
 This package contains files needed for advanced tab completion in zsh.
@@ -99,11 +107,12 @@ Ten pakiet zawiera pliki wymagane przez zsh dla zaawansowanej
 TAB-completion.
 
 %package static
-Summary:       Statically linked Enhanced bourne shell
-Summary(pl):   Zaawansowany bourne SHell - linkowany statycznie
+Summary:       Statically linked Enhanced Bourne shell
+Summary(pl):   Zaawansowana pow³oka Bourne'a - skonsolidowana statycznie
 Group:         Applications/Shells
-Requires:      %{name} = %{version}
 Requires(post,preun):  grep
+Requires(preun):       fileutils
+Requires:      %{name} = %{version}-%{release}
 
 %description static
 zsh is an enhanced version of the Bourne shell with csh additions and
@@ -111,13 +120,13 @@ most features of ksh, bash, and tcsh.
 
 %description static -l pl
 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
-wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
-linkowany.
+wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest wersja
+skonsolidowana statycznie.
 
 %package guide
 Summary:       A User's Guide to the Z-Shell
 Summary(pl):   Podrêcznik U¿ytkownika Z-Shella
-Group:         Applications/Shells
+Group:         Documentation
 URL:           http://zsh.sunsite.dk/Guide/
 
 %description guide
@@ -133,79 +142,85 @@ Podr
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 install %{SOURCE2} .
 
 %build
+cp -f /usr/share/automake/config.sub .
 %{__autoconf}
+CPPFLAGS="-I/usr/include/ncurses"
 
-%if %{!?_without_static:1}%{?_without_static:0}
+%if %{with static}
 LDFLAGS="%{rpmldflags} -static"
-%configure
-%{__make}
+%configure \
+       --disable-dynamic
+%{__make} \
+       DLLDFLAGS=""
 mv -f Src/zsh Src/zsh.static
+%{__make} clean || :
 LDFLAGS="%{rpmldflags}"
 %endif
 
 %configure \
-       --enable-maildir-support
+       ac_cv_have_dev_ptmx=yes \
+       --enable-maildir-support \
+       --enable-pcre \
+       --enable-cap
 %{__make}
 
-(cd Doc; makeinfo zsh.texi)
+cd Doc
+makeinfo zsh.texi
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir},%{_bindir},%{_mandir}/pl/man1}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-%{!?_without_static:install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}}
-install Doc/zsh.info*  $RPM_BUILD_ROOT%{_infodir}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zlogin,zshenv}
-echo "setopt no_function_argzero" > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
-echo ". %{_sysconfdir}/profile" >> $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
+%{?with_static:install Src/zsh.static $RPM_BUILD_ROOT%{_bindir}}
+install Doc/zsh.info* $RPM_BUILD_ROOT%{_infodir}
 
-cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
-PS1='[%%n@%%m %%~]%%(!.#.%%\\$) '
-bindkey -e >/dev/null 2>&1
-alias which=whence
-
-# xterm
-bindkey \`tput khome\` beginning-of-line >/dev/null 2>&1
-bindkey \`tput kend\` end-of-line >/dev/null 2>&1
-bindkey \`tput kdch1\` delete-char >/dev/null 2>&1
-bindkey \`tput kpp\` up-history >/dev/null 2>&1
-bindkey \`tput knp\` end-of-history >/dev/null 2>&1
-bindkey \`tput kcuu1\` history-beginning-search-backward >/dev/null 2>&1
-bindkey \`tput kcud1\` history-beginning-search-forward >/dev/null 2>&1
-EOF
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogin,zlogout,zshenv}
+touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogin,zlogout,zprofile,zshenv,zshrc}.zwc
+install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
+install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
 
 rm -f Etc/Makefile*
 find Functions Util StartupFiles -name .distfiles -o -name .cvsignore | xargs rm -f
 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/zsh.1
 
+# for kdesdk's completion
+ln -sf %{version} $RPM_BUILD_ROOT%{_datadir}/zsh/latest
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
 %post
+umask 022
 if [ ! -f /etc/shells ]; then
        echo "%{_bindir}/zsh" >> /etc/shells
 else
        grep -q '^%{_bindir}/zsh$' /etc/shells || echo "%{_bindir}/zsh" >> /etc/shells
 fi
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
-
-ln -sf %{_datadir}/zsh/%{version} %{_datadir}/zsh/latest
+for i in zlogin zlogout zprofile zshenv zshrc; do
+       [ -f /etc/$i ] && zsh -c "zcompile /etc/$i"
+done
 
 %preun
 if [ "$1" = "0" ]; then
+       umask 022
        grep -v '^%{_bindir}/zsh$' /etc/shells > /etc/shells.new
        mv -f /etc/shells.new /etc/shells
 fi
-rm -rf %{_datadir}/zsh/latest
 
 %postun
 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
 
 %post static
+umask 022
 if [ ! -f /etc/shells ]; then
        echo "%{_bindir}/zsh.static" >> /etc/shells
 else
@@ -214,27 +229,27 @@ fi
 
 %preun static
 if [ "$1" = "0" ]; then
+       umask 022
        grep -v '^%{_bindir}/zsh\.static$' /etc/shells > /etc/shells.new
        mv -f /etc/shells.new /etc/shells
 fi
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
 %doc Etc/* README LICENCE ChangeLog META-FAQ Util StartupFiles
 %attr(755,root,root) %{_bindir}/zsh
-%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/*
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/*[!w]?
+%ghost %{_sysconfdir}/*.zwc
 %dir %{_libdir}/zsh
 %dir %{_libdir}/zsh/%{version}
-%dir %{_datadir}/zsh/
+%dir %{_datadir}/zsh
 %dir %{_datadir}/zsh/site-functions
+%{_datadir}/zsh/latest
 %dir %{_datadir}/zsh/%{version}
 %dir %{_datadir}/zsh/%{version}/functions
-%{_datadir}/zsh/%{version}/functions/[^_c]*
-%{_datadir}/zsh/%{version}/functions/c[^o]*
-%{_datadir}/zsh/%{version}/functions/co[^m]*
+%{_datadir}/zsh/%{version}/functions/[!_c]*
+%{_datadir}/zsh/%{version}/functions/c[!o]*
+%{_datadir}/zsh/%{version}/functions/co[!m]*
 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
 %{_infodir}/zsh.info*
 %{_mandir}/man1/zsh*.1*
@@ -249,7 +264,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc zshguide.pdf
 
-%if %{!?_without_static:1}%{?_without_static:0}
+%if %{with static}
 %files static
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/zsh.static
This page took 0.16726 seconds and 4 git commands to generate.