]> git.pld-linux.org Git - packages/zsh.git/blob - zsh.spec
d5ba917fe805c6b2d771724fd1dd9a343f0f4c76
[packages/zsh.git] / zsh.spec
1 # $Revision: 1.29 $ $Date: 2001-03-20 18:19:15 $
2 Summary:        Enhanced bourne shell
3 Summary(de):    Enhanced Bourne Shell
4 Summary(fr):    Bourne shell amélioré
5 Summary(tr):    Geliþmiþ bir BASH sürümü
6 Summary(pl):    Ulepszona pow³oka Bourne'a
7 Name:           zsh
8 Version:        3.1.9
9 Release:        8
10 License:        GPL
11 Group:          Applications/Shells
12 Group(de):      Applikationen/Shells
13 Group(pl):      Aplikacje/Pow³oki
14 URL:            http://www.zsh.org/
15 Source0:        ftp://ftp.zsh.org/pub/zsh/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-DESTDIR.patch
18 Patch2:         %{name}-sys_capability.patch
19 Patch3:         %{name}-cap_get_proc.patch
20 Patch4:         %{name}-tinfo.patch
21 Patch5:         %{name}-addons.patch
22 Prereq:         grep
23 Prereq:         fileutils
24 Obsoletes:      zsh-doc-html, zsh-doc-ps, zsh-doc-dvi
25 BuildRequires:  ncurses-devel >= 5.1
26 BuildRequires:  glibc-static
27 BuildRequires:  ncurses-static
28 BuildRequires:  texinfo
29 BuildRequires:  autoconf
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _bindir         /bin
33
34 %description
35 zsh is an enhanced version of the Bourne shell with csh additions and
36 most features of ksh, bash, and tcsh.
37
38 %description -l pl
39 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
40 wiêkszo¶æ cech ksh, bash i tcsh.
41
42 %package static
43 Summary:        Statically linked Enhanced bourne shell
44 Summary(pl):    Zaawansowany bourne SHell - linkowany statycznie
45 Group:          Applications/Shells
46 Group(de):      Applikationen/Shells
47 Group(pl):      Aplikacje/Pow³oki
48 Requires:       %{name} = %{version}
49
50 %description static
51 zsh is an enhanced version of the Bourne shell with csh additions and
52 most features of ksh, bash, and tcsh.
53
54 %description -l pl static
55 zsh jest ulepszon± pow³ok± Bourne'a z elementami pow³oki csh. Posiada
56 wiêkszo¶æ cech ksh, bash i tcsh. W tym pakiecie jest statycznie
57 linkowany.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64 %patch3 -p1
65 %patch4 -p1
66 %patch5 -p1
67
68 %build
69 autoconf
70
71 %configure
72 %{__make}
73 mv -f Src/zsh Src/zsh.static
74
75 %configure \
76         --enable-maildir-support
77 %{__make}
78
79 (cd Doc; makeinfo zsh.texi)
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_infodir},%{_sysconfdir},%{_bindir}}
84
85 %{__make} install DESTDIR=$RPM_BUILD_ROOT
86
87 install Src/zsh.static  $RPM_BUILD_ROOT%{_bindir}
88 install Doc/zsh.info*   $RPM_BUILD_ROOT%{_infodir}
89
90 touch $RPM_BUILD_ROOT%{_sysconfdir}/{zlogout,zlogin,zshenv}
91 echo    ". /etc/profile"                > $RPM_BUILD_ROOT%{_sysconfdir}/zprofile
92 echo -e "PS1='[%n@%m %~]%(!.#.%\$) '\nbindkey -e >/dev/null 2>&1" > \
93                                           $RPM_BUILD_ROOT%{_sysconfdir}/zshrc
94                                         
95 rm -f Etc/Makefile*
96 gzip -9nf Etc/* README ChangeLog META-FAQ
97
98 %post
99 if [ ! -f /etc/shells ]; then
100         echo "%{_bindir}/zsh" >> /etc/shells
101 else
102         grep -q '^%{_bindir}/zsh$' /etc/shells || echo "%{_bindir}/zsh" >> /etc/shells
103 fi
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
105
106 %preun
107 if [ "$1" = "0" ]; then
108         grep -v '^%{_bindir}/zsh$' /etc/shells > /etc/shells.new
109         mv -f /etc/shells.new /etc/shells
110 fi
111
112 %postun
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} > /dev/null 2>&1
114
115 %post static
116 if [ ! -f /etc/shells ]; then
117         echo "%{_bindir}/zsh.static" >> /etc/shells
118 else
119         grep -q '^%{_bindir}/zsh\.static$' /etc/shells || echo "%{_bindir}/zsh.static" >> /etc/shells
120 fi
121
122 %preun static
123 if [ "$1" = "0" ]; then
124         grep -v '^%{_bindir}/zsh\.static$' /etc/shells > /etc/shells.new
125         mv -f /etc/shells.new /etc/shells
126 fi
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %files
132 %defattr(644,root,root,755)
133 %doc *.gz Etc/* Util Functions
134 %attr(755,root,root) %{_bindir}/zsh
135 %config %{_sysconfdir}/*
136 %dir %{_libdir}/zsh
137 %dir %{_libdir}/zsh/%{version}
138 %attr(755,root,root) %{_libdir}/zsh/%{version}/*
139 %{_infodir}/zsh.info*
140 %{_mandir}/man1/zsh*.1*
141
142 %files static
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/zsh.static
This page took 0.070707 seconds and 2 git commands to generate.