]> git.pld-linux.org Git - packages/zfs.git/commitdiff
- fix building with linux 3.19 auto/th/zfs-0.6.3-7
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 30 Mar 2015 19:42:03 +0000 (21:42 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 30 Mar 2015 19:42:03 +0000 (21:42 +0200)
- rel 7

linux-3.19.patch [new file with mode: 0644]
zfs.spec

diff --git a/linux-3.19.patch b/linux-3.19.patch
new file mode 100644 (file)
index 0000000..59f354a
--- /dev/null
@@ -0,0 +1,92 @@
+--- zfs-0.6.3/module/zfs/zpl_file.c~   2014-06-12 22:58:09.000000000 +0200
++++ zfs-0.6.3/module/zfs/zpl_file.c    2015-03-30 21:34:49.848900638 +0200
+@@ -23,6 +23,7 @@
+  */
++#include <linux/version.h>
+ #include <sys/dmu_objset.h>
+ #include <sys/zfs_vfsops.h>
+ #include <sys/zfs_vnops.h>
+@@ -527,7 +528,11 @@
+ static int
+ zpl_ioctl_getflags(struct file *filp, void __user *arg)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++      struct inode *ip = filp->f_path.dentry->d_inode;
++#else
+       struct inode *ip = filp->f_dentry->d_inode;
++#endif
+       unsigned int ioctl_flags = 0;
+       uint64_t zfs_flags = ITOZ(ip)->z_pflags;
+       int error;
+@@ -563,7 +568,11 @@
+ static int
+ zpl_ioctl_setflags(struct file *filp, void __user *arg)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++      struct inode    *ip = filp->f_path.dentry->d_inode;
++#else
+       struct inode    *ip = filp->f_dentry->d_inode;
++#endif
+       uint64_t        zfs_flags = ITOZ(ip)->z_pflags;
+       unsigned int    ioctl_flags;
+       cred_t          *cr = CRED();
+--- zfs-0.6.3/module/zpios/pios.c~     2014-06-12 22:58:09.000000000 +0200
++++ zfs-0.6.3/module/zpios/pios.c      2015-03-30 21:38:27.752243085 +0200
+@@ -36,6 +36,7 @@
+ #include <sys/txg.h>
+ #include <sys/dsl_destroy.h>
+ #include <linux/cdev.h>
++#include <linux/version.h>
+ #include "zpios-internal.h"
+@@ -1143,7 +1144,11 @@
+ static long
+ zpios_unlocked_ioctl(struct file *file, unsigned int cmd, unsigned long arg)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++      unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+       unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       int rc = 0;
+       /* Ignore tty ioctls */
+@@ -1187,7 +1192,11 @@
+ zpios_write(struct file *file, const char __user *buf,
+     size_t count, loff_t *ppos)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++      unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+       unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       zpios_info_t *info = (zpios_info_t *)file->private_data;
+       int rc = 0;
+@@ -1224,7 +1233,11 @@
+ static ssize_t
+ zpios_read(struct file *file, char __user *buf, size_t count, loff_t *ppos)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++      unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+       unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       zpios_info_t *info = (zpios_info_t *)file->private_data;
+       int rc = 0;
+@@ -1258,7 +1271,11 @@
+ static loff_t zpios_seek(struct file *file, loff_t offset, int origin)
+ {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3,19,0)
++      unsigned int minor = iminor(file->f_path.dentry->d_inode);
++#else
+       unsigned int minor = iminor(file->f_dentry->d_inode);
++#endif
+       zpios_info_t *info = (zpios_info_t *)file->private_data;
+       int rc = -EINVAL;
index f583c094b668e06f7b4ba6ecaf7f45de42f0126f..275cafda8b37e150178d49d87a4c8177084e7a84 100644 (file)
--- a/zfs.spec
+++ b/zfs.spec
@@ -22,7 +22,7 @@ exit 1
 %define                _duplicate_files_terminate_build        0
 
 %define        pname   zfs
-%define        rel     6
+%define        rel     7
 Summary:       Native Linux port of the ZFS filesystem
 Summary(pl.UTF-8):     Natywny linuksowy port systemu plików ZFS
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
@@ -35,6 +35,7 @@ Source0:      http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/%{pname}-%{versi
 Patch0:                %{pname}-link.patch
 Patch1:                linux-3.18.patch
 Patch2:                x32.patch
+Patch3:                linux-3.19.patch
 URL:           http://zfsonlinux.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -215,6 +216,7 @@ p=`pwd`\
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.930701 seconds and 4 git commands to generate.