]> git.pld-linux.org Git - packages/zfs.git/commitdiff
- added sh patch (kill bashisms in configure)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 10 May 2019 15:17:10 +0000 (17:17 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 10 May 2019 15:17:10 +0000 (17:17 +0200)
- completed BRs

zfs-sh.patch [new file with mode: 0644]
zfs.spec

diff --git a/zfs-sh.patch b/zfs-sh.patch
new file mode 100644 (file)
index 0000000..714c23c
--- /dev/null
@@ -0,0 +1,41 @@
+--- zfs-zfs-0.8.0-rc4/config/always-python.m4.orig     2019-04-16 22:24:49.000000000 +0200
++++ zfs-zfs-0.8.0-rc4/config/always-python.m4  2019-05-08 18:38:16.579298208 +0200
+@@ -68,19 +68,19 @@
+       AM_PATH_PYTHON([2.6], [], [:])
+       AM_CONDITIONAL([USING_PYTHON], [test "$PYTHON" != :])
+-      AM_CONDITIONAL([USING_PYTHON_2], [test "${PYTHON_VERSION:0:2}" = "2."])
+-      AM_CONDITIONAL([USING_PYTHON_3], [test "${PYTHON_VERSION:0:2}" = "3."])
++      AM_CONDITIONAL([USING_PYTHON_2], [test "${PYTHON_VERSION%%.*}" = "2"])
++      AM_CONDITIONAL([USING_PYTHON_3], [test "${PYTHON_VERSION%%.*}" = "3"])
+       dnl #
+       dnl # Minimum supported Python versions for utilities:
+       dnl # Python 2.6.x, or Python 3.4.x
+       dnl #
+-      AS_IF([test "${PYTHON_VERSION:0:2}" = "2."], [
++      AS_IF([test "${PYTHON_VERSION%%.*}" = "2"], [
+               ZFS_AC_PYTHON_VERSION([>= '2.6'], [ /bin/true ],
+                       [AC_MSG_ERROR("Python >= 2.6.x is not available")])
+       ])
+-      AS_IF([test "${PYTHON_VERSION:0:2}" = "3."], [
++      AS_IF([test "${PYTHON_VERSION%%.*}" = "3"], [
+               ZFS_AC_PYTHON_VERSION([>= '3.4'], [ /bin/true ],
+                       [AC_MSG_ERROR("Python >= 3.4.x is not available")])
+       ])
+--- zfs-zfs-0.8.0-rc4/config/always-pyzfs.m4.orig      2019-04-16 22:24:49.000000000 +0200
++++ zfs-zfs-0.8.0-rc4/config/always-pyzfs.m4   2019-05-08 19:29:53.339188287 +0200
+@@ -26,10 +26,10 @@
+       dnl # Require python-devel libraries
+       dnl #
+       AS_IF([test "x$enable_pyzfs" = xcheck  -o "x$enable_pyzfs" = xyes], [
+-              AS_IF([test "${PYTHON_VERSION:0:2}" = "2."], [
++              AS_IF([test "${PYTHON_VERSION%%.*}" = "2"], [
+                       PYTHON_REQUIRED_VERSION=">= '2.7.0'"
+               ], [
+-                      AS_IF([test "${PYTHON_VERSION:0:2}" = "3."], [
++                      AS_IF([test "${PYTHON_VERSION%%.*}" = "3"], [
+                               PYTHON_REQUIRED_VERSION=">= '3.4.0'"
+                       ], [
+                               AC_MSG_ERROR("Python $PYTHON_VERSION unknown")
index 90852c6483ae3fd04883109a08a37d3461a1d0ec..a4021629fd8b59554f05b887c1d7b94efdc1c3c0 100644 (file)
--- a/zfs.spec
+++ b/zfs.spec
@@ -44,6 +44,7 @@ Source0:      https://github.com/zfsonlinux/zfs/archive/zfs-%{version}-%{_rc}/%{pname
 Patch0:                x32.patch
 Patch1:                am.patch
 Patch2:                highmem.patch
 Patch0:                x32.patch
 Patch1:                am.patch
 Patch2:                highmem.patch
+Patch3:                zfs-sh.patch
 URL:           http://zfsonlinux.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 URL:           http://zfsonlinux.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -53,17 +54,26 @@ BuildRequires:      rpmbuild(macros) >= 1.714
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 %endif
 %if %{with userspace}
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 %endif
 %if %{with userspace}
+# only for mmap_libaio test command
+#BuildRequires:        libaio-devel
 BuildRequires: libblkid-devel
 BuildRequires: libselinux-devel
 BuildRequires: libblkid-devel
 BuildRequires: libselinux-devel
+# if xdr gets removed from glibc
+#BuildRequires:        libtirpc-devel
 BuildRequires: libuuid-devel
 BuildRequires: libuuid-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: udev-devel
 BuildRequires: zlib-devel
 %if %{with python2}
 BuildRequires: rpm-pythonprov
 BuildRequires: zlib-devel
 %if %{with python2}
 BuildRequires: rpm-pythonprov
-BuildRequires: python-modules
+BuildRequires: python-cffi
+BuildRequires: python-modules >= 1:2.6
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
 BuildRequires: python-setuptools
 %endif
 %if %{with python3}
-BuildRequires: python3-modules
+BuildRequires: python3-cffi
+BuildRequires: python3-modules >= 1:3.4
 BuildRequires: python3-setuptools
 %endif
 %endif
 BuildRequires: python3-setuptools
 %endif
 %endif
@@ -258,6 +268,7 @@ p=`pwd`\
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
 
 %build
 %{__libtoolize}
@@ -351,7 +362,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYRIGHT LICENSE README.md
+%doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
 %attr(755,root,root) /sbin/mount.zfs
 %attr(755,root,root) %{_bindir}/arc_summary
 %attr(755,root,root) %{_bindir}/arcstat
 %attr(755,root,root) /sbin/mount.zfs
 %attr(755,root,root) %{_bindir}/arc_summary
 %attr(755,root,root) %{_bindir}/arcstat
This page took 0.052943 seconds and 4 git commands to generate.