]> git.pld-linux.org Git - packages/zfs.git/commitdiff
- use xattr syscalls directly from glibc auto/th/zfs-0.7.3-5
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 18 Nov 2017 16:31:44 +0000 (17:31 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 18 Nov 2017 16:31:44 +0000 (17:31 +0100)
- rel 5

xattr-in-glibc.patch [new file with mode: 0644]
zfs.spec

diff --git a/xattr-in-glibc.patch b/xattr-in-glibc.patch
new file mode 100644 (file)
index 0000000..3c984b5
--- /dev/null
@@ -0,0 +1,47 @@
+--- zfs-0.7.3/tests/zfs-tests/cmd/xattrtest/xattrtest.c~       2017-10-18 23:43:13.000000000 +0200
++++ zfs-0.7.3/tests/zfs-tests/cmd/xattrtest/xattrtest.c        2017-11-18 17:15:18.389310337 +0100
+@@ -37,7 +37,7 @@
+ #include <fcntl.h>
+ #include <time.h>
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
+--- zfs-0.7.3/tests/zfs-tests/cmd/mktree/mktree.c~     2017-10-18 23:43:13.000000000 +0200
++++ zfs-0.7.3/tests/zfs-tests/cmd/mktree/mktree.c      2017-11-18 17:15:46.816754985 +0100
+@@ -30,7 +30,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <fcntl.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/param.h>
+--- zfs-0.7.3/config/user-libattr.m4   2017-10-18 23:43:14.000000000 +0200
++++ /dev/null  2017-11-04 00:31:38.176382048 +0100
+@@ -1,12 +0,0 @@
+-dnl #
+-dnl # Check for libattr
+-dnl #
+-AC_DEFUN([ZFS_AC_CONFIG_USER_LIBATTR], [
+-      LIBATTR=
+-
+-      AC_CHECK_HEADER([attr/xattr.h], [], [AC_MSG_FAILURE([
+-      *** attr/xattr.h missing, libattr-devel package required])])
+-
+-      AC_SUBST([LIBATTR], ["-lattr"])
+-      AC_DEFINE([HAVE_LIBATTR], 1, [Define if you have libattr])
+-])
+--- zfs-0.7.3/config/user.m4~  2017-10-18 23:43:14.000000000 +0200
++++ zfs-0.7.3/config/user.m4   2017-11-18 17:17:18.399261345 +0100
+@@ -11,7 +11,6 @@
+       ZFS_AC_CONFIG_USER_LIBUUID
+       ZFS_AC_CONFIG_USER_LIBTIRPC
+       ZFS_AC_CONFIG_USER_LIBBLKID
+-      ZFS_AC_CONFIG_USER_LIBATTR
+       ZFS_AC_CONFIG_USER_LIBUDEV
+       ZFS_AC_CONFIG_USER_FRAME_LARGER_THAN
+       ZFS_AC_CONFIG_USER_RUNSTATEDIR
index 34a14d03a478df52cc4f10ecee8b60d158fd009b..16fc397f1091a7961f201961e834b9f41bbc7b64 100644 (file)
--- a/zfs.spec
+++ b/zfs.spec
@@ -26,7 +26,7 @@ exit 1
 
 %define                _duplicate_files_terminate_build        0
 
-%define        rel     4
+%define        rel     5
 %define        pname   zfs
 Summary:       Native Linux port of the ZFS filesystem
 Summary(pl.UTF-8):     Natywny linuksowy port systemu plików ZFS
@@ -40,8 +40,8 @@ Source0:      https://github.com/zfsonlinux/zfs/releases/download/zfs-%{version}/%{pn
 Patch0:                %{pname}-link.patch
 Patch1:                x32.patch
 Patch2:                randstruct.patch
+Patch3:                xattr-in-glibc.patch
 URL:           http://zfsonlinux.org/
-BuildRequires: attr-devel
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
@@ -224,6 +224,7 @@ p=`pwd`\
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.10719 seconds and 4 git commands to generate.