]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
- up to 2.2.0-rc3
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define pre     rc3
28 %define rel     0.%{pre}.1
29 %define pname   zfs
30 Summary:        Native Linux port of the ZFS filesystem
31 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
32 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
33 Version:        2.2.0
34 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
35 License:        CDDL
36 Group:          Applications/System
37 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}-%{pre}/%{pname}-%{version}-%{pre}.tar.gz
38 # Source0-md5:  75fd8dc40d9601db40029b357c824f3f
39 Patch0:         initdir.patch
40 Patch3:         kernel-6.5.patch
41 URL:            https://zfsonlinux.org/
42 BuildRequires:  autoconf >= 2.50
43 BuildRequires:  automake
44 BuildRequires:  libtool
45 BuildRequires:  rpmbuild(macros) >= 1.714
46 %if %{with kernel}
47 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
48 %endif
49 %if %{with userspace}
50 # only for mmap_libaio test command
51 #BuildRequires: libaio-devel
52 BuildRequires:  libblkid-devel
53 BuildRequires:  libselinux-devel
54 BuildRequires:  libtirpc-devel
55 BuildRequires:  libuuid-devel
56 BuildRequires:  openssl-devel
57 BuildRequires:  pam-devel
58 BuildRequires:  pkgconfig
59 BuildRequires:  udev-devel
60 BuildRequires:  zlib-devel
61 %if %{with python2}
62 BuildRequires:  python-cffi
63 BuildRequires:  python-modules >= 1:2.6
64 BuildRequires:  python-setuptools
65 %endif
66 %if %{with python3}
67 BuildRequires:  python3-cffi
68 BuildRequires:  python3-modules >= 1:3.4
69 BuildRequires:  python3-setuptools
70 %endif
71 %if %{with python2} || %{with python3}
72 BuildRequires:  rpm-pythonprov
73 %endif
74 %endif
75 Requires:       %{pname}-libs = %{version}-%{release}
76 Obsoletes:      spl < 0.7.9-2
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         dracutlibdir    %{_prefix}/lib/dracut
80
81 %description
82 ZFS is an advanced file system and volume manager which was originally
83 developed for Solaris and is now maintained by the Illumos community.
84
85 ZFS on Linux, which is also known as ZoL, is currently feature
86 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
87 ZPL layers.
88
89 %description -l pl.UTF-8
90 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
91 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
92
93 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
94 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
95 SPA, DMU, ZVOL i ZPL.
96
97 %package libs
98 Summary:        ZFS on Linux libraries
99 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
100 License:        CDDL
101 Group:          Libraries
102 Requires(post,postun):  /sbin/ldconfig
103
104 %description libs
105 ZFS on Linux libraries.
106
107 %description libs -l pl.UTF-8
108 Biblioteki ZFS-a dla Linuksa.
109
110 %package devel
111 Summary:        Header files for ZFS libraries
112 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
113 License:        CDDL
114 Group:          Development/Libraries
115 Requires:       %{pname}-libs = %{version}-%{release}
116 Requires:       libselinux-devel
117 Requires:       libtirpc-devel
118 Requires:       libuuid-devel
119 Requires:       zlib-devel
120
121 %description devel
122 Header files for ZFS libraries.
123
124 %description devel -l pl.UTF-8
125 Pliki nagłówkowe bibliotek ZFS-a.
126
127 %package static
128 Summary:        Static ZFS libraries
129 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
130 License:        CDDL
131 Group:          Development/Libraries
132 Requires:       %{pname}-devel = %{version}-%{release}
133
134 %description static
135 Static ZFS libraries.
136
137 %description static -l pl.UTF-8
138 Statyczne biblioteki ZFS-a.
139
140 %package -n dracut-zfs
141 Summary:        ZFS support for Dracut
142 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
143 Group:          Applications/System
144 Requires:       %{pname} = %{version}-%{release}
145 Requires:       dracut
146
147 %description -n dracut-zfs
148 ZFS support for Dracut.
149
150 %description -n dracut-zfs -l pl.UTF-8
151 Obsługa ZFS-a dla Dracuta.
152
153 %package -n pam-pam_zfs_key
154 Summary:        PAM module to unlock ZFS datasets for user
155 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
156 Group:          Libraries
157 Requires:       %{pname}-libs = %{version}-%{release}
158 Requires:       pam
159
160 %description -n pam-pam_zfs_key
161 PAM module to unlock ZFS datasets for user.
162
163 %description -n pam-pam_zfs_key -l pl.UTF-8
164 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
165
166 %package -n python-pyzfs
167 Summary:        Python 2 wrapper for libzfs_core C library
168 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
169 License:        Apache v2.0
170 Group:          Libraries/Python
171 Requires:       %{pname}-libs = %{version}-%{release}
172
173 %description -n python-pyzfs
174 Python 2 wrapper for libzfs_core C library.
175
176 %description -n python-pyzfs -l pl.UTF-8
177 Interfejs Pythona 2 do biblioteki C libzfs_core.
178
179 %package -n python3-pyzfs
180 Summary:        Python 3 wrapper for libzfs_core C library
181 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
182 License:        Apache v2.0
183 Group:          Libraries/Python
184 Requires:       %{pname}-libs = %{version}-%{release}
185
186 %description -n python3-pyzfs
187 Python 3 wrapper for libzfs_core C library.
188
189 %description -n python3-pyzfs -l pl.UTF-8
190 Interfejs Pythona 3 do biblioteki C libzfs_core.
191
192 %package -n kernel-zfs-common-devel
193 Summary:        ZFS Linux kernel headers
194 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
195 Group:          Development/Building
196 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
197
198 %description -n kernel-zfs-common-devel
199 ZFS Linux kernel headers common for all PLD kernel versions.
200
201 %description -n kernel-zfs-common-devel -l pl.UTF-8
202 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
203 wersji jąder PLD.
204
205 %define kernel_pkg()\
206 %package -n kernel%{_alt_kernel}-zfs\
207 Summary:        ZFS Linux kernel modules\
208 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
209 Release:        %{rel}@%{_kernel_ver_str}\
210 Group:          Base/Kernel\
211 Requires(post,postun):  /sbin/depmod\
212 %requires_releq_kernel\
213 Requires(postun):       %releq_kernel\
214 \
215 %description -n kernel%{_alt_kernel}-zfs\
216 ZFS Linux kernel modules.\
217 \
218 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
219 ZFS - moduły jądra Linuksa.\
220 \
221 %package -n kernel%{_alt_kernel}-zfs-devel\
222 Summary:        ZFS Linux kernel headers\
223 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
224 Release:        %{rel}@%{_kernel_ver_str}\
225 Group:          Development/Building\
226 Requires:       kernel%{_alt_kernel}-headers\
227 Requires:       kernel-zfs-common-devel\
228 Obsoletes:      kernel-spl-devel < 0.7.9-2\
229 \
230 %description -n kernel%{_alt_kernel}-zfs-devel\
231 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
232 version %{_kernel_ver}.\
233 \
234 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
235 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
236 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
237 \
238 %files -n kernel%{_alt_kernel}-zfs\
239 %defattr(644,root,root,755)\
240 /lib/modules/%{_kernel_ver}/misc/spl.ko*\
241 /lib/modules/%{_kernel_ver}/misc/zfs.ko*\
242 \
243 %files -n kernel%{_alt_kernel}-zfs-devel\
244 %defattr(644,root,root,755)\
245 /usr/src/zfs-%{version}/%{_kernel_ver}\
246 \
247 %post   -n kernel%{_alt_kernel}-zfs\
248 %depmod %{_kernel_ver}\
249 \
250 %postun -n kernel%{_alt_kernel}-zfs\
251 %depmod %{_kernel_ver}\
252 %{nil}
253
254 %define build_kernel_pkg()\
255 %configure \\\
256         --disable-silent-rules \\\
257         --with-config="kernel" \\\
258         --with-linux=%{_kernelsrcdir}\\\
259         --with-linux-obj=%{_kernelsrcdir}\
260 \
261 %{__make} clean\
262 %{__make} %{?with_verbose:V=1}\
263 p=`pwd`\
264 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
265 %{nil}
266
267 %{?with_kernel:%{expand:%create_kernel_packages}}
268
269 %prep
270 %setup -q -n %{pname}-%{version}-%{pre}
271 %patch0 -p1
272 %patch3 -p1
273
274 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
275       cmd/arc_summary
276
277 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
278       cmd/arcstat.in \
279       cmd/dbufstat.in \
280       cmd/zilstat.in
281
282 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
283       contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
284       contrib/dracut/90zfs/module-setup.sh.in \
285       scripts/zimport.sh \
286       scripts/zloop.sh
287
288 %build
289 %{__libtoolize}
290 %{__aclocal} -I config
291 %{__autoconf}
292 %{__autoheader}
293 %{__automake}
294 %{?with_kernel:%{expand:%build_kernel_packages}}
295
296 %if %{with userspace}
297 %configure \
298         --disable-silent-rules \
299         --enable-pam \
300         --enable-systemd \
301         --with-config="user" \
302         --with-linux=%{_kernelsrcdir} \
303         --with-pammoduledir=/%{_lib}/security \
304         --with-systemdunitdir=%{systemdunitdir} \
305         --with-systemdpresetdir=/etc/systemd/system-preset \
306         --with-systemdmodulesloaddir=/etc/modules-load.d \
307         --with-systemdgeneratordir=/lib/systemd/system-generators \
308         --with-udevdir=/lib/udev
309
310 %{__make} \
311         %{?with_verbose:V=1}
312
313 %if %{with python2}
314 cd contrib/pyzfs
315 %py_build
316 cd ../..
317 %endif
318
319 %if %{with python3}
320 cd contrib/pyzfs
321 %py3_build
322 cd ../..
323 %endif
324 %endif
325
326 %install
327 rm -rf $RPM_BUILD_ROOT
328
329 %if %{with kernel}
330 install -d $RPM_BUILD_ROOT
331 cp -a installed/* $RPM_BUILD_ROOT
332 %endif
333
334 %if %{with userspace}
335 %{__make} install \
336         DESTDIR=$RPM_BUILD_ROOT \
337         DEFAULT_INIT_DIR=/etc/rc.d/init.d
338
339 %if %{with python2}
340 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
341 cd contrib/pyzfs
342 %py_install
343
344 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
345 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
346
347 %py_postclean
348 cd ../..
349 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
350 %endif
351
352 %if %{with python3}
353 cd contrib/pyzfs
354 %py3_install
355 cd ../..
356 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
357 %endif
358
359 # Debian specific stuff
360 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
361
362 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
363 # Ubuntu PAM config framework file
364 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
365
366 # Package these? These are integration tests of the implementation.
367 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
368 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
369 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
370 %endif
371
372 %clean
373 rm -rf $RPM_BUILD_ROOT
374
375 %post   libs -p /sbin/ldconfig
376 %postun libs -p /sbin/ldconfig
377
378 %if %{with userspace}
379 %files
380 %defattr(644,root,root,755)
381 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
382 %attr(755,root,root) /sbin/mount.zfs
383 %attr(755,root,root) %{_bindir}/arc_summary
384 %attr(755,root,root) %{_bindir}/arcstat
385 %attr(755,root,root) %{_bindir}/dbufstat
386 %attr(755,root,root) %{_bindir}/zilstat
387 %attr(755,root,root) %{_bindir}/zvol_wait
388 %attr(755,root,root) %{_sbindir}/fsck.zfs
389 %attr(755,root,root) %{_sbindir}/zdb
390 %attr(755,root,root) %{_sbindir}/zed
391 %attr(755,root,root) %{_sbindir}/zfs
392 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
393 %attr(755,root,root) %{_sbindir}/zgenhostid
394 %attr(755,root,root) %{_sbindir}/zhack
395 %attr(755,root,root) %{_sbindir}/zinject
396 %attr(755,root,root) %{_sbindir}/zpool
397 %attr(755,root,root) %{_sbindir}/zstream
398 %attr(755,root,root) %{_sbindir}/zstreamdump
399 %attr(755,root,root) %{_sbindir}/ztest
400 %dir %{_sysconfdir}/zfs
401 # package *.example as %doc? (they cannot act as default configuration)
402 %{_sysconfdir}/zfs/vdev_id.conf.*.example
403 %dir %{_sysconfdir}/zfs/zed.d
404 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
405 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
406 %dir %{_sysconfdir}/zfs/zpool.d
407 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
408 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
409 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
410 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
411 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
412 %attr(754,root,root) /etc/rc.d/init.d/zfs-load-key
413 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
414 /etc/zfs/zfs-functions
415 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
416 # for zpool iostat/status -c smart
417 #/ets/sudoers.d/zfs
418 /etc/systemd/system-preset/50-zfs.preset
419 /lib/systemd/system-generators/zfs-mount-generator
420 %{systemdunitdir}/zfs.target
421 %{systemdunitdir}/zfs-import.service
422 %{systemdunitdir}/zfs-import.target
423 %{systemdunitdir}/zfs-import-cache.service
424 %{systemdunitdir}/zfs-import-scan.service
425 %{systemdunitdir}/zfs-load-key.service
426 %{systemdunitdir}/zfs-mount.service
427 %{systemdunitdir}/zfs-scrub@.service
428 %{systemdunitdir}/zfs-scrub-monthly@.timer
429 %{systemdunitdir}/zfs-scrub-weekly@.timer
430 %{systemdunitdir}/zfs-share.service
431 %{systemdunitdir}/zfs-trim-monthly@.timer
432 %{systemdunitdir}/zfs-trim-weekly@.timer
433 %{systemdunitdir}/zfs-trim@.service
434 %{systemdunitdir}/zfs-volume-wait.service
435 %{systemdunitdir}/zfs-volumes.target
436 %{systemdunitdir}/zfs-zed.service
437 %attr(755,root,root) /lib/udev/vdev_id
438 %attr(755,root,root) /lib/udev/zvol_id
439 /lib/udev/rules.d/60-zvol.rules
440 /lib/udev/rules.d/69-vdev.rules
441 /lib/udev/rules.d/90-zfs.rules
442 %dir %{_libexecdir}/zfs
443 %dir %{_libexecdir}/zfs/zed.d
444 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
445 %dir %{_libexecdir}/zfs/zpool.d
446 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
447 %dir %{_datadir}/zfs
448 %attr(755,root,root) %{_datadir}/zfs/*.sh
449 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
450 %{_datadir}/zfs/compatibility.d
451 %{_mandir}/man1/arcstat.1*
452 %{_mandir}/man1/zhack.1*
453 %{_mandir}/man1/ztest.1*
454 %{_mandir}/man1/zvol_wait.1*
455 %{_mandir}/man4/spl.4*
456 %{_mandir}/man4/zfs.4*
457 %{_mandir}/man5/vdev_id.conf.5*
458 %{_mandir}/man7/vdevprops.7*
459 %{_mandir}/man7/zfsconcepts.7*
460 %{_mandir}/man7/zfsprops.7*
461 %{_mandir}/man7/zpool-features.7*
462 %{_mandir}/man7/zpoolconcepts.7*
463 %{_mandir}/man7/zpoolprops.7*
464 %{_mandir}/man8/fsck.zfs.8*
465 %{_mandir}/man8/mount.zfs.8*
466 %{_mandir}/man8/vdev_id.8*
467 %{_mandir}/man8/zdb.8*
468 %{_mandir}/man8/zed.8*
469 %{_mandir}/man8/zfs.8*
470 %{_mandir}/man8/zfs-allow.8*
471 %{_mandir}/man8/zfs-bookmark.8*
472 %{_mandir}/man8/zfs-change-key.8*
473 %{_mandir}/man8/zfs-clone.8*
474 %{_mandir}/man8/zfs-create.8*
475 %{_mandir}/man8/zfs-destroy.8*
476 %{_mandir}/man8/zfs-diff.8*
477 %{_mandir}/man8/zfs-get.8*
478 %{_mandir}/man8/zfs-groupspace.8*
479 %{_mandir}/man8/zfs-hold.8*
480 %{_mandir}/man8/zfs-inherit.8*
481 %{_mandir}/man8/zfs-jail.8*
482 %{_mandir}/man8/zfs-list.8*
483 %{_mandir}/man8/zfs-load-key.8*
484 %{_mandir}/man8/zfs-mount.8*
485 %{_mandir}/man8/zfs-mount-generator.8*
486 %{_mandir}/man8/zfs-program.8*
487 %{_mandir}/man8/zfs-project.8*
488 %{_mandir}/man8/zfs-projectspace.8*
489 %{_mandir}/man8/zfs-promote.8*
490 %{_mandir}/man8/zfs-receive.8*
491 %{_mandir}/man8/zfs-recv.8*
492 %{_mandir}/man8/zfs-redact.8*
493 %{_mandir}/man8/zfs-release.8*
494 %{_mandir}/man8/zfs-rename.8*
495 %{_mandir}/man8/zfs-rollback.8*
496 %{_mandir}/man8/zfs-send.8*
497 %{_mandir}/man8/zfs-set.8*
498 %{_mandir}/man8/zfs-share.8*
499 %{_mandir}/man8/zfs-snapshot.8*
500 %{_mandir}/man8/zfs-unallow.8*
501 %{_mandir}/man8/zfs-unjail.8*
502 %{_mandir}/man8/zfs-unload-key.8*
503 %{_mandir}/man8/zfs-unzone.8*
504 %{_mandir}/man8/zfs-unmount.8*
505 %{_mandir}/man8/zfs-upgrade.8*
506 %{_mandir}/man8/zfs-userspace.8*
507 %{_mandir}/man8/zfs-wait.8*
508 %{_mandir}/man8/zfs-zone.8*
509 %{_mandir}/man8/zfs_ids_to_path.8*
510 %{_mandir}/man8/zgenhostid.8*
511 %{_mandir}/man8/zinject.8*
512 %{_mandir}/man8/zpool.8*
513 %{_mandir}/man8/zpool-add.8*
514 %{_mandir}/man8/zpool-attach.8*
515 %{_mandir}/man8/zpool-checkpoint.8*
516 %{_mandir}/man8/zpool-clear.8*
517 %{_mandir}/man8/zpool-create.8*
518 %{_mandir}/man8/zpool-destroy.8*
519 %{_mandir}/man8/zpool-detach.8*
520 %{_mandir}/man8/zpool-events.8*
521 %{_mandir}/man8/zpool-export.8*
522 %{_mandir}/man8/zpool-get.8*
523 %{_mandir}/man8/zpool-history.8*
524 %{_mandir}/man8/zpool-import.8*
525 %{_mandir}/man8/zpool-initialize.8*
526 %{_mandir}/man8/zpool-iostat.8*
527 %{_mandir}/man8/zpool-labelclear.8*
528 %{_mandir}/man8/zpool-list.8*
529 %{_mandir}/man8/zpool-offline.8*
530 %{_mandir}/man8/zpool-online.8*
531 %{_mandir}/man8/zpool-reguid.8*
532 %{_mandir}/man8/zpool-remove.8*
533 %{_mandir}/man8/zpool-reopen.8*
534 %{_mandir}/man8/zpool-replace.8*
535 %{_mandir}/man8/zpool-resilver.8*
536 %{_mandir}/man8/zpool-scrub.8*
537 %{_mandir}/man8/zpool-set.8*
538 %{_mandir}/man8/zpool-split.8*
539 %{_mandir}/man8/zpool-status.8*
540 %{_mandir}/man8/zpool-sync.8*
541 %{_mandir}/man8/zpool-trim.8*
542 %{_mandir}/man8/zpool-upgrade.8*
543 %{_mandir}/man8/zpool-wait.8*
544 %{_mandir}/man8/zpool_influxdb.8*
545 %{_mandir}/man8/zstream.8*
546 %{_mandir}/man8/zstreamdump.8*
547
548 %files libs
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
551 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
552 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
553 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
554 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
555 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
556 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
557 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
558 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
560 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
562
563 %files devel
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_libdir}/libnvpair.so
566 %attr(755,root,root) %{_libdir}/libuutil.so
567 %attr(755,root,root) %{_libdir}/libzfs.so
568 %attr(755,root,root) %{_libdir}/libzfs_core.so
569 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
570 %attr(755,root,root) %{_libdir}/libzpool.so
571 %{_libdir}/libnvpair.la
572 %{_libdir}/libuutil.la
573 %{_libdir}/libzfs.la
574 %{_libdir}/libzfs_core.la
575 %{_libdir}/libzfsbootenv.la
576 %{_libdir}/libzpool.la
577 %{_includedir}/libspl
578 %{_includedir}/libzfs
579 %{_pkgconfigdir}/libzfs.pc
580 %{_pkgconfigdir}/libzfs_core.pc
581 %{_pkgconfigdir}/libzfsbootenv.pc
582
583 %files static
584 %defattr(644,root,root,755)
585 %{_libdir}/libnvpair.a
586 %{_libdir}/libuutil.a
587 %{_libdir}/libzfs.a
588 %{_libdir}/libzfs_core.a
589 %{_libdir}/libzfsbootenv.a
590 %{_libdir}/libzpool.a
591
592 %files -n dracut-zfs
593 %defattr(644,root,root,755)
594 %doc contrib/dracut/README.md
595 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
596 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
597 %dir %{dracutlibdir}/modules.d/90zfs
598 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
599 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
600 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
601 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
602 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
603 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
604 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
605 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
606 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
607 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
608 %{dracutlibdir}/modules.d/90zfs/zfs-nonroot-necessities.service
609 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
610 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
611 %{_mandir}/man7/dracut.zfs.7*
612
613 %files -n pam-pam_zfs_key
614 %defattr(644,root,root,755)
615 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
616
617 %if %{with python2}
618 %files -n python-pyzfs
619 %defattr(644,root,root,755)
620 %doc contrib/pyzfs/README
621 %{py_sitescriptdir}/libzfs_core
622 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
623 %endif
624
625 %if %{with python3}
626 %files -n python3-pyzfs
627 %defattr(644,root,root,755)
628 %doc contrib/pyzfs/README
629 %{py3_sitescriptdir}/libzfs_core
630 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
631 %endif
632 %endif
633
634 %if %{with kernel}
635 %files -n kernel-zfs-common-devel
636 %defattr(644,root,root,755)
637 %dir /usr/src/zfs-%{version}
638 /usr/src/zfs-%{version}/include
639 /usr/src/zfs-%{version}/zfs.release.in
640 /usr/src/zfs-%{version}/zfs_config.h.in
641 %endif
This page took 0.145153 seconds and 4 git commands to generate.