]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
- blkdev fixes for kernel 6.2.8+, rel 2
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define rel     2
28 %define pname   zfs
29 Summary:        Native Linux port of the ZFS filesystem
30 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
31 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
32 Version:        2.1.9
33 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
34 License:        CDDL
35 Group:          Applications/System
36 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
37 # Source0-md5:  d464a712eb43411f2360214badd3b35a
38 Patch0:         initdir.patch
39 Patch1:         am.patch
40 Patch2:         no-Werror.patch
41 Patch3:         blkdev.patch
42 URL:            https://zfsonlinux.org/
43 BuildRequires:  autoconf >= 2.50
44 BuildRequires:  automake
45 BuildRequires:  libtool
46 BuildRequires:  rpmbuild(macros) >= 1.714
47 %if %{with kernel}
48 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
49 %endif
50 %if %{with userspace}
51 # only for mmap_libaio test command
52 #BuildRequires: libaio-devel
53 BuildRequires:  libblkid-devel
54 BuildRequires:  libselinux-devel
55 BuildRequires:  libtirpc-devel
56 BuildRequires:  libuuid-devel
57 BuildRequires:  openssl-devel
58 BuildRequires:  pam-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  udev-devel
61 BuildRequires:  zlib-devel
62 %if %{with python2}
63 BuildRequires:  python-cffi
64 BuildRequires:  python-modules >= 1:2.6
65 BuildRequires:  python-setuptools
66 %endif
67 %if %{with python3}
68 BuildRequires:  python3-cffi
69 BuildRequires:  python3-modules >= 1:3.4
70 BuildRequires:  python3-setuptools
71 %endif
72 %if %{with python2} || %{with python3}
73 BuildRequires:  rpm-pythonprov
74 %endif
75 %endif
76 Requires:       %{pname}-libs = %{version}-%{release}
77 Obsoletes:      spl < 0.7.9-2
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         dracutlibdir    %{_prefix}/lib/dracut
81
82 %description
83 ZFS is an advanced file system and volume manager which was originally
84 developed for Solaris and is now maintained by the Illumos community.
85
86 ZFS on Linux, which is also known as ZoL, is currently feature
87 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
88 ZPL layers.
89
90 %description -l pl.UTF-8
91 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
92 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
93
94 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
95 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
96 SPA, DMU, ZVOL i ZPL.
97
98 %package libs
99 Summary:        ZFS on Linux libraries
100 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
101 License:        CDDL
102 Group:          Libraries
103 Requires(post,postun):  /sbin/ldconfig
104
105 %description libs
106 ZFS on Linux libraries.
107
108 %description libs -l pl.UTF-8
109 Biblioteki ZFS-a dla Linuksa.
110
111 %package devel
112 Summary:        Header files for ZFS libraries
113 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
114 License:        CDDL
115 Group:          Development/Libraries
116 Requires:       %{pname}-libs = %{version}-%{release}
117 Requires:       libselinux-devel
118 Requires:       libtirpc-devel
119 Requires:       libuuid-devel
120 Requires:       zlib-devel
121
122 %description devel
123 Header files for ZFS libraries.
124
125 %description devel -l pl.UTF-8
126 Pliki nagłówkowe bibliotek ZFS-a.
127
128 %package static
129 Summary:        Static ZFS libraries
130 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
131 License:        CDDL
132 Group:          Development/Libraries
133 Requires:       %{pname}-devel = %{version}-%{release}
134
135 %description static
136 Static ZFS libraries.
137
138 %description static -l pl.UTF-8
139 Statyczne biblioteki ZFS-a.
140
141 %package -n dracut-zfs
142 Summary:        ZFS support for Dracut
143 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
144 Group:          Applications/System
145 Requires:       %{pname} = %{version}-%{release}
146 Requires:       dracut
147
148 %description -n dracut-zfs
149 ZFS support for Dracut.
150
151 %description -n dracut-zfs -l pl.UTF-8
152 Obsługa ZFS-a dla Dracuta.
153
154 %package -n pam-pam_zfs_key
155 Summary:        PAM module to unlock ZFS datasets for user
156 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
157 Group:          Libraries
158 Requires:       %{pname}-libs = %{version}-%{release}
159 Requires:       pam
160
161 %description -n pam-pam_zfs_key
162 PAM module to unlock ZFS datasets for user.
163
164 %description -n pam-pam_zfs_key -l pl.UTF-8
165 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
166
167 %package -n python-pyzfs
168 Summary:        Python 2 wrapper for libzfs_core C library
169 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
170 License:        Apache v2.0
171 Group:          Libraries/Python
172 Requires:       %{pname}-libs = %{version}-%{release}
173
174 %description -n python-pyzfs
175 Python 2 wrapper for libzfs_core C library.
176
177 %description -n python-pyzfs -l pl.UTF-8
178 Interfejs Pythona 2 do biblioteki C libzfs_core.
179
180 %package -n python3-pyzfs
181 Summary:        Python 3 wrapper for libzfs_core C library
182 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
183 License:        Apache v2.0
184 Group:          Libraries/Python
185 Requires:       %{pname}-libs = %{version}-%{release}
186
187 %description -n python3-pyzfs
188 Python 3 wrapper for libzfs_core C library.
189
190 %description -n python3-pyzfs -l pl.UTF-8
191 Interfejs Pythona 3 do biblioteki C libzfs_core.
192
193 %package -n kernel-zfs-common-devel
194 Summary:        ZFS Linux kernel headers
195 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
196 Group:          Development/Building
197 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
198
199 %description -n kernel-zfs-common-devel
200 ZFS Linux kernel headers common for all PLD kernel versions.
201
202 %description -n kernel-zfs-common-devel -l pl.UTF-8
203 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
204 wersji jąder PLD.
205
206 %define kernel_pkg()\
207 %package -n kernel%{_alt_kernel}-zfs\
208 Summary:        ZFS Linux kernel modules\
209 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
210 Release:        %{rel}@%{_kernel_ver_str}\
211 Group:          Base/Kernel\
212 Requires(post,postun):  /sbin/depmod\
213 %requires_releq_kernel\
214 Requires(postun):       %releq_kernel\
215 \
216 %description -n kernel%{_alt_kernel}-zfs\
217 ZFS Linux kernel modules.\
218 \
219 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
220 ZFS - moduły jądra Linuksa.\
221 \
222 %package -n kernel%{_alt_kernel}-zfs-devel\
223 Summary:        ZFS Linux kernel headers\
224 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
225 Release:        %{rel}@%{_kernel_ver_str}\
226 Group:          Development/Building\
227 Requires:       kernel%{_alt_kernel}-headers\
228 Requires:       kernel-zfs-common-devel\
229 Obsoletes:      kernel-spl-devel < 0.7.9-2\
230 \
231 %description -n kernel%{_alt_kernel}-zfs-devel\
232 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
233 version %{_kernel_ver}.\
234 \
235 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
236 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
237 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
238 \
239 %files -n kernel%{_alt_kernel}-zfs\
240 %defattr(644,root,root,755)\
241 %dir /lib/modules/%{_kernel_ver}/misc/lua\
242 /lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
243 %dir /lib/modules/%{_kernel_ver}/misc/avl\
244 /lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
245 %dir /lib/modules/%{_kernel_ver}/misc/icp\
246 /lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
247 %dir /lib/modules/%{_kernel_ver}/misc/nvpair\
248 /lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
249 %dir /lib/modules/%{_kernel_ver}/misc/spl\
250 /lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
251 %dir /lib/modules/%{_kernel_ver}/misc/unicode\
252 /lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
253 %dir /lib/modules/%{_kernel_ver}/misc/zcommon\
254 /lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
255 %dir /lib/modules/%{_kernel_ver}/misc/zfs\
256 /lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
257 %dir /lib/modules/%{_kernel_ver}/misc/zstd\
258 /lib/modules/%{_kernel_ver}/misc/zstd/zzstd.ko*\
259 \
260 %files -n kernel%{_alt_kernel}-zfs-devel\
261 %defattr(644,root,root,755)\
262 /usr/src/zfs-%{version}/%{_kernel_ver}\
263 \
264 %post   -n kernel%{_alt_kernel}-zfs\
265 %depmod %{_kernel_ver}\
266 \
267 %postun -n kernel%{_alt_kernel}-zfs\
268 %depmod %{_kernel_ver}\
269 %{nil}
270
271 %define build_kernel_pkg()\
272 %configure \\\
273         --disable-silent-rules \\\
274         --with-config="kernel" \\\
275         --with-linux=%{_kernelsrcdir}\\\
276         --with-linux-obj=%{_kernelsrcdir}\
277 \
278 %{__make} clean\
279 %{__make} %{?with_verbose:V=1}\
280 p=`pwd`\
281 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
282 %{nil}
283
284 %{?with_kernel:%{expand:%create_kernel_packages}}
285
286 %prep
287 %setup -q -n %{pname}-%{version}
288 %patch0 -p1
289 %patch1 -p1
290 %patch2 -p1
291 %patch3 -p1
292
293 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
294       cmd/arc_summary/arc_summary2
295
296 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
297       cmd/arc_summary/arc_summary3
298
299 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
300       cmd/arcstat/arcstat.in \
301       cmd/dbufstat/dbufstat.in
302
303 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
304       contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
305       contrib/dracut/90zfs/module-setup.sh.in \
306       scripts/zimport.sh \
307       scripts/zloop.sh
308
309 %build
310 %{__libtoolize}
311 %{__aclocal} -I config
312 %{__autoconf}
313 %{__autoheader}
314 %{__automake}
315 %{?with_kernel:%{expand:%build_kernel_packages}}
316
317 %if %{with userspace}
318 %configure \
319         --disable-silent-rules \
320         --enable-pam \
321         --enable-systemd \
322         --with-config="user" \
323         --with-linux=%{_kernelsrcdir} \
324         --with-pammoduledir=/%{_lib}/security \
325         --with-systemdunitdir=%{systemdunitdir} \
326         --with-systemdpresetdir=/etc/systemd/system-preset \
327         --with-systemdmodulesloaddir=/etc/modules-load.d \
328         --with-systemdgeneratordir=/lib/systemd/system-generators \
329         --with-udevdir=/lib/udev
330
331 %{__make} \
332         %{?with_verbose:V=1}
333
334 %if %{with python2}
335 cd contrib/pyzfs
336 %py_build
337 cd ../..
338 %endif
339
340 %if %{with python3}
341 cd contrib/pyzfs
342 %py3_build
343 cd ../..
344 %endif
345 %endif
346
347 %install
348 rm -rf $RPM_BUILD_ROOT
349
350 %if %{with kernel}
351 install -d $RPM_BUILD_ROOT
352 cp -a installed/* $RPM_BUILD_ROOT
353 # Drop unneeded spl compat links
354 %{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
355 %endif
356
357 %if %{with userspace}
358 %{__make} install \
359         DESTDIR=$RPM_BUILD_ROOT \
360         DEFAULT_INIT_DIR=/etc/rc.d/init.d
361
362 %if %{with python2}
363 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
364 cd contrib/pyzfs
365 %py_install
366
367 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
368 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
369
370 %py_postclean
371 cd ../..
372 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
373 %endif
374
375 %if %{with python3}
376 cd contrib/pyzfs
377 %py3_install
378 cd ../..
379 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
380 %endif
381
382 # Debian specific stuff
383 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
384
385 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
386 # Ubuntu PAM config framework file
387 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
388
389 # Package these? These are integration tests of the implementation.
390 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
391 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
392 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
393 %endif
394
395 %clean
396 rm -rf $RPM_BUILD_ROOT
397
398 %post   libs -p /sbin/ldconfig
399 %postun libs -p /sbin/ldconfig
400
401 %if %{with userspace}
402 %files
403 %defattr(644,root,root,755)
404 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
405 %attr(755,root,root) /sbin/mount.zfs
406 %attr(755,root,root) %{_bindir}/arc_summary
407 %attr(755,root,root) %{_bindir}/arcstat
408 %attr(755,root,root) %{_bindir}/dbufstat
409 %attr(755,root,root) %{_bindir}/zvol_wait
410 %attr(755,root,root) %{_sbindir}/fsck.zfs
411 %attr(755,root,root) %{_sbindir}/zdb
412 %attr(755,root,root) %{_sbindir}/zed
413 %attr(755,root,root) %{_sbindir}/zfs
414 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
415 %attr(755,root,root) %{_sbindir}/zgenhostid
416 %attr(755,root,root) %{_sbindir}/zhack
417 %attr(755,root,root) %{_sbindir}/zinject
418 %attr(755,root,root) %{_sbindir}/zpool
419 %attr(755,root,root) %{_sbindir}/zstream
420 %attr(755,root,root) %{_sbindir}/zstreamdump
421 %attr(755,root,root) %{_sbindir}/ztest
422 %dir %{_sysconfdir}/zfs
423 # package *.example as %doc? (they cannot act as default configuration)
424 %{_sysconfdir}/zfs/vdev_id.conf.*.example
425 %dir %{_sysconfdir}/zfs/zed.d
426 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
427 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
428 %dir %{_sysconfdir}/zfs/zpool.d
429 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
430 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
431 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
432 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
433 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
434 %attr(754,root,root) /etc/rc.d/init.d/zfs-load-key
435 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
436 /etc/zfs/zfs-functions
437 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
438 # for zpool iostat/status -c smart
439 #/ets/sudoers.d/zfs
440 /etc/systemd/system-preset/50-zfs.preset
441 /lib/systemd/system-generators/zfs-mount-generator
442 %{systemdunitdir}/zfs.target
443 %{systemdunitdir}/zfs-import.service
444 %{systemdunitdir}/zfs-import.target
445 %{systemdunitdir}/zfs-import-cache.service
446 %{systemdunitdir}/zfs-import-scan.service
447 %{systemdunitdir}/zfs-load-key.service
448 %{systemdunitdir}/zfs-mount.service
449 %{systemdunitdir}/zfs-scrub@.service
450 %{systemdunitdir}/zfs-scrub-monthly@.timer
451 %{systemdunitdir}/zfs-scrub-weekly@.timer
452 %{systemdunitdir}/zfs-share.service
453 %{systemdunitdir}/zfs-volume-wait.service
454 %{systemdunitdir}/zfs-volumes.target
455 %{systemdunitdir}/zfs-zed.service
456 %attr(755,root,root) /lib/udev/vdev_id
457 %attr(755,root,root) /lib/udev/zvol_id
458 /lib/udev/rules.d/60-zvol.rules
459 /lib/udev/rules.d/69-vdev.rules
460 /lib/udev/rules.d/90-zfs.rules
461 %dir %{_libexecdir}/zfs
462 %dir %{_libexecdir}/zfs/zed.d
463 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
464 %dir %{_libexecdir}/zfs/zpool.d
465 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
466 %dir %{_datadir}/zfs
467 %attr(755,root,root) %{_datadir}/zfs/*.sh
468 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
469 %{_datadir}/zfs/compatibility.d
470 %{_mandir}/man1/arcstat.1*
471 %{_mandir}/man1/zhack.1*
472 %{_mandir}/man1/ztest.1*
473 %{_mandir}/man1/zvol_wait.1*
474 %{_mandir}/man4/spl.4*
475 %{_mandir}/man4/zfs.4*
476 %{_mandir}/man5/vdev_id.conf.5*
477 %{_mandir}/man7/zfsconcepts.7*
478 %{_mandir}/man7/zfsprops.7*
479 %{_mandir}/man7/zpool-features.7*
480 %{_mandir}/man7/zpoolconcepts.7*
481 %{_mandir}/man7/zpoolprops.7*
482 %{_mandir}/man8/fsck.zfs.8*
483 %{_mandir}/man8/mount.zfs.8*
484 %{_mandir}/man8/vdev_id.8*
485 %{_mandir}/man8/zdb.8*
486 %{_mandir}/man8/zed.8*
487 %{_mandir}/man8/zfs.8*
488 %{_mandir}/man8/zfs-allow.8*
489 %{_mandir}/man8/zfs-bookmark.8*
490 %{_mandir}/man8/zfs-change-key.8*
491 %{_mandir}/man8/zfs-clone.8*
492 %{_mandir}/man8/zfs-create.8*
493 %{_mandir}/man8/zfs-destroy.8*
494 %{_mandir}/man8/zfs-diff.8*
495 %{_mandir}/man8/zfs-get.8*
496 %{_mandir}/man8/zfs-groupspace.8*
497 %{_mandir}/man8/zfs-hold.8*
498 %{_mandir}/man8/zfs-inherit.8*
499 %{_mandir}/man8/zfs-jail.8*
500 %{_mandir}/man8/zfs-list.8*
501 %{_mandir}/man8/zfs-load-key.8*
502 %{_mandir}/man8/zfs-mount.8*
503 %{_mandir}/man8/zfs-mount-generator.8*
504 %{_mandir}/man8/zfs-program.8*
505 %{_mandir}/man8/zfs-project.8*
506 %{_mandir}/man8/zfs-projectspace.8*
507 %{_mandir}/man8/zfs-promote.8*
508 %{_mandir}/man8/zfs-receive.8*
509 %{_mandir}/man8/zfs-recv.8*
510 %{_mandir}/man8/zfs-redact.8*
511 %{_mandir}/man8/zfs-release.8*
512 %{_mandir}/man8/zfs-rename.8*
513 %{_mandir}/man8/zfs-rollback.8*
514 %{_mandir}/man8/zfs-send.8*
515 %{_mandir}/man8/zfs-set.8*
516 %{_mandir}/man8/zfs-share.8*
517 %{_mandir}/man8/zfs-snapshot.8*
518 %{_mandir}/man8/zfs-unallow.8*
519 %{_mandir}/man8/zfs-unjail.8*
520 %{_mandir}/man8/zfs-unload-key.8*
521 %{_mandir}/man8/zfs-unmount.8*
522 %{_mandir}/man8/zfs-upgrade.8*
523 %{_mandir}/man8/zfs-userspace.8*
524 %{_mandir}/man8/zfs-wait.8*
525 %{_mandir}/man8/zfs_ids_to_path.8*
526 %{_mandir}/man8/zgenhostid.8*
527 %{_mandir}/man8/zinject.8*
528 %{_mandir}/man8/zpool.8*
529 %{_mandir}/man8/zpool-add.8*
530 %{_mandir}/man8/zpool-attach.8*
531 %{_mandir}/man8/zpool-checkpoint.8*
532 %{_mandir}/man8/zpool-clear.8*
533 %{_mandir}/man8/zpool-create.8*
534 %{_mandir}/man8/zpool-destroy.8*
535 %{_mandir}/man8/zpool-detach.8*
536 %{_mandir}/man8/zpool-events.8*
537 %{_mandir}/man8/zpool-export.8*
538 %{_mandir}/man8/zpool-get.8*
539 %{_mandir}/man8/zpool-history.8*
540 %{_mandir}/man8/zpool-import.8*
541 %{_mandir}/man8/zpool-initialize.8*
542 %{_mandir}/man8/zpool-iostat.8*
543 %{_mandir}/man8/zpool-labelclear.8*
544 %{_mandir}/man8/zpool-list.8*
545 %{_mandir}/man8/zpool-offline.8*
546 %{_mandir}/man8/zpool-online.8*
547 %{_mandir}/man8/zpool-reguid.8*
548 %{_mandir}/man8/zpool-remove.8*
549 %{_mandir}/man8/zpool-reopen.8*
550 %{_mandir}/man8/zpool-replace.8*
551 %{_mandir}/man8/zpool-resilver.8*
552 %{_mandir}/man8/zpool-scrub.8*
553 %{_mandir}/man8/zpool-set.8*
554 %{_mandir}/man8/zpool-split.8*
555 %{_mandir}/man8/zpool-status.8*
556 %{_mandir}/man8/zpool-sync.8*
557 %{_mandir}/man8/zpool-trim.8*
558 %{_mandir}/man8/zpool-upgrade.8*
559 %{_mandir}/man8/zpool-wait.8*
560 %{_mandir}/man8/zpool_influxdb.8*
561 %{_mandir}/man8/zstream.8*
562 %{_mandir}/man8/zstreamdump.8*
563
564 %files libs
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
567 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
568 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
570 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
571 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
572 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
573 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
574 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
576 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
578
579 %files devel
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/libnvpair.so
582 %attr(755,root,root) %{_libdir}/libuutil.so
583 %attr(755,root,root) %{_libdir}/libzfs.so
584 %attr(755,root,root) %{_libdir}/libzfs_core.so
585 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
586 %attr(755,root,root) %{_libdir}/libzpool.so
587 %{_libdir}/libnvpair.la
588 %{_libdir}/libuutil.la
589 %{_libdir}/libzfs.la
590 %{_libdir}/libzfs_core.la
591 %{_libdir}/libzfsbootenv.la
592 %{_libdir}/libzpool.la
593 %{_includedir}/libspl
594 %{_includedir}/libzfs
595 %{_pkgconfigdir}/libzfs.pc
596 %{_pkgconfigdir}/libzfs_core.pc
597 %{_pkgconfigdir}/libzfsbootenv.pc
598
599 %files static
600 %defattr(644,root,root,755)
601 %{_libdir}/libnvpair.a
602 %{_libdir}/libuutil.a
603 %{_libdir}/libzfs.a
604 %{_libdir}/libzfs_core.a
605 %{_libdir}/libzfsbootenv.a
606 %{_libdir}/libzpool.a
607
608 %files -n dracut-zfs
609 %defattr(644,root,root,755)
610 %doc contrib/dracut/README.dracut.markdown
611 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
612 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
613 %dir %{dracutlibdir}/modules.d/90zfs
614 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
615 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
616 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
617 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
618 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
619 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
620 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
621 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
622 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
623 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
624 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
625 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
626 %{_mandir}/man7/dracut.zfs.7*
627
628 %files -n pam-pam_zfs_key
629 %defattr(644,root,root,755)
630 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
631
632 %if %{with python2}
633 %files -n python-pyzfs
634 %defattr(644,root,root,755)
635 %doc contrib/pyzfs/README
636 %{py_sitescriptdir}/libzfs_core
637 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
638 %endif
639
640 %if %{with python3}
641 %files -n python3-pyzfs
642 %defattr(644,root,root,755)
643 %doc contrib/pyzfs/README
644 %{py3_sitescriptdir}/libzfs_core
645 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
646 %endif
647 %endif
648
649 %if %{with kernel}
650 %files -n kernel-zfs-common-devel
651 %defattr(644,root,root,755)
652 %dir /usr/src/zfs-%{version}
653 /usr/src/zfs-%{version}/include
654 /usr/src/zfs-%{version}/zfs.release
655 /usr/src/zfs-%{version}/zfs_config.h
656 %endif
This page took 0.165771 seconds and 4 git commands to generate.