]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
- fixes for building with kernel 5.12, rel 2
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define rel     2
28 %define pname   zfs
29 Summary:        Native Linux port of the ZFS filesystem
30 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
31 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
32 Version:        2.0.4
33 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
34 License:        CDDL
35 Group:          Applications/System
36 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
37 # Source0-md5:  33976ba76135d6fc6f67e767a7242bd6
38 Patch0:         initdir.patch
39 Patch1:         am.patch
40 Patch2:         kernel-5.12.patch
41 URL:            https://zfsonlinux.org/
42 BuildRequires:  autoconf >= 2.50
43 BuildRequires:  automake
44 BuildRequires:  libtool
45 BuildRequires:  rpmbuild(macros) >= 1.714
46 %if %{with kernel}
47 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
48 %endif
49 %if %{with userspace}
50 # only for mmap_libaio test command
51 #BuildRequires: libaio-devel
52 BuildRequires:  libblkid-devel
53 BuildRequires:  libselinux-devel
54 BuildRequires:  libtirpc-devel
55 BuildRequires:  libuuid-devel
56 BuildRequires:  openssl-devel
57 BuildRequires:  pam-devel
58 BuildRequires:  pkgconfig
59 BuildRequires:  udev-devel
60 BuildRequires:  zlib-devel
61 %if %{with python2}
62 BuildRequires:  python-cffi
63 BuildRequires:  python-modules >= 1:2.6
64 BuildRequires:  python-setuptools
65 %endif
66 %if %{with python3}
67 BuildRequires:  python3-cffi
68 BuildRequires:  python3-modules >= 1:3.4
69 BuildRequires:  python3-setuptools
70 %endif
71 %if %{with python2} || %{with python3}
72 BuildRequires:  rpm-pythonprov
73 %endif
74 %endif
75 Requires:       %{pname}-libs = %{version}-%{release}
76 Obsoletes:      spl < 0.7.9-2
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         dracutlibdir    %{_prefix}/lib/dracut
80
81 %description
82 ZFS is an advanced file system and volume manager which was originally
83 developed for Solaris and is now maintained by the Illumos community.
84
85 ZFS on Linux, which is also known as ZoL, is currently feature
86 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
87 ZPL layers.
88
89 %description -l pl.UTF-8
90 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
91 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
92
93 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
94 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
95 SPA, DMU, ZVOL i ZPL.
96
97 %package libs
98 Summary:        ZFS on Linux libraries
99 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
100 License:        CDDL
101 Group:          Libraries
102 Requires(post,postun):  /sbin/ldconfig
103
104 %description libs
105 ZFS on Linux libraries.
106
107 %description libs -l pl.UTF-8
108 Biblioteki ZFS-a dla Linuksa.
109
110 %package devel
111 Summary:        Header files for ZFS libraries
112 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
113 License:        CDDL
114 Group:          Development/Libraries
115 Requires:       %{pname}-libs = %{version}-%{release}
116 Requires:       libselinux-devel
117 Requires:       libtirpc-devel
118 Requires:       libuuid-devel
119 Requires:       zlib-devel
120
121 %description devel
122 Header files for ZFS libraries.
123
124 %description devel -l pl.UTF-8
125 Pliki nagłówkowe bibliotek ZFS-a.
126
127 %package static
128 Summary:        Static ZFS libraries
129 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
130 License:        CDDL
131 Group:          Development/Libraries
132 Requires:       %{pname}-devel = %{version}-%{release}
133
134 %description static
135 Static ZFS libraries.
136
137 %description static -l pl.UTF-8
138 Statyczne biblioteki ZFS-a.
139
140 %package -n dracut-zfs
141 Summary:        ZFS support for Dracut
142 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
143 Group:          Applications/System
144 Requires:       %{pname} = %{version}-%{release}
145 Requires:       dracut
146
147 %description -n dracut-zfs
148 ZFS support for Dracut.
149
150 %description -n dracut-zfs -l pl.UTF-8
151 Obsługa ZFS-a dla Dracuta.
152
153 %package -n pam-pam_zfs_key
154 Summary:        PAM module to unlock ZFS datasets for user
155 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
156 Group:          Libraries
157 Requires:       %{pname}-libs = %{version}-%{release}
158 Requires:       pam
159
160 %description -n pam-pam_zfs_key
161 PAM module to unlock ZFS datasets for user.
162
163 %description -n pam-pam_zfs_key -l pl.UTF-8
164 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
165
166 %package -n python-pyzfs
167 Summary:        Python 2 wrapper for libzfs_core C library
168 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
169 License:        Apache v2.0
170 Group:          Libraries/Python
171 Requires:       %{pname}-libs = %{version}-%{release}
172
173 %description -n python-pyzfs
174 Python 2 wrapper for libzfs_core C library.
175
176 %description -n python-pyzfs -l pl.UTF-8
177 Interfejs Pythona 2 do biblioteki C libzfs_core.
178
179 %package -n python3-pyzfs
180 Summary:        Python 3 wrapper for libzfs_core C library
181 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
182 License:        Apache v2.0
183 Group:          Libraries/Python
184 Requires:       %{pname}-libs = %{version}-%{release}
185
186 %description -n python3-pyzfs
187 Python 3 wrapper for libzfs_core C library.
188
189 %description -n python3-pyzfs -l pl.UTF-8
190 Interfejs Pythona 3 do biblioteki C libzfs_core.
191
192 %package -n kernel-zfs-common-devel
193 Summary:        ZFS Linux kernel headers
194 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
195 Group:          Development/Building
196 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
197
198 %description -n kernel-zfs-common-devel
199 ZFS Linux kernel headers common for all PLD kernel versions.
200
201 %description -n kernel-zfs-common-devel -l pl.UTF-8
202 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
203 wersji jąder PLD.
204
205 %define kernel_pkg()\
206 %package -n kernel%{_alt_kernel}-zfs\
207 Summary:        ZFS Linux kernel modules\
208 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
209 Release:        %{rel}@%{_kernel_ver_str}\
210 Group:          Base/Kernel\
211 Requires(post,postun):  /sbin/depmod\
212 %requires_releq_kernel\
213 Requires(postun):       %releq_kernel\
214 \
215 %description -n kernel%{_alt_kernel}-zfs\
216 ZFS Linux kernel modules.\
217 \
218 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
219 ZFS - moduły jądra Linuksa.\
220 \
221 %package -n kernel%{_alt_kernel}-zfs-devel\
222 Summary:        ZFS Linux kernel headers\
223 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
224 Release:        %{rel}@%{_kernel_ver_str}\
225 Group:          Development/Building\
226 Requires:       kernel%{_alt_kernel}-headers\
227 Requires:       kernel-zfs-common-devel\
228 Obsoletes:      kernel-spl-devel < 0.7.9-2\
229 \
230 %description -n kernel%{_alt_kernel}-zfs-devel\
231 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
232 version %{_kernel_ver}.\
233 \
234 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
235 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
236 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
237 \
238 %files -n kernel%{_alt_kernel}-zfs\
239 %defattr(644,root,root,755)\
240 %dir /lib/modules/%{_kernel_ver}/misc/lua\
241 /lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
242 %dir /lib/modules/%{_kernel_ver}/misc/avl\
243 /lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
244 %dir /lib/modules/%{_kernel_ver}/misc/icp\
245 /lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
246 %dir /lib/modules/%{_kernel_ver}/misc/nvpair\
247 /lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
248 %dir /lib/modules/%{_kernel_ver}/misc/spl\
249 /lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
250 %dir /lib/modules/%{_kernel_ver}/misc/unicode\
251 /lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
252 %dir /lib/modules/%{_kernel_ver}/misc/zcommon\
253 /lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
254 %dir /lib/modules/%{_kernel_ver}/misc/zfs\
255 /lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
256 %dir /lib/modules/%{_kernel_ver}/misc/zstd\
257 /lib/modules/%{_kernel_ver}/misc/zstd/zzstd.ko*\
258 \
259 %files -n kernel%{_alt_kernel}-zfs-devel\
260 %defattr(644,root,root,755)\
261 /usr/src/zfs-%{version}/%{_kernel_ver}\
262 \
263 %post   -n kernel%{_alt_kernel}-zfs\
264 %depmod %{_kernel_ver}\
265 \
266 %postun -n kernel%{_alt_kernel}-zfs\
267 %depmod %{_kernel_ver}\
268 %{nil}
269
270 %define build_kernel_pkg()\
271 %configure \\\
272         --disable-silent-rules \\\
273         --with-config="kernel" \\\
274         --with-linux=%{_kernelsrcdir}\\\
275         --with-linux-obj=%{_kernelsrcdir}\
276 \
277 %{__make} clean\
278 %{__make} %{?with_verbose:V=1}\
279 p=`pwd`\
280 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
281 %{nil}
282
283 %{?with_kernel:%{expand:%create_kernel_packages}}
284
285 %prep
286 %setup -q -n %{pname}-%{version}
287 %patch0 -p1
288 %patch1 -p1
289 %patch2 -p1
290
291 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
292       cmd/arc_summary/arc_summary2
293
294 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
295       cmd/arc_summary/arc_summary3
296
297 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
298       cmd/arcstat/arcstat.in \
299       cmd/dbufstat/dbufstat.in
300
301 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
302       contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
303       contrib/dracut/90zfs/module-setup.sh.in \
304       scripts/zimport.sh \
305       scripts/zloop.sh
306
307 %build
308 %{__libtoolize}
309 %{__aclocal} -I config
310 %{__autoconf}
311 %{__autoheader}
312 %{__automake}
313 %{?with_kernel:%{expand:%build_kernel_packages}}
314
315 %if %{with userspace}
316 %configure \
317         --disable-silent-rules \
318         --enable-pam \
319         --enable-systemd \
320         --with-config="user" \
321         --with-linux=%{_kernelsrcdir} \
322         --with-pammoduledir=/%{_lib}/security \
323         --with-systemdunitdir=%{systemdunitdir} \
324         --with-systemdpresetdir=/etc/systemd/system-preset \
325         --with-systemdmodulesloaddir=/etc/modules-load.d \
326         --with-systemdgeneratordir=/lib/systemd/system-generators \
327         --with-udevdir=/lib/udev
328
329 %{__make} \
330         %{?with_verbose:V=1}
331
332 %if %{with python2}
333 cd contrib/pyzfs
334 %py_build
335 cd ../..
336 %endif
337
338 %if %{with python3}
339 cd contrib/pyzfs
340 %py3_build
341 cd ../..
342 %endif
343 %endif
344
345 %install
346 rm -rf $RPM_BUILD_ROOT
347
348 %if %{with kernel}
349 install -d $RPM_BUILD_ROOT
350 cp -a installed/* $RPM_BUILD_ROOT
351 # Drop unneeded spl compat links
352 %{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
353 %endif
354
355 %if %{with userspace}
356 %{__make} install \
357         DESTDIR=$RPM_BUILD_ROOT \
358         DEFAULT_INIT_DIR=/etc/rc.d/init.d
359
360 %if %{with python2}
361 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
362 cd contrib/pyzfs
363 %py_install
364
365 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
366 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
367
368 %py_postclean
369 cd ../..
370 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
371 %endif
372
373 %if %{with python3}
374 %{__rm} -r $RPM_BUILD_ROOT/usr/local/%{_lib}/python3*
375 cd contrib/pyzfs
376 %py3_install
377 cd ../..
378 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
379 %endif
380
381 # Debian specific stuff
382 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
383
384 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
385 # Ubuntu PAM config framework file
386 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
387
388 # Package these? These are integration tests of the implementation.
389 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
390 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
391 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
392 %endif
393
394 %clean
395 rm -rf $RPM_BUILD_ROOT
396
397 %post   libs -p /sbin/ldconfig
398 %postun libs -p /sbin/ldconfig
399
400 %if %{with userspace}
401 %files
402 %defattr(644,root,root,755)
403 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
404 %attr(755,root,root) /sbin/mount.zfs
405 %attr(755,root,root) %{_bindir}/arc_summary
406 %attr(755,root,root) %{_bindir}/arcstat
407 %attr(755,root,root) %{_bindir}/dbufstat
408 %attr(755,root,root) %{_bindir}/zvol_wait
409 %attr(755,root,root) %{_sbindir}/fsck.zfs
410 %attr(755,root,root) %{_sbindir}/zdb
411 %attr(755,root,root) %{_sbindir}/zed
412 %attr(755,root,root) %{_sbindir}/zfs
413 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
414 %attr(755,root,root) %{_sbindir}/zgenhostid
415 %attr(755,root,root) %{_sbindir}/zhack
416 %attr(755,root,root) %{_sbindir}/zinject
417 %attr(755,root,root) %{_sbindir}/zpool
418 %attr(755,root,root) %{_sbindir}/zstream
419 %attr(755,root,root) %{_sbindir}/zstreamdump
420 %attr(755,root,root) %{_sbindir}/ztest
421 %dir %{_sysconfdir}/zfs
422 # package *.example as %doc? (they cannot act as default configuration)
423 %{_sysconfdir}/zfs/vdev_id.conf.*.example
424 %dir %{_sysconfdir}/zfs/zed.d
425 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
426 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
427 %dir %{_sysconfdir}/zfs/zpool.d
428 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
429 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
430 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
431 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
432 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
433 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
434 /etc/zfs/zfs-functions
435 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
436 # for zpool iostat/status -c smart
437 #/ets/sudoers.d/zfs
438 /etc/systemd/system-preset/50-zfs.preset
439 /lib/systemd/system-generators/zfs-mount-generator
440 %{systemdunitdir}/zfs.target
441 %{systemdunitdir}/zfs-import.service
442 %{systemdunitdir}/zfs-import.target
443 %{systemdunitdir}/zfs-import-cache.service
444 %{systemdunitdir}/zfs-import-scan.service
445 %{systemdunitdir}/zfs-mount.service
446 %{systemdunitdir}/zfs-share.service
447 %{systemdunitdir}/zfs-volume-wait.service
448 %{systemdunitdir}/zfs-volumes.target
449 %{systemdunitdir}/zfs-zed.service
450 %attr(755,root,root) /lib/udev/vdev_id
451 %attr(755,root,root) /lib/udev/zvol_id
452 /lib/udev/rules.d/60-zvol.rules
453 /lib/udev/rules.d/69-vdev.rules
454 /lib/udev/rules.d/90-zfs.rules
455 %dir %{_libexecdir}/zfs
456 %dir %{_libexecdir}/zfs/zed.d
457 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
458 %dir %{_libexecdir}/zfs/zpool.d
459 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
460 %dir %{_datadir}/zfs
461 %attr(755,root,root) %{_datadir}/zfs/*.sh
462 %{_mandir}/man1/arcstat.1*
463 %{_mandir}/man1/zhack.1*
464 %{_mandir}/man1/ztest.1*
465 %{_mandir}/man1/zvol_wait.1*
466 %{_mandir}/man5/spl-module-parameters.5*
467 %{_mandir}/man5/vdev_id.conf.5*
468 %{_mandir}/man5/zfs-events.5*
469 %{_mandir}/man5/zfs-module-parameters.5*
470 %{_mandir}/man5/zpool-features.5*
471 %{_mandir}/man8/fsck.zfs.8*
472 %{_mandir}/man8/mount.zfs.8*
473 %{_mandir}/man8/vdev_id.8*
474 %{_mandir}/man8/zdb.8*
475 %{_mandir}/man8/zed.8*
476 %{_mandir}/man8/zfs.8*
477 %{_mandir}/man8/zfs-allow.8*
478 %{_mandir}/man8/zfs-bookmark.8*
479 %{_mandir}/man8/zfs-change-key.8*
480 %{_mandir}/man8/zfs-clone.8*
481 %{_mandir}/man8/zfs-create.8*
482 %{_mandir}/man8/zfs-destroy.8*
483 %{_mandir}/man8/zfs-diff.8*
484 %{_mandir}/man8/zfs-get.8*
485 %{_mandir}/man8/zfs-groupspace.8*
486 %{_mandir}/man8/zfs-hold.8*
487 %{_mandir}/man8/zfs-inherit.8*
488 %{_mandir}/man8/zfs-jail.8*
489 %{_mandir}/man8/zfs-list.8*
490 %{_mandir}/man8/zfs-load-key.8*
491 %{_mandir}/man8/zfs-mount.8*
492 %{_mandir}/man8/zfs-mount-generator.8*
493 %{_mandir}/man8/zfs-program.8*
494 %{_mandir}/man8/zfs-project.8*
495 %{_mandir}/man8/zfs-projectspace.8*
496 %{_mandir}/man8/zfs-promote.8*
497 %{_mandir}/man8/zfs-receive.8*
498 %{_mandir}/man8/zfs-recv.8*
499 %{_mandir}/man8/zfs-redact.8*
500 %{_mandir}/man8/zfs-release.8*
501 %{_mandir}/man8/zfs-rename.8*
502 %{_mandir}/man8/zfs-rollback.8*
503 %{_mandir}/man8/zfs-send.8*
504 %{_mandir}/man8/zfs-set.8*
505 %{_mandir}/man8/zfs-share.8*
506 %{_mandir}/man8/zfs-snapshot.8*
507 %{_mandir}/man8/zfs-unallow.8*
508 %{_mandir}/man8/zfs-unjail.8*
509 %{_mandir}/man8/zfs-unload-key.8*
510 %{_mandir}/man8/zfs-unmount.8*
511 %{_mandir}/man8/zfs-upgrade.8*
512 %{_mandir}/man8/zfs-userspace.8*
513 %{_mandir}/man8/zfs-wait.8*
514 %{_mandir}/man8/zfs_ids_to_path.8*
515 %{_mandir}/man8/zfsconcepts.8*
516 %{_mandir}/man8/zfsprops.8*
517 %{_mandir}/man8/zgenhostid.8*
518 %{_mandir}/man8/zinject.8*
519 %{_mandir}/man8/zpool.8*
520 %{_mandir}/man8/zpool-add.8*
521 %{_mandir}/man8/zpool-attach.8*
522 %{_mandir}/man8/zpool-checkpoint.8*
523 %{_mandir}/man8/zpool-clear.8*
524 %{_mandir}/man8/zpool-create.8*
525 %{_mandir}/man8/zpool-destroy.8*
526 %{_mandir}/man8/zpool-detach.8*
527 %{_mandir}/man8/zpool-events.8*
528 %{_mandir}/man8/zpool-export.8*
529 %{_mandir}/man8/zpool-get.8*
530 %{_mandir}/man8/zpool-history.8*
531 %{_mandir}/man8/zpool-import.8*
532 %{_mandir}/man8/zpool-initialize.8*
533 %{_mandir}/man8/zpool-iostat.8*
534 %{_mandir}/man8/zpool-labelclear.8*
535 %{_mandir}/man8/zpool-list.8*
536 %{_mandir}/man8/zpool-offline.8*
537 %{_mandir}/man8/zpool-online.8*
538 %{_mandir}/man8/zpool-reguid.8*
539 %{_mandir}/man8/zpool-remove.8*
540 %{_mandir}/man8/zpool-reopen.8*
541 %{_mandir}/man8/zpool-replace.8*
542 %{_mandir}/man8/zpool-resilver.8*
543 %{_mandir}/man8/zpool-scrub.8*
544 %{_mandir}/man8/zpool-set.8*
545 %{_mandir}/man8/zpool-split.8*
546 %{_mandir}/man8/zpool-status.8*
547 %{_mandir}/man8/zpool-sync.8*
548 %{_mandir}/man8/zpool-trim.8*
549 %{_mandir}/man8/zpool-upgrade.8*
550 %{_mandir}/man8/zpool-wait.8*
551 %{_mandir}/man8/zpoolconcepts.8*
552 %{_mandir}/man8/zpoolprops.8*
553 %{_mandir}/man8/zstream.8*
554 %{_mandir}/man8/zstreamdump.8*
555
556 %files libs
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
559 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
560 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
561 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
562 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
563 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
564 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
565 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
566 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
567 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
568 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
569 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.4
570
571 %files devel
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/libnvpair.so
574 %attr(755,root,root) %{_libdir}/libuutil.so
575 %attr(755,root,root) %{_libdir}/libzfs.so
576 %attr(755,root,root) %{_libdir}/libzfs_core.so
577 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
578 %attr(755,root,root) %{_libdir}/libzpool.so
579 %{_libdir}/libnvpair.la
580 %{_libdir}/libuutil.la
581 %{_libdir}/libzfs.la
582 %{_libdir}/libzfs_core.la
583 %{_libdir}/libzfsbootenv.la
584 %{_libdir}/libzpool.la
585 %{_includedir}/libspl
586 %{_includedir}/libzfs
587 %{_pkgconfigdir}/libzfs.pc
588 %{_pkgconfigdir}/libzfs_core.pc
589 %{_pkgconfigdir}/libzfsbootenv.pc
590
591 %files static
592 %defattr(644,root,root,755)
593 %{_libdir}/libnvpair.a
594 %{_libdir}/libuutil.a
595 %{_libdir}/libzfs.a
596 %{_libdir}/libzfs_core.a
597 %{_libdir}/libzfsbootenv.a
598 %{_libdir}/libzpool.a
599
600 %files -n dracut-zfs
601 %defattr(644,root,root,755)
602 %doc contrib/dracut/README.dracut.markdown
603 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
604 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
605 %dir %{dracutlibdir}/modules.d/90zfs
606 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
607 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
608 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
609 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
610 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
611 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
612 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
613 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
614 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
615 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
616 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
617
618 %files -n pam-pam_zfs_key
619 %defattr(644,root,root,755)
620 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
621
622 %if %{with python2}
623 %files -n python-pyzfs
624 %defattr(644,root,root,755)
625 %doc contrib/pyzfs/README
626 %{py_sitescriptdir}/libzfs_core
627 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
628 %endif
629
630 %if %{with python3}
631 %files -n python3-pyzfs
632 %defattr(644,root,root,755)
633 %doc contrib/pyzfs/README
634 %{py3_sitescriptdir}/libzfs_core
635 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
636 %endif
637 %endif
638
639 %if %{with kernel}
640 %files -n kernel-zfs-common-devel
641 %defattr(644,root,root,755)
642 %dir /usr/src/zfs-%{version}
643 /usr/src/zfs-%{version}/include
644 /usr/src/zfs-%{version}/zfs.release
645 /usr/src/zfs-%{version}/zfs_config.h
646 %endif
This page took 0.134207 seconds and 4 git commands to generate.