]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
- upstream fixes for kernel 6.6
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define rel     1
28 %define pname   zfs
29 Summary:        Native Linux port of the ZFS filesystem
30 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
31 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
32 Version:        2.2.0
33 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
34 License:        CDDL
35 Group:          Applications/System
36 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
37 # Source0-md5:  d7e2ec4c52d6a48653ce4a5b96c24a01
38 Patch0:         initdir.patch
39 Patch1:         kernel-6.6.patch
40 URL:            https://zfsonlinux.org/
41 BuildRequires:  autoconf >= 2.50
42 BuildRequires:  automake
43 BuildRequires:  libtool
44 BuildRequires:  rpmbuild(macros) >= 1.714
45 %if %{with kernel}
46 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
47 %endif
48 %if %{with userspace}
49 # only for mmap_libaio test command
50 #BuildRequires: libaio-devel
51 BuildRequires:  libblkid-devel
52 BuildRequires:  libselinux-devel
53 BuildRequires:  libtirpc-devel
54 BuildRequires:  libuuid-devel
55 BuildRequires:  openssl-devel
56 BuildRequires:  pam-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  udev-devel
59 BuildRequires:  zlib-devel
60 %if %{with python2}
61 BuildRequires:  python-cffi
62 BuildRequires:  python-modules >= 1:2.6
63 BuildRequires:  python-setuptools
64 %endif
65 %if %{with python3}
66 BuildRequires:  python3-cffi
67 BuildRequires:  python3-modules >= 1:3.4
68 BuildRequires:  python3-setuptools
69 %endif
70 %if %{with python2} || %{with python3}
71 BuildRequires:  rpm-pythonprov
72 %endif
73 %endif
74 Requires:       %{pname}-libs = %{version}-%{release}
75 Obsoletes:      spl < 0.7.9-2
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         dracutlibdir    %{_prefix}/lib/dracut
79
80 %description
81 ZFS is an advanced file system and volume manager which was originally
82 developed for Solaris and is now maintained by the Illumos community.
83
84 ZFS on Linux, which is also known as ZoL, is currently feature
85 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
86 ZPL layers.
87
88 %description -l pl.UTF-8
89 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
90 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
91
92 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
93 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
94 SPA, DMU, ZVOL i ZPL.
95
96 %package libs
97 Summary:        ZFS on Linux libraries
98 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
99 License:        CDDL
100 Group:          Libraries
101 Requires(post,postun):  /sbin/ldconfig
102
103 %description libs
104 ZFS on Linux libraries.
105
106 %description libs -l pl.UTF-8
107 Biblioteki ZFS-a dla Linuksa.
108
109 %package devel
110 Summary:        Header files for ZFS libraries
111 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
112 License:        CDDL
113 Group:          Development/Libraries
114 Requires:       %{pname}-libs = %{version}-%{release}
115 Requires:       libselinux-devel
116 Requires:       libtirpc-devel
117 Requires:       libuuid-devel
118 Requires:       zlib-devel
119
120 %description devel
121 Header files for ZFS libraries.
122
123 %description devel -l pl.UTF-8
124 Pliki nagłówkowe bibliotek ZFS-a.
125
126 %package static
127 Summary:        Static ZFS libraries
128 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
129 License:        CDDL
130 Group:          Development/Libraries
131 Requires:       %{pname}-devel = %{version}-%{release}
132
133 %description static
134 Static ZFS libraries.
135
136 %description static -l pl.UTF-8
137 Statyczne biblioteki ZFS-a.
138
139 %package -n dracut-zfs
140 Summary:        ZFS support for Dracut
141 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
142 Group:          Applications/System
143 Requires:       %{pname} = %{version}-%{release}
144 Requires:       dracut
145
146 %description -n dracut-zfs
147 ZFS support for Dracut.
148
149 %description -n dracut-zfs -l pl.UTF-8
150 Obsługa ZFS-a dla Dracuta.
151
152 %package -n pam-pam_zfs_key
153 Summary:        PAM module to unlock ZFS datasets for user
154 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
155 Group:          Libraries
156 Requires:       %{pname}-libs = %{version}-%{release}
157 Requires:       pam
158
159 %description -n pam-pam_zfs_key
160 PAM module to unlock ZFS datasets for user.
161
162 %description -n pam-pam_zfs_key -l pl.UTF-8
163 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
164
165 %package -n python-pyzfs
166 Summary:        Python 2 wrapper for libzfs_core C library
167 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
168 License:        Apache v2.0
169 Group:          Libraries/Python
170 Requires:       %{pname}-libs = %{version}-%{release}
171
172 %description -n python-pyzfs
173 Python 2 wrapper for libzfs_core C library.
174
175 %description -n python-pyzfs -l pl.UTF-8
176 Interfejs Pythona 2 do biblioteki C libzfs_core.
177
178 %package -n python3-pyzfs
179 Summary:        Python 3 wrapper for libzfs_core C library
180 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
181 License:        Apache v2.0
182 Group:          Libraries/Python
183 Requires:       %{pname}-libs = %{version}-%{release}
184
185 %description -n python3-pyzfs
186 Python 3 wrapper for libzfs_core C library.
187
188 %description -n python3-pyzfs -l pl.UTF-8
189 Interfejs Pythona 3 do biblioteki C libzfs_core.
190
191 %package -n kernel-zfs-common-devel
192 Summary:        ZFS Linux kernel headers
193 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
194 Group:          Development/Building
195 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
196
197 %description -n kernel-zfs-common-devel
198 ZFS Linux kernel headers common for all PLD kernel versions.
199
200 %description -n kernel-zfs-common-devel -l pl.UTF-8
201 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
202 wersji jąder PLD.
203
204 %define kernel_pkg()\
205 %package -n kernel%{_alt_kernel}-zfs\
206 Summary:        ZFS Linux kernel modules\
207 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
208 Release:        %{rel}@%{_kernel_ver_str}\
209 Group:          Base/Kernel\
210 Requires(post,postun):  /sbin/depmod\
211 %requires_releq_kernel\
212 Requires(postun):       %releq_kernel\
213 \
214 %description -n kernel%{_alt_kernel}-zfs\
215 ZFS Linux kernel modules.\
216 \
217 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
218 ZFS - moduły jądra Linuksa.\
219 \
220 %package -n kernel%{_alt_kernel}-zfs-devel\
221 Summary:        ZFS Linux kernel headers\
222 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
223 Release:        %{rel}@%{_kernel_ver_str}\
224 Group:          Development/Building\
225 Requires:       kernel%{_alt_kernel}-headers\
226 Requires:       kernel-zfs-common-devel\
227 Obsoletes:      kernel-spl-devel < 0.7.9-2\
228 \
229 %description -n kernel%{_alt_kernel}-zfs-devel\
230 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
231 version %{_kernel_ver}.\
232 \
233 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
234 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
235 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
236 \
237 %files -n kernel%{_alt_kernel}-zfs\
238 %defattr(644,root,root,755)\
239 /lib/modules/%{_kernel_ver}/misc/spl.ko*\
240 /lib/modules/%{_kernel_ver}/misc/zfs.ko*\
241 \
242 %files -n kernel%{_alt_kernel}-zfs-devel\
243 %defattr(644,root,root,755)\
244 /usr/src/zfs-%{version}/%{_kernel_ver}\
245 \
246 %post   -n kernel%{_alt_kernel}-zfs\
247 %depmod %{_kernel_ver}\
248 \
249 %postun -n kernel%{_alt_kernel}-zfs\
250 %depmod %{_kernel_ver}\
251 %{nil}
252
253 %define build_kernel_pkg()\
254 %configure \\\
255         --disable-silent-rules \\\
256         --with-config="kernel" \\\
257         --with-linux=%{_kernelsrcdir}\\\
258         --with-linux-obj=%{_kernelsrcdir}\
259 \
260 %{__make} clean\
261 %{__make} %{?with_verbose:V=1}\
262 p=`pwd`\
263 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
264 %{nil}
265
266 %{?with_kernel:%{expand:%create_kernel_packages}}
267
268 %prep
269 %setup -q -n %{pname}-%{version}
270 %patch0 -p1
271 %patch1 -p1
272
273 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
274       cmd/arc_summary
275
276 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
277       cmd/arcstat.in \
278       cmd/dbufstat.in \
279       cmd/zilstat.in
280
281 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
282       contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
283       contrib/dracut/90zfs/module-setup.sh.in \
284       scripts/zimport.sh \
285       scripts/zloop.sh
286
287 %build
288 %{__libtoolize}
289 %{__aclocal} -I config
290 %{__autoconf}
291 %{__autoheader}
292 %{__automake}
293 %{?with_kernel:%{expand:%build_kernel_packages}}
294
295 %if %{with userspace}
296 %configure \
297         --disable-silent-rules \
298         --enable-pam \
299         --enable-systemd \
300         --with-config="user" \
301         --with-linux=%{_kernelsrcdir} \
302         --with-pammoduledir=/%{_lib}/security \
303         --with-systemdunitdir=%{systemdunitdir} \
304         --with-systemdpresetdir=/etc/systemd/system-preset \
305         --with-systemdmodulesloaddir=/etc/modules-load.d \
306         --with-systemdgeneratordir=/lib/systemd/system-generators \
307         --with-udevdir=/lib/udev
308
309 %{__make} \
310         %{?with_verbose:V=1}
311
312 %if %{with python2}
313 cd contrib/pyzfs
314 %py_build
315 cd ../..
316 %endif
317
318 %if %{with python3}
319 cd contrib/pyzfs
320 %py3_build
321 cd ../..
322 %endif
323 %endif
324
325 %install
326 rm -rf $RPM_BUILD_ROOT
327
328 %if %{with kernel}
329 install -d $RPM_BUILD_ROOT
330 cp -a installed/* $RPM_BUILD_ROOT
331 %endif
332
333 %if %{with userspace}
334 %{__make} install \
335         DESTDIR=$RPM_BUILD_ROOT \
336         DEFAULT_INIT_DIR=/etc/rc.d/init.d
337
338 %if %{with python2}
339 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
340 cd contrib/pyzfs
341 %py_install
342
343 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
344 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
345
346 %py_postclean
347 cd ../..
348 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
349 %endif
350
351 %if %{with python3}
352 cd contrib/pyzfs
353 %py3_install
354 cd ../..
355 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
356 %endif
357
358 # Debian specific stuff
359 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
360
361 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
362 # Ubuntu PAM config framework file
363 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
364
365 # Package these? These are integration tests of the implementation.
366 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
367 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
368 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
369 %endif
370
371 %clean
372 rm -rf $RPM_BUILD_ROOT
373
374 %post   libs -p /sbin/ldconfig
375 %postun libs -p /sbin/ldconfig
376
377 %if %{with userspace}
378 %files
379 %defattr(644,root,root,755)
380 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
381 %attr(755,root,root) /sbin/mount.zfs
382 %attr(755,root,root) %{_bindir}/arc_summary
383 %attr(755,root,root) %{_bindir}/arcstat
384 %attr(755,root,root) %{_bindir}/dbufstat
385 %attr(755,root,root) %{_bindir}/zilstat
386 %attr(755,root,root) %{_bindir}/zvol_wait
387 %attr(755,root,root) %{_sbindir}/fsck.zfs
388 %attr(755,root,root) %{_sbindir}/zdb
389 %attr(755,root,root) %{_sbindir}/zed
390 %attr(755,root,root) %{_sbindir}/zfs
391 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
392 %attr(755,root,root) %{_sbindir}/zgenhostid
393 %attr(755,root,root) %{_sbindir}/zhack
394 %attr(755,root,root) %{_sbindir}/zinject
395 %attr(755,root,root) %{_sbindir}/zpool
396 %attr(755,root,root) %{_sbindir}/zstream
397 %attr(755,root,root) %{_sbindir}/zstreamdump
398 %attr(755,root,root) %{_sbindir}/ztest
399 %dir %{_sysconfdir}/zfs
400 # package *.example as %doc? (they cannot act as default configuration)
401 %{_sysconfdir}/zfs/vdev_id.conf.*.example
402 %dir %{_sysconfdir}/zfs/zed.d
403 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
404 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
405 %dir %{_sysconfdir}/zfs/zpool.d
406 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
407 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
408 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
409 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
410 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
411 %attr(754,root,root) /etc/rc.d/init.d/zfs-load-key
412 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
413 /etc/zfs/zfs-functions
414 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
415 # for zpool iostat/status -c smart
416 #/ets/sudoers.d/zfs
417 /etc/systemd/system-preset/50-zfs.preset
418 /lib/systemd/system-generators/zfs-mount-generator
419 %{systemdunitdir}/zfs.target
420 %{systemdunitdir}/zfs-import.service
421 %{systemdunitdir}/zfs-import.target
422 %{systemdunitdir}/zfs-import-cache.service
423 %{systemdunitdir}/zfs-import-scan.service
424 %{systemdunitdir}/zfs-load-key.service
425 %{systemdunitdir}/zfs-mount.service
426 %{systemdunitdir}/zfs-scrub@.service
427 %{systemdunitdir}/zfs-scrub-monthly@.timer
428 %{systemdunitdir}/zfs-scrub-weekly@.timer
429 %{systemdunitdir}/zfs-share.service
430 %{systemdunitdir}/zfs-trim-monthly@.timer
431 %{systemdunitdir}/zfs-trim-weekly@.timer
432 %{systemdunitdir}/zfs-trim@.service
433 %{systemdunitdir}/zfs-volume-wait.service
434 %{systemdunitdir}/zfs-volumes.target
435 %{systemdunitdir}/zfs-zed.service
436 %attr(755,root,root) /lib/udev/vdev_id
437 %attr(755,root,root) /lib/udev/zvol_id
438 /lib/udev/rules.d/60-zvol.rules
439 /lib/udev/rules.d/69-vdev.rules
440 /lib/udev/rules.d/90-zfs.rules
441 %dir %{_libexecdir}/zfs
442 %dir %{_libexecdir}/zfs/zed.d
443 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
444 %dir %{_libexecdir}/zfs/zpool.d
445 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
446 %dir %{_datadir}/zfs
447 %attr(755,root,root) %{_datadir}/zfs/*.sh
448 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
449 %{_datadir}/zfs/compatibility.d
450 %{_mandir}/man1/arcstat.1*
451 %{_mandir}/man1/zhack.1*
452 %{_mandir}/man1/ztest.1*
453 %{_mandir}/man1/zvol_wait.1*
454 %{_mandir}/man4/spl.4*
455 %{_mandir}/man4/zfs.4*
456 %{_mandir}/man5/vdev_id.conf.5*
457 %{_mandir}/man7/vdevprops.7*
458 %{_mandir}/man7/zfsconcepts.7*
459 %{_mandir}/man7/zfsprops.7*
460 %{_mandir}/man7/zpool-features.7*
461 %{_mandir}/man7/zpoolconcepts.7*
462 %{_mandir}/man7/zpoolprops.7*
463 %{_mandir}/man8/fsck.zfs.8*
464 %{_mandir}/man8/mount.zfs.8*
465 %{_mandir}/man8/vdev_id.8*
466 %{_mandir}/man8/zdb.8*
467 %{_mandir}/man8/zed.8*
468 %{_mandir}/man8/zfs.8*
469 %{_mandir}/man8/zfs-allow.8*
470 %{_mandir}/man8/zfs-bookmark.8*
471 %{_mandir}/man8/zfs-change-key.8*
472 %{_mandir}/man8/zfs-clone.8*
473 %{_mandir}/man8/zfs-create.8*
474 %{_mandir}/man8/zfs-destroy.8*
475 %{_mandir}/man8/zfs-diff.8*
476 %{_mandir}/man8/zfs-get.8*
477 %{_mandir}/man8/zfs-groupspace.8*
478 %{_mandir}/man8/zfs-hold.8*
479 %{_mandir}/man8/zfs-inherit.8*
480 %{_mandir}/man8/zfs-list.8*
481 %{_mandir}/man8/zfs-load-key.8*
482 %{_mandir}/man8/zfs-mount.8*
483 %{_mandir}/man8/zfs-mount-generator.8*
484 %{_mandir}/man8/zfs-program.8*
485 %{_mandir}/man8/zfs-project.8*
486 %{_mandir}/man8/zfs-projectspace.8*
487 %{_mandir}/man8/zfs-promote.8*
488 %{_mandir}/man8/zfs-receive.8*
489 %{_mandir}/man8/zfs-recv.8*
490 %{_mandir}/man8/zfs-redact.8*
491 %{_mandir}/man8/zfs-release.8*
492 %{_mandir}/man8/zfs-rename.8*
493 %{_mandir}/man8/zfs-rollback.8*
494 %{_mandir}/man8/zfs-send.8*
495 %{_mandir}/man8/zfs-set.8*
496 %{_mandir}/man8/zfs-share.8*
497 %{_mandir}/man8/zfs-snapshot.8*
498 %{_mandir}/man8/zfs-unallow.8*
499 %{_mandir}/man8/zfs-unload-key.8*
500 %{_mandir}/man8/zfs-unzone.8*
501 %{_mandir}/man8/zfs-unmount.8*
502 %{_mandir}/man8/zfs-upgrade.8*
503 %{_mandir}/man8/zfs-userspace.8*
504 %{_mandir}/man8/zfs-wait.8*
505 %{_mandir}/man8/zfs-zone.8*
506 %{_mandir}/man8/zfs_ids_to_path.8*
507 %{_mandir}/man8/zgenhostid.8*
508 %{_mandir}/man8/zinject.8*
509 %{_mandir}/man8/zpool.8*
510 %{_mandir}/man8/zpool-add.8*
511 %{_mandir}/man8/zpool-attach.8*
512 %{_mandir}/man8/zpool-checkpoint.8*
513 %{_mandir}/man8/zpool-clear.8*
514 %{_mandir}/man8/zpool-create.8*
515 %{_mandir}/man8/zpool-destroy.8*
516 %{_mandir}/man8/zpool-detach.8*
517 %{_mandir}/man8/zpool-events.8*
518 %{_mandir}/man8/zpool-export.8*
519 %{_mandir}/man8/zpool-get.8*
520 %{_mandir}/man8/zpool-history.8*
521 %{_mandir}/man8/zpool-import.8*
522 %{_mandir}/man8/zpool-initialize.8*
523 %{_mandir}/man8/zpool-iostat.8*
524 %{_mandir}/man8/zpool-labelclear.8*
525 %{_mandir}/man8/zpool-list.8*
526 %{_mandir}/man8/zpool-offline.8*
527 %{_mandir}/man8/zpool-online.8*
528 %{_mandir}/man8/zpool-reguid.8*
529 %{_mandir}/man8/zpool-remove.8*
530 %{_mandir}/man8/zpool-reopen.8*
531 %{_mandir}/man8/zpool-replace.8*
532 %{_mandir}/man8/zpool-resilver.8*
533 %{_mandir}/man8/zpool-scrub.8*
534 %{_mandir}/man8/zpool-set.8*
535 %{_mandir}/man8/zpool-split.8*
536 %{_mandir}/man8/zpool-status.8*
537 %{_mandir}/man8/zpool-sync.8*
538 %{_mandir}/man8/zpool-trim.8*
539 %{_mandir}/man8/zpool-upgrade.8*
540 %{_mandir}/man8/zpool-wait.8*
541 %{_mandir}/man8/zpool_influxdb.8*
542 %{_mandir}/man8/zstream.8*
543 %{_mandir}/man8/zstreamdump.8*
544
545 %files libs
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
548 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
549 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
550 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
551 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
552 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
553 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
554 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
555 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
556 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
557 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
559
560 %files devel
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/libnvpair.so
563 %attr(755,root,root) %{_libdir}/libuutil.so
564 %attr(755,root,root) %{_libdir}/libzfs.so
565 %attr(755,root,root) %{_libdir}/libzfs_core.so
566 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
567 %attr(755,root,root) %{_libdir}/libzpool.so
568 %{_libdir}/libnvpair.la
569 %{_libdir}/libuutil.la
570 %{_libdir}/libzfs.la
571 %{_libdir}/libzfs_core.la
572 %{_libdir}/libzfsbootenv.la
573 %{_libdir}/libzpool.la
574 %{_includedir}/libspl
575 %{_includedir}/libzfs
576 %{_pkgconfigdir}/libzfs.pc
577 %{_pkgconfigdir}/libzfs_core.pc
578 %{_pkgconfigdir}/libzfsbootenv.pc
579
580 %files static
581 %defattr(644,root,root,755)
582 %{_libdir}/libnvpair.a
583 %{_libdir}/libuutil.a
584 %{_libdir}/libzfs.a
585 %{_libdir}/libzfs_core.a
586 %{_libdir}/libzfsbootenv.a
587 %{_libdir}/libzpool.a
588
589 %files -n dracut-zfs
590 %defattr(644,root,root,755)
591 %doc contrib/dracut/README.md
592 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
593 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
594 %dir %{dracutlibdir}/modules.d/90zfs
595 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
596 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
597 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
598 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
599 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
600 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
601 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
602 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
603 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
604 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
605 %{dracutlibdir}/modules.d/90zfs/zfs-nonroot-necessities.service
606 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
607 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
608 %{_mandir}/man7/dracut.zfs.7*
609
610 %files -n pam-pam_zfs_key
611 %defattr(644,root,root,755)
612 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
613
614 %if %{with python2}
615 %files -n python-pyzfs
616 %defattr(644,root,root,755)
617 %doc contrib/pyzfs/README
618 %{py_sitescriptdir}/libzfs_core
619 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
620 %endif
621
622 %if %{with python3}
623 %files -n python3-pyzfs
624 %defattr(644,root,root,755)
625 %doc contrib/pyzfs/README
626 %{py3_sitescriptdir}/libzfs_core
627 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
628 %endif
629 %endif
630
631 %if %{with kernel}
632 %files -n kernel-zfs-common-devel
633 %defattr(644,root,root,755)
634 %dir /usr/src/zfs-%{version}
635 /usr/src/zfs-%{version}/include
636 /usr/src/zfs-%{version}/zfs.release.in
637 /usr/src/zfs-%{version}/zfs_config.h.in
638 %endif
This page took 0.471892 seconds and 3 git commands to generate.