]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
7bd749b5a6a72a80e766944eaa6521475bd8cc2f
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_without  static_libs     # static libraries
10 %bcond_with     verbose         # verbose build (V=1)
11 #
12 # The goal here is to have main, userspace, package built once with
13 # simple release number, and only rebuild kernel packages with kernel
14 # version as part of release number, without the need to bump release
15 # with every kernel change.
16 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
17 %{error:kernel and userspace cannot be built at the same time on PLD builders}
18 exit 1
19 %endif
20
21 %if %{without userspace}
22 # nothing to be placed to debuginfo package
23 %define         _enable_debug_packages  0
24 %endif
25
26 %define         _duplicate_files_terminate_build        0
27
28 %define rel     1
29 %define pname   zfs
30 Summary:        Native Linux port of the ZFS filesystem
31 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
32 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
33 Version:        2.2.2
34 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
35 License:        CDDL
36 Group:          Applications/System
37 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
38 # Source0-md5:  bbfea5e8d22e7484150038668d0d410a
39 Patch0:         initdir.patch
40 URL:            https://zfsonlinux.org/
41 BuildRequires:  autoconf >= 2.50
42 BuildRequires:  automake
43 BuildRequires:  libtool
44 BuildRequires:  rpmbuild(macros) >= 2.030
45 %if %{with kernel}
46 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
47 %endif
48 %if %{with userspace}
49 # only for mmap_libaio test command
50 #BuildRequires: libaio-devel
51 %ifnarch %arch_with_atomics64
52 BuildRequires:  libatomic-devel
53 %endif
54 BuildRequires:  libblkid-devel
55 BuildRequires:  libselinux-devel
56 BuildRequires:  libtirpc-devel
57 BuildRequires:  libuuid-devel
58 BuildRequires:  openssl-devel
59 BuildRequires:  pam-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  udev-devel
62 BuildRequires:  zlib-devel
63 %if %{with python2}
64 BuildRequires:  python >= 1:2.6
65 BuildRequires:  python-cffi
66 BuildRequires:  python-modules >= 1:2.6
67 BuildRequires:  python-setuptools
68 %endif
69 %if %{with python3}
70 BuildRequires:  python3 >= 1:3.4
71 BuildRequires:  python3-cffi
72 BuildRequires:  python3-modules >= 1:3.4
73 BuildRequires:  python3-setuptools
74 %endif
75 %if %{with python2} || %{with python3}
76 BuildRequires:  rpm-pythonprov
77 %endif
78 %endif
79 Requires:       %{pname}-libs = %{version}-%{release}
80 Obsoletes:      spl < 0.7.9-2
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         dracutlibdir    %{_prefix}/lib/dracut
84
85 %description
86 ZFS is an advanced file system and volume manager which was originally
87 developed for Solaris and is now maintained by the Illumos community.
88
89 ZFS on Linux, which is also known as ZoL, is currently feature
90 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
91 ZPL layers.
92
93 %description -l pl.UTF-8
94 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
95 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
96
97 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
98 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
99 SPA, DMU, ZVOL i ZPL.
100
101 %package libs
102 Summary:        ZFS on Linux libraries
103 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
104 License:        CDDL
105 Group:          Libraries
106 Requires(post,postun):  /sbin/ldconfig
107
108 %description libs
109 ZFS on Linux libraries.
110
111 %description libs -l pl.UTF-8
112 Biblioteki ZFS-a dla Linuksa.
113
114 %package devel
115 Summary:        Header files for ZFS libraries
116 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
117 License:        CDDL
118 Group:          Development/Libraries
119 Requires:       %{pname}-libs = %{version}-%{release}
120 Requires:       libselinux-devel
121 Requires:       libtirpc-devel
122 Requires:       libuuid-devel
123 Requires:       zlib-devel
124
125 %description devel
126 Header files for ZFS libraries.
127
128 %description devel -l pl.UTF-8
129 Pliki nagłówkowe bibliotek ZFS-a.
130
131 %package static
132 Summary:        Static ZFS libraries
133 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
134 License:        CDDL
135 Group:          Development/Libraries
136 Requires:       %{pname}-devel = %{version}-%{release}
137
138 %description static
139 Static ZFS libraries.
140
141 %description static -l pl.UTF-8
142 Statyczne biblioteki ZFS-a.
143
144 %package -n dracut-zfs
145 Summary:        ZFS support for Dracut
146 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
147 Group:          Applications/System
148 Requires:       %{pname} = %{version}-%{release}
149 Requires:       dracut
150
151 %description -n dracut-zfs
152 ZFS support for Dracut.
153
154 %description -n dracut-zfs -l pl.UTF-8
155 Obsługa ZFS-a dla Dracuta.
156
157 %package -n pam-pam_zfs_key
158 Summary:        PAM module to unlock ZFS datasets for user
159 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
160 Group:          Libraries
161 Requires:       %{pname}-libs = %{version}-%{release}
162 Requires:       pam
163
164 %description -n pam-pam_zfs_key
165 PAM module to unlock ZFS datasets for user.
166
167 %description -n pam-pam_zfs_key -l pl.UTF-8
168 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
169
170 %package -n python-pyzfs
171 Summary:        Python 2 wrapper for libzfs_core C library
172 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
173 License:        Apache v2.0
174 Group:          Libraries/Python
175 Requires:       %{pname}-libs = %{version}-%{release}
176
177 %description -n python-pyzfs
178 Python 2 wrapper for libzfs_core C library.
179
180 %description -n python-pyzfs -l pl.UTF-8
181 Interfejs Pythona 2 do biblioteki C libzfs_core.
182
183 %package -n python3-pyzfs
184 Summary:        Python 3 wrapper for libzfs_core C library
185 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
186 License:        Apache v2.0
187 Group:          Libraries/Python
188 Requires:       %{pname}-libs = %{version}-%{release}
189
190 %description -n python3-pyzfs
191 Python 3 wrapper for libzfs_core C library.
192
193 %description -n python3-pyzfs -l pl.UTF-8
194 Interfejs Pythona 3 do biblioteki C libzfs_core.
195
196 %package -n kernel-zfs-common-devel
197 Summary:        ZFS Linux kernel headers
198 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
199 Group:          Development/Building
200 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
201
202 %description -n kernel-zfs-common-devel
203 ZFS Linux kernel headers common for all PLD kernel versions.
204
205 %description -n kernel-zfs-common-devel -l pl.UTF-8
206 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
207 wersji jąder PLD.
208
209 %define kernel_pkg()\
210 %package -n kernel%{_alt_kernel}-zfs\
211 Summary:        ZFS Linux kernel modules\
212 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
213 Release:        %{rel}@%{_kernel_ver_str}\
214 Group:          Base/Kernel\
215 Requires(post,postun):  /sbin/depmod\
216 %requires_releq_kernel\
217 Requires(postun):       %releq_kernel\
218 \
219 %description -n kernel%{_alt_kernel}-zfs\
220 ZFS Linux kernel modules.\
221 \
222 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
223 ZFS - moduły jądra Linuksa.\
224 \
225 %package -n kernel%{_alt_kernel}-zfs-devel\
226 Summary:        ZFS Linux kernel headers\
227 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
228 Release:        %{rel}@%{_kernel_ver_str}\
229 Group:          Development/Building\
230 Requires:       kernel%{_alt_kernel}-headers\
231 Requires:       kernel-zfs-common-devel\
232 Obsoletes:      kernel-spl-devel < 0.7.9-2\
233 \
234 %description -n kernel%{_alt_kernel}-zfs-devel\
235 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
236 version %{_kernel_ver}.\
237 \
238 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
239 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
240 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
241 \
242 %files -n kernel%{_alt_kernel}-zfs\
243 %defattr(644,root,root,755)\
244 /lib/modules/%{_kernel_ver}/misc/spl.ko*\
245 /lib/modules/%{_kernel_ver}/misc/zfs.ko*\
246 \
247 %files -n kernel%{_alt_kernel}-zfs-devel\
248 %defattr(644,root,root,755)\
249 /usr/src/zfs-%{version}/%{_kernel_ver}\
250 \
251 %post   -n kernel%{_alt_kernel}-zfs\
252 %depmod %{_kernel_ver}\
253 \
254 %postun -n kernel%{_alt_kernel}-zfs\
255 %depmod %{_kernel_ver}\
256 %{nil}
257
258 %define build_kernel_pkg()\
259 KERNEL_MAKE="ARCH=%_kernel_arch" \\\
260 %configure \\\
261         KERNEL_CC="%{__cc}" \\\
262         ARCH_UM="ARCH=%{_kernel_arch}" \\\
263         --disable-silent-rules \\\
264         --with-config="kernel" \\\
265         --with-linux=%{_kernelsrcdir}\\\
266         --with-linux-obj=%{_kernelsrcdir}\
267 \
268 %{__make} clean\
269 %{__make} %{?with_verbose:V=1}\
270 p=`pwd`\
271 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
272 %{nil}
273
274 %{?with_kernel:%{expand:%create_kernel_packages}}
275
276 %prep
277 %setup -q -n %{pname}-%{version}
278 %patch0 -p1
279
280 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
281         cmd/arc_summary
282
283 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
284         cmd/arcstat.in \
285         cmd/dbufstat.in \
286         cmd/zilstat.in
287
288 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
289         contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
290         contrib/dracut/90zfs/module-setup.sh.in \
291         scripts/zimport.sh \
292         scripts/zloop.sh
293
294 %build
295 %{__libtoolize}
296 %{__aclocal} -I config
297 %{__autoconf}
298 %{__autoheader}
299 %{__automake}
300 %{?with_kernel:%{expand:%build_kernel_packages}}
301
302 %if %{with userspace}
303 %configure \
304         --disable-silent-rules \
305         %{__enable_disable static_libs static} \
306         --enable-pam \
307         --enable-systemd \
308         --with-config="user" \
309         --with-linux=%{_kernelsrcdir} \
310         --with-pammoduledir=/%{_lib}/security \
311         --with-systemdunitdir=%{systemdunitdir} \
312         --with-systemdpresetdir=/etc/systemd/system-preset \
313         --with-systemdmodulesloaddir=/etc/modules-load.d \
314         --with-systemdgeneratordir=/lib/systemd/system-generators \
315         --with-udevdir=/lib/udev
316
317 %{__make} \
318         %{?with_verbose:V=1}
319
320 %if %{with python2}
321 cd contrib/pyzfs
322 %py_build
323 cd ../..
324 %endif
325
326 %if %{with python3}
327 cd contrib/pyzfs
328 %py3_build
329 cd ../..
330 %endif
331 %endif
332
333 %install
334 rm -rf $RPM_BUILD_ROOT
335
336 %if %{with kernel}
337 install -d $RPM_BUILD_ROOT
338 cp -a installed/* $RPM_BUILD_ROOT
339 %endif
340
341 %if %{with userspace}
342 %{__make} install \
343         DESTDIR=$RPM_BUILD_ROOT \
344         DEFAULT_INIT_DIR=/etc/rc.d/init.d
345
346 %if %{with python2}
347 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
348 cd contrib/pyzfs
349 %py_install
350
351 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
352 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
353
354 %py_postclean
355 cd ../..
356 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
357 %endif
358
359 %if %{with python3}
360 cd contrib/pyzfs
361 %py3_install
362 cd ../..
363 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
364 %endif
365
366 # Debian specific stuff
367 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
368
369 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
370 # Ubuntu PAM config framework file
371 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
372
373 # Package these? These are integration tests of the implementation.
374 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
375 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
376 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
377 %endif
378
379 %clean
380 rm -rf $RPM_BUILD_ROOT
381
382 %post   libs -p /sbin/ldconfig
383 %postun libs -p /sbin/ldconfig
384
385 %if %{with userspace}
386 %files
387 %defattr(644,root,root,755)
388 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
389 %attr(755,root,root) /sbin/mount.zfs
390 %attr(755,root,root) %{_bindir}/arc_summary
391 %attr(755,root,root) %{_bindir}/arcstat
392 %attr(755,root,root) %{_bindir}/dbufstat
393 %attr(755,root,root) %{_bindir}/zilstat
394 %attr(755,root,root) %{_bindir}/zvol_wait
395 %attr(755,root,root) %{_sbindir}/fsck.zfs
396 %attr(755,root,root) %{_sbindir}/zdb
397 %attr(755,root,root) %{_sbindir}/zed
398 %attr(755,root,root) %{_sbindir}/zfs
399 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
400 %attr(755,root,root) %{_sbindir}/zgenhostid
401 %attr(755,root,root) %{_sbindir}/zhack
402 %attr(755,root,root) %{_sbindir}/zinject
403 %attr(755,root,root) %{_sbindir}/zpool
404 %attr(755,root,root) %{_sbindir}/zstream
405 %attr(755,root,root) %{_sbindir}/zstreamdump
406 %attr(755,root,root) %{_sbindir}/ztest
407 %dir %{_sysconfdir}/zfs
408 # package *.example as %doc? (they cannot act as default configuration)
409 %{_sysconfdir}/zfs/vdev_id.conf.*.example
410 %dir %{_sysconfdir}/zfs/zed.d
411 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
412 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
413 %dir %{_sysconfdir}/zfs/zpool.d
414 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
415 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
416 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
417 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
418 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
419 %attr(754,root,root) /etc/rc.d/init.d/zfs-load-key
420 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
421 /etc/zfs/zfs-functions
422 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
423 # for zpool iostat/status -c smart
424 #/ets/sudoers.d/zfs
425 /etc/systemd/system-preset/50-zfs.preset
426 /lib/systemd/system-generators/zfs-mount-generator
427 %{systemdunitdir}/zfs.target
428 %{systemdunitdir}/zfs-import.service
429 %{systemdunitdir}/zfs-import.target
430 %{systemdunitdir}/zfs-import-cache.service
431 %{systemdunitdir}/zfs-import-scan.service
432 %{systemdunitdir}/zfs-load-key.service
433 %{systemdunitdir}/zfs-mount.service
434 %{systemdunitdir}/zfs-scrub@.service
435 %{systemdunitdir}/zfs-scrub-monthly@.timer
436 %{systemdunitdir}/zfs-scrub-weekly@.timer
437 %{systemdunitdir}/zfs-share.service
438 %{systemdunitdir}/zfs-trim-monthly@.timer
439 %{systemdunitdir}/zfs-trim-weekly@.timer
440 %{systemdunitdir}/zfs-trim@.service
441 %{systemdunitdir}/zfs-volume-wait.service
442 %{systemdunitdir}/zfs-volumes.target
443 %{systemdunitdir}/zfs-zed.service
444 %attr(755,root,root) /lib/udev/vdev_id
445 %attr(755,root,root) /lib/udev/zvol_id
446 /lib/udev/rules.d/60-zvol.rules
447 /lib/udev/rules.d/69-vdev.rules
448 /lib/udev/rules.d/90-zfs.rules
449 %dir %{_libexecdir}/zfs
450 %dir %{_libexecdir}/zfs/zed.d
451 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
452 %dir %{_libexecdir}/zfs/zpool.d
453 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
454 %dir %{_datadir}/zfs
455 %attr(755,root,root) %{_datadir}/zfs/*.sh
456 %attr(755,root,root) %{_libexecdir}/zfs/zfs_prepare_disk
457 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
458 %{_datadir}/zfs/compatibility.d
459 %{_mandir}/man1/arcstat.1*
460 %{_mandir}/man1/zhack.1*
461 %{_mandir}/man1/ztest.1*
462 %{_mandir}/man1/zvol_wait.1*
463 %{_mandir}/man4/spl.4*
464 %{_mandir}/man4/zfs.4*
465 %{_mandir}/man5/vdev_id.conf.5*
466 %{_mandir}/man7/vdevprops.7*
467 %{_mandir}/man7/zfsconcepts.7*
468 %{_mandir}/man7/zfsprops.7*
469 %{_mandir}/man7/zpool-features.7*
470 %{_mandir}/man7/zpoolconcepts.7*
471 %{_mandir}/man7/zpoolprops.7*
472 %{_mandir}/man8/fsck.zfs.8*
473 %{_mandir}/man8/mount.zfs.8*
474 %{_mandir}/man8/vdev_id.8*
475 %{_mandir}/man8/zdb.8*
476 %{_mandir}/man8/zed.8*
477 %{_mandir}/man8/zfs.8*
478 %{_mandir}/man8/zfs-allow.8*
479 %{_mandir}/man8/zfs-bookmark.8*
480 %{_mandir}/man8/zfs-change-key.8*
481 %{_mandir}/man8/zfs-clone.8*
482 %{_mandir}/man8/zfs-create.8*
483 %{_mandir}/man8/zfs-destroy.8*
484 %{_mandir}/man8/zfs-diff.8*
485 %{_mandir}/man8/zfs-get.8*
486 %{_mandir}/man8/zfs-groupspace.8*
487 %{_mandir}/man8/zfs-hold.8*
488 %{_mandir}/man8/zfs-inherit.8*
489 %{_mandir}/man8/zfs-list.8*
490 %{_mandir}/man8/zfs-load-key.8*
491 %{_mandir}/man8/zfs-mount.8*
492 %{_mandir}/man8/zfs-mount-generator.8*
493 %{_mandir}/man8/zfs-program.8*
494 %{_mandir}/man8/zfs-project.8*
495 %{_mandir}/man8/zfs-projectspace.8*
496 %{_mandir}/man8/zfs-promote.8*
497 %{_mandir}/man8/zfs-receive.8*
498 %{_mandir}/man8/zfs-recv.8*
499 %{_mandir}/man8/zfs-redact.8*
500 %{_mandir}/man8/zfs-release.8*
501 %{_mandir}/man8/zfs-rename.8*
502 %{_mandir}/man8/zfs-rollback.8*
503 %{_mandir}/man8/zfs-send.8*
504 %{_mandir}/man8/zfs-set.8*
505 %{_mandir}/man8/zfs-share.8*
506 %{_mandir}/man8/zfs-snapshot.8*
507 %{_mandir}/man8/zfs-unallow.8*
508 %{_mandir}/man8/zfs-unload-key.8*
509 %{_mandir}/man8/zfs-unzone.8*
510 %{_mandir}/man8/zfs-unmount.8*
511 %{_mandir}/man8/zfs-upgrade.8*
512 %{_mandir}/man8/zfs-userspace.8*
513 %{_mandir}/man8/zfs-wait.8*
514 %{_mandir}/man8/zfs-zone.8*
515 %{_mandir}/man8/zfs_ids_to_path.8*
516 %{_mandir}/man8/zfs_prepare_disk.8*
517 %{_mandir}/man8/zgenhostid.8*
518 %{_mandir}/man8/zinject.8*
519 %{_mandir}/man8/zpool.8*
520 %{_mandir}/man8/zpool-add.8*
521 %{_mandir}/man8/zpool-attach.8*
522 %{_mandir}/man8/zpool-checkpoint.8*
523 %{_mandir}/man8/zpool-clear.8*
524 %{_mandir}/man8/zpool-create.8*
525 %{_mandir}/man8/zpool-destroy.8*
526 %{_mandir}/man8/zpool-detach.8*
527 %{_mandir}/man8/zpool-events.8*
528 %{_mandir}/man8/zpool-export.8*
529 %{_mandir}/man8/zpool-get.8*
530 %{_mandir}/man8/zpool-history.8*
531 %{_mandir}/man8/zpool-import.8*
532 %{_mandir}/man8/zpool-initialize.8*
533 %{_mandir}/man8/zpool-iostat.8*
534 %{_mandir}/man8/zpool-labelclear.8*
535 %{_mandir}/man8/zpool-list.8*
536 %{_mandir}/man8/zpool-offline.8*
537 %{_mandir}/man8/zpool-online.8*
538 %{_mandir}/man8/zpool-reguid.8*
539 %{_mandir}/man8/zpool-remove.8*
540 %{_mandir}/man8/zpool-reopen.8*
541 %{_mandir}/man8/zpool-replace.8*
542 %{_mandir}/man8/zpool-resilver.8*
543 %{_mandir}/man8/zpool-scrub.8*
544 %{_mandir}/man8/zpool-set.8*
545 %{_mandir}/man8/zpool-split.8*
546 %{_mandir}/man8/zpool-status.8*
547 %{_mandir}/man8/zpool-sync.8*
548 %{_mandir}/man8/zpool-trim.8*
549 %{_mandir}/man8/zpool-upgrade.8*
550 %{_mandir}/man8/zpool-wait.8*
551 %{_mandir}/man8/zpool_influxdb.8*
552 %{_mandir}/man8/zstream.8*
553 %{_mandir}/man8/zstreamdump.8*
554
555 %files libs
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
559 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
561 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
563 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
565 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
567 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
569
570 %files devel
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/libnvpair.so
573 %attr(755,root,root) %{_libdir}/libuutil.so
574 %attr(755,root,root) %{_libdir}/libzfs.so
575 %attr(755,root,root) %{_libdir}/libzfs_core.so
576 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
577 %attr(755,root,root) %{_libdir}/libzpool.so
578 %{_libdir}/libnvpair.la
579 %{_libdir}/libuutil.la
580 %{_libdir}/libzfs.la
581 %{_libdir}/libzfs_core.la
582 %{_libdir}/libzfsbootenv.la
583 %{_libdir}/libzpool.la
584 %{_includedir}/libspl
585 %{_includedir}/libzfs
586 %{_pkgconfigdir}/libzfs.pc
587 %{_pkgconfigdir}/libzfs_core.pc
588 %{_pkgconfigdir}/libzfsbootenv.pc
589
590 %if %{with static_libs}
591 %files static
592 %defattr(644,root,root,755)
593 %{_libdir}/libnvpair.a
594 %{_libdir}/libuutil.a
595 %{_libdir}/libzfs.a
596 %{_libdir}/libzfs_core.a
597 %{_libdir}/libzfsbootenv.a
598 %{_libdir}/libzpool.a
599 %endif
600
601 %files -n dracut-zfs
602 %defattr(644,root,root,755)
603 %doc contrib/dracut/README.md
604 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
605 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
606 %dir %{dracutlibdir}/modules.d/90zfs
607 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
608 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
609 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
610 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
611 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
612 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
613 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
614 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
615 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
616 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
617 %{dracutlibdir}/modules.d/90zfs/zfs-nonroot-necessities.service
618 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
619 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
620 %{_mandir}/man7/dracut.zfs.7*
621
622 %files -n pam-pam_zfs_key
623 %defattr(644,root,root,755)
624 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
625
626 %if %{with python2}
627 %files -n python-pyzfs
628 %defattr(644,root,root,755)
629 %doc contrib/pyzfs/README
630 %{py_sitescriptdir}/libzfs_core
631 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
632 %endif
633
634 %if %{with python3}
635 %files -n python3-pyzfs
636 %defattr(644,root,root,755)
637 %doc contrib/pyzfs/README
638 %{py3_sitescriptdir}/libzfs_core
639 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
640 %endif
641 %endif
642
643 %if %{with kernel}
644 %files -n kernel-zfs-common-devel
645 %defattr(644,root,root,755)
646 %dir /usr/src/zfs-%{version}
647 /usr/src/zfs-%{version}/include
648 /usr/src/zfs-%{version}/zfs.release.in
649 /usr/src/zfs-%{version}/zfs_config.h.in
650 %endif
This page took 0.079169 seconds and 2 git commands to generate.