]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
b414b4fdc64c10eb036910f9c6612551589e3c55
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python3         # CPython 3.x module
8 %bcond_without  static_libs     # static libraries
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define rel     2
28 %define pname   zfs
29 Summary:        Native Linux port of the ZFS filesystem
30 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
31 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
32 Version:        2.2.3
33 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
34 License:        CDDL
35 Group:          Applications/System
36 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
37 # Source0-md5:  e0f2b72ccd47a5b401cbc9f38b1d9073
38 Patch0:         initdir.patch
39 Patch1:         pld.patch
40 URL:            https://zfsonlinux.org/
41 BuildRequires:  autoconf >= 2.50
42 BuildRequires:  automake
43 BuildRequires:  libtool
44 BuildRequires:  rpmbuild(macros) >= 2.030
45 %if %{with kernel}
46 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
47 %endif
48 %if %{with userspace}
49 # only for mmap_libaio test command
50 #BuildRequires: libaio-devel
51 %ifnarch %arch_with_atomics64
52 BuildRequires:  libatomic-devel
53 %endif
54 BuildRequires:  libblkid-devel
55 BuildRequires:  libselinux-devel
56 BuildRequires:  libtirpc-devel
57 BuildRequires:  libuuid-devel
58 BuildRequires:  openssl-devel
59 BuildRequires:  pam-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  udev-devel
62 BuildRequires:  zlib-devel
63 %if %{with python3}
64 BuildRequires:  python3 >= 1:3.6
65 BuildRequires:  python3-cffi
66 BuildRequires:  python3-devel >= 1:3.6
67 BuildRequires:  python3-modules >= 1:3.6
68 BuildRequires:  python3-packaging
69 BuildRequires:  python3-setuptools
70 %endif
71 %if %{with python3}
72 BuildRequires:  rpm-pythonprov
73 %endif
74 %endif
75 Requires:       %{pname}-libs = %{version}-%{release}
76 Obsoletes:      spl < 0.7.9-2
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         dracutlibdir    %{_prefix}/lib/dracut
80
81 %description
82 ZFS is an advanced file system and volume manager which was originally
83 developed for Solaris and is now maintained by the Illumos community.
84
85 ZFS on Linux, which is also known as ZoL, is currently feature
86 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
87 ZPL layers.
88
89 %description -l pl.UTF-8
90 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
91 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
92
93 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
94 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
95 SPA, DMU, ZVOL i ZPL.
96
97 %package libs
98 Summary:        ZFS on Linux libraries
99 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
100 License:        CDDL
101 Group:          Libraries
102 Requires(post,postun):  /sbin/ldconfig
103
104 %description libs
105 ZFS on Linux libraries.
106
107 %description libs -l pl.UTF-8
108 Biblioteki ZFS-a dla Linuksa.
109
110 %package devel
111 Summary:        Header files for ZFS libraries
112 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
113 License:        CDDL
114 Group:          Development/Libraries
115 Requires:       %{pname}-libs = %{version}-%{release}
116 Requires:       libselinux-devel
117 Requires:       libtirpc-devel
118 Requires:       libuuid-devel
119 Requires:       zlib-devel
120
121 %description devel
122 Header files for ZFS libraries.
123
124 %description devel -l pl.UTF-8
125 Pliki nagłówkowe bibliotek ZFS-a.
126
127 %package static
128 Summary:        Static ZFS libraries
129 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
130 License:        CDDL
131 Group:          Development/Libraries
132 Requires:       %{pname}-devel = %{version}-%{release}
133
134 %description static
135 Static ZFS libraries.
136
137 %description static -l pl.UTF-8
138 Statyczne biblioteki ZFS-a.
139
140 %package -n dracut-zfs
141 Summary:        ZFS support for Dracut
142 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
143 Group:          Applications/System
144 Requires:       %{pname} = %{version}-%{release}
145 Requires:       dracut
146
147 %description -n dracut-zfs
148 ZFS support for Dracut.
149
150 %description -n dracut-zfs -l pl.UTF-8
151 Obsługa ZFS-a dla Dracuta.
152
153 %package -n pam-pam_zfs_key
154 Summary:        PAM module to unlock ZFS datasets for user
155 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
156 Group:          Libraries
157 Requires:       %{pname}-libs = %{version}-%{release}
158 Requires:       pam
159
160 %description -n pam-pam_zfs_key
161 PAM module to unlock ZFS datasets for user.
162
163 %description -n pam-pam_zfs_key -l pl.UTF-8
164 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
165
166 %package -n python3-pyzfs
167 Summary:        Python 3 wrapper for libzfs_core C library
168 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
169 License:        Apache v2.0
170 Group:          Libraries/Python
171 Requires:       %{pname}-libs = %{version}-%{release}
172 Obsoletes:      python-pyzfs < 2.2.3-2
173
174 %description -n python3-pyzfs
175 Python 3 wrapper for libzfs_core C library.
176
177 %description -n python3-pyzfs -l pl.UTF-8
178 Interfejs Pythona 3 do biblioteki C libzfs_core.
179
180 %package -n kernel-zfs-common-devel
181 Summary:        ZFS Linux kernel headers
182 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
183 Group:          Development/Building
184 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
185
186 %description -n kernel-zfs-common-devel
187 ZFS Linux kernel headers common for all PLD kernel versions.
188
189 %description -n kernel-zfs-common-devel -l pl.UTF-8
190 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
191 wersji jąder PLD.
192
193 %define kernel_pkg()\
194 %package -n kernel%{_alt_kernel}-zfs\
195 Summary:        ZFS Linux kernel modules\
196 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
197 Release:        %{rel}@%{_kernel_ver_str}\
198 Group:          Base/Kernel\
199 Requires(post,postun):  /sbin/depmod\
200 %requires_releq_kernel\
201 Requires(postun):       %releq_kernel\
202 \
203 %description -n kernel%{_alt_kernel}-zfs\
204 ZFS Linux kernel modules.\
205 \
206 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
207 ZFS - moduły jądra Linuksa.\
208 \
209 %package -n kernel%{_alt_kernel}-zfs-devel\
210 Summary:        ZFS Linux kernel headers\
211 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
212 Release:        %{rel}@%{_kernel_ver_str}\
213 Group:          Development/Building\
214 Requires:       kernel%{_alt_kernel}-headers\
215 Requires:       kernel-zfs-common-devel\
216 Obsoletes:      kernel-spl-devel < 0.7.9-2\
217 \
218 %description -n kernel%{_alt_kernel}-zfs-devel\
219 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
220 version %{_kernel_ver}.\
221 \
222 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
223 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
224 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
225 \
226 %files -n kernel%{_alt_kernel}-zfs\
227 %defattr(644,root,root,755)\
228 /lib/modules/%{_kernel_ver}/misc/spl.ko*\
229 /lib/modules/%{_kernel_ver}/misc/zfs.ko*\
230 \
231 %files -n kernel%{_alt_kernel}-zfs-devel\
232 %defattr(644,root,root,755)\
233 /usr/src/zfs-%{version}/%{_kernel_ver}\
234 \
235 %post   -n kernel%{_alt_kernel}-zfs\
236 %depmod %{_kernel_ver}\
237 \
238 %postun -n kernel%{_alt_kernel}-zfs\
239 %depmod %{_kernel_ver}\
240 %{nil}
241
242 %define build_kernel_pkg()\
243 KERNEL_MAKE="ARCH=%_kernel_arch" \\\
244 %configure \\\
245         KERNEL_CC="%{__cc}" \\\
246         ARCH_UM="ARCH=%{_kernel_arch}" \\\
247         --disable-silent-rules \\\
248         --with-config="kernel" \\\
249         --with-linux=%{_kernelsrcdir}\\\
250         --with-linux-obj=%{_kernelsrcdir}\
251 \
252 %{__make} clean\
253 %{__make} %{?with_verbose:V=1}\
254 p=`pwd`\
255 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
256 %{nil}
257
258 %{?with_kernel:%{expand:%create_kernel_packages}}
259
260 %prep
261 %setup -q -n %{pname}-%{version}
262 %patch0 -p1
263 %patch1 -p1
264
265 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
266         cmd/arc_summary
267
268 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
269         cmd/arcstat.in \
270         cmd/dbufstat.in \
271         cmd/zilstat.in
272
273 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
274         contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
275         contrib/dracut/90zfs/module-setup.sh.in \
276         scripts/zimport.sh \
277         scripts/zloop.sh
278
279 %build
280 %{__libtoolize}
281 %{__aclocal} -I config
282 %{__autoconf}
283 %{__autoheader}
284 %{__automake}
285 %{?with_kernel:%{expand:%build_kernel_packages}}
286
287 %if %{with userspace}
288 %configure \
289         --disable-silent-rules \
290         %{__enable_disable static_libs static} \
291         --enable-pam \
292         --enable-systemd \
293         --with-config="user" \
294         --with-linux=%{_kernelsrcdir} \
295         --with-pammoduledir=/%{_lib}/security \
296         --with-systemdunitdir=%{systemdunitdir} \
297         --with-systemdpresetdir=/etc/systemd/system-preset \
298         --with-systemdmodulesloaddir=/etc/modules-load.d \
299         --with-systemdgeneratordir=/lib/systemd/system-generators \
300         --with-udevdir=/lib/udev \
301         --with-vendor=pld
302
303 %{__make} \
304         %{?with_verbose:V=1}
305
306 %if %{with python3}
307 cd contrib/pyzfs
308 %py3_build
309 cd ../..
310 %endif
311 %endif
312
313 %install
314 rm -rf $RPM_BUILD_ROOT
315
316 %if %{with kernel}
317 install -d $RPM_BUILD_ROOT
318 cp -a installed/* $RPM_BUILD_ROOT
319 %endif
320
321 %if %{with userspace}
322 %{__make} install \
323         DESTDIR=$RPM_BUILD_ROOT \
324         DEFAULT_INIT_DIR=/etc/rc.d/init.d
325
326 %if %{with python3}
327 cd contrib/pyzfs
328 %py3_install
329 cd ../..
330 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
331 %endif
332
333 # Debian specific stuff
334 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
335
336 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
337 # Ubuntu PAM config framework file
338 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
339
340 # Package these? These are integration tests of the implementation.
341 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
342 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
343 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
344 %endif
345
346 %clean
347 rm -rf $RPM_BUILD_ROOT
348
349 %post   libs -p /sbin/ldconfig
350 %postun libs -p /sbin/ldconfig
351
352 %if %{with userspace}
353 %files
354 %defattr(644,root,root,755)
355 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
356 %attr(755,root,root) /sbin/mount.zfs
357 %attr(755,root,root) %{_bindir}/arc_summary
358 %attr(755,root,root) %{_bindir}/arcstat
359 %attr(755,root,root) %{_bindir}/dbufstat
360 %attr(755,root,root) %{_bindir}/zilstat
361 %attr(755,root,root) %{_bindir}/zvol_wait
362 %attr(755,root,root) %{_sbindir}/fsck.zfs
363 %attr(755,root,root) %{_sbindir}/zdb
364 %attr(755,root,root) %{_sbindir}/zed
365 %attr(755,root,root) %{_sbindir}/zfs
366 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
367 %attr(755,root,root) %{_sbindir}/zgenhostid
368 %attr(755,root,root) %{_sbindir}/zhack
369 %attr(755,root,root) %{_sbindir}/zinject
370 %attr(755,root,root) %{_sbindir}/zpool
371 %attr(755,root,root) %{_sbindir}/zstream
372 %attr(755,root,root) %{_sbindir}/zstreamdump
373 %attr(755,root,root) %{_sbindir}/ztest
374 %dir %{_sysconfdir}/zfs
375 # package *.example as %doc? (they cannot act as default configuration)
376 %{_sysconfdir}/zfs/vdev_id.conf.*.example
377 %{_sysconfdir}/zfs/zfs-functions
378 %dir %{_sysconfdir}/zfs/zed.d
379 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
380 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
381 %dir %{_sysconfdir}/zfs/zpool.d
382 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
383 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
384 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
385 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
386 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
387 %attr(754,root,root) /etc/rc.d/init.d/zfs-load-key
388 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
389 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
390 # for zpool iostat/status -c smart
391 #/ets/sudoers.d/zfs
392 /etc/systemd/system-preset/50-zfs.preset
393 /lib/systemd/system-generators/zfs-mount-generator
394 %{systemdunitdir}/zfs.target
395 %{systemdunitdir}/zfs-import.service
396 %{systemdunitdir}/zfs-import.target
397 %{systemdunitdir}/zfs-import-cache.service
398 %{systemdunitdir}/zfs-import-scan.service
399 %{systemdunitdir}/zfs-load-key.service
400 %{systemdunitdir}/zfs-mount.service
401 %{systemdunitdir}/zfs-scrub@.service
402 %{systemdunitdir}/zfs-scrub-monthly@.timer
403 %{systemdunitdir}/zfs-scrub-weekly@.timer
404 %{systemdunitdir}/zfs-share.service
405 %{systemdunitdir}/zfs-trim-monthly@.timer
406 %{systemdunitdir}/zfs-trim-weekly@.timer
407 %{systemdunitdir}/zfs-trim@.service
408 %{systemdunitdir}/zfs-volume-wait.service
409 %{systemdunitdir}/zfs-volumes.target
410 %{systemdunitdir}/zfs-zed.service
411 %attr(755,root,root) /lib/udev/vdev_id
412 %attr(755,root,root) /lib/udev/zvol_id
413 /lib/udev/rules.d/60-zvol.rules
414 /lib/udev/rules.d/69-vdev.rules
415 /lib/udev/rules.d/90-zfs.rules
416 %dir %{_libexecdir}/zfs
417 %dir %{_libexecdir}/zfs/zed.d
418 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
419 %dir %{_libexecdir}/zfs/zpool.d
420 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
421 %attr(755,root,root) %{_libexecdir}/zfs/zfs_prepare_disk
422 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
423 %dir %{_datadir}/zfs
424 %attr(755,root,root) %{_datadir}/zfs/*.sh
425 %{_datadir}/zfs/compatibility.d
426 %{bash_compdir}/zfs
427 %{_mandir}/man1/arcstat.1*
428 %{_mandir}/man1/zhack.1*
429 %{_mandir}/man1/ztest.1*
430 %{_mandir}/man1/zvol_wait.1*
431 %{_mandir}/man4/spl.4*
432 %{_mandir}/man4/zfs.4*
433 %{_mandir}/man5/vdev_id.conf.5*
434 %{_mandir}/man7/vdevprops.7*
435 %{_mandir}/man7/zfsconcepts.7*
436 %{_mandir}/man7/zfsprops.7*
437 %{_mandir}/man7/zpool-features.7*
438 %{_mandir}/man7/zpoolconcepts.7*
439 %{_mandir}/man7/zpoolprops.7*
440 %{_mandir}/man8/fsck.zfs.8*
441 %{_mandir}/man8/mount.zfs.8*
442 %{_mandir}/man8/vdev_id.8*
443 %{_mandir}/man8/zdb.8*
444 %{_mandir}/man8/zed.8*
445 %{_mandir}/man8/zfs.8*
446 %{_mandir}/man8/zfs-allow.8*
447 %{_mandir}/man8/zfs-bookmark.8*
448 %{_mandir}/man8/zfs-change-key.8*
449 %{_mandir}/man8/zfs-clone.8*
450 %{_mandir}/man8/zfs-create.8*
451 %{_mandir}/man8/zfs-destroy.8*
452 %{_mandir}/man8/zfs-diff.8*
453 %{_mandir}/man8/zfs-get.8*
454 %{_mandir}/man8/zfs-groupspace.8*
455 %{_mandir}/man8/zfs-hold.8*
456 %{_mandir}/man8/zfs-inherit.8*
457 %{_mandir}/man8/zfs-list.8*
458 %{_mandir}/man8/zfs-load-key.8*
459 %{_mandir}/man8/zfs-mount.8*
460 %{_mandir}/man8/zfs-mount-generator.8*
461 %{_mandir}/man8/zfs-program.8*
462 %{_mandir}/man8/zfs-project.8*
463 %{_mandir}/man8/zfs-projectspace.8*
464 %{_mandir}/man8/zfs-promote.8*
465 %{_mandir}/man8/zfs-receive.8*
466 %{_mandir}/man8/zfs-recv.8*
467 %{_mandir}/man8/zfs-redact.8*
468 %{_mandir}/man8/zfs-release.8*
469 %{_mandir}/man8/zfs-rename.8*
470 %{_mandir}/man8/zfs-rollback.8*
471 %{_mandir}/man8/zfs-send.8*
472 %{_mandir}/man8/zfs-set.8*
473 %{_mandir}/man8/zfs-share.8*
474 %{_mandir}/man8/zfs-snapshot.8*
475 %{_mandir}/man8/zfs-unallow.8*
476 %{_mandir}/man8/zfs-unload-key.8*
477 %{_mandir}/man8/zfs-unzone.8*
478 %{_mandir}/man8/zfs-unmount.8*
479 %{_mandir}/man8/zfs-upgrade.8*
480 %{_mandir}/man8/zfs-userspace.8*
481 %{_mandir}/man8/zfs-wait.8*
482 %{_mandir}/man8/zfs-zone.8*
483 %{_mandir}/man8/zfs_ids_to_path.8*
484 %{_mandir}/man8/zfs_prepare_disk.8*
485 %{_mandir}/man8/zgenhostid.8*
486 %{_mandir}/man8/zinject.8*
487 %{_mandir}/man8/zpool.8*
488 %{_mandir}/man8/zpool-add.8*
489 %{_mandir}/man8/zpool-attach.8*
490 %{_mandir}/man8/zpool-checkpoint.8*
491 %{_mandir}/man8/zpool-clear.8*
492 %{_mandir}/man8/zpool-create.8*
493 %{_mandir}/man8/zpool-destroy.8*
494 %{_mandir}/man8/zpool-detach.8*
495 %{_mandir}/man8/zpool-events.8*
496 %{_mandir}/man8/zpool-export.8*
497 %{_mandir}/man8/zpool-get.8*
498 %{_mandir}/man8/zpool-history.8*
499 %{_mandir}/man8/zpool-import.8*
500 %{_mandir}/man8/zpool-initialize.8*
501 %{_mandir}/man8/zpool-iostat.8*
502 %{_mandir}/man8/zpool-labelclear.8*
503 %{_mandir}/man8/zpool-list.8*
504 %{_mandir}/man8/zpool-offline.8*
505 %{_mandir}/man8/zpool-online.8*
506 %{_mandir}/man8/zpool-reguid.8*
507 %{_mandir}/man8/zpool-remove.8*
508 %{_mandir}/man8/zpool-reopen.8*
509 %{_mandir}/man8/zpool-replace.8*
510 %{_mandir}/man8/zpool-resilver.8*
511 %{_mandir}/man8/zpool-scrub.8*
512 %{_mandir}/man8/zpool-set.8*
513 %{_mandir}/man8/zpool-split.8*
514 %{_mandir}/man8/zpool-status.8*
515 %{_mandir}/man8/zpool-sync.8*
516 %{_mandir}/man8/zpool-trim.8*
517 %{_mandir}/man8/zpool-upgrade.8*
518 %{_mandir}/man8/zpool-wait.8*
519 %{_mandir}/man8/zpool_influxdb.8*
520 %{_mandir}/man8/zstream.8*
521 %{_mandir}/man8/zstreamdump.8*
522
523 %files libs
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
526 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
527 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
529 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
530 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
531 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
532 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
533 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
534 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
535 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
536 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
537
538 %files devel
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_libdir}/libnvpair.so
541 %attr(755,root,root) %{_libdir}/libuutil.so
542 %attr(755,root,root) %{_libdir}/libzfs.so
543 %attr(755,root,root) %{_libdir}/libzfs_core.so
544 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
545 %attr(755,root,root) %{_libdir}/libzpool.so
546 %{_libdir}/libnvpair.la
547 %{_libdir}/libuutil.la
548 %{_libdir}/libzfs.la
549 %{_libdir}/libzfs_core.la
550 %{_libdir}/libzfsbootenv.la
551 %{_libdir}/libzpool.la
552 %{_includedir}/libspl
553 %{_includedir}/libzfs
554 %{_pkgconfigdir}/libzfs.pc
555 %{_pkgconfigdir}/libzfs_core.pc
556 %{_pkgconfigdir}/libzfsbootenv.pc
557
558 %if %{with static_libs}
559 %files static
560 %defattr(644,root,root,755)
561 %{_libdir}/libnvpair.a
562 %{_libdir}/libuutil.a
563 %{_libdir}/libzfs.a
564 %{_libdir}/libzfs_core.a
565 %{_libdir}/libzfsbootenv.a
566 %{_libdir}/libzpool.a
567 %endif
568
569 %files -n dracut-zfs
570 %defattr(644,root,root,755)
571 %doc contrib/dracut/README.md
572 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
573 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
574 %dir %{dracutlibdir}/modules.d/90zfs
575 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
576 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
577 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
578 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
579 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
580 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
581 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
582 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
583 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
584 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
585 %{dracutlibdir}/modules.d/90zfs/zfs-nonroot-necessities.service
586 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
587 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
588 %{_mandir}/man7/dracut.zfs.7*
589
590 %files -n pam-pam_zfs_key
591 %defattr(644,root,root,755)
592 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
593
594 %if %{with python3}
595 %files -n python3-pyzfs
596 %defattr(644,root,root,755)
597 %doc contrib/pyzfs/README
598 %{py3_sitescriptdir}/libzfs_core
599 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
600 %endif
601 %endif
602
603 %if %{with kernel}
604 %files -n kernel-zfs-common-devel
605 %defattr(644,root,root,755)
606 %dir /usr/src/zfs-%{version}
607 /usr/src/zfs-%{version}/include
608 /usr/src/zfs-%{version}/zfs.release.in
609 /usr/src/zfs-%{version}/zfs_config.h.in
610 %endif
This page took 0.106334 seconds and 4 git commands to generate.