]> git.pld-linux.org Git - packages/zathura.git/commitdiff
up to 0.3.4 auto/th/zathura-0.3.4-1
authorJan Palus <atler@pld-linux.org>
Mon, 28 Dec 2015 21:06:28 +0000 (22:06 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 28 Dec 2015 21:06:28 +0000 (22:06 +0100)
- added patch to fix build without synctex
- updated BRs

zathura-no_synctex.patch [new file with mode: 0644]
zathura.spec

diff --git a/zathura-no_synctex.patch b/zathura-no_synctex.patch
new file mode 100644 (file)
index 0000000..e76496d
--- /dev/null
@@ -0,0 +1,39 @@
+--- zathura/main.c.orig        2015-12-28 21:29:43.603042279 +0100
++++ zathura/main.c     2015-12-28 21:34:24.880442191 +0100
+@@ -84,12 +84,14 @@
+ static zathura_t*
+ init_zathura(const char* config_dir, const char* data_dir,
+-    const char* cache_dir, const char* plugin_path, char** argv,
++    const char* cache_dir, const char* plugin_path, char** argv
++#ifdef WITH_SYNCTEX
++    , char* synctex_editor
++#endif
+ #ifdef GDK_WINDOWING_X11
+-    char* synctex_editor, Window embed)
+-#else
+-    char* synctex_editor)
++    , Window embed
+ #endif
++    )
+ {
+   /* create zathura session */
+   zathura_t* zathura = zathura_create();
+@@ -250,11 +252,14 @@
+   /* Create zathura session */
+   zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir,
++      plugin_path, argv
++#ifdef WITH_SYNCTEX
++      , synctex_editor
++#endif
+ #ifdef GDK_WINDOWING_X11
+-      plugin_path, argv, synctex_editor, embed);
+-#else
+-      plugin_path, argv, synctex_editor);
++      , embed
+ #endif
++      );
+   if (zathura == NULL) {
+     girara_error("Could not initialize zathura.");
+     return -1;
index 136534e6d67a88e0a75f26c34d4664349ee5a0be..2e2ce5709f680f63358380995ab1d6c685f2c61f 100644 (file)
@@ -2,17 +2,18 @@ Summary:      A vi-like pdf reader
 Summary(hu.UTF-8):     Egy vi-szerű pdf olvasó
 Summary(pl.UTF-8):     Czytnik pdf podobny do vi
 Name:          zathura
-Version:       0.3.3
+Version:       0.3.4
 Release:       1
 License:       BSD-like
 Group:         Applications
 Source0:       http://pwmt.org/projects/zathura/download/%{name}-%{version}.tar.gz
-# Source0-md5: d360252210ce51a29e8d341b1b72a7cc
+# Source0-md5: 64a19c0a78d06e3a8c2098911d59b072
 Source1:       config.txt
+Patch0:                %{name}-no_synctex.patch
 URL:           http://pwmt.org/projects/zathura
-BuildRequires: girara-devel >= 0.2.4
-BuildRequires: glib2-devel >= 1:2.28.0
-BuildRequires: gtk+3-devel
+BuildRequires: girara-devel >= 0.2.5
+BuildRequires: glib2-devel >= 1:2.32.0
+BuildRequires: gtk+3-devel >= 3.6
 BuildRequires: intltool
 BuildRequires: libmagic-devel
 BuildRequires: pkgconfig
@@ -53,6 +54,7 @@ Header files for zathura.
 
 %prep
 %setup -q
+%patch0 -p0
 cp %{SOURCE1} config.txt
 %{__mv} po/id_ID.po po/id.po
 
This page took 0.223394 seconds and 4 git commands to generate.