]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
dd3a01730e9b5c9502a79ae7f0b9b26bd8a425be
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-agentd, zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  pgsql   # enable PostgreSQL support
6 %bcond_without  sqlite3 # enable sqlite3 support
7 %bcond_without  mysql   # enable MySQL support
8 %bcond_without  java    # disable java support
9
10 %define databases %{?with_pgsql:postgresql} %{?with_mysql:mysql} %{?with_sqlite3:sqlite3}
11 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
12
13 %define         php_min_version 5.4.0
14 Summary:        Zabbix - network monitoring software
15 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
16 Name:           zabbix
17 Version:        3.2.6
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        http://downloads.sourceforge.net/zabbix/%{name}-%{version}.tar.gz
22 # Source0-md5:  87428256f7e48b8bf10a926df27a34c8
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}_server.service
25 Source3:        %{name}_agentd.service
26 Source4:        %{name}_proxy.service
27 Source5:        %{name}_java.service
28 Source6:        %{name}.tmpfiles
29 Patch0:         config.patch
30 Patch1:         sqlite3_dbname.patch
31 URL:            http://zabbix.sourceforge.net/
32 BuildRequires:  OpenIPMI-devel
33 BuildRequires:  curl-devel
34 BuildRequires:  iksemel-devel
35 %{?with_java:BuildRequires:     jdk}
36 BuildRequires:  libssh2-devel
37 BuildRequires:  libxml2-devel
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 BuildRequires:  net-snmp-devel
40 BuildRequires:  openldap-devel >= 2.4.6
41 BuildRequires:  openssl-devel >= 0.9.7d
42 %{?with_pgsql:BuildRequires:    postgresql-devel}
43 BuildRequires:  rpmbuild(macros) >= 1.671
44 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
45 BuildRequires:  unixODBC-devel
46 Requires:       %{name}-agentd = %{version}-%{release}
47 Requires:       %{name}-frontend-php = %{version}-%{release}
48 Requires:       %{name}-server = %{version}-%{release}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _sysconfdir     /etc/%{name}
52 %define         _appdir         %{_datadir}/%{name}
53 %define         _webapps        /etc/webapps
54 %define         _webapp         %{name}
55
56 %description
57 Zabbix is software that monitors numerous parameters of a network and
58 the servers on that network. It is a useful tool for monitoring the
59 health and integrity of servers. Zabbix uses a flexible notification
60 mechanism that allows users to configure email based alerts for
61 virtually any event. All monitored parameters are stored in a
62 database. Zabbix offers excellent reporting and data visualisation
63 features based on the stored data. Zabbix supports both polling and
64 trapping. All Zabbix reports and statistics, as well as configuration
65 parameters, are accessed through a web-based front end.
66
67 %description -l pl.UTF-8
68 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
69 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
70 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
71 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
72 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
73 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
74 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
75 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
76 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
77
78 %package common
79 Summary:        Common files for Zabbix monitoring software
80 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
81 Group:          Networking/Utilities
82 Requires(postun):       /usr/sbin/groupdel
83 Requires(postun):       /usr/sbin/userdel
84 Requires(pre):  /bin/id
85 Requires(pre):  /usr/bin/getgid
86 Requires(pre):  /usr/sbin/groupadd
87 Requires(pre):  /usr/sbin/useradd
88 Provides:       group(zabbix)
89 Provides:       user(zabbix)
90
91 %description common
92 Common files for Zabbix monitoring software.
93
94 %description common -l pl.UTF-8
95 Wspólne pliki dla oprogramowania monitorującego Zabbix.
96
97 %package agentd
98 Summary:        Zabbix Agent
99 Summary(pl.UTF-8):      Agenta Zabbiksa
100 Group:          Networking/Utilities
101 Requires:       %{name}-common = %{version}-%{release}
102 Requires:       systemd-units >= 38
103 Obsoletes:      zabbix-agent-inetd
104 Obsoletes:      zabbix-agent-standalone
105
106 %description agentd
107 Zabbix agent collects data from the local system for a Zabbix server.
108
109 %description agentd -l pl.UTF-8
110 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
111
112 %package frontend-php
113 Summary:        PHP frontend for Zabbix
114 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
115 Group:          Applications/WWW
116 Requires:       php(bcmath)
117 Requires:       php(core) >= %{php_min_version}
118 Requires:       php(ctype)
119 Requires:       php(gd)
120 Requires:       php(gettext)
121 Requires:       php(json)
122 Requires:       php(mbstring)
123 Requires:       php(pcre)
124 Requires:       php(session)
125 Requires:       php(sockets)
126 Requires:       php(xml)
127 Requires:       php(xmlreader)
128 Requires:       php(xmlwriter)
129 Requires:       webapps
130 Requires:       webserver(alias)
131 Requires:       webserver(indexfile)
132 Requires:       webserver(php)
133 Suggests:       php(mysql)
134 Suggests:       php(pgsql)
135 Suggests:       php(sqlite3)
136 # used with sqlite3
137 Suggests:       php(sysvsem)
138 BuildArch:      noarch
139
140 %description frontend-php
141 This package provides web based (PHP) frontend for Zabbix.
142
143 %description frontend-php -l pl.UTF-8
144 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
145
146 %package get
147 Summary:        Program retrieving data from Zabbix agent
148 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
149 Group:          Networking/Utilities
150
151 %description get
152 This package provides a program retrieving data from Zabbix agent.
153
154 %description get -l pl.UTF-8
155 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
156
157 %package proxy
158 Summary:        Zabbix proxy
159 Summary(pl.UTF-8):      Proxy do Zabbiksa
160 Group:          Networking/Utilities
161 Requires:       %{name}-common = %{version}-%{release}
162 Requires:       systemd-units >= 38
163 Requires:       zabbix-proxy(db) = %{version}-%{release}
164
165 %description proxy
166 This package provides the Zabbix proxy.
167
168 %description proxy -l pl.UTF-8
169 Ten pakiet zawiera proxy Zabbix.
170
171 %package proxy-mysql
172 Summary:        MySQL support for Zabbix proxy
173 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
174 Group:          Networking/Utilities
175 Provides:       %{name}-proxy(db) = %{version}-%{release}
176 Obsoletes:      zabbix-proxy-postgresql
177 Obsoletes:      zabbix-proxy-sqlite3
178
179 %description proxy-mysql
180 This package provides the Zabbix proxy binary with MySQL support.
181
182 %description proxy-mysql -l pl.UTF-8
183 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
184
185 %package proxy-postgresql
186 Summary:        PostgreSQL support for Zabbix proxy
187 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
188 Group:          Networking/Utilities
189 Provides:       %{name}-proxy(db) = %{version}-%{release}
190 Obsoletes:      zabbix-proxy-mysql
191 Obsoletes:      zabbix-proxy-sqlite3
192
193 %description proxy-postgresql
194 This package provides the Zabbix proxy binary with PostgreSQL support.
195
196 %description proxy-postgresql -l pl.UTF-8
197 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
198
199 %package proxy-sqlite3
200 Summary:        SQLite 3 support for Zabbix proxy
201 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
202 Group:          Networking/Utilities
203 Provides:       %{name}-proxy(db) = %{version}-%{release}
204 Obsoletes:      zabbix-proxy-mysql
205 Obsoletes:      zabbix-proxy-postgresql
206
207 %description proxy-sqlite3
208 This package provides the Zabbix proxy binary with SQLite 3 support.
209
210 %description proxy-sqlite3 -l pl.UTF-8
211 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
212
213 %package sender
214 Summary:        Zabbix sender
215 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
216 Group:          Networking/Utilities
217
218 %description sender
219 This package provides the Zabbix sender.
220
221 %description sender -l pl.UTF-8
222 Ten pakiet zawiera program zawiadamiający Zabbiksa.
223
224 %package server
225 Summary:        Zabbix server
226 Summary(pl.UTF-8):      Serwer Zabbiksa
227 Group:          Networking/Utilities
228 Requires:       %{name}-common = %{version}-%{release}
229 Requires:       %{name}-server(db) = %{version}-%{release}
230 Requires:       systemd-units >= 38
231 Obsoletes:      zabbix-suckerd
232 Obsoletes:      zabbix-trapper-inetd
233 Obsoletes:      zabbix-trapper-standalone
234
235 %description server
236 This package provides the Zabbix server.
237
238 %description server -l pl.UTF-8
239 Ten pakiet zawiera serwer Zabbiksa.
240
241 %package server-mysql
242 Summary:        MySQL support for Zabbix server
243 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
244 Group:          Networking/Utilities
245 Provides:       %{name}-server(db) = %{version}-%{release}
246 Obsoletes:      zabbix-server-postgresql
247 Obsoletes:      zabbix-server-sqlite3
248
249 %description server-mysql
250 This package provides the Zabbix server binary for use with MySQL
251 database.
252
253 %description server-mysql -l pl.UTF-8
254 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
255
256 %package server-postgresql
257 Summary:        PostgreSQL support for Zabbix server
258 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
259 Group:          Networking/Utilities
260 Provides:       %{name}-server(db) = %{version}-%{release}
261 Obsoletes:      zabbix-server-mysql
262 Obsoletes:      zabbix-server-sqlite3
263
264 %description server-postgresql
265 This package provides the Zabbix server binary for use with PostgreSQL
266 database.
267
268 %description server-postgresql -l pl.UTF-8
269 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
270
271 %package server-sqlite3
272 Summary:        SQLite 3 support for Zabbix server
273 Summary(pl.UTF-8):      Obsługa SQLite 3 sla serwera Zabbiksa
274 Group:          Networking/Utilities
275 Requires(post): /bin/zcat
276 Provides:       %{name}-server(db) = %{version}-%{release}
277 Obsoletes:      zabbix-server-mysql
278 Obsoletes:      zabbix-server-postgresql
279
280 %description server-sqlite3
281 This package provides the Zabbix server binary for use with SQLite 3
282 database.
283
284 NOTE: Support for SQLite 3 is EXPERIMENTAL and not recommended.
285
286 %description server-sqlite3 -l pl.UTF-8
287 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych SQLite 3.
288
289 INFO: Wsparcie dla SQLite 3 jest EKSPERYMENTALNE i nie rekomendowane.
290
291 %package java
292 Summary:        Zabbix Java Gateway
293 Group:          Networking/Utilities
294 Requires:       %{name}-common = %{version}-%{release}
295 Requires:       systemd-units >= 38
296
297 %description java
298 This package provides the Zabbix Java Gateway.
299
300 %prep
301 %setup -q
302
303 %patch0 -p1
304 %patch1 -p1
305
306 %build
307
308 configure() {
309         %configure \
310         --enable-agent \
311         --enable-ipv6 \
312         %{__enable_disable java} \
313         --with-jabber \
314         --with-ldap \
315         --with-libcurl \
316         --with-libxml2 \
317         --with-net-snmp \
318         --with-openipmi \
319         --with-openssl \
320         --with-ssh2 \
321         --with-unixodbc \
322         "$@"
323 }
324
325 configure \
326         --disable-server \
327         --disable-proxy
328
329 %{__make}
330
331 # keep timestamps to prevent unneccessary rebuilds
332 cp -a include/config.h include/config.h.old
333 cp -a include/stamp-h1 include/stamp-h1.old
334
335 for database in %{databases} ; do
336         configure \
337                 --with-$database \
338                 --enable-server \
339                 --enable-proxy
340
341         # restore timestamps
342         touch --reference=include/config.h.old include/config.h
343         touch --reference=include/stamp-h1.old include/stamp-h1
344
345         # clean what needs rebuilding
346         for dir in src/libs/zbxdb* src/libs/zbxserver ; do
347                 %{__make} -C $dir clean
348         done
349
350         touch include/zbxdb.h
351
352         %{__make}
353
354         %{__make} install \
355                 -C src/zabbix_server \
356                 DESTDIR=$PWD/install-${database}
357         %{__make} install \
358                 -C src/zabbix_proxy \
359                 DESTDIR=$PWD/install-${database}
360
361         # prepare dirs for %%doc
362         for dir in upgrades/dbpatches/* ; do
363                 [ -d $dir/${database} ] || continue
364                 mkdir -p install-${database}/upgrade/$(basename $dir)
365                 cp -a $dir/${databases}/* install-${database}/upgrade/$(basename $dir)
366         done
367 done
368
369 %install
370 rm -rf $RPM_BUILD_ROOT
371 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/webapps/%{_webapp},%{_appdir}} \
372         $RPM_BUILD_ROOT{/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
373
374 %{__make} install \
375         DESTDIR=$RPM_BUILD_ROOT \
376         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
377
378 for database in %{databases} ; do
379         cp -p install-$database/%{_sbindir}/zabbix_server \
380                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
381         cp -p install-$database/%{_sbindir}/zabbix_proxy \
382                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
383 done
384
385 if [ -n "$database" ] ; then
386         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
387         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
388 fi
389
390 %if %{with sqlite3}
391 install -d $RPM_BUILD_ROOT/var/lib/zabbix
392 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
393 %endif
394
395 cp -r frontends $RPM_BUILD_ROOT%{_appdir}
396
397 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
398 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
399
400 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
401 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
402 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
403 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
404
405 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
406
407 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
408 ln -s %{_sysconfdir}/frontend $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf
409 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
410
411 %if %{with java}
412 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
413 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
414 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
415 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
416 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
417 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
418
419 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
420 #!/bin/sh
421
422 exec %{_datadir}/zabbix_java/startup.sh "$@"
423 EOF
424
425 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
426 #!/bin/sh
427
428 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
429 EOF
430 %endif
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
436 %webapp_register apache %{_webapp}
437
438 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
439 %webapp_unregister apache %{_webapp}
440
441 %triggerin frontend-php -- apache < 2.2.0, apache-base
442 %webapp_register httpd %{_webapp}
443
444 %triggerun frontend-php -- apache < 2.2.0, apache-base
445 %webapp_unregister httpd %{_webapp}
446
447 %pre common
448 %groupadd -g 111 zabbix
449 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
450 %addusertogroup -q zabbix proc
451
452 %postun common
453 if [ "$1" = "0" ]; then
454         %userremove zabbix
455         %groupremove zabbix
456 fi
457
458 %post server-mysql
459 if [ "$1" = 1 ]; then
460         %banner -e %{name}-server <<-EOF
461         You should create database for Zabbix.
462
463         Running these should be fine in most cases:
464         mysqladmin create zabbix
465         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
466         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
467         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
468 EOF
469 fi
470 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
471
472 %post server-postgresql
473 if [ "$1" = 1 ]; then
474         %banner -e %{name}-server <<-EOF
475         You should create database for Zabbix.
476
477         Running these should be fine in most cases:
478
479         createuser zabbix
480         createdb -O zabbix zabbix
481         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
482         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
483         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
484 EOF
485 fi
486 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
487
488 %post server-sqlite3
489 if [ "$1" = 1 ]; then
490         if [ ! -f /var/lib/zabbix/zabbix.db ] ; then
491                 %banner -e %{name}-server <<-EOF
492                 Creating sqlite3 database for Zabbix in /var/lib/zabbix/zabbix.db
493 EOF
494                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/schema.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
495                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/images.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
496                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/data.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
497                 chown zabbix:zabbix /var/lib/zabbix/zabbix.db && \
498                 chmod 644 /var/lib/zabbix/zabbix.db || :
499         fi
500 fi
501 ln -sf %{_sbindir}/zabbix_server-sqlite3 %{_sbindir}/zabbix_server || :
502
503 %post server
504 %systemd_post zabbix_server.service
505
506 %preun server
507 %systemd_preun zabbix_server.service
508
509 %postun server
510 if [ "$1" = "0" ]; then
511         if [ -L %{_sbindir}/zabbix_server ] ; then
512                 rm -f %{_sbindir}/zabbix_server || :
513         fi
514 fi
515 %systemd_reload
516
517 %post agentd
518 %systemd_post zabbix_agentd.service
519
520 %preun agentd
521 %systemd_preun zabbix_agentd.service
522
523 %postun agentd
524 %systemd_reload
525
526 %post proxy-mysql
527 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
528
529 %post proxy-postgresql
530 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
531
532 %post proxy-sqlite3
533 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
534
535 %post proxy
536 %systemd_post zabbix_proxy.service
537
538 %preun proxy
539 %systemd_preun zabbix_proxy.service
540
541 %postun proxy
542 %systemd_reload
543
544 %post java
545 %systemd_post zabbix_java.service
546
547 %preun java
548 %systemd_preun zabbix_java.service
549
550 %postun java
551 %systemd_reload
552
553 %files
554 %defattr(644,root,root,755)
555 %doc AUTHORS ChangeLog README
556
557 %files common
558 %defattr(644,root,root,755)
559 %doc AUTHORS ChangeLog README
560 %attr(751,root,zabbix) %dir %{_sysconfdir}
561 %attr(751,root,http) %dir %{_sysconfdir}/frontend
562 %dir %{_appdir}
563 %dir %{_appdir}/frontends
564 %dir %attr(770,root,zabbix) /run/zabbix
565 %dir %attr(775,root,zabbix) /var/log/zabbix
566 %{systemdtmpfilesdir}/zabbix.conf
567
568 %files agentd
569 %defattr(644,root,root,755)
570 %doc conf/zabbix_agentd/*.conf
571 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
572 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
573 %attr(755,root,root) %{_sbindir}/zabbix_agentd
574 %{_mandir}/man8/zabbix_agentd*
575 %{systemdunitdir}/zabbix_agentd.service
576
577 %files frontend-php
578 %defattr(644,root,root,755)
579 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
580 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*
581 %{_appdir}/frontends/php
582 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
583 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
584 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
585 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
586
587 %files get
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/zabbix_get
590 %{_mandir}/man1/zabbix_get*
591
592 %if %{any_database}
593 %files proxy
594 %defattr(644,root,root,755)
595 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
596 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
597 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
598 %{_mandir}/man8/zabbix_proxy*
599 %{systemdunitdir}/zabbix_proxy.service
600 %endif
601
602 %if %{with mysql}
603 %files proxy-mysql
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
606 %endif
607
608 %if %{with pgsql}
609 %files proxy-postgresql
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
612 %endif
613
614 %if %{with sqlite3}
615 %files proxy-sqlite3
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
618 %endif
619
620 %files sender
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/zabbix_sender
623 %{_mandir}/man1/zabbix_sender*
624
625 %if %{any_database}
626 %files server
627 %defattr(644,root,root,755)
628 %doc upgrades/dbpatches
629 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
630 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
631 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
632 %{_mandir}/man8/zabbix_server*
633 %{systemdunitdir}/zabbix_server.service
634 %endif
635
636 %if %{with mysql}
637 %files server-mysql
638 %defattr(644,root,root,755)
639 %doc database/mysql/*.sql install-mysql/upgrade
640 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
641 %endif
642
643 %if %{with pgsql}
644 %files server-postgresql
645 %defattr(644,root,root,755)
646 %doc database/postgresql/*.sql install-postgresql/upgrade
647 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
648 %endif
649
650 %if %{with sqlite3}
651 %files server-sqlite3
652 %defattr(644,root,root,755)
653 %doc database/sqlite3/*.sql
654 %attr(755,root,root) %{_sbindir}/zabbix_server-sqlite3
655 %dir %attr(771,root,zabbix) /var/lib/zabbix
656 %ghost %attr(644,zabbix,zabbix) /var/lib/zabbix/zabbix.db
657 %endif
658
659 %if %{with java}
660 %files java
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_sbindir}/zabbix_java-start
663 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
664 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
665 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
666 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
667 %dir %{_datadir}/zabbix_java
668 %{_datadir}/zabbix_java/bin
669 %{_datadir}/zabbix_java/lib
670 %{_datadir}/zabbix_java/settings.sh
671 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
672 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
673 %{systemdunitdir}/zabbix_java.service
674 %endif
This page took 0.121693 seconds and 2 git commands to generate.