]> git.pld-linux.org Git - packages/zabbix.git/blob - zabbix.spec
adapter
[packages/zabbix.git] / zabbix.spec
1 # TODO:
2 # - initscript for zabbix-agentd, zabbix-server, zabbix-proxy and zabbix-java
3 #
4 # Conditional build:
5 %bcond_without  pgsql   # enable PostgreSQL support
6 %bcond_without  sqlite3 # enable sqlite3 support
7 %bcond_without  mysql   # enable MySQL support
8 %bcond_without  java    # disable java support
9
10 %define databases %{?with_pgsql:postgresql} %{?with_mysql:mysql} %{?with_sqlite3:sqlite3}
11 %define any_database %{with pgsql}%{with mysql}%{with sqlite3}
12
13 %define         php_min_version 5.4.0
14 Summary:        Zabbix - network monitoring software
15 Summary(pl.UTF-8):      Zabbix - oprogramowanie do monitorowania sieci
16 Name:           zabbix
17 Version:        3.2.6
18 Release:        1
19 License:        GPL v2+
20 Group:          Networking/Utilities
21 Source0:        http://downloads.sourceforge.net/zabbix/%{name}-%{version}.tar.gz
22 # Source0-md5:  87428256f7e48b8bf10a926df27a34c8
23 Source1:        %{name}-apache.conf
24 Source2:        %{name}_server.service
25 Source3:        %{name}_agentd.service
26 Source4:        %{name}_proxy.service
27 Source5:        %{name}_java.service
28 Source6:        %{name}.tmpfiles
29 Patch0:         config.patch
30 Patch1:         sqlite3_dbname.patch
31 URL:            http://zabbix.sourceforge.net/
32 BuildRequires:  OpenIPMI-devel
33 BuildRequires:  curl-devel
34 BuildRequires:  iksemel-devel
35 %{?with_java:BuildRequires:     jdk}
36 BuildRequires:  libssh2-devel
37 BuildRequires:  libxml2-devel
38 %{?with_mysql:BuildRequires:    mysql-devel}
39 BuildRequires:  net-snmp-devel
40 BuildRequires:  openldap-devel >= 2.4.6
41 BuildRequires:  openssl-devel >= 0.9.7d
42 %{?with_pgsql:BuildRequires:    postgresql-devel}
43 BuildRequires:  rpmbuild(macros) >= 1.671
44 %{?with_sqlite3:BuildRequires:  sqlite3-devel}
45 BuildRequires:  unixODBC-devel
46 Requires:       %{name}-agentd = %{version}-%{release}
47 Requires:       %{name}-frontend-php = %{version}-%{release}
48 Requires:       %{name}-server = %{version}-%{release}
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %define         _sysconfdir     /etc/%{name}
52 %define         _appdir         %{_datadir}/%{name}
53 %define         _webapps        /etc/webapps
54 %define         _webapp         %{name}
55
56 %description
57 Zabbix is software that monitors numerous parameters of a network and
58 the servers on that network. It is a useful tool for monitoring the
59 health and integrity of servers. Zabbix uses a flexible notification
60 mechanism that allows users to configure email based alerts for
61 virtually any event. All monitored parameters are stored in a
62 database. Zabbix offers excellent reporting and data visualisation
63 features based on the stored data. Zabbix supports both polling and
64 trapping. All Zabbix reports and statistics, as well as configuration
65 parameters, are accessed through a web-based front end.
66
67 %description -l pl.UTF-8
68 Zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
69 serwerów sieciowych. Jest przydatny przy monitorowaniu działania
70 serwerów. Jorzysta z elastycznego mechanizmu powiadamiania, który
71 pozwala użytkownikom konfigurować powiadamianie pocztą elektroniczną
72 dla praktycznie wszelkich zdarzeń. Monitorowane parametry są
73 przechowywane w bazie danych. W oparciu o przechowywane dane Zabbix
74 oferuje świetne raportowanie i funkcje wizualizacji. Wspiera zarówno
75 odpytywanie jak i pułapkowanie. Dostęp do wszystkich raportów i
76 statystyk Zabbiksa jest możliwy poprzez interfejs oparty o WWW.
77
78 %package common
79 Summary:        Common files for Zabbix monitoring software
80 Summary(pl.UTF-8):      Wspólne pliki dla oprogramowania monitorującego Zabbix
81 Group:          Networking/Utilities
82 Requires(postun):       /usr/sbin/groupdel
83 Requires(postun):       /usr/sbin/userdel
84 Requires(pre):  /bin/id
85 Requires(pre):  /usr/bin/getgid
86 Requires(pre):  /usr/sbin/groupadd
87 Requires(pre):  /usr/sbin/useradd
88 Provides:       group(zabbix)
89 Provides:       user(zabbix)
90
91 %description common
92 Common files for Zabbix monitoring software.
93
94 %description common -l pl.UTF-8
95 Wspólne pliki dla oprogramowania monitorującego Zabbix.
96
97 %package agentd
98 Summary:        Zabbix Agent
99 Summary(pl.UTF-8):      Agenta Zabbiksa
100 Group:          Networking/Utilities
101 Requires:       %{name}-common = %{version}-%{release}
102 Requires:       systemd-units >= 38
103 Obsoletes:      zabbix-agent-inetd
104 Obsoletes:      zabbix-agent-standalone
105
106 %description agentd
107 Zabbix agent collects data from the local system for a Zabbix server.
108
109 %description agentd -l pl.UTF-8
110 Agent zbiera dane z lokalnej maszyny dla serwera Zabbix.
111
112 %package frontend-php
113 Summary:        PHP frontend for Zabbix
114 Summary(pl.UTF-8):      Interfejs PHP dla Zabbiksa
115 Group:          Applications/WWW
116 Requires:       php(bcmath)
117 Requires:       php(core) >= %{php_min_version}
118 Requires:       php(ctype)
119 Requires:       php(gd)
120 Requires:       php(gettext)
121 Requires:       php(json)
122 Requires:       php(mbstring)
123 Requires:       php(pcre)
124 Requires:       php(session)
125 Requires:       php(sockets)
126 Requires:       php(xml)
127 Requires:       php(xmlreader)
128 Requires:       php(xmlwriter)
129 Requires:       webapps
130 Requires:       webserver(alias)
131 Requires:       webserver(indexfile)
132 Requires:       webserver(php)
133 Suggests:       php(mysql)
134 Suggests:       php(pgsql)
135 Suggests:       php(sqlite3)
136 # used with sqlite3
137 Suggests:       php(sysvsem)
138
139 %description frontend-php
140 This package provides web based (PHP) frontend for Zabbix.
141
142 %description frontend-php -l pl.UTF-8
143 Ten pakiet dostarcza napisany w PHP frontend dla Zabbiksa.
144
145 %package get
146 Summary:        Program retrieving data from Zabbix agent
147 Summary(pl.UTF-8):      Program odpytujÄcy agenta Zabbiksa
148 Group:          Networking/Utilities
149
150 %description get
151 This package provides a program retrieving data from Zabbix agent.
152
153 %description get -l pl.UTF-8
154 Ten pakiet zawiera program odpytujÄcy agenta Zabbiksa.
155
156 %package proxy
157 Summary:        Zabbix proxy
158 Summary(pl.UTF-8):      Proxy do Zabbiksa
159 Group:          Networking/Utilities
160 Requires:       %{name}-common = %{version}-%{release}
161 Requires:       systemd-units >= 38
162 Requires:       zabbix-proxy(db) = %{version}-%{release}
163
164 %description proxy
165 This package provides the Zabbix proxy.
166
167 %description proxy -l pl.UTF-8
168 Ten pakiet zawiera proxy Zabbix.
169
170 %package proxy-mysql
171 Summary:        MySQL support for Zabbix proxy
172 Summary(pl.UTF-8):      Obsługa MySQL dla proxy do Zabbiksa
173 Group:          Networking/Utilities
174 Provides:       %{name}-proxy(db) = %{version}-%{release}
175 Obsoletes:      zabbix-proxy-postgresql
176 Obsoletes:      zabbix-proxy-sqlite3
177
178 %description proxy-mysql
179 This package provides the Zabbix proxy binary with MySQL support.
180
181 %description proxy-mysql -l pl.UTF-8
182 Ten pakiet zawiera proxy Zabbix z obsługą MySQL.
183
184 %package proxy-postgresql
185 Summary:        PostgreSQL support for Zabbix proxy
186 Summary(pl.UTF-8):      Obsługa PostgreSQL dla proxy do Zabbiksa
187 Group:          Networking/Utilities
188 Provides:       %{name}-proxy(db) = %{version}-%{release}
189 Obsoletes:      zabbix-proxy-mysql
190 Obsoletes:      zabbix-proxy-sqlite3
191
192 %description proxy-postgresql
193 This package provides the Zabbix proxy binary with PostgreSQL support.
194
195 %description proxy-postgresql -l pl.UTF-8
196 Ten pakiet zawiera proxy Zabbix z obsługą PostgreSQL.
197
198 %package proxy-sqlite3
199 Summary:        SQLite 3 support for Zabbix proxy
200 Summary(pl.UTF-8):      Obsługa SQLite 3 dla proxy do Zabbiksa
201 Group:          Networking/Utilities
202 Provides:       %{name}-proxy(db) = %{version}-%{release}
203 Obsoletes:      zabbix-proxy-mysql
204 Obsoletes:      zabbix-proxy-postgresql
205
206 %description proxy-sqlite3
207 This package provides the Zabbix proxy binary with SQLite 3 support.
208
209 %description proxy-sqlite3 -l pl.UTF-8
210 Ten pakiet zawiera proxy Zabbix z obsługą SQLite 3.
211
212 %package sender
213 Summary:        Zabbix sender
214 Summary(pl.UTF-8):      Program zawiadamiający Zabbiksa
215 Group:          Networking/Utilities
216
217 %description sender
218 This package provides the Zabbix sender.
219
220 %description sender -l pl.UTF-8
221 Ten pakiet zawiera program zawiadamiający Zabbiksa.
222
223 %package server
224 Summary:        Zabbix server
225 Summary(pl.UTF-8):      Serwer Zabbiksa
226 Group:          Networking/Utilities
227 Requires:       %{name}-common = %{version}-%{release}
228 Requires:       %{name}-server(db) = %{version}-%{release}
229 Requires:       systemd-units >= 38
230 Obsoletes:      zabbix-suckerd
231 Obsoletes:      zabbix-trapper-inetd
232 Obsoletes:      zabbix-trapper-standalone
233
234 %description server
235 This package provides the Zabbix server.
236
237 %description server -l pl.UTF-8
238 Ten pakiet zawiera serwer Zabbiksa.
239
240 %package server-mysql
241 Summary:        MySQL support for Zabbix server
242 Summary(pl.UTF-8):      Obsługa MySQL sla serwera Zabbiksa
243 Group:          Networking/Utilities
244 Provides:       %{name}-server(db) = %{version}-%{release}
245 Obsoletes:      zabbix-server-postgresql
246 Obsoletes:      zabbix-server-sqlite3
247
248 %description server-mysql
249 This package provides the Zabbix server binary for use with MySQL
250 database.
251
252 %description server-mysql -l pl.UTF-8
253 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych MySQL.
254
255 %package server-postgresql
256 Summary:        PostgreSQL support for Zabbix server
257 Summary(pl.UTF-8):      Obsługa PostgreSQL sla serwera Zabbiksa
258 Group:          Networking/Utilities
259 Provides:       %{name}-server(db) = %{version}-%{release}
260 Obsoletes:      zabbix-server-mysql
261 Obsoletes:      zabbix-server-sqlite3
262
263 %description server-postgresql
264 This package provides the Zabbix server binary for use with PostgreSQL
265 database.
266
267 %description server-postgresql -l pl.UTF-8
268 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych PostgreSQL.
269
270 %package server-sqlite3
271 Summary:        SQLite 3 support for Zabbix server
272 Summary(pl.UTF-8):      Obsługa SQLite 3 sla serwera Zabbiksa
273 Group:          Networking/Utilities
274 Requires(post): /bin/zcat
275 Provides:       %{name}-server(db) = %{version}-%{release}
276 Obsoletes:      zabbix-server-mysql
277 Obsoletes:      zabbix-server-postgresql
278
279 %description server-sqlite3
280 This package provides the Zabbix server binary for use with SQLite 3
281 database.
282
283 NOTE: Support for SQLite 3 is EXPERIMENTAL and not recommended.
284
285 %description server-sqlite3 -l pl.UTF-8
286 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych SQLite 3.
287
288 INFO: Wsparcie dla SQLite 3 jest EKSPERYMENTALNE i nie rekomendowane.
289
290 %package java
291 Summary:        Zabbix Java Gateway
292 Group:          Networking/Utilities
293 Requires:       %{name}-common = %{version}-%{release}
294 Requires:       systemd-units >= 38
295
296 %description java
297 This package provides the Zabbix Java Gateway.
298
299 %prep
300 %setup -q
301
302 %patch0 -p1
303 %patch1 -p1
304
305 %build
306
307 configure() {
308         %configure \
309         --enable-agent \
310         --enable-ipv6 \
311         %{__enable_disable java} \
312         --with-jabber \
313         --with-ldap \
314         --with-libcurl \
315         --with-libxml2 \
316         --with-net-snmp \
317         --with-openipmi \
318         --with-openssl \
319         --with-ssh2 \
320         --with-unixodbc \
321         "$@"
322 }
323
324 configure \
325         --disable-server \
326         --disable-proxy
327
328 %{__make}
329
330 # keep timestamps to prevent unneccessary rebuilds
331 cp -a include/config.h include/config.h.old
332 cp -a include/stamp-h1 include/stamp-h1.old
333
334 for database in %{databases} ; do
335         configure \
336                 --with-$database \
337                 --enable-server \
338                 --enable-proxy
339
340         # restore timestamps
341         touch --reference=include/config.h.old include/config.h
342         touch --reference=include/stamp-h1.old include/stamp-h1
343
344         # clean what needs rebuilding
345         for dir in src/libs/zbxdb* src/libs/zbxserver ; do
346                 %{__make} -C $dir clean
347         done
348
349         touch include/zbxdb.h
350
351         %{__make}
352
353         %{__make} install \
354                 -C src/zabbix_server \
355                 DESTDIR=$PWD/install-${database}
356         %{__make} install \
357                 -C src/zabbix_proxy \
358                 DESTDIR=$PWD/install-${database}
359
360         # prepare dirs for %%doc
361         for dir in upgrades/dbpatches/* ; do
362                 [ -d $dir/${database} ] || continue
363                 mkdir -p install-${database}/upgrade/$(basename $dir)
364                 cp -a $dir/${databases}/* install-${database}/upgrade/$(basename $dir)
365         done
366 done
367
368 %install
369 rm -rf $RPM_BUILD_ROOT
370 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/webapps/%{_webapp},%{_appdir}} \
371         $RPM_BUILD_ROOT{/run/zabbix,/var/log/zabbix,%{systemdunitdir},%{systemdtmpfilesdir}}
372
373 %{__make} install \
374         DESTDIR=$RPM_BUILD_ROOT \
375         ZJG_DEST=$RPM_BUILD_ROOT%{_datadir}/zabbix_java
376
377 for database in %{databases} ; do
378         cp -p install-$database/%{_sbindir}/zabbix_server \
379                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_server-$database
380         cp -p install-$database/%{_sbindir}/zabbix_proxy \
381                 $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy-$database
382 done
383
384 if [ -n "$database" ] ; then
385         ln -sf %{_sbindir}/zabbix_server-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_server
386         ln -sf %{_sbindir}/zabbix_proxy-$database $RPM_BUILD_ROOT%{_sbindir}/zabbix_proxy
387 fi
388
389 %if %{with sqlite3}
390 install -d $RPM_BUILD_ROOT/var/lib/zabbix
391 touch $RPM_BUILD_ROOT/var/lib/zabbix/zabbix.db
392 %endif
393
394 cp -r frontends $RPM_BUILD_ROOT%{_appdir}
395
396 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
397 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
398
399 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_server.service
400 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_agentd.service
401 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_proxy.service
402 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/zabbix_java.service
403
404 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/zabbix.conf
405
406 mv $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf $RPM_BUILD_ROOT%{_sysconfdir}/frontend
407 ln -s %{_sysconfdir}/frontend $RPM_BUILD_ROOT%{_appdir}/frontends/php/conf
408 touch $RPM_BUILD_ROOT%{_sysconfdir}/frontend/zabbix.conf.php
409
410 %if %{with java}
411 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh $RPM_BUILD_ROOT%{_sysconfdir}/zabbix_java.conf
412 ln -s %{_sysconfdir}/zabbix_java.conf $RPM_BUILD_ROOT%{_datadir}/zabbix_java/settings.sh
413 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback.xml
414 ln -s %{_sysconfdir}/java-logback.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback.xml
415 mv $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml $RPM_BUILD_ROOT%{_sysconfdir}/java-logback-console.xml
416 ln -s %{_sysconfdir}/java-logback-console.xml $RPM_BUILD_ROOT%{_datadir}/zabbix_java/lib/logback-console.xml
417
418 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-start <<'EOF'
419 #!/bin/sh
420
421 exec %{_datadir}/zabbix_java/startup.sh "$@"
422 EOF
423
424 cat >$RPM_BUILD_ROOT%{_sbindir}/zabbix_java-stop <<'EOF'
425 #!/bin/sh
426
427 exec %{_datadir}/zabbix_java/shutdown.sh "$@"
428 EOF
429 %endif
430
431 %clean
432 rm -rf $RPM_BUILD_ROOT
433
434 %triggerin frontend-php -- apache1 < 1.3.37-3, apache1-base
435 %webapp_register apache %{_webapp}
436
437 %triggerun frontend-php -- apache1 < 1.3.37-3, apache1-base
438 %webapp_unregister apache %{_webapp}
439
440 %triggerin frontend-php -- apache < 2.2.0, apache-base
441 %webapp_register httpd %{_webapp}
442
443 %triggerun frontend-php -- apache < 2.2.0, apache-base
444 %webapp_unregister httpd %{_webapp}
445
446 %pre common
447 %groupadd -g 111 zabbix
448 %useradd -d / -u 111 -g zabbix -c "Zabbix User" -s /bin/false zabbix
449 %addusertogroup -q zabbix proc
450
451 %postun common
452 if [ "$1" = "0" ]; then
453         %userremove zabbix
454         %groupremove zabbix
455 fi
456
457 %post server-mysql
458 if [ "$1" = 1 ]; then
459         %banner -e %{name}-server <<-EOF
460         You should create database for Zabbix.
461
462         Running these should be fine in most cases:
463         mysqladmin create zabbix
464         zcat %{_docdir}/%{name}-server-mysql-%{version}/schema.sql.gz | mysql zabbix
465         zcat %{_docdir}/%{name}-server-mysql-%{version}/images.sql.gz | mysql zabbix
466         zcat %{_docdir}/%{name}-server-mysql-%{version}/data.sql.gz | mysql zabbix
467 EOF
468 fi
469 ln -sf %{_sbindir}/zabbix_server-mysql %{_sbindir}/zabbix_server || :
470
471 %post server-postgresql
472 if [ "$1" = 1 ]; then
473         %banner -e %{name}-server <<-EOF
474         You should create database for Zabbix.
475
476         Running these should be fine in most cases:
477
478         createuser zabbix
479         createdb -O zabbix zabbix
480         zcat %{_docdir}/%{name}-server-postgresql-%{version}/schema.sql.gz | psql -u zabbix zabbix
481         zcat %{_docdir}/%{name}-server-postgresql-%{version}/images.sql.gz | psql -u zabbix zabbix
482         zcat %{_docdir}/%{name}-server-postgresql-%{version}/data.sql.gz | psql -u zabbix zabbix
483 EOF
484 fi
485 ln -sf %{_sbindir}/zabbix_server-postgresql %{_sbindir}/zabbix_server || :
486
487 %post server-sqlite3
488 if [ "$1" = 1 ]; then
489         if [ ! -f /var/lib/zabbix/zabbix.db ] ; then
490                 %banner -e %{name}-server <<-EOF
491                 Creating sqlite3 database for Zabbix in /var/lib/zabbix/zabbix.db
492 EOF
493                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/schema.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
494                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/images.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
495                 zcat %{_docdir}/%{name}-server-sqlite3-%{version}/data.sql.gz | sqlite3 /var/lib/zabbix/zabbix.db && \
496                 chown zabbix:zabbix /var/lib/zabbix/zabbix.db && \
497                 chmod 644 /var/lib/zabbix/zabbix.db || :
498         fi
499 fi
500 ln -sf %{_sbindir}/zabbix_server-sqlite3 %{_sbindir}/zabbix_server || :
501
502 %post server
503 %systemd_post zabbix_server.service
504
505 %preun server
506 %systemd_preun zabbix_server.service
507
508 %postun server
509 if [ "$1" = "0" ]; then
510         if [ -L %{_sbindir}/zabbix_server ] ; then
511                 rm -f %{_sbindir}/zabbix_server || :
512         fi
513 fi
514 %systemd_reload
515
516 %post agentd
517 %systemd_post zabbix_agentd.service
518
519 %preun agentd
520 %systemd_preun zabbix_agentd.service
521
522 %postun agentd
523 %systemd_reload
524
525 %post proxy-mysql
526 ln -sf %{_sbindir}/zabbix_proxy-mysql %{_sbindir}/zabbix_proxy || :
527
528 %post proxy-postgresql
529 ln -sf %{_sbindir}/zabbix_proxy-postgresql %{_sbindir}/zabbix_proxy || :
530
531 %post proxy-sqlite3
532 ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
533
534 %post proxy
535 %systemd_post zabbix_proxy.service
536
537 %preun proxy
538 %systemd_preun zabbix_proxy.service
539
540 %postun proxy
541 %systemd_reload
542
543 %post java
544 %systemd_post zabbix_java.service
545
546 %preun java
547 %systemd_preun zabbix_java.service
548
549 %postun java
550 %systemd_reload
551
552 %files
553 %defattr(644,root,root,755)
554 %doc AUTHORS ChangeLog README
555
556 %files common
557 %defattr(644,root,root,755)
558 %doc AUTHORS ChangeLog README
559 %attr(751,root,zabbix) %dir %{_sysconfdir}
560 %attr(751,root,http) %dir %{_sysconfdir}/frontend
561 %dir %{_appdir}
562 %dir %{_appdir}/frontends
563 %dir %attr(770,root,zabbix) /run/zabbix
564 %dir %attr(775,root,zabbix) /var/log/zabbix
565 %{systemdtmpfilesdir}/zabbix.conf
566
567 %files agentd
568 %defattr(644,root,root,755)
569 %doc conf/zabbix_agentd/*.conf
570 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
571 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
572 %attr(755,root,root) %{_sbindir}/zabbix_agentd
573 %{_mandir}/man8/zabbix_agentd*
574 %{systemdunitdir}/zabbix_agentd.service
575
576 %files frontend-php
577 %defattr(644,root,root,755)
578 %attr(750,root,http) %dir %{_webapps}/%{_webapp}
579 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*
580 %{_appdir}/frontends/php
581 %ghost %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php
582 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/.htaccess
583 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/maintenance.inc.php
584 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/frontend/zabbix.conf.php.example
585
586 %files get
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_bindir}/zabbix_get
589 %{_mandir}/man1/zabbix_get*
590
591 %if %{any_database}
592 %files proxy
593 %defattr(644,root,root,755)
594 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
595 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
596 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
597 %{_mandir}/man8/zabbix_proxy*
598 %{systemdunitdir}/zabbix_proxy.service
599 %endif
600
601 %if %{with mysql}
602 %files proxy-mysql
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_sbindir}/zabbix_proxy-mysql
605 %endif
606
607 %if %{with pgsql}
608 %files proxy-postgresql
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_sbindir}/zabbix_proxy-postgresql
611 %endif
612
613 %if %{with sqlite3}
614 %files proxy-sqlite3
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_sbindir}/zabbix_proxy-sqlite3
617 %endif
618
619 %files sender
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_bindir}/zabbix_sender
622 %{_mandir}/man1/zabbix_sender*
623
624 %if %{any_database}
625 %files server
626 %defattr(644,root,root,755)
627 %doc upgrades/dbpatches
628 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
629 %dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
630 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
631 %{_mandir}/man8/zabbix_server*
632 %{systemdunitdir}/zabbix_server.service
633 %endif
634
635 %if %{with mysql}
636 %files server-mysql
637 %defattr(644,root,root,755)
638 %doc database/mysql/*.sql install-mysql/upgrade
639 %attr(755,root,root) %{_sbindir}/zabbix_server-mysql
640 %endif
641
642 %if %{with pgsql}
643 %files server-postgresql
644 %defattr(644,root,root,755)
645 %doc database/postgresql/*.sql install-postgresql/upgrade
646 %attr(755,root,root) %{_sbindir}/zabbix_server-postgresql
647 %endif
648
649 %if %{with sqlite3}
650 %files server-sqlite3
651 %defattr(644,root,root,755)
652 %doc database/sqlite3/*.sql
653 %attr(755,root,root) %{_sbindir}/zabbix_server-sqlite3
654 %dir %attr(771,root,zabbix) /var/lib/zabbix
655 %ghost %attr(644,zabbix,zabbix) /var/lib/zabbix/zabbix.db
656 %endif
657
658 %if %{with java}
659 %files java
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_sbindir}/zabbix_java-start
662 %attr(755,root,root) %{_sbindir}/zabbix_java-stop
663 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_java.conf
664 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback.xml
665 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/java-logback-console.xml
666 %dir %{_datadir}/zabbix_java
667 %{_datadir}/zabbix_java/bin
668 %{_datadir}/zabbix_java/lib
669 %{_datadir}/zabbix_java/settings.sh
670 %attr(755,root,root) %{_datadir}/zabbix_java/shutdown.sh
671 %attr(755,root,root) %{_datadir}/zabbix_java/startup.sh
672 %{systemdunitdir}/zabbix_java.service
673 %endif
This page took 0.092384 seconds and 3 git commands to generate.