]> git.pld-linux.org Git - packages/youtube-dl.git/blob - youtube-dl.spec
- add version validation and update to 20130329 (which fails that validation unfortun...
[packages/youtube-dl.git] / youtube-dl.spec
1 %define ver     2013.03.29
2 Summary:        Video extraction utility for YouTube
3 Summary(pl.UTF-8):      Narzędzie do wydobywania filmów z YouTube
4 Name:           youtube-dl
5 Version:        %(echo %{ver} | tr -d .)
6 Release:        1
7 License:        Public Domain
8 Group:          Applications/System
9 Source0:        https://github.com/rg3/youtube-dl/raw/%{ver}/youtube-dl?/%{name}-%{version}
10 # Source0-md5:  a2a30e4b9ad06538d92968ceb2d58b3f
11 URL:            http://rg3.github.com/youtube-dl/
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.219
14 %pyrequires_eq  python-libs
15 Requires:       python >= 2.6
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 youtube-dl is a small command-line program to download videos from
21 YouTube.com.
22
23 %description -l pl.UTF-8
24 youtube-dl jest programem do ściągania plików video z YouTube.com.
25
26 %prep
27 %setup -c -T
28
29 %build
30 ver=$(%{__python} %{SOURCE0} --version | tr -d .)
31
32 if [ "$ver" != "%{version}" ]; then
33         echo "Source with $ver found while expecting %{version}!" >&2
34         exit 1
35 fi
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_bindir}
40 install %{SOURCE0} $RPM_BUILD_ROOT%{_bindir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %attr(755,root,root) %{_bindir}/youtube-dl
This page took 0.031896 seconds and 4 git commands to generate.