]> git.pld-linux.org Git - packages/yamagi-quake2.git/blob - yamagi-quake2.spec
macros for %cmake
[packages/yamagi-quake2.git] / yamagi-quake2.spec
1 Summary:        Yamagi Quake II client
2 Name:           yamagi-quake2
3 Version:        8.00
4 Release:        1
5 License:        GPL v2+
6 Group:          X11/Applications/Games
7 Source0:        https://deponie.yamagi.org/quake2/quake2-%{version}.tar.xz
8 # Source0-md5:  e0c7fb6031e2cbf4396959b074ec7d72
9 URL:            https://www.yamagi.org/quake2/
10 BuildRequires:  OpenAL-devel
11 BuildRequires:  OpenGL-devel
12 BuildRequires:  SDL2-devel
13 BuildRequires:  cmake >= 3.0
14 BuildRequires:  curl-devel
15 BuildRequires:  rpmbuild(macros) >= 1.605
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         gamedir         %{_libdir}/%{name}
19
20 %description
21 Yamagi Quake II is an enhanced client for id Software's Quake II with
22 focus on offline and coop gameplay. Both the gameplay and the graphics
23 are unchanged, but many bugs in the last official release were fixed
24 and some nice to have features like widescreen support and a modern
25 OpenGL 3.2 renderer were added. Unlike most other Quake II source
26 ports Yamagi Quake II is fully 64-bit clean. It works perfectly on
27 modern processors and operating systems.
28
29 %prep
30 %setup -q -n quake2-%{version}
31
32 %build
33 mkdir -p build
34 cd build
35 %cmake .. \
36         -DSYSTEMWIDE_SUPPORT=ON
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 install -d $RPM_BUILD_ROOT{%{_bindir},%{gamedir}/baseq2}
43
44 cd build/release
45 install -p q2ded quake2 *.so $RPM_BUILD_ROOT%{gamedir}
46 install -p baseq2/*.so $RPM_BUILD_ROOT%{gamedir}/baseq2
47 ln -s %{gamedir}/quake2 $RPM_BUILD_ROOT%{_bindir}/yamagi-quake2
48 ln -s %{gamedir}/q2ded $RPM_BUILD_ROOT%{_bindir}/yamagi-q2ded
49
50 cd ../../stuff
51 install -p yq2.cfg $RPM_BUILD_ROOT%{gamedir}/baseq2
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc doc/*.md
59 %{_bindir}/yamagi-quake2
60 %{_bindir}/yamagi-q2ded
61 %dir %{gamedir}
62 %attr(755,root,root) %{gamedir}/quake2
63 %attr(755,root,root) %{gamedir}/q2ded
64 %attr(755,root,root) %{gamedir}/ref_gl1.so
65 %attr(755,root,root) %{gamedir}/ref_gl3.so
66 %attr(755,root,root) %{gamedir}/ref_soft.so
67 %dir %{gamedir}/baseq2
68 %attr(755,root,root) %{gamedir}/baseq2/game.so
69 %{gamedir}/baseq2/yq2.cfg
This page took 0.071676 seconds and 3 git commands to generate.