]> git.pld-linux.org Git - packages/xtables-geoip.git/blob - xtables-geoip.spec
- migrate database source to GeoLite2 (GeoLite Legacy databases are being discontinue...
[packages/xtables-geoip.git] / xtables-geoip.spec
1 Summary:        GeoIP database files for xt_geoip
2 Summary(pl.UTF-8):      Pliki baz danych GeoIP dla xt_geoip
3 Name:           xtables-geoip
4 Version:        20181023
5 Release:        1
6 License:        GPL, Open Data License
7 Group:          Networking/Admin
8 Source0:        http://geolite.maxmind.com/download/geoip/database/GeoLite2-Country-CSV.zip
9 # Source0-md5:  1f5524d5ac54a779831bffc57d91e2a2
10 Source1:        http://geolite.maxmind.com/download/geoip/database/LICENSE.txt
11 # Source1-md5:  a1381bd1aa0a0c91dc31b3f1e847cf4a
12 Source2:        http://sourceforge.net/p/xtables-addons/xtables-addons/ci/master/tree/geoip/xt_geoip_build?format=raw&/xt_geoip_build
13 # Source2-md5:  462ca00be38471d19dc6e0f32c098275
14 URL:            http://www.maxmind.com/
15 BuildRequires:  perl-Text-CSV_XS >= 0.69
16 BuildRequires:  perl-base
17 BuildRequires:  rpm >= 4.4.9-56
18 BuildRequires:  unzip
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         dbdir   /usr/share/xt_geoip
22
23 # no debuginfo to package
24 %define         _enable_debug_packages  0
25
26 %ifarch ppc ppc64 s390 s390x sparc sparc64 sparcv9
27 %define         byteorder       BE
28 %else
29 %define         byteorder       LE
30 %endif
31
32 %description
33 The package contains the GeoIP definition files (which IP addresses
34 belong to which country) that are needed for Xtables-addons's xt_geoip
35 module.
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera pliki definicji GeoIP (określające, które adresy IP
39 należą do jakiego kraju), wymagane przez moduł xt_geoip z pakietu
40 xtables-addons.
41
42 %prep
43 %setup -qc
44
45 ver=$(ls -d GeoLite2-Country-CSV_* | head -1 | %{__sed} 's/^GeoLite2-Country-CSV_//')
46 if [ "$ver" != %{version} ]; then
47         exit 1
48 fi
49
50 cp -p %{SOURCE1} .
51
52 %build
53 %{__mkdir} %{byteorder}
54 %{__perl} %{SOURCE2} -S GeoLite2-Country-CSV_%{version} -D %{byteorder} > ranges.txt
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{dbdir}
59 cp -a %{byteorder} $RPM_BUILD_ROOT%{dbdir}
60
61 %if "%{pld_release}" == "ac"
62 # handle older xtables in ac:
63 # kernel-net-xtables-addons-1.18-15@2.6.27.53_1.amd64
64 # still having old .iv0 names requirement
65 # http://xtables-addons.git.sourceforge.net/git/gitweb.cgi?p=xtables-addons/xtables-addons;a=commitdiff;h=25bf680ead80e505d5073308f151b4007cb5683f
66 # create hardlink, to be most compatible
67 for a in $RPM_BUILD_ROOT%{dbdir}/%{byteorder}/*.iv4; do
68         ln $a ${a%.iv4}.iv0
69 done
70 # kernel-net-xtables-addons-1.18-8@2.6.27.45_1.i686  searches from /var/lib:
71 # Could not open /var/lib/geoip/LE/EE.iv0: No such file or directory
72 install -d $RPM_BUILD_ROOT/var/lib
73 ln -s %{_datadir}/xt_geoip $RPM_BUILD_ROOT/var/lib/geoip
74 %endif
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %if "%{pld_release}" == "ac"
80 %pretrans
81 # this needs to be a symlink
82 if [ -d /var/lib/geoip -a ! -L /var/lib/geoip ]; then
83         mv -f /var/lib/geoip{,.rpmsave}
84         install -d %{dbdir}
85         ln -s %{dbdir} /var/lib/geoip
86 fi
87 %endif
88
89 %files
90 %defattr(644,root,root,755)
91 %doc LICENSE.txt ranges.txt
92 %dir %{dbdir}
93 %{dbdir}/%{byteorder}
94
95 %if "%{pld_release}" == "ac"
96 /var/lib/geoip
97 %endif
This page took 0.101323 seconds and 3 git commands to generate.