]> git.pld-linux.org Git - packages/xtables-addons.git/commitdiff
- up to 3.19 auto/th/xtables-addons-3.19-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 2 Apr 2022 11:28:07 +0000 (13:28 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 2 Apr 2022 11:28:07 +0000 (13:28 +0200)
kernel-5.17.patch [new file with mode: 0644]
xtables-addons.spec

diff --git a/kernel-5.17.patch b/kernel-5.17.patch
new file mode 100644 (file)
index 0000000..e347aff
--- /dev/null
@@ -0,0 +1,64 @@
+--- xtables-addons-3.19/extensions/pknock/xt_pknock.c~ 2022-02-01 18:24:03.000000000 +0100
++++ xtables-addons-3.19/extensions/pknock/xt_pknock.c  2022-04-02 13:22:18.309078729 +0200
+@@ -277,7 +277,11 @@
+       int ret = seq_open(file, &pknock_seq_ops);
+       if (ret == 0) {
+               struct seq_file *sf = file->private_data;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0)
+               sf->private = PDE_DATA(inode);
++#else
++              sf->private = pde_data(inode);
++#endif
+       }
+       return ret;
+ }
+--- xtables-addons-3.19/extensions/xt_condition.c~     2022-02-01 18:24:03.000000000 +0100
++++ xtables-addons-3.19/extensions/xt_condition.c      2022-04-02 13:25:17.366962445 +0200
+@@ -83,14 +83,22 @@
+ static int condition_proc_open(struct inode *inode, struct file *file)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0)
+       return single_open(file, condition_proc_show, PDE_DATA(inode));
++#else
++      return single_open(file, condition_proc_show, pde_data(inode));
++#endif
+ }
+ static ssize_t
+ condition_proc_write(struct file *file, const char __user *buffer,
+                      size_t length, loff_t *loff)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0)
+       struct condition_variable *var = PDE_DATA(file_inode(file));
++#else
++      struct condition_variable *var = pde_data(file_inode(file));
++#endif
+       char newval;
+       if (length > 0) {
+--- xtables-addons-3.19/extensions/xt_quota2.c~        2022-02-01 18:24:03.000000000 +0100
++++ xtables-addons-3.19/extensions/xt_quota2.c 2022-04-02 13:26:27.276139534 +0200
+@@ -73,14 +73,22 @@
+ static int quota_proc_open(struct inode *inode, struct file *file)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0)
+       return single_open(file, quota_proc_show, PDE_DATA(inode));
++#else
++      return single_open(file, quota_proc_show, pde_data(inode));
++#endif
+ }
+ static ssize_t
+ quota_proc_write(struct file *file, const char __user *input,
+                  size_t size, loff_t *loff)
+ {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0)
+       struct xt_quota_counter *e = PDE_DATA(file_inode(file));
++#else
++      struct xt_quota_counter *e = pde_data(file_inode(file));
++#endif
+       char buf[sizeof("+-18446744073709551616")];
+       if (size > sizeof(buf))
index d49da351d04b7b2465640c1608266996cef71c89..5b4dae9c7710aa25754333feb8fcb7d9b6f51013 100644 (file)
@@ -26,12 +26,13 @@ exit 1
 Summary:       Additional extensions for xtables packet filtering system
 Summary(pl.UTF-8):     Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       3.18
+Version:       3.19
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 License:       GPL v2
 Group:         Networking/Admin
 Source0:       https://inai.de/files/xtables-addons/%{pname}-%{version}.tar.xz
-# Source0-md5: 755471b1dc6808f274f914fa11552698
+# Source0-md5: 66185eeb44e8f9b30a299ece875a694f
+Patch0:                kernel-5.17.patch
 URL:           http://xtables-addons.sourceforge.net/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -110,6 +111,7 @@ done\
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
 
 %build
 %configure \
@@ -163,7 +165,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_sbindir}/iptaccount
 %attr(755,root,root) %{_sbindir}/pknlusr
 %attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
+%attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.1
 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
 %{_mandir}/man8/iptaccount.8*
 %{_mandir}/man8/xtables-addons.8*
This page took 0.05438 seconds and 4 git commands to generate.