]> git.pld-linux.org Git - packages/xtables-addons.git/blob - xtables-addons.spec
742d2ab8cbdbdb974ce2471790b151985b3847cd
[packages/xtables-addons.git] / xtables-addons.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  userspace       # # don't build userspace tools
6
7 %if %{without kernel}
8 %undefine       with_dist_kernel
9 %endif
10 %if "%{_alt_kernel}" != "%{nil}"
11 %undefine       with_userspace
12 %endif
13 %if %{without userspace}
14 # nothing to be placed to debuginfo package
15 %define         _enable_debug_packages  0
16 %endif
17
18 %define         rel     1
19 Summary:        Additional extensions for xtables packet filtering system
20 Summary(pl.UTF-8):      Dodatkowe rozszerzenia do systemu filtrowania pakietów xtables
21 Name:           xtables-addons
22 Version:        1.37
23 Release:        %{rel}
24 License:        GPL v2
25 Group:          Networking/Admin
26 Source0:        http://downloads.sourceforge.net/xtables-addons/%{name}-%{version}.tar.xz
27 # Source0-md5:  bfb0adba948fa885fffa6443eeaee28a
28 URL:            http://xtables-addons.sourceforge.net/
29 BuildRequires:  autoconf >= 2.50
30 BuildRequires:  automake >= 1:1.11
31 BuildRequires:  iptables-devel >= 1.4.3
32 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.29}
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig >= 0.9.0
35 BuildRequires:  rpmbuild(macros) >= 1.379
36 BuildRequires:  tar >= 1.22
37 BuildRequires:  xz
38 Requires:       iptables >= 1.4.3
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # use macro, so adapter won't try to wrap
42 %define         kpackage        kernel%{_alt_kernel}-net-xtables-addons = %{version}-%{rel}@%{_kernel_ver_str}
43
44 %description
45 xtables-addons is the proclaimed successor to patch-o-matic(-ng). It
46 contains extensions that were not accepted in the main
47 xtables/iptables package.
48
49 For the tools to work, you should install kernel modules, which could
50 be found in %{kpackage}.
51
52 %description -l pl.UTF-8
53 xtables-addons to następca patch-o-matic(-ng). Zawiera rozszerzenia,
54 które nie zostały zaakceptowane do głównego pakietu xtables/iptables.
55
56 Aby narzędzia działały należy zainstalować moduły jądra, które można
57 znaleźć w pakiecie %{kpackage}.
58
59 %package -n kernel%{_alt_kernel}-net-xtables-addons
60 Summary:        Kernel modules for xtables addons
61 Summary(pl.UTF-8):      Moudły jądra dla rozszerzeń z pakietu xtables-addons
62 Release:        %{rel}@%{_kernel_ver_str}
63 Group:          Base/Kernel
64 # VERSION only dependency is intentional, for allowing multiple kernel pkgs and
65 # single userspace package installs.
66 Requires:       %{name} = %{version}
67 Suggests:       xtables-geoip
68 Conflicts:      xtables-geoip < 20090901-2
69 %{?with_dist_kernel:%requires_releq_kernel}
70 Requires(post,postun):  /sbin/depmod
71
72 %description -n kernel%{_alt_kernel}-net-xtables-addons
73 Kernel modules for xtables addons.
74
75 %description -n kernel%{_alt_kernel}-net-xtables-addons -l pl.UTF-8
76 Moduły jądra dla rozszerzeń z pakietu xtables-addons.
77
78 %prep
79 %setup -q
80
81 %{__sed} -i -e 's#build_ipset4=m#build_ipset4=#' mconfig
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         --without-kbuild
91
92 %if %{with kernel}
93 srcdir=${PWD:-$(pwd)}
94 %build_kernel_modules V=1 XA_ABSTOPSRCDIR=$srcdir -C extensions -m compat_xtables
95 %endif
96
97 %if %{with userspace}
98 %{__make} \
99         V=1
100 %endif
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %if %{with kernel}
106 install -d $RPM_BUILD_ROOT{/etc/modprobe.d,/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter}
107 cd extensions
108 install iptable_rawpost.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter
109 %install_kernel_modules -m compat_xtables -d kernel/net/netfilter
110 install -p {ACCOUNT/,pknock/,}xt_*.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/net/netfilter
111 cd ..
112
113 cat <<'EOF' > $RPM_BUILD_ROOT/etc/modprobe.d/xt_sysrq.conf
114 # Set password at modprobe time. This file is secure if properly guarded,
115 # i.e only readable by root.
116 #options xt_SYSRQ password=cookies
117
118 # The hash algorithm can also be specified as a module option, for example, to use SHA-256 instead of the default SHA-1:
119 #options xt_SYSRQ hash=sha256
120 EOF
121 %endif
122
123 %if %{with userspace}
124 %{__make} -C extensions install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxt_ACCOUNT_cl.{la,so}
128
129 install -d $RPM_BUILD_ROOT%{_mandir}/man8
130 cp -a xtables-addons.8 $RPM_BUILD_ROOT%{_mandir}/man8
131 %endif
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %post -n kernel%{_alt_kernel}-net-xtables-addons
140 %depmod %{_kernel_ver}
141
142 %postun -n kernel%{_alt_kernel}-net-xtables-addons
143 %depmod %{_kernel_ver}
144
145 %if %{with userspace}
146 %files
147 %defattr(644,root,root,755)
148 %doc README doc/{README.psd,changelog.txt}
149 %attr(755,root,root) %{_sbindir}/iptaccount
150 %attr(755,root,root) %{_libdir}/libxt_ACCOUNT_cl.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libxt_ACCOUNT_cl.so.0
152 %attr(755,root,root) %{_libdir}/xtables/libxt_*.so
153 %{_mandir}/man8/iptaccount.8*
154 %{_mandir}/man8/xtables-addons.8*
155 %endif
156
157 %if %{with kernel}
158 %files -n kernel%{_alt_kernel}-net-xtables-addons
159 %defattr(644,root,root,755)
160 # restricted permissions - may contain password
161 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/xt_sysrq.conf
162 /lib/modules/%{_kernel_ver}/kernel/net/ipv4/netfilter/iptable_rawpost.ko.gz
163 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/compat_xtables.ko.gz
164 /lib/modules/%{_kernel_ver}/kernel/net/netfilter/xt_*.ko.gz
165 %endif
This page took 0.033426 seconds and 2 git commands to generate.