]> git.pld-linux.org Git - packages/xqilla.git/commitdiff
- added gcc11 patch (fix for gcc 11+); release 3 master auto/th/xqilla-2.3.4-3
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 25 Sep 2022 20:19:05 +0000 (22:19 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 25 Sep 2022 20:19:05 +0000 (22:19 +0200)
xqilla-gcc11.patch [new file with mode: 0644]
xqilla.spec

diff --git a/xqilla-gcc11.patch b/xqilla-gcc11.patch
new file mode 100644 (file)
index 0000000..c9e28be
--- /dev/null
@@ -0,0 +1,11 @@
+--- XQilla-2.3.4/include/xqilla/ast/XQDocumentOrder.hpp.orig   2018-07-03 20:37:15.000000000 +0200
++++ XQilla-2.3.4/include/xqilla/ast/XQDocumentOrder.hpp        2022-09-25 20:51:54.768846899 +0200
+@@ -68,7 +68,7 @@ private:
+   public:
+     uniqueLessThanCompareFn(const DynamicContext *context)
+       : context_(context) {}
+-    bool operator()(const Node::Ptr &first, const Node::Ptr &second)
++    bool operator()(const Node::Ptr &first, const Node::Ptr &second) const
+     {
+       return first->uniqueLessThan(second, context_);
+     }
index 85cda841f8d6fd52e547e3d2e435c5fdd859ddef..4980aa505053678c49d3386027d2ed4459cdad8f 100644 (file)
@@ -6,13 +6,14 @@ Summary:      XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
 Summary(pl.UTF-8):     XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
 Name:          xqilla
 Version:       2.3.4
-Release:       2
+Release:       3
 License:       Apache v2.0
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
 # Source0-md5: 9b77644c8b0d0741d895d3ccfbfe0016
 Patch0:                %{name}-link.patch
 Patch1:                %{name}-soname.patch
+Patch2:                %{name}-gcc11.patch
 URL:           http://xqilla.sourceforge.net/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -77,6 +78,7 @@ Dokumentacja API biblioteki XQilla.
 %setup -q -n XQilla-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
This page took 0.125084 seconds and 4 git commands to generate.