]> git.pld-linux.org Git - packages/xqilla.git/blob - xqilla.spec
- release 2 (tidy soname change)
[packages/xqilla.git] / xqilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
6 Summary(pl.UTF-8):      XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
7 Name:           xqilla
8 Version:        2.3.4
9 Release:        2
10 License:        Apache v2.0
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
13 # Source0-md5:  9b77644c8b0d0741d895d3ccfbfe0016
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-soname.patch
16 URL:            http://xqilla.sourceforge.net/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  faxpp-devel
20 BuildRequires:  flex
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  rpm-build >= 4.6
24 BuildRequires:  rpmbuild(macros) >= 1.752
25 BuildRequires:  tidy-devel
26 BuildRequires:  xerces-c-devel >= 3
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
31
32 %description -l pl.UTF-8
33 XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
34 Xerces-C.
35
36 %package devel
37 Summary:        Header files for XQilla library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki XQilla
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       faxpp-devel
42 Requires:       libstdc++-devel
43 Requires:       tidy-devel
44 Requires:       xerces-c-devel >= 3
45
46 %description devel
47 Header files for XQilla library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki XQilla.
51
52 %package static
53 Summary:        Static XQilla library
54 Summary(pl.UTF-8):      Statyczna biblioteka XQilla
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static XQilla library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka XQilla.
63
64 %package apidocs
65 Summary:        XQilla API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki XQilla
67 Group:          Documentation
68 BuildArch:      noarch
69
70 %description apidocs
71 API and internal documentation for XQilla library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki XQilla.
75
76 %prep
77 %setup -q -n XQilla-%{version}
78 %patch0 -p1
79 %patch1 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I autotools/m4
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         --with-faxpp=/usr \
89         --with-xerces=/usr
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README TODO
108 %attr(755,root,root) %{_bindir}/xqilla
109 %attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libxqilla.so
115 %{_libdir}/libxqilla.la
116 %{_includedir}/xqilla
117 %{_includedir}/xqc.h
118
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libxqilla.a
122
123 %if %{with apidocs}
124 %files apidocs
125 %defattr(644,root,root,755)
126 %doc docs/{dom3-api,simple-api,xqc-api,*.html}
127 %endif
This page took 0.124742 seconds and 3 git commands to generate.