]> git.pld-linux.org Git - packages/xqilla.git/blob - xqilla.spec
- enabled faxpp support
[packages/xqilla.git] / xqilla.spec
1 # $Revision: 1.21 $, $Date: 2011/07/16 18:25:43 $
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # do not build and package API docs
5 #
6 Summary:        XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C
7 Summary(pl.UTF-8):      XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece Xerces-C
8 Name:           xqilla
9 Version:        2.3.0
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/xqilla/XQilla-%{version}.tar.gz
14 # Source0-md5:  7261c7b4bb5a45cbf6270073976a51ce
15 Patch0:         %{name}-link.patch
16 URL:            http://xqilla.sourceforge.net/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake
19 BuildRequires:  faxpp-devel
20 BuildRequires:  flex
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  tidy-devel
24 BuildRequires:  xerces-c-devel >= 3
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 XQilla - C++ implementation of XQuery and XPath 2.0 based on Xerces-C.
29
30 %description -l pl.UTF-8
31 XQilla - implementacja C++ XQuary i XPath 2.0 oparta na bibliotece
32 Xerces-C.
33
34 %package devel
35 Summary:        Header files for XQilla library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki XQilla
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       faxpp-devel
40 Requires:       libstdc++-devel
41 Requires:       tidy-devel
42 Requires:       xerces-c-devel >= 3
43
44 %description devel
45 Header files for XQilla library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki XQilla.
49
50 %package static
51 Summary:        Static XQilla library
52 Summary(pl.UTF-8):      Statyczna biblioteka XQilla
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static XQilla library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka XQilla.
61
62 %package apidocs
63 Summary:        XQilla API documentation
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki XQilla
65 Group:          Documentation
66
67 %description apidocs
68 API and internal documentation for XQilla library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki XQilla.
72
73 %prep
74 %setup -q -n XQilla-%{version}
75 %patch0 -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure \
84         --with-faxpp=/usr \
85         --with-xerces=/usr
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc README TODO
104 %attr(755,root,root) %{_bindir}/xqilla
105 %attr(755,root,root) %{_libdir}/libxqilla.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libxqilla.so.6
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libxqilla.so
111 %{_libdir}/libxqilla.la
112 %{_includedir}/xqilla
113 %{_includedir}/xqc.h
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libxqilla.a
118
119 %if %{with apidocs}
120 %files apidocs
121 %defattr(644,root,root,755)
122 %doc docs/{dom3-api,simple-api,xqc-api,*.html}
123 %endif
This page took 0.05627 seconds and 3 git commands to generate.