BR update by cleanbuild
authorElan Ruusamäe <glen@delfi.ee>
Mon, 28 Jan 2013 13:07:58 +0000 (15:07 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 28 Jan 2013 13:07:58 +0000 (15:07 +0200)
- ERROR: Cannot find Cython: No module named Cython.Compiler.Version
- ERROR: cannot find a valid pkg-config package for ['gdk-x11-2.0']
- ERROR: cannot find a valid pkg-config package for ['libswscale']
- ERROR: cannot find a valid pkg-config package for ['pygobject-2.0']
- ERROR: cannot find a valid pkg-config package for ['x264']
- ERROR: cannot find a valid pkg-config package for ['xtst']
- wimpiggy/lowlevel/bindings.c:256:25: fatal error: pygtk/pygtk.h: No such file or directory

xpra.spec

index 48795d08a95fc26302ce41dd21cb8b679ec403ac..c5db2f9a5924ad222f83c78a9cfbedb8af38032a 100644 (file)
--- a/xpra.spec
+++ b/xpra.spec
@@ -1,5 +1,6 @@
 # TODO
 # - package just xpra, get rid of the wm stuff
+# - subpackages for client/server, see http://xpra.org/dev.html
 Summary:       Xpra gives you "persistent remote applications" for X
 Name:          xpra
 Version:       0.7.8
@@ -9,9 +10,17 @@ Source0:      http://xpra.org/src/%{name}-%{version}.tar.xz
 # Source0-md5: 940d20f26c1cfaa16bd0aee69bfb2233
 Group:         Networking
 URL:           http://xpra.org/
+BuildRequires: ffmpeg-devel
+BuildRequires: gtk+2-devel
+BuildRequires: libx264-devel
+BuildRequires: pkgconfig
+BuildRequires: python-Cython
 BuildRequires: python-distribute
+BuildRequires: python-pygobject-devel
+BuildRequires: python-pygtk-devel
 BuildRequires: rpm-pythonprov
 BuildRequires: tar >= 1:1.22
+BuildRequires: xorg-lib-libXtst-devel
 BuildRequires: xz
 #Requires:     PyOpenGL
 #Requires:     libvpx
This page took 0.048982 seconds and 4 git commands to generate.