]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- up to 1.14.4; fixes CVE-2013-4396
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dmx             # DMX support
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  record          # RECORD extension
10 %bcond_without  systemtap       # systemtap/dtrace probes
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       7.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        14.1
20 %define xorg_xserver_server_xinput_abi          19.1
21 #
22 %define pixman_ver      0.30.0
23
24 Summary:        X.org server
25 Summary(pl.UTF-8):      Serwer X.org
26 Name:           xorg-xserver-server
27 Version:        1.14.4
28 Release:        1
29 License:        MIT
30 Group:          X11/Servers
31 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
32 # Source0-md5:  9d68a30258c67faa3c036a4a85e8bf97
33 Source1:        10-quirks.conf
34 Source2:        xserver.pamd
35 Source10:       %{name}-Xvfb.init
36 Source11:       %{name}-Xvfb.sysconfig
37 Source12:       xvfb-run.sh
38
39 Patch0:         %{name}-xwrapper.patch
40 Patch1:         %{name}-pic-libxf86config.patch
41
42 Patch3:         %{name}-less-acpi-brokenness.patch
43 Patch4:         %{name}-builtin-SHA1.patch
44 Patch5:         %{name}-export-GetMaster.patch
45 Patch6:         110_nvidia_slowdow_fix.patch
46 Patch7:         %{name}-include-defs.patch
47 URL:            http://xorg.freedesktop.org/
48 BuildRequires:  Mesa-libGL-devel >= 7.8.1
49 # for glx headers
50 BuildRequires:  OpenGL-GLX-devel
51 %{?with_xselinux:BuildRequires: audit-libs-devel}
52 BuildRequires:  autoconf >= 2.60
53 BuildRequires:  automake
54 BuildRequires:  cpp
55 BuildRequires:  docbook-dtd43-xml
56 #BuildRequires: doxygen >= 1.6.1
57 %if %{with hal} || %{with dbus}
58 BuildRequires:  dbus-devel >= 1.0
59 %endif
60 %{?with_hal:BuildRequires:      hal-devel}
61 BuildRequires:  libdrm-devel >= 2.4.39
62 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
63 BuildRequires:  libtool
64 BuildRequires:  ncurses-devel
65 BuildRequires:  pam-devel
66 BuildRequires:  perl-base
67 BuildRequires:  pixman-devel >= %{pixman_ver}
68 BuildRequires:  pkgconfig >= 1:0.19
69 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
70 BuildRequires:  udev-devel >= 1:143
71 BuildRequires:  xmlto >= 0.0.20
72 BuildRequires:  xorg-app-mkfontscale
73 BuildRequires:  xorg-font-font-util >= 1.1
74 BuildRequires:  xorg-lib-libX11-devel
75 BuildRequires:  xorg-lib-libXau-devel
76 BuildRequires:  xorg-lib-libXaw-devel
77 BuildRequires:  xorg-lib-libXdamage-devel
78 BuildRequires:  xorg-lib-libXdmcp-devel
79 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
80 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
81 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
82 BuildRequires:  xorg-lib-libXmu-devel
83 BuildRequires:  xorg-lib-libXpm-devel
84 BuildRequires:  xorg-lib-libXrender-devel
85 BuildRequires:  xorg-lib-libXres-devel
86 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
87 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
88 BuildRequires:  xorg-lib-libXv-devel
89 BuildRequires:  xorg-lib-libXxf86dga-devel
90 BuildRequires:  xorg-lib-libXxf86misc-devel
91 BuildRequires:  xorg-lib-libXxf86vm-devel
92 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
93 BuildRequires:  xorg-lib-libfontenc-devel
94 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
95 BuildRequires:  xorg-lib-libxkbfile-devel
96 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
97 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
98 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
99 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
100 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
101 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
102 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
103 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
104 BuildRequires:  xorg-proto-fontcacheproto-devel
105 BuildRequires:  xorg-proto-fontsproto-devel
106 BuildRequires:  xorg-proto-glproto-devel >= 1.4.16
107 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
108 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
109 BuildRequires:  xorg-proto-printproto-devel
110 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
111 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
112 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
113 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
114 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
115 BuildRequires:  xorg-proto-videoproto-devel
116 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
117 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
118 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
119 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
120 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
121 BuildRequires:  xorg-proto-xf86miscproto-devel
122 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
123 BuildRequires:  xorg-proto-xineramaproto-devel
124 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
125 BuildRequires:  xorg-sgml-doctools >= 1.8
126 BuildRequires:  xorg-util-util-macros >= 1.14
127 #BR: tslib (for KDRIVE only)
128 Requires(triggerpostun):        sed >= 4.0
129 Requires:       pixman >= %{pixman_ver}
130 Requires:       xkeyboard-config
131 # for rgb.txt
132 Requires:       xorg-app-rgb >= 0.99.3
133 Requires:       xorg-app-xkbcomp
134 %{?with_hal:Suggests:   hal}
135 Suggests:       udev-acl >= 1:143
136 %{?with_udev:Suggests:  udev-core >= 1:143}
137 Suggests:       xorg-driver-input-evdev
138 # xserver requires fixed and cursor fonts
139 Requires:       xorg-font-font-alias
140 Requires:       xorg-font-font-cursor-misc
141 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
142 Suggests:       dbus-x11 >= 1.0
143 Suggests:       xkeyboard-config
144 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
145 Suggests:       xorg-driver-video
146 Provides:       xorg-xserver-libdri = %{version}-%{release}
147 Provides:       xorg-xserver-module(dri)
148 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
149 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
150 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
151 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
152 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
153 Obsoletes:      X11-Xserver < 1:7.0.0
154 Obsoletes:      X11-driver-i2c < 1:7.0.0
155 Obsoletes:      X11-modules < 1:7.0.0
156 Obsoletes:      X11-setup < 1:7.0.0
157 Obsoletes:      XFree86-Xserver < 1:7.0.0
158 Obsoletes:      XFree86-modules < 1:7.0.0
159 Obsoletes:      XFree86-setup < 1:7.0.0
160 Obsoletes:      Xserver
161 Obsoletes:      xorg-xserver-libdri
162 Obsoletes:      xorg-xserver-server-xorgcfg
163 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
164
165 # avoid self-dependencies on included modules
166 %define         _noautoreq      libscanpci.so libxf1bpp.so
167
168 %description
169 Xorg server is a generally used X server which uses display hardware.
170 It requires proper driver for your display hardware.
171
172 %description -l pl.UTF-8
173 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
174 graficznej. Do działania wymaga odpowiedniego sterownika.
175
176 %package -n xorg-xserver-Xdmx
177 Summary:        Xdmx - distributed multi-head X server
178 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
179 Group:          X11/Servers
180
181 %description -n xorg-xserver-Xdmx
182 Xdmx - distributed multi-head X server.
183
184 %description -n xorg-xserver-Xdmx -l pl.UTF-8
185 Xdmx - rozproszony, wielomonitorowy serwer X.
186
187 %package -n xorg-xserver-Xnest
188 Summary:        Xnest - nested X server
189 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
190 Group:          X11/Servers
191 Obsoletes:      X11-Xnest < 1:7.0.0
192 Obsoletes:      XFree86-Xnest < 1:7.0.0
193 Obsoletes:      Xserver-Xnest
194
195 %description -n xorg-xserver-Xnest
196 Xnest is an X Window System server which runs in an X window. Xnest is
197 a 'nested' window server, actually a client of the real X server,
198 which manages windows and graphics requests for Xnest, while Xnest
199 manages the windows and graphics requests for its own clients.
200
201 %description -n xorg-xserver-Xnest -l pl.UTF-8
202 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
203 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
204 serwer X dla własnych klientów.
205
206 %description -n xorg-xserver-Xnest -l ru.UTF-8
207 Xnest - это сервер X Window System, который работает в окне X. На
208 самом деле это клиент реального X-сервера, который управляет окнами и
209 графическими запросами для Xnest в то время, как Xnest управляет
210 окнами и графическими запросами для своих собственных клиентов.
211
212 %description -n xorg-xserver-Xnest -l uk.UTF-8
213 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
214 клієнт реального X-сервера, який керує вікнами та графічними запитами
215 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
216 своїх власних клієнтів.
217
218 %package -n xorg-xserver-Xephyr
219 Summary:        Xephyr - nested X server
220 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
221 Group:          X11/Servers
222 Requires:       pixman >= %{pixman_ver}
223
224 %description -n xorg-xserver-Xephyr
225 Xephyr is a a kdrive server that outputs to a window on a pre-existing
226 'host' X display. Think Xnest but with support for modern extensions
227 like composite, damage and randr.
228
229 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
230 the host X server, Xephyr is a real X server which uses the host X
231 server window as "framebuffer" via fast SHM XImages.
232
233 It also has support for 'visually' debugging what the server is
234 painting.
235
236 %description -n xorg-xserver-Xephyr -l pl.UTF-8
237 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
238 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
239 wspólczesnych rozszerzeń jak composite, damage i randr.
240
241 %package -n xorg-xserver-Xfbdev
242 Summary:        Xfbdev - Linux framebuffer device X server
243 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
244 Group:          X11/Servers
245
246 %description -n xorg-xserver-Xfbdev
247 Xfbdev is a Linux framebuffer device X server based on the kdrive X
248 server.
249
250 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
251 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
252
253 %package -n xorg-xserver-Xvfb
254 Summary:        Xvfb - virtual framebuffer X server
255 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
256 Group:          X11/Servers
257 Requires:       mktemp
258 Requires:       util-linux
259 Requires:       which
260 Requires:       xorg-app-xauth
261 # requires fixed and cursor fonts
262 Requires:       xorg-font-font-alias
263 Requires:       xorg-font-font-cursor-misc
264 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
265 Obsoletes:      X11-Xvfb < 1:7.0.0
266 Obsoletes:      XFree86-Xvfb < 1:7.0.0
267
268 %description -n xorg-xserver-Xvfb
269 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
270 capable of running on machines with no display hardware and no
271 physical input devices. Xvfb emulates a dumb framebuffer using virtual
272 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
273 display. Xvfb is normally used for testing servers. Using Xvfb, the
274 mfb or cfb code for any depth can be exercised without using real
275 hardware that supports the desired depths. Xvfb has also been used to
276 test X clients against unusual depths and screen configurations, to do
277 batch processing with Xvfb as a background rendering engine, to do
278 load testing, to help with porting an X server to a new platform, and
279 to provide an unobtrusive way of running applications which really
280 don't need an X server but insist on having one.
281
282 %description -n xorg-xserver-Xvfb -l pl.UTF-8
283 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
284 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
285 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
286 używany do testowania serwerów X, może też być używany do testowania
287 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
288 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
289 serwera X, ale odmawiają uruchomienia bez niego.
290
291 %package -n xorg-xserver-Xvfb-init
292 Summary:        Init scripts for Xvfb
293 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
294 Group:          X11/Servers
295 Requires:       xorg-xserver-Xvfb
296
297 %description -n xorg-xserver-Xvfb-init
298 This package contains init scripts for Xvfb and registers Xvfb as
299 system service.
300
301 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
302 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
303 usługę systemową.
304
305 %package devel
306 Summary:        Header files for X.org server
307 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
308 Group:          X11/Development/Libraries
309 Requires:       libdrm-devel >= 2.4.39
310 Requires:       pixman-devel >= %{pixman_ver}
311 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
312 Requires:       xorg-lib-libxkbfile-devel
313 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
314 Requires:       xorg-proto-fontsproto-devel
315 Requires:       xorg-proto-inputproto-devel >= 2.3
316 Requires:       xorg-proto-kbproto-devel >= 1.0.3
317 Requires:       xorg-proto-randrproto-devel >= 1.4.0
318 Requires:       xorg-proto-renderproto-devel >= 0.11
319 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
320 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
321 Requires:       xorg-proto-videoproto-devel
322 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
323 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
324 Requires:       xorg-proto-xineramaproto-devel
325 Requires:       xorg-proto-xproto-devel >= 7.0.22
326 Obsoletes:      X11-Xserver-devel < 1:7.0.0
327 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
328
329 %description devel
330 Header files for X.org server.
331
332 %description devel -l pl.UTF-8
333 Pliki nagłówkowe dla serwera X.org.
334
335 %package source
336 Summary:        X.org server source code
337 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
338 Group:          X11/Development/Libraries
339
340 %description source
341 X.org server source code.
342
343 %description source -l pl.UTF-8
344 Pliki źródłowe dla serwera X.org.
345
346 %package -n xorg-xserver-libglx
347 Summary:        GLX extension library for X.org server
348 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
349 Group:          X11/Servers
350 Requires:       %{name} = %{version}-%{release}
351 # Mesa version glapi tables in glx/ dir come from
352 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
353 Provides:       xorg-xserver-module(glx)
354 Obsoletes:      X11-OpenGL-core < 1:7.0.0
355 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
356
357 %description -n xorg-xserver-libglx
358 GLX extension library for X.org server.
359
360 %description -n xorg-xserver-libglx -l pl.UTF-8
361 Biblioteka rozszerzenia GLX dla serwera X.org.
362
363 %prep
364 %setup -q -n xorg-server-%{version}
365 %patch0 -p0
366 %patch1 -p1
367
368 %patch3 -p1
369 %patch4 -p1
370 %patch5 -p1
371 %patch6 -p1
372
373 #unfortunately breaks build
374 #patch7 -p1
375
376 # xserver uses pixman-1 API/ABI so put that explictly here
377 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
378
379 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
380 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
381
382 %build
383 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
384 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
385         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
386         exit 1
387 fi
388
389 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
390 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
391         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
392         exit 1
393 fi
394
395 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
396 if [ $API != %{xorg_xserver_server_font_abi} ]; then
397         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
398         exit 1
399 fi
400 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
401 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
402         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
403         exit 1
404 fi
405 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
406 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
407         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
408         exit 1
409 fi
410
411 %{__libtoolize}
412 %{__aclocal} -I m4
413 %{__autoconf}
414 %{__autoheader}
415 %{__automake}
416 %configure \
417         --with-os-name="PLD/Linux" \
418         --with-os-vendor="PLD/Team" \
419         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
420         --with-xkb-output=/var/lib/xkb \
421         %{!?with_systemtap:--without-dtrace} \
422         --without-fop \
423         --enable-aiglx \
424         %{?with_dbus:--enable-config-dbus} \
425         --enable-config-hal%{!?with_hal:=no} \
426         --enable-config-udev%{!?with_udev:=no} \
427         --enable-dga \
428         %{?with_dmx:--enable-dmx} \
429         --enable-dri2%{!?with_dri2:=no} \
430         --enable-glx-tls \
431         --enable-install-libxf86config \
432         --enable-kdrive \
433         %{?with_record:--enable-record} \
434         --enable-secure-rpc \
435         %{?with_xcsecurity:--enable-xcsecurity} \
436         --enable-xephyr \
437         %{?with_xf86bigfont:--enable-xf86bigfont} \
438         --disable-xfake \
439         --enable-xfbdev \
440         %{?with_xselinux:--enable-xselinux}
441
442 %{__make}
443
444 %install
445 rm -rf $RPM_BUILD_ROOT
446
447 %if "%{_libdir}" != "%{_exec_prefix}/lib"
448 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
449 %endif
450
451 %{__make} install \
452         DESTDIR=$RPM_BUILD_ROOT
453
454 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
455 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
456 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
457 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
458 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
459
460 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
461 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
462
463 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
464
465 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
466
467 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
468 install -d $RPM_BUILD_ROOT/etc/sysconfig
469 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
470 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
471
472 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
473 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
474 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
475 %{__make} distclean
476 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
477 find -name '*.h' | xargs chmod a-x
478
479 %clean
480 rm -rf $RPM_BUILD_ROOT
481
482 %triggerpostun -- xorg-xserver-server < 1.5.0
483 if [ -f /etc/X11/xorg.conf ]; then
484         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
485         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
486 %if %{without record}
487         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
488 %endif
489         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
490 fi
491
492 %post -n xorg-xserver-Xvfb-init
493 /sbin/chkconfig --add Xvfb
494 %service Xvfb restart
495
496 %preun -n xorg-xserver-Xvfb-init
497 if [ "$1" = "0" ]; then
498         %service -q Xvfb stop
499         /sbin/chkconfig --del Xvfb
500 fi
501
502 %files
503 %defattr(644,root,root,755)
504 %doc COPYING ChangeLog README
505 %attr(755,root,root) %{_bindir}/X
506 %attr(755,root,root) %{_bindir}/Xorg
507 %attr(4755,root,root) %{_bindir}/Xwrapper
508 %attr(755,root,root) %{_bindir}/cvt
509 %attr(755,root,root) %{_bindir}/gtf
510 %dir %{_libdir}/xorg
511 %{_libdir}/xorg/protocol.txt
512 %dir %{_libdir}/xorg/modules
513 %dir %{_libdir}/xorg/modules/dri
514 %dir %{_libdir}/xorg/modules/drivers
515 %dir %{_libdir}/xorg/modules/extensions
516 %dir %{_libdir}/xorg/modules/input
517 %dir %{_libdir}/xorg/modules/multimedia
518 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
519 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
520 %if "%{_libdir}" != "%{_exec_prefix}/lib"
521 %dir %{_exec_prefix}/lib/xorg
522 %dir %{_exec_prefix}/lib/xorg/modules
523 %dir %{_exec_prefix}/lib/xorg/modules/dri
524 %endif
525 %dir /var/lib/xkb
526 /var/lib/xkb/README.compiled
527 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
528 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
529 %config(missingok) /etc/security/console.apps/xserver
530 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
531 %dir /etc/X11/xorg.conf.d
532 %dir %{_datadir}/X11/xorg.conf.d
533 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
534 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
535 %{_mandir}/man1/Xorg.1*
536 %{_mandir}/man1/Xserver.1*
537 %{_mandir}/man1/cvt.1*
538 %{_mandir}/man1/gtf.1*
539 %{_mandir}/man4/exa.4*
540 %{_mandir}/man4/fbdevhw.4*
541 %{_mandir}/man5/xorg.conf.5*
542 %{_mandir}/man5/xorg.conf.d.5*
543
544 %if %{with dmx}
545 %files -n xorg-xserver-Xdmx
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/Xdmx
548 %attr(755,root,root) %{_bindir}/dmxaddinput
549 %attr(755,root,root) %{_bindir}/dmxaddscreen
550 %attr(755,root,root) %{_bindir}/dmxinfo
551 %attr(755,root,root) %{_bindir}/dmxreconfig
552 %attr(755,root,root) %{_bindir}/dmxresize
553 %attr(755,root,root) %{_bindir}/dmxrminput
554 %attr(755,root,root) %{_bindir}/dmxrmscreen
555 %attr(755,root,root) %{_bindir}/dmxtodmx
556 %attr(755,root,root) %{_bindir}/dmxwininfo
557 %attr(755,root,root) %{_bindir}/vdltodmx
558 %attr(755,root,root) %{_bindir}/xdmxconfig
559 %{_mandir}/man1/Xdmx.1*
560 %{_mandir}/man1/dmxtodmx.1*
561 %{_mandir}/man1/vdltodmx.1*
562 %{_mandir}/man1/xdmxconfig.1*
563 %endif
564
565 %files -n xorg-xserver-Xnest
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_bindir}/Xnest
568 %{_mandir}/man1/Xnest.1*
569
570 %files -n xorg-xserver-Xephyr
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_bindir}/Xephyr
573 %{_mandir}/man1/Xephyr.1*
574
575 %files -n xorg-xserver-Xfbdev
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_bindir}/Xfbdev
578
579 %files -n xorg-xserver-Xvfb
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_bindir}/Xvfb
582 %attr(755,root,root) %{_bindir}/xvfb-run
583 %{_mandir}/man1/Xvfb.1*
584
585 %files -n xorg-xserver-Xvfb-init
586 %defattr(644,root,root,755)
587 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
588 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
589
590 %files devel
591 %defattr(644,root,root,755)
592 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
593 %{_includedir}/xorg
594 %{_libdir}/libxf86config.a
595 %{_libdir}/libxf86config.la
596 %{_aclocaldir}/xorg-server.m4
597 %{_pkgconfigdir}/xorg-server.pc
598
599 %files source
600 %defattr(644,root,root,755)
601 # keep file perms from install time, but have default defattr to keep adapter happy
602 %defattr(-,root,root,755)
603 %{_usrsrc}/%{name}-%{version}
604
605 %files -n xorg-xserver-libglx
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.086538 seconds and 4 git commands to generate.