]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- fix mouse stuck on primary display with separate X screens regression
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dri2            # DRI2 extension
8 %bcond_without  dmx             # DMX support
9 %bcond_without  record          # RECORD extension
10 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
11 %bcond_with     xf86bigfont     # XF86BigFont extension
12 %bcond_with     xselinux        # SELinux extension
13 #
14 # ABI versions, see hw/xfree86/common/xf86Module.h
15 %define xorg_xserver_server_ansic_abi           0.4
16 %define xorg_xserver_server_extension_abi       7.0
17 %define xorg_xserver_server_font_abi            0.6
18 %define xorg_xserver_server_videodrv_abi        13.0
19 %define xorg_xserver_server_xinput_abi          18.0
20 #
21 %define pixman_ver      0.26.0
22
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.13.0
27 Release:        2
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  bde3d178b756597d2ec2a19ef60d2e1f
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 Patch5:         %{name}-export-GetMaster.patch
42 Patch6:         110_nvidia_slowdow_fix.patch
43 Patch7:         %{name}-include-defs.patch
44 # https://bugs.freedesktop.org/show_bug.cgi?id=54654
45 Patch8:         0001-dix-fix-zaphod-screen-scrossing-54654.patch
46 URL:            http://xorg.freedesktop.org/
47 BuildRequires:  Mesa-libGL-devel >= 7.8.1
48 # for glx headers
49 BuildRequires:  OpenGL-GLX-devel
50 %{?with_xselinux:BuildRequires: audit-libs-devel}
51 BuildRequires:  autoconf >= 2.57
52 BuildRequires:  automake
53 BuildRequires:  cpp
54 BuildRequires:  docbook-dtd43-xml
55 #BuildRequires: doxygen >= 1.6.1
56 %if %{with hal} || %{with dbus}
57 BuildRequires:  dbus-devel >= 1.0
58 %endif
59 %{?with_hal:BuildRequires:      hal-devel}
60 BuildRequires:  libdrm-devel >= 2.4.39
61 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
62 BuildRequires:  libtool
63 BuildRequires:  ncurses-devel
64 BuildRequires:  pam-devel
65 BuildRequires:  perl-base
66 BuildRequires:  pixman-devel >= %{pixman_ver}
67 BuildRequires:  pkgconfig >= 1:0.19
68 BuildRequires:  udev-devel >= 1:143
69 BuildRequires:  xmlto >= 0.0.20
70 BuildRequires:  xorg-app-mkfontscale
71 BuildRequires:  xorg-font-font-util >= 1.1
72 BuildRequires:  xorg-lib-libX11-devel
73 BuildRequires:  xorg-lib-libXau-devel
74 BuildRequires:  xorg-lib-libXaw-devel
75 BuildRequires:  xorg-lib-libXdamage-devel
76 BuildRequires:  xorg-lib-libXdmcp-devel
77 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
78 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
79 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
80 BuildRequires:  xorg-lib-libXmu-devel
81 BuildRequires:  xorg-lib-libXpm-devel
82 BuildRequires:  xorg-lib-libXrender-devel
83 BuildRequires:  xorg-lib-libXres-devel
84 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
85 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
86 BuildRequires:  xorg-lib-libXv-devel
87 BuildRequires:  xorg-lib-libXxf86dga-devel
88 BuildRequires:  xorg-lib-libXxf86misc-devel
89 BuildRequires:  xorg-lib-libXxf86vm-devel
90 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
91 BuildRequires:  xorg-lib-libfontenc-devel
92 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
93 BuildRequires:  xorg-lib-libxkbfile-devel
94 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
95 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
96 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
97 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
98 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
99 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
100 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
101 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
102 BuildRequires:  xorg-proto-fontcacheproto-devel
103 BuildRequires:  xorg-proto-fontsproto-devel
104 BuildRequires:  xorg-proto-glproto-devel >= 1.4.16
105 BuildRequires:  xorg-proto-inputproto-devel >= 2.2
106 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
107 BuildRequires:  xorg-proto-printproto-devel
108 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
109 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
110 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
111 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
112 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
113 BuildRequires:  xorg-proto-videoproto-devel
114 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
115 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
116 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
117 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
118 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
119 BuildRequires:  xorg-proto-xf86miscproto-devel
120 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
121 BuildRequires:  xorg-proto-xineramaproto-devel
122 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
123 BuildRequires:  xorg-sgml-doctools >= 1.8
124 BuildRequires:  xorg-util-util-macros >= 1.14
125 #BR: tslib (for KDRIVE only)
126 Requires(triggerpostun):        sed >= 4.0
127 Requires:       pixman >= %{pixman_ver}
128 Requires:       xkeyboard-config
129 # for rgb.txt
130 Requires:       xorg-app-rgb >= 0.99.3
131 Requires:       xorg-app-xkbcomp
132 %{?with_hal:Suggests:   hal}
133 Suggests:       udev-acl >= 1:143
134 %{?with_udev:Suggests:  udev-core >= 1:143}
135 Suggests:       xorg-driver-input-evdev
136 # xserver requires fixed and cursor fonts
137 Requires:       xorg-font-font-alias
138 Requires:       xorg-font-font-cursor-misc
139 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
140 Suggests:       dbus-x11 >= 1.0
141 Suggests:       xkeyboard-config
142 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
143 Suggests:       xorg-driver-video
144 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
145 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
146 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
147 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
148 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
149 Provides:       xorg-xserver-module(dri)
150 Provides:       xorg-xserver-libdri = %{version}-%{release}
151 Obsoletes:      X11-Xserver < 1:7.0.0
152 Obsoletes:      X11-driver-i2c < 1:7.0.0
153 Obsoletes:      X11-modules < 1:7.0.0
154 Obsoletes:      X11-setup < 1:7.0.0
155 Obsoletes:      XFree86-Xserver < 1:7.0.0
156 Obsoletes:      XFree86-modules < 1:7.0.0
157 Obsoletes:      XFree86-setup < 1:7.0.0
158 Obsoletes:      Xserver
159 Obsoletes:      xorg-xserver-server-xorgcfg
160 Obsoletes:      xorg-xserver-libdri
161 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
162
163 # avoid self-dependencies on included modules
164 %define         _noautoreq      libscanpci.so libxf1bpp.so
165
166 %description
167 Xorg server is a generally used X server which uses display hardware.
168 It requires proper driver for your display hardware.
169
170 %description -l pl.UTF-8
171 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
172 graficznej. Do działania wymaga odpowiedniego sterownika.
173
174 %package -n xorg-xserver-Xdmx
175 Summary:        Xdmx - distributed multi-head X server
176 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
177 Group:          X11/Servers
178
179 %description -n xorg-xserver-Xdmx
180 Xdmx - distributed multi-head X server.
181
182 %description -n xorg-xserver-Xdmx -l pl.UTF-8
183 Xdmx - rozproszony, wielomonitorowy serwer X.
184
185 %package -n xorg-xserver-Xnest
186 Summary:        Xnest - nested X server
187 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
188 Group:          X11/Servers
189 Obsoletes:      X11-Xnest < 1:7.0.0
190 Obsoletes:      XFree86-Xnest < 1:7.0.0
191 Obsoletes:      Xserver-Xnest
192
193 %description -n xorg-xserver-Xnest
194 Xnest is an X Window System server which runs in an X window. Xnest is
195 a 'nested' window server, actually a client of the real X server,
196 which manages windows and graphics requests for Xnest, while Xnest
197 manages the windows and graphics requests for its own clients.
198
199 %description -n xorg-xserver-Xnest -l pl.UTF-8
200 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
201 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
202 serwer X dla własnych klientów.
203
204 %description -n xorg-xserver-Xnest -l ru.UTF-8
205 Xnest - это сервер X Window System, который работает в окне X. На
206 самом деле это клиент реального X-сервера, который управляет окнами и
207 графическими запросами для Xnest в то время, как Xnest управляет
208 окнами и графическими запросами для своих собственных клиентов.
209
210 %description -n xorg-xserver-Xnest -l uk.UTF-8
211 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
212 клієнт реального X-сервера, який керує вікнами та графічними запитами
213 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
214 своїх власних клієнтів.
215
216 %package -n xorg-xserver-Xephyr
217 Summary:        Xephyr - nested X server
218 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
219 Group:          X11/Servers
220 Requires:       pixman >= %{pixman_ver}
221
222 %description -n xorg-xserver-Xephyr
223 Xephyr is a a kdrive server that outputs to a window on a pre-existing
224 'host' X display. Think Xnest but with support for modern extensions
225 like composite, damage and randr.
226
227 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
228 the host X server, Xephyr is a real X server which uses the host X
229 server window as "framebuffer" via fast SHM XImages.
230
231 It also has support for 'visually' debugging what the server is
232 painting.
233
234 %description -n xorg-xserver-Xephyr -l pl.UTF-8
235 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
236 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
237 wspólczesnych rozszerzeń jak composite, damage i randr.
238
239 %package -n xorg-xserver-Xfbdev
240 Summary:        Xfbdev - Linux framebuffer device X server
241 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
242 Group:          X11/Servers
243
244 %description -n xorg-xserver-Xfbdev
245 Xfbdev is a Linux framebuffer device X server based on the kdrive X
246 server.
247
248 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
249 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
250
251 %package -n xorg-xserver-Xvfb
252 Summary:        Xvfb - virtual framebuffer X server
253 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
254 Group:          X11/Servers
255 # requires fixed and cursor fonts
256 Requires:       xorg-font-font-alias
257 Requires:       xorg-font-font-cursor-misc
258 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
259 Obsoletes:      X11-Xvfb < 1:7.0.0
260 Obsoletes:      XFree86-Xvfb < 1:7.0.0
261
262 %description -n xorg-xserver-Xvfb
263 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
264 capable of running on machines with no display hardware and no
265 physical input devices. Xvfb emulates a dumb framebuffer using virtual
266 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
267 display. Xvfb is normally used for testing servers. Using Xvfb, the
268 mfb or cfb code for any depth can be exercised without using real
269 hardware that supports the desired depths. Xvfb has also been used to
270 test X clients against unusual depths and screen configurations, to do
271 batch processing with Xvfb as a background rendering engine, to do
272 load testing, to help with porting an X server to a new platform, and
273 to provide an unobtrusive way of running applications which really
274 don't need an X server but insist on having one.
275
276 %description -n xorg-xserver-Xvfb -l pl.UTF-8
277 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
278 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
279 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
280 używany do testowania serwerów X, może też być używany do testowania
281 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
282 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
283 serwera X, ale odmawiają uruchomienia bez niego.
284
285 %package -n xorg-xserver-Xvfb-init
286 Summary:        Init scripts for Xvfb
287 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
288 Group:          X11/Servers
289 Requires:       xorg-xserver-Xvfb
290
291 %description -n xorg-xserver-Xvfb-init
292 This package contains init scripts for Xvfb and registers Xvfb as
293 system service.
294
295 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
296 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
297 usługę systemową.
298
299 %package devel
300 Summary:        Header files for X.org server
301 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
302 Group:          X11/Development/Libraries
303 Requires:       libdrm-devel >= 2.4.39
304 Requires:       pixman-devel >= %{pixman_ver}
305 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
306 Requires:       xorg-lib-libxkbfile-devel
307 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
308 Requires:       xorg-proto-fontsproto-devel
309 Requires:       xorg-proto-inputproto-devel >= 2.2
310 Requires:       xorg-proto-kbproto-devel >= 1.0.3
311 Requires:       xorg-proto-randrproto-devel >= 1.4.0
312 Requires:       xorg-proto-renderproto-devel >= 0.11
313 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
314 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
315 Requires:       xorg-proto-videoproto-devel
316 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
317 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
318 Requires:       xorg-proto-xineramaproto-devel
319 Requires:       xorg-proto-xproto-devel >= 7.0.22
320 Obsoletes:      X11-Xserver-devel < 1:7.0.0
321 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
322
323 %description devel
324 Header files for X.org server.
325
326 %description devel -l pl.UTF-8
327 Pliki nagłówkowe dla serwera X.org.
328
329 %package source
330 Summary:        X.org server source code
331 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
332 Group:          X11/Development/Libraries
333
334 %description source
335 X.org server source code.
336
337 %description source -l pl.UTF-8
338 Pliki źródłowe dla serwera X.org.
339
340 %package -n xorg-xserver-libglx
341 Summary:        GLX extension library for X.org server
342 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
343 Group:          X11/Servers
344 Requires:       %{name} = %{version}-%{release}
345 # Mesa version glapi tables in glx/ dir come from
346 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
347 Provides:       xorg-xserver-module(glx)
348 Obsoletes:      X11-OpenGL-core < 1:7.0.0
349 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
350
351 %description -n xorg-xserver-libglx
352 GLX extension library for X.org server.
353
354 %description -n xorg-xserver-libglx -l pl.UTF-8
355 Biblioteka rozszerzenia GLX dla serwera X.org.
356
357 %prep
358 %setup -q -n xorg-server-%{version}
359 %patch0 -p0
360 %patch1 -p1
361
362 %patch3 -p1
363 %patch4 -p1
364 %patch5 -p1
365 %patch6 -p1
366
367 #unfortunately breaks build
368 #patch7 -p1
369
370 %patch8 -p1
371
372 # xserver uses pixman-1 API/ABI so put that explictly here
373 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
374
375 %build
376 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
377 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
378         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
379         exit 1
380 fi
381
382 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
383 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
384         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
385         exit 1
386 fi
387
388 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
389 if [ $API != %{xorg_xserver_server_font_abi} ]; then
390         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
391         exit 1
392 fi
393 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
394 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
395         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
396         exit 1
397 fi
398 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
399 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
400         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
401         exit 1
402 fi
403
404 %{__libtoolize}
405 %{__aclocal} -I m4
406 %{__autoconf}
407 %{__autoheader}
408 %{__automake}
409 %configure \
410         --with-os-name="PLD/Linux" \
411         --with-os-vendor="PLD/Team" \
412         --without-fop \
413         %{?with_dbus:--enable-config-dbus} \
414         --enable-config-hal%{!?with_hal:=no} \
415         --enable-config-udev%{!?with_udev:=no} \
416         --enable-aiglx \
417         --enable-dga \
418         %{?with_dmx:--enable-dmx} \
419         --enable-glx-tls \
420         --enable-install-libxf86config \
421         %{?with_record:--enable-record} \
422         --enable-kdrive \
423         %{?with_xcsecurity:--enable-xcsecurity} \
424         --enable-xephyr \
425         %{?with_xf86bigfont:--enable-xf86bigfont} \
426         --enable-xfbdev \
427         %{?with_xselinux:--enable-xselinux} \
428         --enable-glx-tls \
429         --disable-xfake \
430         --enable-secure-rpc \
431         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
432         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
433         --with-xkb-output=/var/lib/xkb
434
435 %{__make}
436
437 %install
438 rm -rf $RPM_BUILD_ROOT
439
440 %{__make} install \
441         DESTDIR=$RPM_BUILD_ROOT
442
443 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
444 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
445 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
446 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
447
448 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
449 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
450
451 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
452
453 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
454
455 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
456 install -d $RPM_BUILD_ROOT/etc/sysconfig
457 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
458 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
459
460 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
461 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
462 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
463 %{__make} distclean
464 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
465 find -name '*.h' | xargs chmod a-x
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %triggerpostun -- xorg-xserver-server < 1.5.0
471 if [ -f /etc/X11/xorg.conf ]; then
472         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
473         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
474 %if %{without record}
475         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
476 %endif
477         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
478 fi
479
480 %post -n xorg-xserver-Xvfb-init
481 /sbin/chkconfig --add Xvfb
482 %service Xvfb restart
483
484 %preun -n xorg-xserver-Xvfb-init
485 if [ "$1" = "0" ]; then
486         %service -q Xvfb stop
487         /sbin/chkconfig --del Xvfb
488 fi
489
490 %files
491 %defattr(644,root,root,755)
492 %doc COPYING ChangeLog README
493 %attr(755,root,root) %{_bindir}/X
494 %attr(755,root,root) %{_bindir}/Xorg
495 %attr(4755,root,root) %{_bindir}/Xwrapper
496 %attr(755,root,root) %{_bindir}/cvt
497 %attr(755,root,root) %{_bindir}/gtf
498 %dir %{_libdir}/xorg
499 %{_libdir}/xorg/protocol.txt
500 %dir %{_libdir}/xorg/modules
501 %dir %{_libdir}/xorg/modules/dri
502 %dir %{_libdir}/xorg/modules/drivers
503 %dir %{_libdir}/xorg/modules/extensions
504 %dir %{_libdir}/xorg/modules/input
505 %dir %{_libdir}/xorg/modules/multimedia
506 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
507 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
508 %dir /var/lib/xkb
509 /var/lib/xkb/README.compiled
510 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
511 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
512 %config(missingok) /etc/security/console.apps/xserver
513 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
514 %dir /etc/X11/xorg.conf.d
515 %dir %{_datadir}/X11/xorg.conf.d
516 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
517 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
518 %{_mandir}/man1/Xorg.1x*
519 %{_mandir}/man1/Xserver.1x*
520 %{_mandir}/man1/cvt.1*
521 %{_mandir}/man1/gtf.1x*
522 %{_mandir}/man4/exa.4*
523 %{_mandir}/man4/fbdevhw.4*
524 %{_mandir}/man5/xorg.conf.5x*
525 %{_mandir}/man5/xorg.conf.d.5x
526
527 %if %{with dmx}
528 %files -n xorg-xserver-Xdmx
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_bindir}/Xdmx
531 %attr(755,root,root) %{_bindir}/dmxaddinput
532 %attr(755,root,root) %{_bindir}/dmxaddscreen
533 %attr(755,root,root) %{_bindir}/dmxinfo
534 %attr(755,root,root) %{_bindir}/dmxreconfig
535 %attr(755,root,root) %{_bindir}/dmxresize
536 %attr(755,root,root) %{_bindir}/dmxrminput
537 %attr(755,root,root) %{_bindir}/dmxrmscreen
538 %attr(755,root,root) %{_bindir}/dmxtodmx
539 %attr(755,root,root) %{_bindir}/dmxwininfo
540 %attr(755,root,root) %{_bindir}/vdltodmx
541 %attr(755,root,root) %{_bindir}/xdmxconfig
542 %{_mandir}/man1/Xdmx.1x*
543 %{_mandir}/man1/dmxtodmx.1x*
544 %{_mandir}/man1/vdltodmx.1x*
545 %{_mandir}/man1/xdmxconfig.1x*
546 %endif
547
548 %files -n xorg-xserver-Xnest
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/Xnest
551 %{_mandir}/man1/Xnest.1x*
552
553 %files -n xorg-xserver-Xephyr
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/Xephyr
556 %{_mandir}/man1/Xephyr.1x*
557
558 %files -n xorg-xserver-Xfbdev
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/Xfbdev
561
562 %files -n xorg-xserver-Xvfb
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/Xvfb
565 %{_mandir}/man1/Xvfb.1x*
566
567 %files -n xorg-xserver-Xvfb-init
568 %defattr(644,root,root,755)
569 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
570 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
571
572 %files devel
573 %defattr(644,root,root,755)
574 %doc doc/{Xinput,Xserver-spec}.html
575 %{_includedir}/xorg
576 %{_libdir}/libxf86config.a
577 %{_libdir}/libxf86config.la
578 %{_aclocaldir}/xorg-server.m4
579 %{_pkgconfigdir}/xorg-server.pc
580
581 %files source
582 %defattr(644,root,root,755)
583 # keep file perms from install time, but have default defattr to keep adapter happy
584 %defattr(-,root,root,755)
585 %{_usrsrc}/%{name}-%{version}
586
587 %files -n xorg-xserver-libglx
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.064627 seconds and 4 git commands to generate.