]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
force use of TI-RPC now that glibc dropped Sun RPC; rel 2
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_with     eglstream       # XWayland eglstream support
18 %bcond_without  glamor          # glamor dix module
19 %bcond_without  systemtap       # systemtap/dtrace probes
20 %bcond_without  libunwind       # use libunwind for backtracing
21 #
22 # ABI versions, see hw/xfree86/common/xf86Module.h
23 %define xorg_xserver_server_ansic_abi           0.4
24 %define xorg_xserver_server_extension_abi       10.0
25 %define xorg_xserver_server_videodrv_abi        24.1
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.20.9
38 Release:        2
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  afcae2f46d47c33863cab7fd9db7279a
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 URL:            https://xorg.freedesktop.org/
54 BuildRequires:  Mesa-libGL-devel >= 7.8.1
55 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
56 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
57 # for glx headers
58 BuildRequires:  OpenGL-GLX-devel
59 %{?with_xselinux:BuildRequires: audit-libs-devel}
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  cpp
63 BuildRequires:  docbook-dtd43-xml
64 #BuildRequires: doxygen >= 1.6.1
65 %if %{with hal} || %{with dbus}
66 BuildRequires:  dbus-devel >= 1.0
67 %endif
68 %{?with_eglstream:BuildRequires:        egl-wayland-devel >= 1.0.2}
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.89
71 %if %{with glamor}
72 BuildRequires:  libepoxy-devel >= 1.5.4
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtirpc-devel
76 BuildRequires:  libtool >= 2:2.2
77 %{?with_libunwind:BuildRequires:        libunwind-devel}
78 BuildRequires:  libxcb-devel >= 1.9.3
79 BuildRequires:  pam-devel
80 BuildRequires:  perl-base
81 BuildRequires:  pixman-devel >= %{pixman_ver}
82 BuildRequires:  pkgconfig >= 1:0.19
83 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
84 BuildRequires:  systemd-devel >= 1:209
85 BuildRequires:  udev-devel >= 1:143
86 # wayland-client
87 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
88 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.10}
89 BuildRequires:  xcb-util-devel
90 BuildRequires:  xcb-util-image-devel
91 BuildRequires:  xcb-util-keysyms-devel
92 BuildRequires:  xcb-util-renderutil-devel
93 BuildRequires:  xcb-util-wm-devel
94 BuildRequires:  xmlto >= 0.0.20
95 BuildRequires:  xorg-app-mkfontscale
96 BuildRequires:  xorg-font-font-util >= 1.1
97 BuildRequires:  xorg-lib-libX11-devel >= 1.6
98 BuildRequires:  xorg-lib-libXau-devel
99 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
100 BuildRequires:  xorg-lib-libXdamage-devel
101 BuildRequires:  xorg-lib-libXdmcp-devel
102 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
103 BuildRequires:  xorg-lib-libXfixes-devel
104 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
105 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
106 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
107 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
108 BuildRequires:  xorg-lib-libXrender-devel
109 BuildRequires:  xorg-lib-libXres-devel
110 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
111 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
112 BuildRequires:  xorg-lib-libXv-devel
113 BuildRequires:  xorg-lib-libXxf86dga-devel
114 BuildRequires:  xorg-lib-libXxf86misc-devel
115 BuildRequires:  xorg-lib-libXxf86vm-devel
116 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
117 BuildRequires:  xorg-lib-libfontenc-devel
118 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
119 BuildRequires:  xorg-lib-libxkbfile-devel
120 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
121 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
122 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
123 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
124 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
125 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
126 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
127 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
128 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
129 BuildRequires:  xorg-proto-fontcacheproto-devel
130 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
131 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
132 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
133 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
134 BuildRequires:  xorg-proto-presentproto-devel >= 1.1
135 BuildRequires:  xorg-proto-printproto-devel
136 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
137 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
138 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
139 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
140 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
141 BuildRequires:  xorg-proto-videoproto-devel
142 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
143 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
144 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
145 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
146 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
147 BuildRequires:  xorg-proto-xf86miscproto-devel
148 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
149 BuildRequires:  xorg-proto-xineramaproto-devel
150 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
151 BuildRequires:  xorg-sgml-doctools >= 1.8
152 BuildRequires:  xorg-util-util-macros >= 1.14
153 #BR: tslib (for KDRIVE only)
154 Requires(triggerpostun):        sed >= 4.0
155 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
156 Requires:       libdrm >= 2.4.89
157 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
158 Requires:       pixman >= %{pixman_ver}
159 Requires:       udev-libs >= 1:143
160 Requires:       xkeyboard-config
161 # for rgb.txt
162 Requires:       xorg-app-rgb >= 0.99.3
163 Requires:       xorg-app-xkbcomp
164 Requires:       xorg-lib-libXfont2 >= 2.0.0
165 Requires:       xorg-lib-libpciaccess >= 0.12.901
166 Requires:       xorg-lib-libxshmfence >= 1.1
167 Suggests:       dbus-x11 >= 1.0
168 %{?with_hal:Suggests:   hal}
169 Suggests:       udev-acl >= 1:143
170 %{?with_udev:Suggests:  udev-core >= 1:143}
171 Suggests:       xkeyboard-config
172 Suggests:       xorg-driver-input-libinput
173 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
174 Suggests:       xorg-driver-video
175 Provides:       xorg-driver-video-modesetting
176 Provides:       xorg-xserver-libdri = %{version}-%{release}
177 Provides:       xorg-xserver-module(dri)
178 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
179 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
180 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
181 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
182 Obsoletes:      X11-Xserver < 1:7.0.0
183 Obsoletes:      X11-driver-i2c < 1:7.0.0
184 Obsoletes:      X11-modules < 1:7.0.0
185 Obsoletes:      X11-setup < 1:7.0.0
186 Obsoletes:      XFree86-Xserver < 1:7.0.0
187 Obsoletes:      XFree86-modules < 1:7.0.0
188 Obsoletes:      XFree86-setup < 1:7.0.0
189 Obsoletes:      Xserver
190 %{?with_glamor:Obsoletes:       glamor}
191 Obsoletes:      xorg-xserver-libdri
192 Obsoletes:      xorg-xserver-server-xorgcfg
193 Obsoletes:      xorg-driver-video-modesetting
194 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
195
196 %define         tirpc_cflags    $(pkg-config --cflags libtirpc)
197 %define         tirpc_libs      $(pkg-config --libs libtirpc)
198
199 %description
200 Xorg server is a generally used X server which uses display hardware.
201 It requires proper driver for your display hardware.
202
203 %description -l pl.UTF-8
204 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
205 graficznej. Do działania wymaga odpowiedniego sterownika.
206
207 %package -n xorg-xserver-Xdmx
208 Summary:        Xdmx - distributed multi-head X server
209 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
210 Group:          X11/Servers
211 Requires:       pixman >= %{pixman_ver}
212 Requires:       xorg-lib-libX11 >= 1.6
213 Requires:       xorg-lib-libXext >= 1.0.99.4
214 Requires:       xorg-lib-libXfont2 >= 2.0.0
215 Requires:       xorg-lib-libXi >= 1.2.99.1
216 Requires:       xorg-lib-libdmx >= 1.0.99.1
217
218 %description -n xorg-xserver-Xdmx
219 Xdmx - distributed multi-head X server.
220
221 %description -n xorg-xserver-Xdmx -l pl.UTF-8
222 Xdmx - rozproszony, wielomonitorowy serwer X.
223
224 %package -n xorg-xserver-Xnest
225 Summary:        Xnest - nested X server
226 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
227 Group:          X11/Servers
228 Requires:       pixman >= %{pixman_ver}
229 Requires:       xorg-lib-libXext >= 1.0.99.4
230 Requires:       xorg-lib-libXfont2 >= 2.0.0
231 Obsoletes:      X11-Xnest < 1:7.0.0
232 Obsoletes:      XFree86-Xnest < 1:7.0.0
233 Obsoletes:      Xserver-Xnest
234
235 %description -n xorg-xserver-Xnest
236 Xnest is an X Window System server which runs in an X window. Xnest is
237 a 'nested' window server, actually a client of the real X server,
238 which manages windows and graphics requests for Xnest, while Xnest
239 manages the windows and graphics requests for its own clients.
240
241 %description -n xorg-xserver-Xnest -l pl.UTF-8
242 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
243 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
244 serwer X dla własnych klientów.
245
246 %description -n xorg-xserver-Xnest -l ru.UTF-8
247 Xnest - это сервер X Window System, который работает в окне X. На
248 самом деле это клиент реального X-сервера, который управляет окнами и
249 графическими запросами для Xnest в то время, как Xnest управляет
250 окнами и графическими запросами для своих собственных клиентов.
251
252 %description -n xorg-xserver-Xnest -l uk.UTF-8
253 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
254 клієнт реального X-сервера, який керує вікнами та графічними запитами
255 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
256 своїх власних клієнтів.
257
258 %package -n xorg-xserver-Xephyr
259 Summary:        Xephyr - nested X server
260 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
261 Group:          X11/Servers
262 Requires:       Mesa-libGL >= 7.1.0
263 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
264 Requires:       libxcb >= 1.9.3
265 Requires:       pixman >= %{pixman_ver}
266 Requires:       xorg-lib-libXfont2 >= 2.0.0
267
268 %description -n xorg-xserver-Xephyr
269 Xephyr is a kdrive server that outputs to a window on a pre-existing
270 'host' X display. Think Xnest but with support for modern extensions
271 like composite, damage and randr.
272
273 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
274 the host X server, Xephyr is a real X server which uses the host X
275 server window as "framebuffer" via fast SHM XImages.
276
277 It also has support for 'visually' debugging what the server is
278 painting.
279
280 %description -n xorg-xserver-Xephyr -l pl.UTF-8
281 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
282 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
283 wspólczesnych rozszerzeń jak composite, damage i randr.
284
285 %package -n xorg-xserver-Xvfb
286 Summary:        Xvfb - virtual framebuffer X server
287 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
288 Group:          X11/Servers
289 Requires:       Mesa-libGL >= 7.1.0
290 Requires:       mktemp
291 Requires:       pixman >= %{pixman_ver}
292 Requires:       util-linux
293 Requires:       which
294 Requires:       xkeyboard-config
295 Requires:       xorg-app-xauth
296 Requires:       xorg-app-xkbcomp
297 Requires:       xorg-lib-libXfont2 >= 2.0.0
298 Obsoletes:      X11-Xvfb < 1:7.0.0
299 Obsoletes:      XFree86-Xvfb < 1:7.0.0
300
301 %description -n xorg-xserver-Xvfb
302 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
303 capable of running on machines with no display hardware and no
304 physical input devices. Xvfb emulates a dumb framebuffer using virtual
305 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
306 display. Xvfb is normally used for testing servers. Using Xvfb, the
307 mfb or cfb code for any depth can be exercised without using real
308 hardware that supports the desired depths. Xvfb has also been used to
309 test X clients against unusual depths and screen configurations, to do
310 batch processing with Xvfb as a background rendering engine, to do
311 load testing, to help with porting an X server to a new platform, and
312 to provide an unobtrusive way of running applications which really
313 don't need an X server but insist on having one.
314
315 %description -n xorg-xserver-Xvfb -l pl.UTF-8
316 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
317 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
318 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
319 używany do testowania serwerów X, może też być używany do testowania
320 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
321 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
322 serwera X, ale odmawiają uruchomienia bez niego.
323
324 %package -n xorg-xserver-Xvfb-init
325 Summary:        Init scripts for Xvfb
326 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
327 Group:          X11/Servers
328 Requires:       xorg-xserver-Xvfb
329
330 %description -n xorg-xserver-Xvfb-init
331 This package contains init scripts for Xvfb and registers Xvfb as
332 system service.
333
334 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
335 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
336 usługę systemową.
337
338 %package -n xorg-xserver-Xwayland
339 Summary:        Xwayland - X server integrated into a Wayland window system
340 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
341 Group:          X11/Servers
342 %{?with_eglstream:Requires:     egl-wayland >= 1.0.2}
343 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
344 Requires:       pixman >= %{pixman_ver}
345 Requires:       xorg-lib-libX11 >= 1.6
346 Requires:       xorg-lib-libXext >= 1.0.99.4
347 Requires:       xorg-lib-libXfont2 >= 2.0.0
348 Requires:       xorg-lib-libXi >= 1.2.99.1
349
350 %description -n xorg-xserver-Xwayland
351 Xwayland - server integrated into a Wayland window system.
352
353 %description -n xorg-xserver-Xwayland -l pl.UTF-8
354 Xwayland - serwer X integrowalny w Wayland.
355
356 %package devel
357 Summary:        Header files for X.org server
358 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
359 Group:          X11/Development/Libraries
360 Requires:       Mesa-libGL-devel >= 7.8.0
361 Requires:       libdrm-devel >= 2.4.89
362 Requires:       pixman-devel >= %{pixman_ver}
363 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
364 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
365 Requires:       xorg-lib-libxkbfile-devel
366 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
367 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
368 Requires:       xorg-proto-dri3proto-devel >= 1.0
369 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
370 Requires:       xorg-proto-glproto-devel >= 1.4.17
371 Requires:       xorg-proto-inputproto-devel >= 2.3
372 Requires:       xorg-proto-kbproto-devel >= 1.0.3
373 Requires:       xorg-proto-presentproto-devel >= 1.1
374 Requires:       xorg-proto-randrproto-devel >= 1.6.0
375 Requires:       xorg-proto-renderproto-devel >= 0.11
376 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
377 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
378 Requires:       xorg-proto-videoproto-devel
379 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
380 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
381 Requires:       xorg-proto-xineramaproto-devel
382 Requires:       xorg-proto-xproto-devel >= 7.0.31
383 Obsoletes:      X11-Xserver-devel < 1:7.0.0
384 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
385 %{?with_glamor:Obsoletes:       glamor-devel}
386
387 %description devel
388 Header files for X.org server.
389
390 %description devel -l pl.UTF-8
391 Pliki nagłówkowe dla serwera X.org.
392
393 %package source
394 Summary:        X.org server source code
395 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
396 Group:          X11/Development/Libraries
397
398 %description source
399 X.org server source code.
400
401 %description source -l pl.UTF-8
402 Pliki źródłowe dla serwera X.org.
403
404 %package -n xorg-xserver-libglx
405 Summary:        GLX extension library for X.org server
406 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
407 Group:          X11/Servers
408 Requires:       %{name} = %{version}-%{release}
409 Requires:       Mesa-libGL >= 7.1.0
410 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
411 # Mesa version glapi tables in glx/ dir come from
412 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
413 Provides:       xorg-xserver-module(glx)
414 Obsoletes:      X11-OpenGL-core < 1:7.0.0
415 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
416
417 %description -n xorg-xserver-libglx
418 GLX extension library for X.org server.
419
420 %description -n xorg-xserver-libglx -l pl.UTF-8
421 Biblioteka rozszerzenia GLX dla serwera X.org.
422
423 %prep
424 %setup -q -n xorg-server-%{version}
425 %patch1 -p1
426
427 %patch4 -p1
428
429 %patch6 -p1
430
431 # xserver uses pixman-1 API/ABI so put that explictly here
432 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
433
434 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
435 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
436
437 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
438
439 %build
440 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
441 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
442         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
443         exit 1
444 fi
445
446 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
447 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
448         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
449         exit 1
450 fi
451
452 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
453 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
454         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
455         exit 1
456 fi
457 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
458 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
459         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
460         exit 1
461 fi
462
463 %{__libtoolize}
464 %{__aclocal} -I m4
465 %{__autoconf}
466 %{__autoheader}
467 %{__automake}
468 %configure \
469         CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
470         LIBS="%{tirpc_libs}" \
471         --libexecdir=%{_libdir}/xorg \
472         --with-os-name="PLD/Linux" \
473         --with-os-vendor="PLD/Team" \
474         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
475         --with-xkb-output=/var/lib/xkb \
476         --disable-linux-acpi \
477         --disable-linux-apm \
478         %{?with_dbus:--enable-config-dbus} \
479         --enable-config-hal%{!?with_hal:=no} \
480         --enable-config-udev%{!?with_udev:=no} \
481         --enable-dga \
482         %{?with_dmx:--enable-dmx} \
483         --enable-dri2%{!?with_dri2:=no} \
484         --enable-dri3%{!?with_dri3:=no} \
485         %{?with_glamor:--enable-glamor} \
486         --enable-kdrive \
487         %{?with_libunwind:--enable-libunwind} \
488         %{?with_record:--enable-record} \
489         --enable-secure-rpc \
490         %{?with_xcsecurity:--enable-xcsecurity} \
491         --enable-xephyr \
492         %{?with_xf86bigfont:--enable-xf86bigfont} \
493         %{?with_xselinux:--enable-xselinux} \
494         %{?with_wayland:--enable-xwayland} \
495         %{?with_eglstream:--enable-xwayland-eglstream} \
496         %{!?with_systemtap:--without-dtrace} \
497         --without-fop \
498         --enable-suid-wrapper \
499         --with-systemd-daemon
500
501 %{__make}
502
503 %install
504 rm -rf $RPM_BUILD_ROOT
505
506 %if "%{_libdir}" != "%{_exec_prefix}/lib"
507 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
508 %endif
509
510 %{__make} install \
511         DESTDIR=$RPM_BUILD_ROOT
512
513 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
514 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
515 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
516 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
517 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
518
519 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
520 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
521
522 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
523
524 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
525
526 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
527 install -d $RPM_BUILD_ROOT/etc/sysconfig
528 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
529 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
530
531 # Xorg.wrap config
532 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
533 # allowed values: rootonly console anybody pam
534 allowed_users = pam
535
536 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
537 #needs_root_rights = yes
538 EOF
539
540 # compatibility with old xwrapper
541 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
542
543 # prepare source package
544 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
545 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
546 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
547 %{__make} distclean
548 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
549 find -name '*.h' | xargs chmod a-x
550
551 %if %{with systemtap}
552 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
553 %endif
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %triggerpostun -- xorg-xserver-server < 1.5.0
559 if [ -f /etc/X11/xorg.conf ]; then
560         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
561         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
562 %if %{without record}
563         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
564 %endif
565         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
566 fi
567
568 %post -n xorg-xserver-Xvfb-init
569 /sbin/chkconfig --add Xvfb
570 %service Xvfb restart
571
572 %preun -n xorg-xserver-Xvfb-init
573 if [ "$1" = "0" ]; then
574         %service -q Xvfb stop
575         /sbin/chkconfig --del Xvfb
576 fi
577
578 %files
579 %defattr(644,root,root,755)
580 %doc COPYING ChangeLog README.md
581 %attr(755,root,root) %{_bindir}/X
582 %attr(755,root,root) %{_bindir}/Xorg
583 %attr(4755,root,root) %{_bindir}/Xwrapper
584 %attr(755,root,root) %{_bindir}/cvt
585 %attr(755,root,root) %{_bindir}/gtf
586 %dir %{_libdir}/xorg
587 %{_libdir}/xorg/protocol.txt
588 %attr(755,root,root) %{_libdir}/xorg/Xorg
589 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
590 %dir %{_libdir}/xorg/modules
591 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
592 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
593 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
594 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
595 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
596 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
597 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
598 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
599 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
600 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
601 %dir %{_libdir}/xorg/modules/dri
602 %dir %{_libdir}/xorg/modules/drivers
603 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
604 %dir %{_libdir}/xorg/modules/extensions
605 %dir %{_libdir}/xorg/modules/input
606 %if "%{_libdir}" != "%{_exec_prefix}/lib"
607 %dir %{_exec_prefix}/lib/xorg
608 %dir %{_exec_prefix}/lib/xorg/modules
609 %dir %{_exec_prefix}/lib/xorg/modules/dri
610 %endif
611 %dir /var/lib/xkb
612 /var/lib/xkb/README.compiled
613 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
615 %config(missingok) /etc/security/console.apps/xserver
616 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
617 %dir /etc/X11/xorg.conf.d
618 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
619 %dir %{_datadir}/X11/xorg.conf.d
620 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
621 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
622 %{_mandir}/man1/Xorg.1*
623 %{_mandir}/man1/Xorg.wrap.1*
624 %{_mandir}/man1/Xserver.1*
625 %{_mandir}/man1/cvt.1*
626 %{_mandir}/man1/gtf.1*
627 %{_mandir}/man4/exa.4*
628 %{_mandir}/man4/fbdevhw.4*
629 %{_mandir}/man4/modesetting.4*
630 %{_mandir}/man5/Xwrapper.config.5*
631 %{_mandir}/man5/xorg.conf.5*
632 %{_mandir}/man5/xorg.conf.d.5*
633
634 %if %{with dmx}
635 %files -n xorg-xserver-Xdmx
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/Xdmx
638 %attr(755,root,root) %{_bindir}/dmxaddinput
639 %attr(755,root,root) %{_bindir}/dmxaddscreen
640 %attr(755,root,root) %{_bindir}/dmxinfo
641 %attr(755,root,root) %{_bindir}/dmxreconfig
642 %attr(755,root,root) %{_bindir}/dmxresize
643 %attr(755,root,root) %{_bindir}/dmxrminput
644 %attr(755,root,root) %{_bindir}/dmxrmscreen
645 %attr(755,root,root) %{_bindir}/dmxtodmx
646 %attr(755,root,root) %{_bindir}/dmxwininfo
647 %attr(755,root,root) %{_bindir}/vdltodmx
648 %attr(755,root,root) %{_bindir}/xdmxconfig
649 %{_mandir}/man1/Xdmx.1*
650 %{_mandir}/man1/dmxtodmx.1*
651 %{_mandir}/man1/vdltodmx.1*
652 %{_mandir}/man1/xdmxconfig.1*
653 %endif
654
655 %files -n xorg-xserver-Xnest
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/Xnest
658 %{_mandir}/man1/Xnest.1*
659
660 %files -n xorg-xserver-Xephyr
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/Xephyr
663 %{_mandir}/man1/Xephyr.1*
664
665 %files -n xorg-xserver-Xvfb
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/Xvfb
668 %attr(755,root,root) %{_bindir}/xvfb-run
669 %{_mandir}/man1/Xvfb.1*
670
671 %files -n xorg-xserver-Xvfb-init
672 %defattr(644,root,root,755)
673 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
674 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
675
676 %if %{with wayland}
677 %files -n xorg-xserver-Xwayland
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/Xwayland
680 %endif
681
682 %files devel
683 %defattr(644,root,root,755)
684 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
685 %{_includedir}/xorg
686 %{_aclocaldir}/xorg-server.m4
687 %{_pkgconfigdir}/xorg-server.pc
688
689 %files source
690 %defattr(644,root,root,755)
691 # keep file perms from install time, but have default defattr to keep adapter happy
692 %defattr(-,root,root,755)
693 %{_usrsrc}/%{name}-%{version}
694
695 %files -n xorg-xserver-libglx
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.087587 seconds and 3 git commands to generate.