]> git.pld-linux.org Git - packages/xorg-driver-video-xgi.git/commitdiff
- updated to 1.6.1 auto/th/xorg-driver-video-xgi-1.6.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Sep 2015 08:09:20 +0000 (10:09 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Sep 2015 08:09:20 +0000 (10:09 +0200)
- added build patch (missing headers + open() mode bugfix)

xorg-driver-video-xgi-build.patch [new file with mode: 0644]
xorg-driver-video-xgi.spec

diff --git a/xorg-driver-video-xgi-build.patch b/xorg-driver-video-xgi-build.patch
new file mode 100644 (file)
index 0000000..6dfb452
--- /dev/null
@@ -0,0 +1,29 @@
+Fix implicit function declarations and open() mode bug.
+--- xf86-video-xgi-1.6.1/src/xgi_driver.c.orig 2015-08-18 00:57:47.000000000 +0200
++++ xf86-video-xgi-1.6.1/src/xgi_driver.c      2015-09-06 09:57:48.143727372 +0200
+@@ -68,13 +68,16 @@
+ #include "mipointer.h"
+ #include "xgi.h"
++#include "xgi_accel.h"
+ #include "xgi_regs.h"
+ #include "xgi_vb.h"
+ #include "xgi_dac.h"
+ #include "vb_def.h"
++#include "vb_ext.h"
+ #include "xgi_driver.h"
+ #include "valid_mode.h"
+ #include "vb_i2c.h"
++#include "vb_setmode.h"
+ #define _XF86DGA_SERVER_
+ #include <X11/extensions/xf86dgaproto.h>
+@@ -2797,7 +2800,7 @@
+     FbDevExist = FALSE;
+    if((pXGI->Chipset != PCI_CHIP_XGIXG20)&&(pXGI->Chipset != PCI_CHIP_XGIXG21)&&( pXGI->Chipset != PCI_CHIP_XGIXG27 ))
+    {
+-        if ((fd = open("/dev/fb", 'r')) != -1) {
++        if ((fd = open("/dev/fb", O_RDONLY)) != -1) {
+             PDEBUG(ErrorF("--- open /dev/fb....   \n"));
+             ioctl(fd, FBIOGET_FSCREENINFO, &fix);
+             if (fix.accel == FB_ACCEL_XGI_GLAMOUR) {
index e84ee66ec88c2fcba5f136183db9e2917119eafd..120b9950682a1d3254005a9675d324b6dbefe6da 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       X.org video drivers for XGI adapters
 Summary(pl.UTF-8):     Sterowniki obrazu X.org do kart graficznych XGI
 Name:          xorg-driver-video-xgi
-Version:       1.6.0
-Release:       4
+Version:       1.6.1
+Release:       1
 License:       MIT
 Group:         X11/Applications
 Source0:       http://xorg.freedesktop.org/releases/individual/driver/xf86-video-xgi-%{version}.tar.bz2
-# Source0-md5: b4ac771ae81b52fca9b6fa68006a258a
+# Source0-md5: 103a17936676318b4b09af94dbc420a9
+Patch0:                %{name}-build.patch
 URL:           http://xorg.freedesktop.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -46,6 +47,7 @@ Sterowniki obrazu X.org do kart graficznych XGI:
 
 %prep
 %setup -q -n xf86-video-xgi-%{version}
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.13942 seconds and 4 git commands to generate.