]> git.pld-linux.org Git - packages/xorg-driver-video-nvidia-legacy-304xx.git/commitdiff
- up to 304.135 auto/th/xorg-driver-video-nvidia-legacy-304xx-304.135-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Mar 2017 08:31:36 +0000 (10:31 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 26 Mar 2017 08:31:36 +0000 (10:31 +0200)
- added build fix for kernel 4.10

linux-4.10.patch [new file with mode: 0644]
xorg-driver-video-nvidia-legacy-304xx.spec

diff --git a/linux-4.10.patch b/linux-4.10.patch
new file mode 100644 (file)
index 0000000..76f5274
--- /dev/null
@@ -0,0 +1,38 @@
+diff --git a/kernel/nv-linux.h b/kernel/nv-linux.h
+index e7068e3..3ac3c0b 100644
+--- a/kernel/nv-linux.h
++++ b/kernel/nv-linux.h
+@@ -270,7 +270,7 @@ RM_STATUS nvos_forward_error_to_cray(struct pci_dev *, NvU32,
+ extern int nv_pat_mode;
+-#if !defined(NV_VMWARE) && defined(CONFIG_HOTPLUG_CPU)
++#if !defined(NV_VMWARE) && defined(CONFIG_HOTPLUG_CPU) && (LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0))
+ #define NV_ENABLE_HOTPLUG_CPU
+ #include <linux/cpu.h>              /* CPU hotplug support              */
+ #include <linux/notifier.h>         /* struct notifier_block, etc       */
+diff --git a/kernel/nv-pat.c b/kernel/nv-pat.c
+index a725533..91070e0 100644
+--- a/kernel/nv-pat.c
++++ b/kernel/nv-pat.c
+@@ -210,14 +210,20 @@ nvidia_cpu_callback(struct notifier_block *nfb, unsigned long action, void *hcpu
+     switch (action)
+     {
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+         case CPU_DOWN_FAILED:
++#endif
+         case CPU_ONLINE:
+             if (cpu == (NvUPtr)hcpu)
+                 nv_setup_pat_entries(NULL);
+             else
+                 NV_SMP_CALL_FUNCTION(nv_setup_pat_entries, hcpu, 1);
+             break;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 10, 0)
+         case CPU_DOWN_PREPARE:
++#else
++        case CPU_DOWN_PREPARE_FROZEN:
++#endif
+             if (cpu == (NvUPtr)hcpu)
+                 nv_restore_pat_entries(NULL);
+             else
index 3040d285d0e45f3f5b515a3fa9c427135dfefb60..94ea8d441d3d8026c53691e1decec2618d6cc029 100644 (file)
@@ -32,15 +32,15 @@ Summary:    Linux Drivers for nVidia GeForce/Quadro Chips
 Summary(hu.UTF-8):     Linux meghajtók nVidia GeForce/Quadro chipekhez
 Summary(pl.UTF-8):     Sterowniki do kart graficznych nVidia GeForce/Quadro
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
 Summary(hu.UTF-8):     Linux meghajtók nVidia GeForce/Quadro chipekhez
 Summary(pl.UTF-8):     Sterowniki do kart graficznych nVidia GeForce/Quadro
 Name:          %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
-Version:       304.134
+Version:       304.135
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 Epoch:         1
 License:       nVidia Binary
 Group:         X11
 Source0:       http://us.download.nvidia.com/XFree86/Linux-x86/%{version}/NVIDIA-Linux-x86-%{version}.run
 Release:       %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
 Epoch:         1
 License:       nVidia Binary
 Group:         X11
 Source0:       http://us.download.nvidia.com/XFree86/Linux-x86/%{version}/NVIDIA-Linux-x86-%{version}.run
-# Source0-md5: 9abd7e9272382bd0e6939c3a367cc1a6
+# Source0-md5: 0e2082ae8490b135eb306befe6db56e1
 Source1:       http://us.download.nvidia.com/XFree86/Linux-x86_64/%{version}/NVIDIA-Linux-x86_64-%{version}-no-compat32.run
 Source1:       http://us.download.nvidia.com/XFree86/Linux-x86_64/%{version}/NVIDIA-Linux-x86_64-%{version}-no-compat32.run
-# Source1-md5: 2ecfa6bd145f673264f7977e0366e259
+# Source1-md5: 8ee9bd0b020508bca9953181811422fa
 Source2:       xinitrc.sh
 Source3:       gl.pc.in
 Source4:       10-nvidia.conf
 Source2:       xinitrc.sh
 Source3:       gl.pc.in
 Source4:       10-nvidia.conf
@@ -48,6 +48,7 @@ Source5:      10-nvidia-modules.conf
 Patch0:                X11-driver-nvidia-GL.patch
 Patch1:                X11-driver-nvidia-desktop.patch
 Patch2:                linux-4.0.patch
 Patch0:                X11-driver-nvidia-GL.patch
 Patch1:                X11-driver-nvidia-desktop.patch
 Patch2:                linux-4.0.patch
+Patch3:                linux-4.10.patch
 URL:           http://www.nvidia.com/object/unix.html
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
 URL:           http://www.nvidia.com/object/unix.html
 BuildRequires: rpmbuild(macros) >= 1.701
 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}}
@@ -248,6 +249,7 @@ rm -rf NVIDIA-Linux-x86*-%{version}*
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{?with_kernel:%{expand:%build_kernel_packages}}
 
 %build
 %{?with_kernel:%{expand:%build_kernel_packages}}
This page took 0.042302 seconds and 4 git commands to generate.