]> git.pld-linux.org Git - packages/xml-security-c.git/commitdiff
- updated to 1.7.3
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Nov 2017 17:24:02 +0000 (18:24 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 24 Nov 2017 17:24:02 +0000 (18:24 +0100)
- removed obsolete xalan-c-1.11-compat patch

xml-security-c-1.5.1-xalan-c-1.11-compat.patch [deleted file]
xml-security-c.spec

diff --git a/xml-security-c-1.5.1-xalan-c-1.11-compat.patch b/xml-security-c-1.5.1-xalan-c-1.11-compat.patch
deleted file mode 100644 (file)
index c3a47b6..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-diff -Naur xml-security-c-1.5.1.orig/src/canon/XSECC14n20010315.cpp xml-security-c-1.5.1/src/canon/XSECC14n20010315.cpp
---- xml-security-c-1.5.1.orig/src/canon/XSECC14n20010315.cpp   2009-07-27 09:23:51.228693118 +0200
-+++ xml-security-c-1.5.1/src/canon/XSECC14n20010315.cpp        2009-07-27 11:37:12.697101082 +0200
-@@ -36,6 +36,7 @@
- // Xerces includes
- #include <xercesc/dom/DOMNamedNodeMap.hpp>
- #include <xercesc/util/XMLUniDefs.hpp>
-+#include <xercesc/dom/DOMElement.hpp>
- XERCES_CPP_NAMESPACE_USE
-@@ -61,7 +62,7 @@
- XALAN_USING_XALAN(NodeRefList)
- XALAN_USING_XALAN(XercesDocumentWrapper)
- XALAN_USING_XALAN(XercesWrapperNavigator)
--
-+XALAN_USING_XALAN(c_wstr)
- #endif
-@@ -450,21 +451,27 @@
-       // We use Xalan to process the Xerces DOM tree and get the XPath nodes
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+      XercesParserLiaison theParserLiaison;
-+      XercesDOMSupport theDOMSupport(theParserLiaison);
-+#else
-       XercesDOMSupport theDOMSupport;
- #if defined XSEC_XERCESPARSERLIAISON_REQS_DOMSUPPORT
-       XercesParserLiaison theParserLiaison(theDOMSupport);
- #else
-       XercesParserLiaison theParserLiaison;
- #endif
-+#endif // XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-       if (mp_doc == 0) {
-               throw XSECException(XSECException::UnsupportedFunction,
-                       "XPath selection only supported in C14n for full documents");
-       }
--      XalanDocument* theDoc = theParserLiaison.createDocument(mp_doc);
--      XalanElement * xe = theDoc->createElement(XalanDOMString("ns"));
--      xe->setAttribute(/*XalanDOMString(""), */XalanDOMString("xmlns:ietf"), XalanDOMString("http://www.ietf.org"));
-+      DOMElement* theXercesNode = mp_doc->createElement(c_wstr(XalanDOMString("ns")));
-+      theXercesNode->setAttribute(c_wstr(XalanDOMString("xmlns:ietf")), c_wstr(XalanDOMString("http://www.ietf.org")));
-+
-+      XalanDocument* theDoc = theParserLiaison.createDocument(mp_doc);
-       // Set up the XPath evaluator
-@@ -505,7 +512,7 @@
-               theDOMSupport,
-               theContextNode,
-               expr,
--              xe));
-+              theDoc->getElementById(XalanDOMString("ns"))));
- #else
-@@ -514,7 +521,7 @@
-               theDOMSupport,
-               theContextNode,
-               expr,
--              xe));
-+              theDoc->getElementById(XalanDOMString("ns"))));
-               //theDoc->getDocumentElement()));
- #endif
-diff -Naur xml-security-c-1.5.1.orig/src/transformers/TXFMXPath.cpp xml-security-c-1.5.1/src/transformers/TXFMXPath.cpp
---- xml-security-c-1.5.1.orig/src/transformers/TXFMXPath.cpp   2009-07-27 09:23:51.254551633 +0200
-+++ xml-security-c-1.5.1/src/transformers/TXFMXPath.cpp        2009-07-27 11:40:30.923733630 +0200
-@@ -283,8 +283,12 @@
-       setXPathNS(document, XPathAtts, addedNodes, formatter, mp_nse);
-       XPathProcessorImpl      xppi;                                   // The processor
--      XercesDOMSupport        xds;
-       XercesParserLiaison xpl;
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+      XercesDOMSupport        xds(xpl);
-+#else
-+      XercesDOMSupport        xds;
-+#endif
-       XPathEvaluator          xpe;
-       XPathFactoryDefault xpf;
-       XPathConstructionContextDefault xpcc;
-diff -Naur xml-security-c-1.5.1.orig/src/transformers/TXFMXPathFilter.cpp xml-security-c-1.5.1/src/transformers/TXFMXPathFilter.cpp
---- xml-security-c-1.5.1.orig/src/transformers/TXFMXPathFilter.cpp     2009-07-27 09:23:51.254551633 +0200
-+++ xml-security-c-1.5.1/src/transformers/TXFMXPathFilter.cpp  2009-07-27 11:39:11.073713584 +0200
-@@ -183,8 +183,12 @@
-       setXPathNS(document, expr->mp_NSMap, addedNodes, mp_formatter, mp_nse);
-       XPathProcessorImpl      xppi;                                   // The processor
--      XercesDOMSupport        xds;
-       XercesParserLiaison xpl;
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+      XercesDOMSupport        xds(xpl);
-+#else
-+      XercesDOMSupport        xds;
-+#endif
-       XPathEvaluator          xpe;
-       XPathFactoryDefault xpf;
-       XPathConstructionContextDefault xpcc;
-diff -Naur xml-security-c-1.5.1.orig/src/transformers/TXFMXSL.cpp xml-security-c-1.5.1/src/transformers/TXFMXSL.cpp
---- xml-security-c-1.5.1.orig/src/transformers/TXFMXSL.cpp     2009-07-27 09:23:51.257885228 +0200
-+++ xml-security-c-1.5.1/src/transformers/TXFMXSL.cpp  2009-07-27 11:42:31.867031516 +0200
-@@ -102,11 +102,15 @@
- TXFMXSL::TXFMXSL(DOMDocument *doc) : 
-       TXFMBase(doc),
-+#if XALAN_VERSION_MAJOR == 1 && XALAN_VERSION_MINOR > 10
-+xds(xpl)
-+#else
- #if defined XSEC_XERCESPARSERLIAISON_REQS_DOMSUPPORT
- xpl(xds) 
- #else
- xpl()
- #endif
-+#endif
- {
-       // Zeroise all the pointers
-
-
index 2c76ec4371778e467850b13ac16e7b178aa3c738..0916a63afe5539d8550ecb19ee7f796d7a7fe9f8 100644 (file)
@@ -1,24 +1,31 @@
 #
 # Conditional build:
-%bcond_without tests           # build without tests
-%bcond_without static_libs     # don't build static libraries
-%bcond_without xalan           # build without xalan-c (XPath and XSLT transformations cannot be performed)
+%bcond_without tests           # unit tests
+%bcond_without static_libs     # static library
+%bcond_with    nss             # NSS crypto provider
+%bcond_without openssl         # OpenSSL crypto provider
+%bcond_without xalan           # xalan-c (XPath and XSLT transformations) support
 
 Summary:       C++ Implementation of W3C security standards for XML
+Summary(pl.UTF-8):     Implementacja w C++ standardów bezpieczeństwa W3C dla XML
 Name:          xml-security-c
-Version:       1.5.1
-Release:       2
-License:       ASL 2.0
+Version:       1.7.3
+Release:       1
+License:       Apache v2.0
 Group:         Libraries
-URL:           http://santuario.apache.org/c/
-Source0:       http://santuario.apache.org/dist/c-library/%{name}-%{version}.tar.gz
-# Source0-md5: 2c47c4ec12e8d6abe967aa5e5e99000c
-Patch0:                %{name}-1.5.1-xalan-c-1.11-compat.patch
-BuildRequires: openssl-devel
+Source0:       http://www.apache.org/dist/santuario/c-library/%{name}-%{version}.tar.bz2
+# Source0-md5: 61130e3273bed410e607d9710eef9de2
+URL:           http://santuario.apache.org/cindex.html
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
+BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 2:1.5
+%{?with_nss:BuildRequires:     nss-devel >= 3}
+%{?with_openssl:BuildRequires: openssl-devel}
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
 %{?with_xalan:BuildRequires:   xalan-c-devel}
-BuildRequires: xerces-c-devel
+BuildRequires: xerces-c-devel >= 2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -29,18 +36,33 @@ The library makes use of the Apache XML project's Xerces-C XML Parser
 and Xalan-C XSLT processor. The latter is used for processing XPath
 and XSLT transforms.
 
+%description -l pl.UTF-8
+Biblioteka xml-security-c to implementacja w C++ specyfikacji XML
+Digital Signature.
+
+Biblioteka wykorzystuje parser XML Xerces-C oraz procesor XSLT Xalan-C
+z projektu Apache XML. Biblioteka Xalan-C jest wykorzystywana do
+przekształceń XPath i XSLT.
+
 %package devel
 Summary:       Development files for xml-security-c
+Summary(pl.UTF-8):     Pliki programistyczne xml-security-c
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      openssl-devel
+Requires:      libstdc++-devel
+%{?with_nss:Requires:  nss-devel >= 3}
+%{?with_openssl:Requires:      openssl-devel}
 %{?with_xalan:Requires:        xalan-c-devel}
-Requires:      xerces-c-devel
+Requires:      xerces-c-devel >= 2.0
 
 %description devel
 This package provides development files for xml-security-c, a C++
 library for XML Digital Signatures.
 
+%description devel -l pl.UTF-8
+Ten pakiet zawiera pliki programistyczne xml-security-c - biblioteki
+C++ do podpisów cyfrowych XML.
+
 %package static
 Summary:       Static xml-security-c library
 Summary(pl.UTF-8):     Statyczna biblioteka xml-security-c
@@ -50,52 +72,60 @@ Requires:   %{name}-devel = %{version}-%{release}
 %description static
 Static xml-security-c library.
 
+%description static -l pl.UTF-8
+Statyczna biblioteka xml-security-c.
+
 %prep
 %setup -q
-%patch0 -p1
 
-# Remove bogus "-O2" from CXXFLAGS to avoid overriding RPM_OPT_FLAGS.
-%{__sed} -i -e 's/-O2 -DNDEBUG/-DNDEBUG/g' configure
+# Remove bogus "-O2" from CXXFLAGS to avoid overriding optflags.
+%{__sed} -i -e 's/-O2 -DNDEBUG/-DNDEBUG/g' configure.ac
 
 %build
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
 %configure \
+       %{?with_nss:--with-nss} \
+       %{!?with_openssl:--without-openssl} \
        %{!?with_xalan:--without-xalan} \
        %{!?with_static_libs:--disable-static}
 %{__make}
 
 %if %{with tests}
 # Verify that what was compiled actually works.
-./bin/xtest
+xsec/xtest
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        CPPROG="cp -p" \
        DESTDIR=$RPM_BUILD_ROOT
 
-# We do not ship .la files.
-rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
-
 # Do not ship library test utilities. These are only needed for
 # xml-security-c developers and they should have the whole source anyway.
-rm -rf $RPM_BUILD_ROOT%{_bindir}
-
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%{__rm} -r $RPM_BUILD_ROOT%{_bindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
+%doc CHANGELOG.txt INSTALL.txt NOTICE.txt
 %attr(755,root,root) %{_libdir}/libxml-security-c.so.*.*.*
-%ghost %attr(755,root,root) %{_libdir}/libxml-security-c.so.15
+%ghost %attr(755,root,root) %{_libdir}/libxml-security-c.so.17
 
 %files devel
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libxml-security-c.so
 %{_includedir}/xsec
-%{_libdir}/libxml-security-c.so
 
 %if %{with static_libs}
 %files static
This page took 0.196187 seconds and 4 git commands to generate.