]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- removed outdated and unneeded Obsoletes
[packages/xfsprogs.git] / xfsprogs.spec
1 Summary:        Tools for the XFS filesystem
2 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
3 Name:           xfsprogs
4 Version:        3.0.0
5 Release:        3
6 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
9 # Source0-md5:  ec734f935ec87ebb8be890d29380a3e6
10 Patch0:         %{name}-miscfix-v2.patch
11 Patch1:         %{name}-install-sh.patch
12 Patch2:         %{name}-sharedlibs.patch
13 Patch3:         %{name}-pl.po-update.patch
14 Patch4:         %{name}-dynamic_exe.patch
15 Patch5:         %{name}-LDFLAGS.patch
16 URL:            http://oss.sgi.com/projects/xfs/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  bash
20 BuildRequires:  gettext-devel
21 BuildRequires:  libtool
22 BuildRequires:  libuuid-devel
23 BuildRequires:  rpmbuild(macros) >= 1.402
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sbindir        /sbin
27 %define         _bindir         /usr/sbin
28 %define         _libdir         /%{_lib}
29 %define         _libexecdir     /usr/%{_lib}
30
31 %description
32 A set of commands to use the XFS filesystem, including mkfs.xfs.
33
34 XFS is a high performance journaling filesystem which originated on
35 the SGI IRIX platform. It is completely multi-threaded, can support
36 large files and large filesystems, extended attributes, variable block
37 sizes, is extent based, and makes extensive use of Btrees
38 (directories, extents, free space) to aid both performance and
39 scalability.
40
41 This implementation is on-disk compatible with the IRIX version of
42 XFS.
43
44 %description -l pl.UTF-8
45 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
46
47 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
48 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
49 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
50 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
51 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
52
53 %package devel
54 Summary:        Header files and libraries to develop XFS software
55 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libuuid-devel
59
60 %description devel
61 Header files and libraries to develop software which operates on XFS
62 filesystems.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
66 operującego na systemie plików XFS.
67
68 %package static
69 Summary:        Static XFS software libraries
70 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static XFS software libraries.
76
77 %description static -l pl.UTF-8
78 Biblioteki statyczne do XFS.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 # currently obsolete until needed again
86 # %patch3 -p1
87 %patch4 -p1
88 %patch5 -p1
89
90 rm -f include/{builddefs,platform_defs}.h
91
92 %build
93 %{__aclocal} -I m4
94 %{__autoconf}
95 %configure \
96         --enable-gettext \
97         --enable-readline \
98         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
99         OPTIMIZER="%{rpmcflags}"
100 %{__make} -j1
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 DIST_ROOT=$RPM_BUILD_ROOT
106 DIST_INSTALL=$(pwd)/install.manifest
107 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
108 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
109
110 %{__make} install \
111         DIST_MANIFEST="$DIST_INSTALL"
112 %{__make} install-dev \
113         DIST_MANIFEST="$DIST_INSTALL_DEV"
114
115 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
116          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
117 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libdisk.so.*.*.*) \
118         $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
119 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxcmd.so.*.*.*) \
120         $RPM_BUILD_ROOT%{_libexecdir}/libxcmd.so
121 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxfs.so.*.*.*) \
122         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
123 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxlog.so.*.*.*) \
124         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
125
126 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
127         $RPM_BUILD_ROOT%{_libexecdir}/lib{disk,handle,xcmd,xfs,xlog}.la
128 %{__sed} -i -e "s| %{_libdir}/libxfs.la | %{_libexecdir}/libxfs.la |" \
129         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.la
130
131 %find_lang %{name}
132
133 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
134
135 # already in /usr
136 rm -f $RPM_BUILD_ROOT%{_libdir}/libdisk.{a,la,so}
137 rm -f $RPM_BUILD_ROOT%{_libdir}/libhandle.{a,la,so}
138 rm -f $RPM_BUILD_ROOT%{_libdir}/libxcmd.{a,la,so}
139 rm -f $RPM_BUILD_ROOT%{_libdir}/libxfs.{a,la,so}
140 rm -f $RPM_BUILD_ROOT%{_libdir}/libxlog.{a,la,so}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc README doc/{CHANGES,CREDITS}
151 %attr(755,root,root) %{_sbindir}/fsck.xfs
152 %attr(755,root,root) %{_sbindir}/mkfs.xfs
153 %attr(755,root,root) %{_sbindir}/xfs_repair
154 %attr(755,root,root) %{_bindir}/xfs_*
155 %attr(755,root,root) %{_libdir}/libdisk.so.*.*
156 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
157 %attr(755,root,root) %{_libdir}/libxcmd.so.*.*
158 %attr(755,root,root) %{_libdir}/libxfs.so.*.*
159 %attr(755,root,root) %{_libdir}/libxlog.so.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libdisk.so.0
161 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
162 %attr(755,root,root) %ghost %{_libdir}/libxcmd.so.0
163 %attr(755,root,root) %ghost %{_libdir}/libxfs.so.0
164 %attr(755,root,root) %ghost %{_libdir}/libxlog.so.0
165 %{_mandir}/man5/xfs.5*
166 %{_mandir}/man8/fsck.xfs.8*
167 %{_mandir}/man8/mkfs.xfs.8*
168 %{_mandir}/man8/xfs_*.8*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libexecdir}/libdisk.so
173 %attr(755,root,root) %{_libexecdir}/libhandle.so
174 %attr(755,root,root) %{_libexecdir}/libxcmd.so
175 %attr(755,root,root) %{_libexecdir}/libxfs.so
176 %attr(755,root,root) %{_libexecdir}/libxlog.so
177 %{_libexecdir}/libdisk.la
178 %{_libexecdir}/libhandle.la
179 %{_libexecdir}/libxcmd.la
180 %{_libexecdir}/libxfs.la
181 %{_libexecdir}/libxlog.la
182 %{_includedir}/xfs
183 %{_mandir}/man3/*handle.3*
184 %{_mandir}/man3/xfsctl.3*
185
186 %files static
187 %defattr(644,root,root,755)
188 %{_libexecdir}/libdisk.a
189 %{_libexecdir}/libhandle.a
190 %{_libexecdir}/libxcmd.a
191 %{_libexecdir}/libxfs.a
192 %{_libexecdir}/libxlog.a
This page took 0.056079 seconds and 4 git commands to generate.