]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- removed obsolete po patch and pl.po source (I'll make pl.po-update later)
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_with     static          # link statically with \-luuid
4 %bcond_with     dynamic_exe     # link executables dynamically with xfs libs
5 #
6 Summary:        Tools for the XFS filesystem
7 Summary(pl):    Narzêdzia do systemu plików XFS
8 Name:           xfsprogs
9 Version:        2.8.3
10 Release:        1
11 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
12 Group:          Applications/System
13 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
14 # Source0-md5:  88703cf432f3e958f15a193e508c0e5c
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch1:         %{name}-install-sh.patch
17 Patch2:         %{name}-sharedlibs.patch
18 Patch3:         %{name}-dynamic_exe.patch
19 URL:            http://oss.sgi.com/projects/xfs/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bash
23 BuildRequires:  gettext-devel
24 BuildRequires:  libtool
25 BuildRequires:  libuuid-devel
26 %{?with_static:BuildRequires:   libuuid-static}
27 %{?with_static:BuildRequires:   sed >= 4.0}
28 Obsoletes:      libxfs1
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sbindir        /sbin
32 %define         _bindir         /usr/sbin
33 %define         _libdir         /%{_lib}
34 %define         _libexecdir     /usr/%{_lib}
35
36 %description
37 A set of commands to use the XFS filesystem, including mkfs.xfs.
38
39 XFS is a high performance journaling filesystem which originated on
40 the SGI IRIX platform. It is completely multi-threaded, can support
41 large files and large filesystems, extended attributes, variable block
42 sizes, is extent based, and makes extensive use of Btrees
43 (directories, extents, free space) to aid both performance and
44 scalability.
45
46 This implementation is on-disk compatible with the IRIX version of
47 XFS.
48
49 %description -l pl
50 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
51
52 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
53 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
54 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
55 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
56 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
57
58 %package devel
59 Summary:        Header files and libraries to develop XFS software
60 Summary(pl):    Pliki nag³ówkowe i biblioteki
61 Group:          Development/Libraries
62 Requires:       libuuid-devel
63 Requires:       %{name} = %{version}-%{release}
64 Obsoletes:      libxfs1-devel
65
66 %description devel
67 Header files and libraries to develop software which operates on XFS
68 filesystems.
69
70 %description devel -l pl
71 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
72 operuj±cego na systemie plików XFS.
73
74 %package static
75 Summary:        Static XFS software libraries
76 Summary(pl):    Biblioteki statyczne do XFS
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static XFS software libraries.
82
83 %description static -l pl
84 Biblioteki statyczne do XFS.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %{?with_dynamic_exe:%patch3 -p1}
92
93 %build
94 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
95 OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
96 export DEBUG OPTIMIZER
97 rm -f aclocal.m4
98 %{__aclocal} -I m4
99 %{__autoconf}
100 %configure \
101         %{!?with_static:--enable-shared-uuid=yes} \
102         %{?with_static:--disable-shared --disable-shared-uuid}
103
104 %{__make} \
105         %{?with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 DIST_ROOT="$RPM_BUILD_ROOT"
111 DIST_INSTALL=`pwd`/install.manifest
112 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
113 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
114 %{?with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
115
116 %{__make} install \
117         DIST_MANIFEST="$DIST_INSTALL"
118 %{__make} install-dev \
119         DIST_MANIFEST="$DIST_INSTALL_DEV"
120
121 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
122         fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
123         handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
124         readlink_by_handle.3; do
125                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
126                 echo ".so path_to_handle.3" \
127                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
128 done
129
130 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
131 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
132
133 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
134          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
135 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
136         $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
137 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
138         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
139 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
140         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
141
142 %{__sed} -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
143         $RPM_BUILD_ROOT%{_libexecdir}/lib{disk,handle,xfs,xlog}.la
144
145 %find_lang %{name}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc README doc/{CHANGES,CREDITS}
156 %attr(755,root,root) %{_sbindir}/*
157 %attr(755,root,root) %{_bindir}/*
158 %{!?with_static:%attr(755,root,root) /%{_lib}/lib*.so.*.*}
159 %{_mandir}/man[185]/*
160
161 %files devel
162 %defattr(644,root,root,755)
163 %{_mandir}/man3/*
164 %{_includedir}/disk
165 %{_includedir}/xfs
166 %if %{without static}
167 %{_libexecdir}/*.la
168 %attr(755,root,root) %{_libexecdir}/*.so
169 %endif
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libexecdir}/*.a
This page took 0.084896 seconds and 4 git commands to generate.