]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- updated to 2.8.11, updated pl.po-update patch
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_with     static          # link statically with \-luuid
4 %bcond_with     dynamic_exe     # link executables dynamically with xfs libs
5 #
6 Summary:        Tools for the XFS filesystem
7 Summary(pl):    Narzêdzia do systemu plików XFS
8 Name:           xfsprogs
9 Version:        2.8.11
10 Release:        1
11 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
12 Group:          Applications/System
13 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
14 # Source0-md5:  fcae4dea0acf79e30d986a38a609be43
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch1:         %{name}-install-sh.patch
17 Patch2:         %{name}-sharedlibs.patch
18 Patch3:         %{name}-pl.po-update.patch
19 Patch4:         %{name}-dynamic_exe.patch
20 Patch5:         %{name}-LDFLAGS.patch
21 URL:            http://oss.sgi.com/projects/xfs/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  bash
25 BuildRequires:  gettext-devel
26 BuildRequires:  libtool
27 BuildRequires:  libuuid-devel
28 %{?with_static:BuildRequires:   libuuid-static}
29 %{?with_static:BuildRequires:   sed >= 4.0}
30 Obsoletes:      libxfs1
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sbindir        /sbin
34 %define         _bindir         /usr/sbin
35 %define         _libdir         /%{_lib}
36 %define         _libexecdir     /usr/%{_lib}
37
38 %description
39 A set of commands to use the XFS filesystem, including mkfs.xfs.
40
41 XFS is a high performance journaling filesystem which originated on
42 the SGI IRIX platform. It is completely multi-threaded, can support
43 large files and large filesystems, extended attributes, variable block
44 sizes, is extent based, and makes extensive use of Btrees
45 (directories, extents, free space) to aid both performance and
46 scalability.
47
48 This implementation is on-disk compatible with the IRIX version of
49 XFS.
50
51 %description -l pl
52 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
53
54 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
55 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
56 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
57 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
58 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
59
60 %package devel
61 Summary:        Header files and libraries to develop XFS software
62 Summary(pl):    Pliki nag³ówkowe i biblioteki
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       libuuid-devel
66 Obsoletes:      libxfs1-devel
67
68 %description devel
69 Header files and libraries to develop software which operates on XFS
70 filesystems.
71
72 %description devel -l pl
73 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
74 operuj±cego na systemie plików XFS.
75
76 %package static
77 Summary:        Static XFS software libraries
78 Summary(pl):    Biblioteki statyczne do XFS
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static XFS software libraries.
84
85 %description static -l pl
86 Biblioteki statyczne do XFS.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93 %patch3 -p1
94 %{?with_dynamic_exe:%patch4 -p1}
95 %patch5 -p1
96
97 %build
98 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
99 OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
100 export DEBUG OPTIMIZER
101 rm -f aclocal.m4
102 %{__aclocal} -I m4
103 %{__autoconf}
104 %configure \
105         %{!?with_static:--enable-shared-uuid=yes} \
106         %{?with_static:--disable-shared --disable-shared-uuid}
107
108 %{__make} \
109         %{?with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 DIST_ROOT="$RPM_BUILD_ROOT"
115 DIST_INSTALL=`pwd`/install.manifest
116 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
117 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
118 %{?with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
119
120 %{__make} install \
121         DIST_MANIFEST="$DIST_INSTALL"
122 %{__make} install-dev \
123         DIST_MANIFEST="$DIST_INSTALL_DEV"
124
125 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
126         fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
127         handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
128         readlink_by_handle.3; do
129                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
130                 echo ".so path_to_handle.3" \
131                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
132 done
133
134 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
135 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
136
137 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
138          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
139 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
140         $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
141 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
142         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
143 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
144         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
145
146 %{__sed} -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
147         $RPM_BUILD_ROOT%{_libexecdir}/lib{disk,handle,xfs,xlog}.la
148
149 %find_lang %{name}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files -f %{name}.lang
158 %defattr(644,root,root,755)
159 %doc README doc/{CHANGES,CREDITS}
160 %attr(755,root,root) %{_sbindir}/*
161 %attr(755,root,root) %{_bindir}/*
162 %{!?with_static:%attr(755,root,root) /%{_lib}/lib*.so.*.*}
163 %{_mandir}/man[185]/*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %{_mandir}/man3/*
168 %{_includedir}/disk
169 %{_includedir}/xfs
170 %if %{without static}
171 %{_libexecdir}/*.la
172 %attr(755,root,root) %{_libexecdir}/*.so
173 %endif
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libexecdir}/*.a
This page took 0.039038 seconds and 4 git commands to generate.