]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- rel2 for ac
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 # _with_static  - link statically with -luuid
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl):    Narzêdzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        2.5.6
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/Release-1.3/cmd_tars/%{name}-%{version}.src.tar.gz
13 # Source0-md5:  4b21a904e5511bd97d87484ba403b120
14 Patch0:         %{name}-miscfix-v2.patch
15 Patch1:         %{name}-install-sh.patch
16 Patch2:         %{name}-sharedlibs.patch
17 URL:            http://oss.sgi.com/projects/xfs/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bash
21 BuildRequires:  libtool
22 BuildRequires:  e2fsprogs-devel
23 %{?_with_static:BuildRequires:  e2fsprogs-static}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25 Obsoletes:      libxfs1
26
27 %define         _sbindir        /sbin
28 %define         _bindir         /usr/sbin
29 %define         _libdir         /lib
30 %define         _libexecdir     /usr/lib
31
32 %description
33 A set of commands to use the XFS filesystem, including mkfs.xfs.
34
35 XFS is a high performance journaling filesystem which originated on
36 the SGI IRIX platform. It is completely multi-threaded, can support
37 large files and large filesystems, extended attributes, variable block
38 sizes, is extent based, and makes extensive use of Btrees
39 (directories, extents, free space) to aid both performance and
40 scalability.
41
42 This implementation is on-disk compatible with the IRIX version of
43 XFS.
44
45 %description -l pl
46 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
47
48 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
49 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
50 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
51 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
52 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
53
54 %package devel
55 Summary:        Header files and libraries to develop XFS software
56 Summary(pl):    Pliki nag³ówkowe i biblioteki
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}
59 Obsoletes:      libxfs1-devel
60
61 %description devel
62 Header files and libraries to develop software which operates on XFS
63 filesystems.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
67 operuj±cego na systemie plików XFS.
68
69 %package static
70 Summary:        Static XFS software libraries
71 Summary(pl):    Biblioteki statyczne do XFS
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 Static XFS software libraries.
77
78 %description static -l pl
79 Biblioteki statyczne do XFS.
80
81 %prep
82 %setup  -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 %build
88 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
89 OPTIMIZER="%{rpmcflags}"
90 export DEBUG OPTIMIZER
91 rm -f aclocal.m4
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %configure \
95         %{!?_with_static:--enable-shared-uuid=yes} \
96         %{?_with_static:--disable-shared --disable-shared-uuid}
97
98 %{__make} \
99         %{?_with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 DIST_ROOT="$RPM_BUILD_ROOT"
105 DIST_INSTALL=`pwd`/install.manifest
106 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
107 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
108 %{?_with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
109
110 %{__make} install \
111         DIST_MANIFEST="$DIST_INSTALL"
112 %{__make} install-dev \
113         DIST_MANIFEST="$DIST_INSTALL_DEV"
114
115 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
116         fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
117         handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
118         readlink_by_handle.3; do
119                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
120                 echo ".so path_to_handle.3" \
121                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
122 done
123
124 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
125 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
126
127 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
128          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
129 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
130         $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
131 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
132         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
133 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
134         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc doc/{CHANGES,CREDITS,README.*}
145 %attr(755,root,root) %{_sbindir}/*
146 %attr(755,root,root) %{_bindir}/*
147 %{!?_with_static:%attr(755,root,root) /lib/lib*.so.*.*}
148 %{_mandir}/man[185]/*
149
150 %files devel
151 %defattr(644,root,root,755)
152 %{_mandir}/man3/*
153 %{_includedir}/disk
154 %{_includedir}/xfs
155 %{!?_with_static:%{_libexecdir}/*.la}
156 %attr(755,root,root) %{_libexecdir}/*.so
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libexecdir}/*.a
This page took 0.234594 seconds and 4 git commands to generate.