]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- up to 3.2.0
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        3.2.0
9 Release:        1
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
13 # Source0-md5:  400047b2f6af87c0345b8f0cc00c13db
14 Source1:        xfs_lsprojid
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch2:         %{name}-sharedlibs.patch
17 Patch3:         %{name}-pl.po-update.patch
18 Patch4:         %{name}-dynamic_exe.patch
19
20 Patch6:         %{name}-repair-tcmalloc.patch
21 Patch7:         %{name}-noquotasync.patch
22 URL:            http://www.xfs.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bash
26 BuildRequires:  gettext-devel
27 BuildRequires:  libblkid-devel
28 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
29 BuildRequires:  libtool
30 BuildRequires:  libuuid-devel
31 BuildRequires:  readline-devel
32 BuildRequires:  rpm >= 4.4.9-56
33 BuildRequires:  rpmbuild(macros) >= 1.402
34 %{?with_tcmalloc:Requires:      libtcmalloc >= 1.8.3-3}
35 Obsoletes:      xfsprogs-initrd
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %if "%{pld_release}" == "ac"
39 # libtool in ac doesn't do the reordering of args properly
40 %define         filterout_ld -Wl,--as-needed
41 %endif
42
43 # libxlog uses symbols from binary that links to libxlog
44 # libxcmd uses ("program") symbol from binary that links to libxcmd
45 %define         skip_post_check_so      libxlog.so.0.0.0        libxcmd.so.0.0.0
46
47 %define         _sbindir        /sbin
48 %define         _bindir         /usr/sbin
49 %define         _libdir         /%{_lib}
50 %define         _libexecdir     /usr/%{_lib}
51
52 %description
53 A set of commands to use the XFS filesystem, including mkfs.xfs.
54
55 XFS is a high performance journaling filesystem which originated on
56 the SGI IRIX platform. It is completely multi-threaded, can support
57 large files and large filesystems, extended attributes, variable block
58 sizes, is extent based, and makes extensive use of Btrees
59 (directories, extents, free space) to aid both performance and
60 scalability.
61
62 This implementation is on-disk compatible with the IRIX version of
63 XFS.
64
65 %description -l pl.UTF-8
66 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
67
68 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
69 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
70 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
71 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
72 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
73
74 %package devel
75 Summary:        Header files and libraries to develop XFS software
76 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       libuuid-devel
80
81 %description devel
82 Header files and libraries to develop software which operates on XFS
83 filesystems.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
87 operującego na systemie plików XFS.
88
89 %package static
90 Summary:        Static XFS software libraries
91 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static XFS software libraries.
97
98 %description static -l pl.UTF-8
99 Biblioteki statyczne do XFS.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch2 -p1
105 %patch3 -p1
106 %patch4 -p1
107
108 %{?with_tcmalloc:%patch6 -p1}
109 %patch7 -p1
110
111 %build
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %configure \
115         --sbindir=%{_bindir}\
116         --enable-gettext \
117         --enable-readline \
118         --enable-blkid \
119         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
120         OPTIMIZER="%{rpmcflags}"
121
122 %{__make} -j1 \
123         V=1
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
128
129 DIST_ROOT=$RPM_BUILD_ROOT
130 DIST_INSTALL=$(pwd)/install.manifest
131 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
132 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
133
134 %{__make} install \
135         DIST_MANIFEST="$DIST_INSTALL"
136 %{__make} install-dev \
137         DIST_MANIFEST="$DIST_INSTALL_DEV"
138
139 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
140
141 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
142          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
143 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxcmd.so.*.*.*) \
144         $RPM_BUILD_ROOT%{_libexecdir}/libxcmd.so
145 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxfs.so.*.*.*) \
146         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
147 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxlog.so.*.*.*) \
148         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
149
150 mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
151 mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
152
153 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
154         $RPM_BUILD_ROOT%{_libexecdir}/lib{handle,xcmd,xfs,xlog}.la
155 %{__sed} -i -e "s| %{_libdir}/libxfs.la | %{_libexecdir}/libxfs.la |" \
156         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.la
157
158 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
159 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
160
161 %find_lang %{name}
162
163 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
164
165 # already in /usr
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{handle,xcmd,xfs,xlog}.so
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc README doc/{CHANGES,CREDITS}
177 %config(noreplace) %verify(not md5 mtime size) /etc/projects
178 %config(noreplace) %verify(not md5 mtime size) /etc/projid
179 %attr(755,root,root) %{_sbindir}/fsck.xfs
180 %attr(755,root,root) %{_sbindir}/mkfs.xfs
181 %attr(755,root,root) %{_sbindir}/xfs_repair
182 %attr(755,root,root) %{_bindir}/xfs_*
183 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
184 %attr(755,root,root) %{_libdir}/libxcmd.so.*.*
185 %attr(755,root,root) %{_libdir}/libxfs.so.*.*
186 %attr(755,root,root) %{_libdir}/libxlog.so.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
188 %attr(755,root,root) %ghost %{_libdir}/libxcmd.so.0
189 %attr(755,root,root) %ghost %{_libdir}/libxfs.so.0
190 %attr(755,root,root) %ghost %{_libdir}/libxlog.so.0
191 %{_mandir}/man5/projects.5*
192 %{_mandir}/man5/projid.5*
193 %{_mandir}/man5/xfs.5*
194 %{_mandir}/man8/fsck.xfs.8*
195 %{_mandir}/man8/mkfs.xfs.8*
196 %{_mandir}/man8/xfs_*.8*
197
198 %files devel
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_libexecdir}/libhandle.so
201 %attr(755,root,root) %{_libexecdir}/libxcmd.so
202 %attr(755,root,root) %{_libexecdir}/libxfs.so
203 %attr(755,root,root) %{_libexecdir}/libxlog.so
204 %{_libexecdir}/libhandle.la
205 %{_libexecdir}/libxcmd.la
206 %{_libexecdir}/libxfs.la
207 %{_libexecdir}/libxlog.la
208 %{_includedir}/xfs
209 %{_mandir}/man3/*handle.3*
210 %{_mandir}/man3/xfsctl.3*
211
212 %files static
213 %defattr(644,root,root,755)
214 %{_libexecdir}/libhandle.a
215 %{_libexecdir}/libxcmd.a
216 %{_libexecdir}/libxfs.a
217 %{_libexecdir}/libxlog.a
This page took 0.042491 seconds and 4 git commands to generate.