]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- updated to 2.7.3
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # link statically with \-luuid
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl):    Narzêdzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        2.7.3
9 Release:        1
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
13 # Source0-md5:  89728c0d84258c94e629bf39e4ba1509
14 Patch0:         %{name}-miscfix-v2.patch
15 Patch1:         %{name}-install-sh.patch
16 Patch2:         %{name}-sharedlibs.patch
17 Patch3:         %{name}-cflags.patch
18 URL:            http://oss.sgi.com/projects/xfs/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bash
22 BuildRequires:  gettext-devel
23 BuildRequires:  libtool
24 BuildRequires:  libuuid-devel
25 %{?with_static:BuildRequires:   libuuid-static}
26 %{?with_static:BuildRequires:   sed >= 4.0}
27 Obsoletes:      libxfs1
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _sbindir        /sbin
31 %define         _bindir         /usr/sbin
32 %define         _libdir         /%{_lib}
33 %define         _libexecdir     /usr/%{_lib}
34
35 %description
36 A set of commands to use the XFS filesystem, including mkfs.xfs.
37
38 XFS is a high performance journaling filesystem which originated on
39 the SGI IRIX platform. It is completely multi-threaded, can support
40 large files and large filesystems, extended attributes, variable block
41 sizes, is extent based, and makes extensive use of Btrees
42 (directories, extents, free space) to aid both performance and
43 scalability.
44
45 This implementation is on-disk compatible with the IRIX version of
46 XFS.
47
48 %description -l pl
49 Zbiór komend do u¿ytku z systemem plików XFS, w³±czaj±c w to mkfs.xfs.
50
51 XFS jest wysoko wydajnym systemem plików z kronik±, który oryginalnie
52 by³ u¿ywany na platformie SGI IRIX. Jest to w pe³ni wielow±tkowy,
53 obs³uguj±cy wielkie pliki oraz wielkie systemy, o rozszerzonych
54 atrybutach, zmiennych wielko¶ciach bloków, mocno wykorzystuj±cy
55 B-drzewa by uzyskaæ wysok± wydajno¶æ oraz skalowalno¶æ.
56
57 %package devel
58 Summary:        Header files and libraries to develop XFS software
59 Summary(pl):    Pliki nag³ówkowe i biblioteki
60 Group:          Development/Libraries
61 Requires:       libuuid-devel
62 Requires:       %{name} = %{version}-%{release}
63 Obsoletes:      libxfs1-devel
64
65 %description devel
66 Header files and libraries to develop software which operates on XFS
67 filesystems.
68
69 %description devel -l pl
70 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
71 operuj±cego na systemie plików XFS.
72
73 %package static
74 Summary:        Static XFS software libraries
75 Summary(pl):    Biblioteki statyczne do XFS
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static XFS software libraries.
81
82 %description static -l pl
83 Biblioteki statyczne do XFS.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90 %patch3 -p1
91
92 %build
93 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"
94 OPTIMIZER="%{rpmcflags}"
95 export DEBUG OPTIMIZER
96 rm -f aclocal.m4
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %configure \
100         %{!?with_static:--enable-shared-uuid=yes} \
101         %{?with_static:--disable-shared --disable-shared-uuid}
102
103 %{__make} \
104         %{?with_static:LTLINK='$(LIBTOOL) --mode=link %{__cc} -all-static' LDFLAGS=-static}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 DIST_ROOT="$RPM_BUILD_ROOT"
110 DIST_INSTALL=`pwd`/install.manifest
111 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
112 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
113 %{?with_static:sed -i -e 's/\.lai/.la/' include/buildmacros}
114
115 %{__make} install \
116         DIST_MANIFEST="$DIST_INSTALL"
117 %{__make} install-dev \
118         DIST_MANIFEST="$DIST_INSTALL_DEV"
119
120 for man in attr_list_by_handle.3 attr_multi_by_handle.3 \
121         fd_to_handle.3 free_handle.3 fssetdm_by_handle.3 \
122         handle_to_fshandle.3 open_by_handle.3 path_to_fshandle.3 \
123         readlink_by_handle.3; do
124                 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/$man
125                 echo ".so path_to_handle.3" \
126                         > $RPM_BUILD_ROOT%{_mandir}/man3/$man
127 done
128
129 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
130 echo ".so xfs_growfs.8" > $RPM_BUILD_ROOT%{_mandir}/man8/xfs_info.8
131
132 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libhandle.so.*.*.*) \
133          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
134 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libdisk.so.*.*.*) \
135         $RPM_BUILD_ROOT%{_libexecdir}/libdisk.so
136 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxfs.so.*.*.*) \
137         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
138 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir}; echo libxlog.so.*.*.*) \
139         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
140
141 %{__sed} -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
142         $RPM_BUILD_ROOT%{_libexecdir}/lib{disk,handle,xfs,xlog}.la
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc README doc/{CHANGES,CREDITS}
153 %attr(755,root,root) %{_sbindir}/*
154 %attr(755,root,root) %{_bindir}/*
155 %{!?with_static:%attr(755,root,root) /%{_lib}/lib*.so.*.*}
156 %{_mandir}/man[185]/*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %{_mandir}/man3/*
161 %{_includedir}/disk
162 %{_includedir}/xfs
163 %if %{without static}
164 %{_libexecdir}/*.la
165 %attr(755,root,root) %{_libexecdir}/*.so
166 %endif
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libexecdir}/*.a
This page took 0.107717 seconds and 3 git commands to generate.