]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- don't abuse _libexecdir and _bindir macros; buildsystem already handles /usr vs...
[packages/xfsprogs.git] / xfsprogs.spec
1 Summary:        Tools for the XFS filesystem
2 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
3 Name:           xfsprogs
4 Version:        4.15.0
5 Release:        2
6 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
7 Group:          Applications/System
8 Source0:        https://kernel.org/pub/linux/utils/fs/xfs/xfsprogs/%{name}-%{version}.tar.gz
9 # Source0-md5:  62096a4a7487bf3b24a6b67be99402f8
10 Source1:        xfs_lsprojid
11 Patch0:         %{name}-miscfix-v2.patch
12 Patch1:         %{name}-pl.po-update.patch
13 URL:            http://www.xfs.org/
14 BuildRequires:  autoconf >= 2.50
15 BuildRequires:  automake
16 BuildRequires:  bash
17 BuildRequires:  gettext-tools
18 BuildRequires:  glibc-static
19 BuildRequires:  libblkid-devel
20 BuildRequires:  libtool
21 BuildRequires:  libuuid-devel
22 BuildRequires:  libuuid-static
23 BuildRequires:  readline-devel
24 BuildRequires:  rpm >= 4.4.9-56
25 BuildRequires:  rpmbuild(macros) >= 1.402
26 Requires:       systemd-units >= 38
27 Obsoletes:      xfsprogs-initrd
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %if "%{pld_release}" == "ac"
31 # libtool in ac doesn't do the reordering of args properly
32 %define         filterout_ld -Wl,--as-needed
33 %endif
34
35 %description
36 A set of commands to use the XFS filesystem, including mkfs.xfs.
37
38 XFS is a high performance journaling filesystem which originated on
39 the SGI IRIX platform. It is completely multi-threaded, can support
40 large files and large filesystems, extended attributes, variable block
41 sizes, is extent based, and makes extensive use of Btrees
42 (directories, extents, free space) to aid both performance and
43 scalability.
44
45 This implementation is on-disk compatible with the IRIX version of
46 XFS.
47
48 %description -l pl.UTF-8
49 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
50
51 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
52 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
53 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
54 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
55 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
56
57 %package devel
58 Summary:        Header files and libraries to develop XFS software
59 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       libuuid-devel
63
64 %description devel
65 Header files and libraries to develop software which operates on XFS
66 filesystems.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
70 operującego na systemie plików XFS.
71
72 %package static
73 Summary:        Static XFS software libraries
74 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static XFS software libraries.
80
81 %description static -l pl.UTF-8
82 Biblioteki statyczne do XFS.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88
89 %build
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %configure \
93         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
94         OPTIMIZER="%{rpmcflags}" \
95         --enable-blkid \
96         --enable-gettext \
97         --enable-readline
98
99 %{__make} -j1 \
100         V=1
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT/etc/cron.d
105
106 DIST_ROOT=$RPM_BUILD_ROOT
107 DIST_INSTALL=$(pwd)/install.manifest
108 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
109 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
110
111 %{__make} install \
112         DIST_MANIFEST="$DIST_INSTALL"
113 %{__make} install-dev \
114         DIST_MANIFEST="$DIST_INSTALL_DEV"
115
116 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/xfs_lsprojid
117
118 # adjust symlink to point to actual library, not libhandle.so symlink, which we remove afterwards
119 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libhandle.so.*.*.*) \
120          $RPM_BUILD_ROOT%{_libdir}/libhandle.so
121 # adjust library path used at link time
122 %{__sed} -i -e "s|libdir='/%{_lib}'|libdir='%{_libdir}'|" \
123         $RPM_BUILD_ROOT%{_libdir}/libhandle.la
124 # already in /usr
125 %{__rm} $RPM_BUILD_ROOT/%{_lib}/libhandle.{so,la,a}
126
127 # install cron file
128 %{__mv} $RPM_BUILD_ROOT{%{_libdir}/%{name}/xfs_scrub_all.cron,/etc/cron.d/xfs_scrub_all}
129
130 # (config file paths are specified in libfrog/projects.c)
131 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
132 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
133
134 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
135
136 %find_lang %{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 /sbin/ldconfig
143 %systemd_reload
144
145 %postun -p /sbin/ldconfig
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc README doc/{CHANGES,CREDITS}
150 %config(noreplace) %verify(not md5 mtime size) /etc/projects
151 %config(noreplace) %verify(not md5 mtime size) /etc/projid
152 %attr(755,root,root) /sbin/fsck.xfs
153 %attr(755,root,root) /sbin/mkfs.xfs
154 %attr(755,root,root) /sbin/xfs_scrub
155 %attr(755,root,root) /sbin/xfs_scrub_all
156 %attr(755,root,root) /sbin/xfs_repair
157 %attr(755,root,root) %{_sbindir}/xfs_*
158 %attr(755,root,root) /%{_lib}/libhandle.so.*.*
159 %attr(755,root,root) %ghost /%{_lib}/libhandle.so.1
160 %dir %{_libdir}/%{name}
161 %attr(755,root,root) %{_libdir}/%{name}/xfs_scrub_fail
162 # [36960.754044] XFS (dm-0): EXPERIMENTAL online scrub feature in use. Use at your own risk!
163 # so don't enable these by default
164 #%{systemdunitdir}/xfs_scrub@.service
165 #%{systemdunitdir}/xfs_scrub_all.service
166 #%{systemdunitdir}/xfs_scrub_all.timer
167 #%{systemdunitdir}/xfs_scrub_fail@.service
168 #%config(noreplace) %verify(not md5 mtime size) /etc/cron.d/xfs_scrub_all
169 %{_mandir}/man5/projects.5*
170 %{_mandir}/man5/projid.5*
171 %{_mandir}/man5/xfs.5*
172 %{_mandir}/man8/fsck.xfs.8*
173 %{_mandir}/man8/mkfs.xfs.8*
174 %{_mandir}/man8/xfs_*.8*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libhandle.so
179 %{_libdir}/libhandle.la
180 %{_includedir}/xfs
181 %{_mandir}/man2/ioctl_xfs_scrub_metadata.2*
182 %{_mandir}/man3/*handle.3*
183 %{_mandir}/man3/xfsctl.3*
184
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libhandle.a
This page took 0.039495 seconds and 3 git commands to generate.