]> git.pld-linux.org Git - packages/xfsprogs.git/blob - xfsprogs.spec
- drop initrd stuff
[packages/xfsprogs.git] / xfsprogs.spec
1 #
2 # Conditional build:
3 %bcond_without  tcmalloc        # don't use tcmalloc
4 #
5 Summary:        Tools for the XFS filesystem
6 Summary(pl.UTF-8):      Narzędzia do systemu plików XFS
7 Name:           xfsprogs
8 Version:        3.1.11
9 Release:        2
10 License:        LGPL v2.1 (libhandle), GPL v2 (the rest)
11 Group:          Applications/System
12 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
13 # Source0-md5:  de9f1f45026c2f4e0776058d429ff4b6
14 Source1:        xfs_lsprojid
15 Patch0:         %{name}-miscfix-v2.patch
16 Patch2:         %{name}-sharedlibs.patch
17 Patch3:         %{name}-pl.po-update.patch
18 Patch4:         %{name}-dynamic_exe.patch
19 Patch5:         %{name}-diet.patch
20 Patch6:         %{name}-repair-tcmalloc.patch
21 Patch7:         %{name}-noquotasync.patch
22 URL:            http://www.xfs.org/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  bash
26 BuildRequires:  gettext-devel
27 BuildRequires:  libblkid-devel
28 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
29 BuildRequires:  libtool
30 BuildRequires:  libuuid-devel
31 BuildRequires:  readline-devel
32 BuildRequires:  rpm >= 4.4.9-56
33 BuildRequires:  rpmbuild(macros) >= 1.402
34 %{?with_tcmalloc:Requires:      libtcmalloc >= 1.8.3-3}
35 Obsoletes:      xfsprogs-initrd
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %if "%{pld_release}" == "ac"
39 # libtool in ac doesn't do the reordering of args properly
40 %define         filterout_ld -Wl,--as-needed
41 %endif
42
43 # libxlog uses symbols from binary that links to libxlog
44 # libxcmd uses ("program") symbol from binary that links to libxcmd
45 %define         skip_post_check_so      libxlog.so.0.0.0        libxcmd.so.0.0.0
46
47 %define         _sbindir        /sbin
48 %define         _bindir         /usr/sbin
49 %define         _libdir         /%{_lib}
50 %define         _libexecdir     /usr/%{_lib}
51 # for some reason known only to rpm there must be "\\|" not "\|" here
52 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
53 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
54
55 %description
56 A set of commands to use the XFS filesystem, including mkfs.xfs.
57
58 XFS is a high performance journaling filesystem which originated on
59 the SGI IRIX platform. It is completely multi-threaded, can support
60 large files and large filesystems, extended attributes, variable block
61 sizes, is extent based, and makes extensive use of Btrees
62 (directories, extents, free space) to aid both performance and
63 scalability.
64
65 This implementation is on-disk compatible with the IRIX version of
66 XFS.
67
68 %description -l pl.UTF-8
69 Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
70
71 XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
72 był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
73 obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
74 atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
75 B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
76
77 %package devel
78 Summary:        Header files and libraries to develop XFS software
79 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       libuuid-devel
83
84 %description devel
85 Header files and libraries to develop software which operates on XFS
86 filesystems.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
90 operującego na systemie plików XFS.
91
92 %package static
93 Summary:        Static XFS software libraries
94 Summary(pl.UTF-8):      Biblioteki statyczne do XFS
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static XFS software libraries.
100
101 %description static -l pl.UTF-8
102 Biblioteki statyczne do XFS.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch2 -p1
108 %patch3 -p1
109 %patch4 -p1
110 %patch5 -p1
111 %{?with_tcmalloc:%patch6 -p1}
112 %patch7 -p1
113
114 %build
115 %{__aclocal} -I m4
116 %{__autoconf}
117 %configure \
118         --sbindir=%{_bindir}\
119         --enable-gettext \
120         --enable-readline \
121         --enable-blkid \
122         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
123         OPTIMIZER="%{rpmcflags}"
124
125 %{__make} -j1 \
126         V=1
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
131
132 DIST_ROOT=$RPM_BUILD_ROOT
133 DIST_INSTALL=$(pwd)/install.manifest
134 DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
135 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
136
137 %{__make} install \
138         DIST_MANIFEST="$DIST_INSTALL"
139 %{__make} install-dev \
140         DIST_MANIFEST="$DIST_INSTALL_DEV"
141
142 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
143
144 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
145          $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
146 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxcmd.so.*.*.*) \
147         $RPM_BUILD_ROOT%{_libexecdir}/libxcmd.so
148 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxfs.so.*.*.*) \
149         $RPM_BUILD_ROOT%{_libexecdir}/libxfs.so
150 ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libxlog.so.*.*.*) \
151         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.so
152
153 mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
154 mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
155
156 %{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
157         $RPM_BUILD_ROOT%{_libexecdir}/lib{handle,xcmd,xfs,xlog}.la
158 %{__sed} -i -e "s| %{_libdir}/libxfs.la | %{_libexecdir}/libxfs.la |" \
159         $RPM_BUILD_ROOT%{_libexecdir}/libxlog.la
160
161 echo "#10:/mnt/ftp/roman"  >> $RPM_BUILD_ROOT/etc/projects
162 echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
163
164 %find_lang %{name}
165
166 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
167
168 # already in /usr
169 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib{handle,xcmd,xfs,xlog}.so
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc README doc/{CHANGES,CREDITS}
180 %config(noreplace) %verify(not md5 mtime size) /etc/projects
181 %config(noreplace) %verify(not md5 mtime size) /etc/projid
182 %attr(755,root,root) %{_sbindir}/fsck.xfs
183 %attr(755,root,root) %{_sbindir}/mkfs.xfs
184 %attr(755,root,root) %{_sbindir}/xfs_repair
185 %attr(755,root,root) %{_bindir}/xfs_*
186 %attr(755,root,root) %{_libdir}/libhandle.so.*.*
187 %attr(755,root,root) %{_libdir}/libxcmd.so.*.*
188 %attr(755,root,root) %{_libdir}/libxfs.so.*.*
189 %attr(755,root,root) %{_libdir}/libxlog.so.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
191 %attr(755,root,root) %ghost %{_libdir}/libxcmd.so.0
192 %attr(755,root,root) %ghost %{_libdir}/libxfs.so.0
193 %attr(755,root,root) %ghost %{_libdir}/libxlog.so.0
194 %{_mandir}/man5/projects.5*
195 %{_mandir}/man5/projid.5*
196 %{_mandir}/man5/xfs.5*
197 %{_mandir}/man8/fsck.xfs.8*
198 %{_mandir}/man8/mkfs.xfs.8*
199 %{_mandir}/man8/xfs_*.8*
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libexecdir}/libhandle.so
204 %attr(755,root,root) %{_libexecdir}/libxcmd.so
205 %attr(755,root,root) %{_libexecdir}/libxfs.so
206 %attr(755,root,root) %{_libexecdir}/libxlog.so
207 %{_libexecdir}/libhandle.la
208 %{_libexecdir}/libxcmd.la
209 %{_libexecdir}/libxfs.la
210 %{_libexecdir}/libxlog.la
211 %{_includedir}/xfs
212 %{_mandir}/man3/*handle.3*
213 %{_mandir}/man3/xfsctl.3*
214
215 %files static
216 %defattr(644,root,root,755)
217 %{_libexecdir}/libhandle.a
218 %{_libexecdir}/libxcmd.a
219 %{_libexecdir}/libxfs.a
220 %{_libexecdir}/libxlog.a
This page took 0.082514 seconds and 3 git commands to generate.