]> git.pld-linux.org Git - packages/xfsprogs.git/blame - xfsprogs.spec
- BR static libs for xfs_copy
[packages/xfsprogs.git] / xfsprogs.spec
CommitLineData
00d1530a
JR
1#
2# Conditional build:
4a867e5e 3%bcond_without tcmalloc # don't use tcmalloc
d9432d77
JR
4
5%ifarch x32
6%undefine with_tcmalloc
7%endif
8
80ded214 9Summary: Tools for the XFS filesystem
809af116 10Summary(pl.UTF-8): Narzędzia do systemu plików XFS
80ded214 11Name: xfsprogs
661ed87b 12Version: 3.2.3
7f3b3fd0 13Release: 2
636af8bd 14License: LGPL v2.1 (libhandle), GPL v2 (the rest)
80ded214 15Group: Applications/System
4ede93fd 16Source0: ftp://linux-xfs.sgi.com/projects/xfs/cmd_tars/%{name}-%{version}.tar.gz
661ed87b 17# Source0-md5: 9f383e36682709e62b12c125e5d8b895
a32e9a39 18Source1: xfs_lsprojid
bc92c0b0 19Patch0: %{name}-miscfix-v2.patch
8e06f9de 20Patch1: %{name}-pl.po-update.patch
661ed87b 21Patch2: %{name}-noquotasync.patch
51a52578 22URL: http://www.xfs.org/
80ded214 23BuildRequires: autoconf
1c0f6863 24BuildRequires: automake
cb58e4a3 25BuildRequires: bash
7fb2d2e7 26BuildRequires: gettext-tools
7f3b3fd0 27BuildRequires: glibc-static
51a52578 28BuildRequires: libblkid-devel
4a867e5e 29%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
92a53cbb 30BuildRequires: libtool
a5769371 31BuildRequires: libuuid-devel
7f3b3fd0 32BuildRequires: libuuid-static
99229502 33BuildRequires: readline-devel
dec839eb 34BuildRequires: rpm >= 4.4.9-56
9656c3b9 35BuildRequires: rpmbuild(macros) >= 1.402
727e5a6d 36%{?with_tcmalloc:Requires: libtcmalloc >= 1.8.3-3}
7c029ef7 37Obsoletes: xfsprogs-initrd
c826f244 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80ded214 39
dec839eb
ER
40%if "%{pld_release}" == "ac"
41# libtool in ac doesn't do the reordering of args properly
42%define filterout_ld -Wl,--as-needed
43%endif
44
b087bbdd
JR
45%define _sbindir /sbin
46%define _bindir /usr/sbin
a19d7677
JK
47%define _libdir /%{_lib}
48%define _libexecdir /usr/%{_lib}
b087bbdd 49
80ded214
AM
50%description
51A set of commands to use the XFS filesystem, including mkfs.xfs.
52
53XFS is a high performance journaling filesystem which originated on
54the SGI IRIX platform. It is completely multi-threaded, can support
55large files and large filesystems, extended attributes, variable block
56sizes, is extent based, and makes extensive use of Btrees
57(directories, extents, free space) to aid both performance and
58scalability.
59
60This implementation is on-disk compatible with the IRIX version of
61XFS.
62
ddc220a9
JR
63%description -l pl.UTF-8
64Zbiór komend do użytku z systemem plików XFS, włączając w to mkfs.xfs.
80ded214 65
ddc220a9
JR
66XFS jest wysoko wydajnym systemem plików z kroniką, który oryginalnie
67był używany na platformie SGI IRIX. Jest to w pełni wielowątkowy,
68obsługujący wielkie pliki oraz wielkie systemy, o rozszerzonych
69atrybutach, zmiennych wielkościach bloków, mocno wykorzystujący
70B-drzewa by uzyskać wysoką wydajność oraz skalowalność.
80ded214
AM
71
72%package devel
73Summary: Header files and libraries to develop XFS software
809af116 74Summary(pl.UTF-8): Pliki nagłówkowe i biblioteki
80ded214 75Group: Development/Libraries
8b4647b2 76Requires: %{name} = %{version}-%{release}
2528905a 77Requires: libuuid-devel
80ded214
AM
78
79%description devel
80Header files and libraries to develop software which operates on XFS
81filesystems.
82
ddc220a9
JR
83%description devel -l pl.UTF-8
84Pliki nagłówkowe i biblioteki potrzebne do rozwoju oprogramowania
85operującego na systemie plików XFS.
80ded214 86
1c0f6863 87%package static
88Summary: Static XFS software libraries
809af116 89Summary(pl.UTF-8): Biblioteki statyczne do XFS
1c0f6863 90Group: Development/Libraries
8b4647b2 91Requires: %{name}-devel = %{version}-%{release}
1c0f6863 92
93%description static
94Static XFS software libraries.
95
ddc220a9 96%description static -l pl.UTF-8
1c0f6863 97Biblioteki statyczne do XFS.
98
80ded214 99%prep
600886d5 100%setup -q
80ded214 101%patch0 -p1
3d585810 102#%patch1 -p1
661ed87b 103%patch2 -p1
4ede93fd 104
80ded214 105%build
ff9c0a4e 106%{__aclocal} -I m4
551b0d1f 107%{__autoconf}
1c0f6863 108%configure \
a084b099 109 --sbindir=%{_bindir}\
4ede93fd
AM
110 --enable-gettext \
111 --enable-readline \
528ce8b7 112 --enable-blkid \
0c1d4bf9 113 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
4ede93fd 114 OPTIMIZER="%{rpmcflags}"
00d1530a 115
03dcab3f
JB
116%{__make} -j1 \
117 V=1
80ded214
AM
118
119%install
120rm -rf $RPM_BUILD_ROOT
0efa133e 121install -d $RPM_BUILD_ROOT{%{_libexecdir},/etc}
df004a70 122
9656c3b9
ER
123DIST_ROOT=$RPM_BUILD_ROOT
124DIST_INSTALL=$(pwd)/install.manifest
125DIST_INSTALL_DEV=$(pwd)/install-dev.manifest
59aa30e8 126export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
ff9c0a4e
JB
127
128%{__make} install \
129 DIST_MANIFEST="$DIST_INSTALL"
130%{__make} install-dev \
131 DIST_MANIFEST="$DIST_INSTALL_DEV"
80ded214 132
a32e9a39
AM
133install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/xfs_lsprojid
134
9656c3b9 135ln -sf %{_libdir}/$(basename $RPM_BUILD_ROOT%{_libdir}/libhandle.so.*.*.*) \
ff9c0a4e 136 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.so
cb190f67 137
51a52578
AM
138mv $RPM_BUILD_ROOT%{_libdir}/lib*.la $RPM_BUILD_ROOT%{_libexecdir}
139mv $RPM_BUILD_ROOT%{_libdir}/lib*.a $RPM_BUILD_ROOT%{_libexecdir}
140
4ede93fd 141%{__sed} -i -e "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
8e06f9de 142 $RPM_BUILD_ROOT%{_libexecdir}/libhandle.la
b756248b 143
6e781c10
PG
144echo "#10:/mnt/ftp/roman" >> $RPM_BUILD_ROOT/etc/projects
145echo "#ftproman:10" >> $RPM_BUILD_ROOT/etc/projid
146
01483858
JB
147%find_lang %{name}
148
03dcab3f 149%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
5e040522 150
9656c3b9 151# already in /usr
8e06f9de 152%{__rm} $RPM_BUILD_ROOT%{_libdir}/libhandle.so
9656c3b9 153
80ded214
AM
154%clean
155rm -rf $RPM_BUILD_ROOT
156
c5b3782d 157%post -p /sbin/ldconfig
c7083593
JR
158%postun -p /sbin/ldconfig
159
01483858 160%files -f %{name}.lang
80ded214 161%defattr(644,root,root,755)
636af8bd 162%doc README doc/{CHANGES,CREDITS}
6e781c10
PG
163%config(noreplace) %verify(not md5 mtime size) /etc/projects
164%config(noreplace) %verify(not md5 mtime size) /etc/projid
0c1d4bf9
JB
165%attr(755,root,root) %{_sbindir}/fsck.xfs
166%attr(755,root,root) %{_sbindir}/mkfs.xfs
167%attr(755,root,root) %{_sbindir}/xfs_repair
168%attr(755,root,root) %{_bindir}/xfs_*
9656c3b9 169%attr(755,root,root) %{_libdir}/libhandle.so.*.*
9656c3b9 170%attr(755,root,root) %ghost %{_libdir}/libhandle.so.1
275db5b4
AM
171%{_mandir}/man5/projects.5*
172%{_mandir}/man5/projid.5*
0c1d4bf9
JB
173%{_mandir}/man5/xfs.5*
174%{_mandir}/man8/fsck.xfs.8*
175%{_mandir}/man8/mkfs.xfs.8*
176%{_mandir}/man8/xfs_*.8*
80ded214
AM
177
178%files devel
179%defattr(644,root,root,755)
0c1d4bf9 180%attr(755,root,root) %{_libexecdir}/libhandle.so
0c1d4bf9 181%{_libexecdir}/libhandle.la
353bc53d 182%{_includedir}/xfs
0c1d4bf9
JB
183%{_mandir}/man3/*handle.3*
184%{_mandir}/man3/xfsctl.3*
1c0f6863 185
186%files static
187%defattr(644,root,root,755)
0c1d4bf9 188%{_libexecdir}/libhandle.a
This page took 0.095844 seconds and 4 git commands to generate.