]> git.pld-linux.org Git - packages/xen.git/commitdiff
Trying update to 4.4.0; nfy
authorMariusz Mazur <mmazur@axeos.com>
Wed, 12 Mar 2014 15:39:11 +0000 (15:39 +0000)
committerMariusz Mazur <mmazur@axeos.com>
Wed, 12 Mar 2014 15:39:11 +0000 (15:39 +0000)
xen-doc.patch
xen-initscript.patch [deleted file]
xen-paths.patch
xen-qemu.patch
xen-xattr.patch [deleted file]
xen.spec

index 5d021d710e4f96c46633419e0cf66cc154731624..509440b27b7b8d77e81314230f44f53e6357a114 100644 (file)
@@ -1,14 +1,3 @@
---- xen-4.2.2/tools/qemu-xen/qemu-options.hx~  2013-04-06 01:39:54.000000000 +0200
-+++ xen-4.2.2/tools/qemu-xen/qemu-options.hx   2013-07-22 14:17:13.970296816 +0200
-@@ -1799,7 +1799,7 @@
- devices.
- Syntax for specifying a sheepdog device
--@table @list
-+@table @code
- ``sheepdog:<vdiname>''
- ``sheepdog:<vdiname>:<snapid>''
 --- xen-4.2.2/tools/qemu-xen/scripts/texi2pod.pl~      2013-04-06 01:39:54.000000000 +0200
 +++ xen-4.2.2/tools/qemu-xen/scripts/texi2pod.pl       2013-07-22 14:27:37.959914694 +0200
 @@ -339,6 +339,8 @@
diff --git a/xen-initscript.patch b/xen-initscript.patch
deleted file mode 100644 (file)
index e01384e..0000000
+++ /dev/null
@@ -1,138 +0,0 @@
---- xen-4.1.0/tools/misc/xend.orig     2010-02-02 20:43:01.000000000 +0000
-+++ xen-4.1.0/tools/misc/xend  2010-02-02 21:16:13.000000000 +0000
-@@ -8,103 +8,16 @@
- """Xen management daemon.
-    Provides console server and HTTP management api.
--   Run:
--   xend start
--
--   Restart:
--   xend restart
--
--   The daemon is stopped with:
--   xend stop
--
-    The daemon should reconnect to device control interfaces
-    and recover its state when restarted.
--   On Solaris, the daemons are SMF managed, and you should not attempt
--   to start xend by hand.
- """
--import fcntl
--import glob
--import os
--import os.path
- import sys
--import socket
--import signal
--import time
--import commands
--
- from xen.xend.server import SrvDaemon
--class CheckError(ValueError):
--    pass
--
--def hline():
--    print >>sys.stderr, "*" * 70
--
--def msg(message):
--    print >>sys.stderr, "*" * 3, message
--
--def check_logging():
--    """Check python logging is installed and raise an error if not.
--    Logging is standard from Python 2.3 on.
--    """
--    try:
--        import logging
--    except ImportError:
--        hline()
--        msg("Python logging is not installed.")
--        msg("Use 'make install-logging' at the xen root to install.")
--        msg("")
--        msg("Alternatively download and install from")
--        msg("http://www.red-dove.com/python_logging.html")
--        hline()
--        raise CheckError("logging is not installed")
--
--def check_user():
--    """Check that the effective user id is 0 (root).
--    """
--    if os.geteuid() != 0:
--        hline()
--        msg("Xend must be run as root.")
--        hline()
--        raise CheckError("invalid user")
--
--def start_daemon(daemon, *args):
--    if os.fork() == 0:
--        os.execvp(daemon, (daemon,) + args)
--
--def start_blktapctrl():
--    start_daemon("blktapctrl", "")
--
- def main():
--    try:
--        check_logging()
--        check_user()
--    except CheckError:
--        sys.exit(1)
--    
-     daemon = SrvDaemon.instance()
--    if not sys.argv[1:]:
--        print 'usage: %s {start|stop|reload|restart}' % sys.argv[0]
--    elif sys.argv[1] == 'start':
--        if os.uname()[0] != "SunOS":
--            start_blktapctrl()
--        return daemon.start()
--    elif sys.argv[1] == 'trace_start':
--        start_blktapctrl()
--        return daemon.start(trace=1)
--    elif sys.argv[1] == 'stop':
--        return daemon.stop()
--    elif sys.argv[1] == 'reload':
--        return daemon.reloadConfig()
--    elif sys.argv[1] == 'restart':
--        start_blktapctrl()
--        return daemon.stop() or daemon.start()
--    elif sys.argv[1] == 'status':
--        return daemon.status()
--    else:
--        print 'not an option:', sys.argv[1]
--    return 1
-+    return daemon.start()
- if __name__ == '__main__':
-     sys.exit(main())
-diff -up xen-3.4.0/tools/python/xen/xend/osdep.py.fix xen-3.4.0/tools/python/xen/xend/osdep.py
---- xen-3.4.0/tools/python/xen/xend/osdep.py.fix       2009-05-18 13:05:38.000000000 +0200
-+++ xen-3.4.0/tools/python/xen/xend/osdep.py   2009-05-20 15:39:18.000000000 +0200
-@@ -27,7 +27,7 @@ _scripts_dir = {
- _xend_autorestart = {
-     "NetBSD": True,
--    "Linux": True,
-+    "Linux": False,
-     "SunOS": False,
- }
-diff -up xen-3.4.0/tools/python/xen/xend/server/SrvDaemon.py.fix xen-3.4.0/tools/python/xen/xend/server/SrvDaemon.py
---- xen-3.4.0/tools/python/xen/xend/server/SrvDaemon.py.fix    2009-05-18 13:05:38.000000000 +0200
-+++ xen-3.4.0/tools/python/xen/xend/server/SrvDaemon.py        2009-05-20 15:39:18.000000000 +0200
-@@ -110,7 +110,14 @@ class Daemon:
-         # Fork, this allows the group leader to exit,
-         # which means the child can never again regain control of the
-         # terminal
--        if os.fork():
-+        child = os.fork()
-+        if child:
-+            if not osdep.xend_autorestart:
-+                pidfile = open(XEND_PID_FILE, 'w')
-+                try:
-+                    pidfile.write(str(child))
-+                finally:
-+                    pidfile.close()
-             os._exit(0)
-         # Detach from standard file descriptors, and redirect them to
index 919d00079d06853cff20b83a4769bfe40940d12f..662488bc16c3cea55e1d8ef5ceb0ad25f8906a7c 100644 (file)
@@ -1,9 +1,9 @@
---- xen-4.3.0/tools/Makefile.orig      2013-08-24 06:55:14.928431689 +0200
-+++ xen-4.3.0/tools/Makefile   2013-08-24 09:11:37.931421617 +0200
+--- xen-4.4.0/tools/Makefile~  2014-03-12 14:39:28.000000000 +0000
++++ xen-4.4.0/tools/Makefile   2014-03-12 14:41:53.427783318 +0000
 @@ -188,7 +188,7 @@
-       fi; \
        cd qemu-xen-dir; \
        $$source/configure --enable-xen --target-list=i386-softmmu \
+               $(QEMU_XEN_ENABLE_DEBUG) \
 -              --prefix=$(PREFIX) \
 +              --prefix=$(PREFIX) --libexecdir=$(LIBEXEC) \
                --source-path=$$source \
index dbbab2a5aa5fe29f0da680ab0bd7e3fa1f8110a2..a163389b766ba3176b6d345801c667930f01f79a 100644 (file)
@@ -23,12 +23,12 @@ qemu-xen/configure: use -O2 for tests to eliminate fortify warnings (-Werror is
              aa="no"
              `$sdl_config --static-libs 2>/dev/null | grep \\\-laa > /dev/null` && aa="yes"
              sdl_static_libs=`$sdl_config --static-libs 2>/dev/null`
---- xen-4.3.0/tools/qemu-xen/configure.orig    2013-08-22 20:01:19.903704095 +0200
-+++ xen-4.3.0/tools/qemu-xen/configure 2013-08-22 20:35:51.880283814 +0200
-@@ -270,10 +270,6 @@
+--- xen-4.4.0/tools/qemu-xen/configure~        2014-02-05 16:59:14.000000000 +0000
++++ xen-4.4.0/tools/qemu-xen/configure 2014-03-12 13:53:34.947877721 +0000
+@@ -342,10 +342,6 @@
  QEMU_CFLAGS="-Wstrict-prototypes -Wredundant-decls $QEMU_CFLAGS"
  QEMU_CFLAGS="-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $QEMU_CFLAGS"
- QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/fpu"
+ QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/include"
 -if test "$debug_info" = "yes"; then
 -    CFLAGS="-g $CFLAGS"
 -    LDFLAGS="-g $LDFLAGS"
@@ -36,12 +36,12 @@ qemu-xen/configure: use -O2 for tests to eliminate fortify warnings (-Werror is
  
  # make source path absolute
  source_path=`cd "$source_path"; pwd`
-@@ -3067,7 +3063,7 @@
- # After here, no more $cc or $ld runs
- if test "$debug" = "no" ; then
+@@ -3450,7 +3446,7 @@
+   CFLAGS="-fprofile-arcs -ftest-coverage -g $CFLAGS"
+   LDFLAGS="-fprofile-arcs -ftest-coverage $LDFLAGS"
elif test "$debug" = "no" ; then
 -  CFLAGS="-O2 -D_FORTIFY_SOURCE=2 $CFLAGS"
 +  CFLAGS="-O2 $CFLAGS"
  fi
  
- # Disable zero malloc errors for official releases unless explicitly told to
diff --git a/xen-xattr.patch b/xen-xattr.patch
deleted file mode 100644 (file)
index 91abad2..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-Workaround <linux/xattr.h> vs <sys/xattr.h> defines conflict:
-When including both, the latter must be included first.
-Move "qemu-xattr.h" (which includes <sys/xattr.h> to the front,
-before <sys/capability.h> (which includes <linux/xattr.h>.
-
---- xen-4.3.2/tools/qemu-xen/fsdev/virtfs-proxy-helper.c.orig  2013-10-10 16:20:18.000000000 +0200
-+++ xen-4.3.2/tools/qemu-xen/fsdev/virtfs-proxy-helper.c       2014-02-24 11:31:45.912924912 +0100
-@@ -9,6 +9,7 @@
-  * the COPYING file in the top-level directory.
-  */
-+#include "qemu-xattr.h"
- #include <sys/resource.h>
- #include <getopt.h>
- #include <syslog.h>
-@@ -22,7 +23,6 @@
- #endif
- #include "qemu-common.h"
- #include "qemu_socket.h"
--#include "qemu-xattr.h"
- #include "virtio-9p-marshal.h"
- #include "hw/9pfs/virtio-9p-proxy.h"
- #include "fsdev/virtio-9p-marshal.h"
index 2c67d0dd1245934e978e56093e3bd98d87283e60..a1ff2af7feb44dc32b36b4ca76dee411b39ac6e2 100644 (file)
--- a/xen.spec
+++ b/xen.spec
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.3.2
-Release:       1
+Version:       4.4.0
+Release:       0.1
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 Source0:       http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 83e0e13678383e4fbcaa69ce6064b187
+# Source0-md5: fd9031d499af38c5d04108681734027e
 # used by stubdoms
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
@@ -108,13 +108,11 @@ Patch6:           %{name}-dumpdir.patch
 # Warning: this disables ingress filtering implemented in xen scripts!
 Patch7:                %{name}-net-disable-iptables-on-bridge.patch
 Patch8:                %{name}-configure-xend.patch
-Patch9:                %{name}-initscript.patch
 Patch10:       %{name}-qemu.patch
 Patch11:       %{name}-ulong.patch
 Patch12:       %{name}-doc.patch
 Patch13:       %{name}-paths.patch
 Patch14:       %{name}-no_fetcher.patch
-Patch15:       %{name}-xattr.patch
 URL:           http://www.xen.org/products/xenhyp.html
 %{?with_opengl:BuildRequires:  OpenGL-devel}
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
@@ -137,6 +135,7 @@ BuildRequires:      gettext-devel
 BuildRequires: glib2-devel >= 1:2.12
 BuildRequires: glusterfs-devel >= 3.4
 BuildRequires: gnutls-devel
+BuildRequires:  keyutils-devel
 BuildRequires: latex2html >= 2008
 BuildRequires: libaio-devel
 BuildRequires: libcap-devel
@@ -405,13 +404,11 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
-%patch15 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
@@ -435,7 +432,7 @@ cd ..
 
 # if gold is used then bioses and grub doesn't build
 install -d our-ld
-ln -s /usr/bin/ld.bfd our-ld/ld
+ln -f -s /usr/bin/ld.bfd our-ld/ld
 export PATH=$(pwd)/our-ld:$PATH
 
 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
This page took 0.202196 seconds and 4 git commands to generate.