]> git.pld-linux.org Git - packages/xen.git/commitdiff
- build fixes for ocaml 4.12 auto/th/xen-4.13.1-2
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 26 Mar 2021 10:15:56 +0000 (11:15 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 26 Mar 2021 10:15:56 +0000 (11:15 +0100)
- rel 2

ocaml-4.12.patch [new file with mode: 0644]
xen.spec

diff --git a/ocaml-4.12.patch b/ocaml-4.12.patch
new file mode 100644 (file)
index 0000000..f82f446
--- /dev/null
@@ -0,0 +1,44 @@
+--- xen-4.14.1/tools/ocaml/libs/xentoollog/xentoollog_stubs.c.orig     2020-12-17 16:47:25.000000000 +0000
++++ xen-4.14.1/tools/ocaml/libs/xentoollog/xentoollog_stubs.c  2021-03-01 22:53:23.106205483 +0000
+@@ -53,8 +53,6 @@
+ #include "_xtl_levels.inc"
+ /* Option type support as per http://www.linux-nantes.org/~fmonnier/ocaml/ocaml-wrapping-c.php */
+-#define Val_none Val_int(0)
+-#define Some_val(v) Field(v,0)
+ static value Val_some(value v)
+ {
+--- xen-4.14.1/tools/ocaml/libs/xl/xenlight_stubs.c.orig       2020-12-17 16:47:25.000000000 +0000
++++ xen-4.14.1/tools/ocaml/libs/xl/xenlight_stubs.c    2021-03-01 23:01:24.229859714 +0000
+@@ -227,8 +227,6 @@
+ }
+ /* Option type support as per http://www.linux-nantes.org/~fmonnier/ocaml/ocaml-wrapping-c.php */
+-#define Val_none Val_int(0)
+-#define Some_val(v) Field(v,0)
+ static value Val_some(value v)
+ {
+--- xen-4.14.1/tools/ocaml/libs/xc/xenctrl_stubs.c.orig        2020-12-17 16:47:25.000000000 +0000
++++ xen-4.14.1/tools/ocaml/libs/xc/xenctrl_stubs.c     2021-03-01 23:24:45.477290290 +0000
+@@ -43,8 +43,6 @@
+ #define _H(__h) ((xc_interface *)(__h))
+ #define _D(__d) ((uint32_t)Int_val(__d))
+-#define Val_none (Val_int(0))
+-
+ #define string_of_option_array(array, index) \
+       ((Field(array, index) == Val_none) ? NULL : String_val(Field(Field(array, index), 0)))
+--- xen-4.13.1/tools/ocaml/common.make~        2020-05-14 14:19:32.000000000 +0200
++++ xen-4.13.1/tools/ocaml/common.make 2021-03-26 11:08:01.558827358 +0100
+@@ -9,7 +9,7 @@
+ OCAMLYACC ?= ocamlyacc
+ OCAMLFIND ?= ocamlfind
+-CFLAGS += -fPIC -Werror -I$(shell ocamlc -where)
++CFLAGS += -fPIC -I$(shell ocamlc -where)
+ OCAMLOPTFLAG_G := $(shell $(OCAMLOPT) -h 2>&1 | sed -n 's/^  *\(-g\) .*/\1/p')
+ OCAMLOPTFLAGS = $(OCAMLOPTFLAG_G) -ccopt "$(LDFLAGS)" -dtypes $(OCAMLINCLUDE) -cc $(CC) -w F -warn-error F
index 27395fb918e91f715e7b1f953826e71fefef8db3..485434288d24c5a8a3ddc46808adeab17a22ea92 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -41,7 +41,7 @@ Summary:      Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
 Version:       4.13.1
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
 Version:       4.13.1
-Release:       1
+Release:       2
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 # for available versions see https://www.xenproject.org/developers/teams/hypervisor.html
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 # for available versions see https://www.xenproject.org/developers/teams/hypervisor.html
@@ -99,6 +99,7 @@ Patch12:      %{name}-systemd.patch
 Patch13:       sysmacros.patch
 Patch14:       gcc9.patch
 Patch15:       gcc10.patch
 Patch13:       sysmacros.patch
 Patch14:       gcc9.patch
 Patch15:       gcc10.patch
+Patch16:       ocaml-4.12.patch
 URL:           http://www.xen.org/products/xenhyp.html
 BuildRequires: autoconf >= 2.67
 %ifarch %{ix86} %{x8664}
 URL:           http://www.xen.org/products/xenhyp.html
 BuildRequires: autoconf >= 2.67
 %ifarch %{ix86} %{x8664}
@@ -393,6 +394,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 # -Wno-error=enum-conversion requires gcc 10
 %patch15 -p1
 %endif
 # -Wno-error=enum-conversion requires gcc 10
 %patch15 -p1
 %endif
+%patch16 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
This page took 0.060105 seconds and 4 git commands to generate.