]> git.pld-linux.org Git - packages/xen.git/commitdiff
- added gawk patch (selinux policy generation fails with mawk, use gawk for it)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Oct 2014 09:31:33 +0000 (10:31 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Oct 2014 09:31:33 +0000 (10:31 +0100)
- added make patch (to avoid recompilation of some objects on install)

xen-gawk.patch [new file with mode: 0644]
xen-make.patch [new file with mode: 0644]
xen.spec

diff --git a/xen-gawk.patch b/xen-gawk.patch
new file mode 100644 (file)
index 0000000..1b217cc
--- /dev/null
@@ -0,0 +1,11 @@
+--- xen-4.4.1/tools/flask/policy/Makefile.orig 2014-10-22 22:35:07.033124118 +0200
++++ xen-4.4.1/tools/flask/policy/Makefile      2014-10-22 22:42:54.523104517 +0200
+@@ -86,7 +86,7 @@
+ MODENABLED := on
+ # extract settings from modules.conf
+-ENABLED_MODS := $(foreach mod,$(shell awk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(MODENABLED)") print $$1 }' $(MOD_CONF) 2> /dev/null),$(subst ./,,$(shell find -iname $(mod).te)))
++ENABLED_MODS := $(foreach mod,$(shell gawk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(MODENABLED)") print $$1 }' $(MOD_CONF) 2> /dev/null),$(subst ./,,$(shell find -iname $(mod).te)))
+ ALL_MODULES := $(filter $(ENABLED_MODS),$(DETECTED_MODS))
diff --git a/xen-make.patch b/xen-make.patch
new file mode 100644 (file)
index 0000000..077b0cb
--- /dev/null
@@ -0,0 +1,22 @@
+--- xen-4.4.1/tools/blktap2/vhd/Makefile.orig  2014-09-02 08:20:19.000000000 +0200
++++ xen-4.4.1/tools/blktap2/vhd/Makefile       2014-10-25 23:08:01.972163664 +0200
+@@ -27,7 +27,7 @@
+ build: $(IBIN)
+-LIBS_DEPENDS    := lib/libvhd.so lib/vhd.a
++LIBS_DEPENDS    := lib/libvhd.so lib/libvhd.a
+ $(LIBS_DEPENDS):subdirs-all
+ vhd-util: vhd-util.o $(LIBS_DEPENDS)
+--- xen-4.4.1/tools/python/Makefile.orig       2014-09-02 08:20:19.000000000 +0200
++++ xen-4.4.1/tools/python/Makefile    2014-10-25 23:17:56.515472047 +0200
+@@ -21,7 +21,7 @@
+ .PHONY: install
+ install: install-dtd
+       CC="$(CC)" CFLAGS="$(CFLAGS)" $(PYTHON) setup.py install \
+-              $(PYTHON_PREFIX_ARG) --root="$(DESTDIR)" --force --xend=$(CONFIG_XEND)
++              $(PYTHON_PREFIX_ARG) --skip-build --root="$(DESTDIR)" --force --xend=$(CONFIG_XEND)
+       $(INSTALL_DIR) $(DESTDIR)$(SBINDIR)
+ ifeq ($(CONFIG_XEND),y)
index e7def1cb96080fbc2f43cff5c7bc31bdfafc5c92..45a887533809465b6d03082b0d3d141178dbff17 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -6,6 +6,7 @@
 #    Xen Makefiles)
 #  - fix %doc - some files are installed in docdir both by make install and %d,
 #    other are installed once
+#  - mini-os objects are relinked on install (because of .PHONY rules used to make them)
 #
 # Conditional build:
 %bcond_without  qemu_traditional # without qemu-xen-traditional
@@ -103,6 +104,7 @@ Patch6:             %{name}-dumpdir.patch
 # Warning: this disables ingress filtering implemented in xen scripts!
 Patch7:                %{name}-net-disable-iptables-on-bridge.patch
 Patch8:                %{name}-configure-xend.patch
+Patch9:                %{name}-gawk.patch
 Patch10:       %{name}-qemu.patch
 Patch11:       %{name}-ulong.patch
 Patch12:       %{name}-doc.patch
@@ -112,6 +114,7 @@ Patch15:    odd-glib2-fix.patch
 Patch16:       %{name}-gmp-abi.patch
 # based on: http://xenbits.xen.org/xsa/xsa99.patch
 Patch17:       xsa99.patch
+Patch18:       %{name}-make.patch
 URL:           http://www.xen.org/products/xenhyp.html
 %if %{with qemu_traditional}
 %{?with_opengl:BuildRequires:  OpenGL-devel}
@@ -410,6 +413,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
@@ -418,6 +422,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch15 -p1
 %patch16 -p1
 %patch17 -p1
+%patch18 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
This page took 0.045707 seconds and 4 git commands to generate.