]> git.pld-linux.org Git - packages/xen.git/commitdiff
EFI boot configuration files added
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Tue, 18 Dec 2012 11:28:29 +0000 (12:28 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Tue, 18 Dec 2012 11:28:29 +0000 (12:28 +0100)
xen.cfg [new file with mode: 0644]
xen.efi-boot-update [new file with mode: 0644]
xen.spec

diff --git a/xen.cfg b/xen.cfg
new file mode 100644 (file)
index 0000000..1ef896d
--- /dev/null
+++ b/xen.cfg
@@ -0,0 +1,14 @@
+# configuration file for xen.efi
+
+[global]
+default=linux
+
+[linux]
+#options=com1=115200,8n1 console=com1,vga
+kernel=vmlinuz console=tty0 console=hvc0
+ramdisk=initrd
+
+[linux-old]
+#options=com1=115200,8n1 console=com1,vga
+kernel=vmlinuz.old console=tty0 console=hvc0
+ramdisk=initrd.old
diff --git a/xen.efi-boot-update b/xen.efi-boot-update
new file mode 100644 (file)
index 0000000..f0ee221
--- /dev/null
@@ -0,0 +1,17 @@
+ENABLED=yes
+LABEL="Xen native EFI"
+ARCH=@target_cpu@
+BINARY=xen.efi
+ARGS=""
+
+install_files() {
+
+    update_file @libdir@/efi/xen.efi xen.efi
+    update_file /etc/efi-boot/xen.cfg xen.cfg
+
+    update_file /boot/initrd initrd
+    update_file /boot/vmlinuz vmlinuz
+
+    update_file --missingok /boot/initrd.old initrd.old
+    update_file --missingok /boot/vmlinuz.old vmlinuz.old
+}
index 856a65b31ced2fee25ce708c7132360fc0ef0bd4..72266c1bac549188c41ca8e72e3feaea0bb30f35 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -73,6 +73,8 @@ Source53:     xen-watchdog.init
 Source54:      xendomains.init
 Source55:      xen.logrotate
 Source56:      xen.tmpfiles
+Source57:      xen.cfg
+Source58:      xen.efi-boot-update
 Patch0:                %{name}-python_scripts.patch
 Patch1:                %{name}-symbols.patch
 Patch2:                %{name}-curses.patch
@@ -417,7 +419,8 @@ unset CXXFLAGS
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
-       $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
+       $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
+       $RPM_BUILD_ROOT/etc/efi-boot/update.d
 
 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
        %{!?with_ocaml:OCAML_TOOLS=n} \
@@ -452,6 +455,12 @@ install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
 
+%if %{with efi}
+install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
+sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
+                       %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
+%endif
+
 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
 
 # for %%doc
@@ -812,4 +821,6 @@ fi
 %defattr(644,root,root,755)
 %dir %{_libdir}/efi
 %{_libdir}/efi/*.efi
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
+%attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
 %endif
This page took 0.078975 seconds and 4 git commands to generate.