]> git.pld-linux.org Git - packages/xen.git/commitdiff
- partial update to 4.6.1
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 7 Apr 2016 12:18:23 +0000 (21:18 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 7 Apr 2016 12:18:23 +0000 (21:18 +0900)
xen-dumpdir.patch [deleted file]
xen-gawk.patch
xen-grep-typo.patch [new file with mode: 0644]
xen-no_Werror.patch
xen.spec

diff --git a/xen-dumpdir.patch b/xen-dumpdir.patch
deleted file mode 100644 (file)
index 771dec0..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-diff -up xen-3.4.0/tools/Makefile.dump xen-3.4.0/tools/Makefile
---- xen-3.4.0/tools/Makefile.dump      2009-05-18 13:05:38.000000000 +0200
-+++ xen-3.4.0/tools/Makefile   2009-05-20 17:03:26.000000000 +0200
-@@ -46,7 +46,7 @@ all: subdirs-all
- .PHONY: install
- install: subdirs-install
--      $(INSTALL_DIR) $(DESTDIR)/var/xen/dump
-+      $(INSTALL_DIR) $(DESTDIR)/var/lib/xen/dump
-       $(INSTALL_DIR) $(DESTDIR)/var/log/xen
-       $(INSTALL_DIR) $(DESTDIR)/var/lib/xen
-       $(INSTALL_DIR) $(DESTDIR)/var/lock/subsys
---- xen-4.5.1/tools/libxl/xl_cmdimpl.c.orig    2015-06-22 15:41:35.000000000 +0200
-+++ xen-4.5.1/tools/libxl/xl_cmdimpl.c 2015-10-01 17:45:14.267331067 +0200
-@@ -2092,7 +2092,7 @@
-         char *corefile;
-         int rc;
--        if (asprintf(&corefile, "/var/xen/dump/%s", d_config->c_info.name) < 0) {
-+        if (asprintf(&corefile, "/var/lib/xen/dump/%s", d_config->c_info.name) < 0) {
-             LOG("failed to construct core dump path");
-         } else {
-             LOG("dumping core to %s", corefile);
---- xen-4.5.1/docs/man/xl.cfg.pod.5.orig       2015-06-22 15:41:35.000000000 +0200
-+++ xen-4.5.1/docs/man/xl.cfg.pod.5    2015-10-01 17:46:38.750661228 +0200
-@@ -298,12 +298,12 @@
- =item B<coredump-destroy>
--write a "coredump" of the domain to F</var/xen/dump/NAME> and then
-+write a "coredump" of the domain to F</var/lib/xen/dump/NAME> and then
- destroy the domain.
- =item B<coredump-restart>
--write a "coredump" of the domain to F</var/xen/dump/NAME> and then
-+write a "coredump" of the domain to F</var/lib/xen/dump/NAME> and then
- restart the domain.
- =back
-@@ -1605,7 +1605,7 @@
- =head1 FILES
- F</etc/xen/NAME.cfg>
--F</var/xen/dump/NAME>
-+F</var/lib/xen/dump/NAME>
- =head1 BUGS
index 1b217ccd9440253653b42b082268e2cf96591817..4b1b29b9d3c1ff78d568a83376d15fa507327fc0 100644 (file)
@@ -4,8 +4,8 @@
  MODENABLED := on
  
  # extract settings from modules.conf
--ENABLED_MODS := $(foreach mod,$(shell awk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(MODENABLED)") print $$1 }' $(MOD_CONF) 2> /dev/null),$(subst ./,,$(shell find -iname $(mod).te)))
-+ENABLED_MODS := $(foreach mod,$(shell gawk '/^[[:blank:]]*[[:alpha:]]/{ if ($$3 == "$(MODENABLED)") print $$1 }' $(MOD_CONF) 2> /dev/null),$(subst ./,,$(shell find -iname $(mod).te)))
+-ENABLED_MODS := $(foreach mod,$(shell awk '/^[ \t]*[a-z]/{ if ($$3 == "$(MODENABLED)") print $$1 }' $(MOD_CONF) 2> /dev/null),$(subst ./,,$(shell find -iname $(mod).te)))
++ENABLED_MODS := $(foreach mod,$(shell gawk '/^[ \t]*[a-z]/{ if ($$3 == "$(MODENABLED)") print $$1 }' $(MOD_CONF) 2> /dev/null),$(subst ./,,$(shell find -iname $(mod).te)))
  
  ALL_MODULES := $(filter $(ENABLED_MODS),$(DETECTED_MODS))
  
diff --git a/xen-grep-typo.patch b/xen-grep-typo.patch
new file mode 100644 (file)
index 0000000..0ceb663
--- /dev/null
@@ -0,0 +1,51 @@
+commit 3f293c7caaefc2c37b61e44e8ebd5a7f1c554afb
+Author: Dario Faggioli <dario.faggioli@citrix.com>
+Date:   Thu Feb 25 13:03:04 2016 +0100
+
+    public: typo: use ' as apostrophe in grant_table.h
+    
+    If grep 2.23 is installed, build fails like this:
+    ...
+    mkdir -p compat
+    grep -v 'DEFINE_XEN_GUEST_HANDLE(long)' public/grant_table.h | \
+    python /home/SOURCES/xen/xen/xen.git/xen/tools/compat-build-source.py >compat/grant_table.c.new
+    mv -f compat/grant_table.c.new compat/grant_table.c
+    gcc  ... -o compat/grant_table.i compat/grant_table.c
+    compat/grant_table.c:33:1: error: unterminated comment
+     /*
+     ^
+    compat/grant_table.c:28:0: error: unterminated #ifndef
+     #ifndef __XEN_PUBLIC_GRANT_TABLE_H__
+     ^
+    Makefile:62: recipe for target 'compat/grant_table.i' failed
+    make[3]: *** [compat/grant_table.i] Error 1
+    rm compat/grant_table.c
+    make[3]: Leaving directory '/home/SOURCES/xen/xen/xen.git/xen/include'
+    ...
+    
+    This is because grant_table.h contains this (note the
+    apostrophe): "granter\92s memory", and `grep -v', in version
+    2.23, stops processing the file (while, for instance,
+    until 2.22, this was not happening).
+    
+    Although the above behavior is likely an issue in grep,
+    (https://debbugs.gnu.org/cgi/bugreport.cgi?bug=22461)
+    I think we better switch to using " ' " in that line
+    anyway, as we do basically everywhere else (even in
+    the same file).
+    
+    Signed-off-by: Dario Faggioli <dario.faggioli@citrix.com>
+
+diff --git a/xen/include/public/grant_table.h b/xen/include/public/grant_table.h
+index e9393fd..e5f04ec 100644
+--- a/xen/include/public/grant_table.h
++++ b/xen/include/public/grant_table.h
+@@ -43,7 +43,7 @@
+  * table are identified by grant references. A grant reference is an
+  * integer, which indexes into the grant table. It acts as a
+  * capability which the grantee can use to perform operations on the
+- * granter’s memory.
++ * granter's memory.
+  *
+  * This capability-based system allows shared-memory communications
+  * between unprivileged domains. A grant reference also encapsulates
index 9f93106011173271676addd7c1d53d5282062eb0..6df40b15b2231844132bef2d53a3f8d900a6e48b 100644 (file)
@@ -10,13 +10,13 @@ diff -dur -x '*~' xen-4.1.2.orig/Config.mk xen-4.1.2/Config.mk
  HOSTCFLAGS += -fno-strict-aliasing
  
  DISTDIR     ?= $(XEN_ROOT)/dist
---- xen-4.4.1/tools/blktap/drivers/Makefile~   2014-09-02 08:20:19.000000000 +0200
-+++ xen-4.4.1/tools/blktap/drivers/Makefile    2014-12-13 19:19:17.070688454 +0100
+--- xen-4.4.1/tools/blktap2/drivers/Makefile~  2014-09-02 08:20:19.000000000 +0200
++++ xen-4.4.1/tools/blktap2/drivers/Makefile   2014-12-13 19:19:17.070688454 +0100
 @@ -4,7 +4,6 @@
- IBIN         = blktapctrl tapdisk
- QCOW_UTIL    = img2qcow qcow2raw qcow-create
+ LOCK_UTIL  = lock-util
+ INST_DIR   = $(sbindir)
  
--CFLAGS   += -Werror
- CFLAGS   += -Wno-unused
- CFLAGS   += -I../lib
- CFLAGS   += $(CFLAGS_libxenctrl)
+-CFLAGS    += -Werror
+ CFLAGS    += -Wno-unused
+ CFLAGS    += -fno-strict-aliasing
+ CFLAGS    += -I$(BLKTAP_ROOT)/include -I$(BLKTAP_ROOT)/drivers
index 2b7a6b71a7e6a122731f808674361e359dd39913..b4385d4d340abf3b16fe2af2403659c451c63e82 100644 (file)
--- a/xen.spec
+++ b/xen.spec
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.5.1
+Version:       4.6.1
 Release:       0.1
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 Source0:       http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d12dc9e5e8bd22a68b5c7f53119221f1
+# Source0-md5: df2d854c3c90ffeefaf71e7f868fb326
 # used by stubdoms
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
@@ -100,7 +100,6 @@ Patch0:             %{name}-python_scripts.patch
 Patch1:                %{name}-symbols.patch
 Patch2:                %{name}-curses.patch
 Patch3:                pygrubfix.patch
-Patch6:                %{name}-dumpdir.patch
 # Warning: this disables ingress filtering implemented in xen scripts!
 Patch7:                %{name}-net-disable-iptables-on-bridge.patch
 Patch9:                %{name}-gawk.patch
@@ -114,6 +113,7 @@ Patch18:    %{name}-make.patch
 Patch19:       %{name}-no_Werror.patch
 # http://git.alpinelinux.org/cgit/aports/plain/main/xen/gnutls-3.4.0.patch
 Patch20:       %{name}-gnutls-3.4.patch
+Patch21:       %{name}-grep-typo.patch
 URL:           http://www.xen.org/products/xenhyp.html
 BuildRequires: autoconf >= 2.67
 %ifarch %{ix86} %{x8664}
@@ -398,7 +398,6 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch6 -p1
 %patch7 -p1
 %patch9 -p1
 %patch10 -p1
@@ -410,6 +409,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
+%patch21 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
This page took 0.100202 seconds and 4 git commands to generate.