]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
xenstored must not be ever stopped
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.0
33 Release:        1
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  f4f217969afc38f09251039966d91a87
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Patch0:         %{name}-python_scripts.patch
76 Patch1:         %{name}-symbols.patch
77 Patch2:         %{name}-curses.patch
78 Patch3:         pygrubfix.patch
79 Patch4:         xend.catchbt.patch
80 Patch5:         xend-pci-loop.patch
81 Patch6:         xen-dumpdir.patch
82 # Warning: this disables ingress filtering implemented in xen scripts!
83 Patch7:         xen-net-disable-iptables-on-bridge.patch
84 Patch8:         xen-configure-xend.patch
85 Patch9:         xen-initscript.patch
86 Patch10:        xen-quemu-softloat-c99.patch
87 Patch11:        xen-qemu.patch
88 Patch12:        xen-scripts-locking.patch
89 URL:            http://www.xen.org/products/xenhyp.html
90 %{?with_opengl:BuildRequires:   OpenGL-devel}
91 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
92 %ifarch %{ix86} %{x8664}
93 BuildRequires:  acpica
94 BuildRequires:  bcc
95 %endif
96 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
97 %{?with_brlapi:BuildRequires:   brlapi-devel}
98 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
99 BuildRequires:  bzip2-devel
100 BuildRequires:  ceph-devel
101 BuildRequires:  curl-devel
102 BuildRequires:  cyrus-sasl-devel >= 2
103 BuildRequires:  e2fsprogs-devel
104 BuildRequires:  gcc >= 5:3.4
105 BuildRequires:  gettext-devel
106 BuildRequires:  glib2-devel >= 1:2.12
107 BuildRequires:  gnutls-devel
108 BuildRequires:  latex2html >= 2008
109 BuildRequires:  libaio-devel
110 BuildRequires:  libiscsi-devel
111 BuildRequires:  libjpeg-devel
112 BuildRequires:  libpng-devel
113 BuildRequires:  libuuid-devel
114 BuildRequires:  lzo-devel >= 2
115 BuildRequires:  ncurses-devel
116 %if %{with ocaml}
117 BuildRequires:  ocaml >= 3.04-7
118 BuildRequires:  ocaml-findlib
119 %endif
120 BuildRequires:  nss-devel >= 3.12.8
121 BuildRequires:  openssl-devel
122 BuildRequires:  pciutils-devel
123 BuildRequires:  perl-base
124 BuildRequires:  pkgconfig
125 BuildRequires:  python-devel
126 BuildRequires:  rpm-pythonprov
127 BuildRequires:  rpmbuild(macros) >= 1.647
128 BuildRequires:  spice-protocol >= 0.6.0
129 BuildRequires:  spice-server-devel >= 0.6.0
130 BuildRequires:  texi2html
131 BuildRequires:  texlive-dvips
132 BuildRequires:  texlive-latex-psnfss
133 BuildRequires:  texlive-xetex
134 BuildRequires:  usbredir-devel
135 BuildRequires:  vde2-devel
136 BuildRequires:  which
137 # for xfsctl (<xfs/xfs.h>)
138 BuildRequires:  xfsprogs-devel
139 BuildRequires:  xorg-lib-libX11-devel
140 BuildRequires:  xorg-lib-libXext-devel
141 BuildRequires:  xz-devel
142 BuildRequires:  yajl-devel
143 BuildRequires:  zlib-devel
144 # FIXME: see qemu configure comments on top of spec
145 %{!?with_opengl:BuildConflicts: OpenGL-devel}
146 %{!?with_sdl:BuildConflicts:    SDL-devel}
147 %{!?with_sdl:BuildConflicts:    SDL-devel}
148 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
149 %{!?with_brlapi:BuildConflicts: brlapi-devel}
150 Requires(post,preun):   /sbin/chkconfig
151 Requires(post,preun,postun):    systemd-units >= 38
152 Requires:       %{name}-libs = %{version}-%{release}
153 Requires:       ZopeInterface
154 Requires:       bridge-utils
155 Requires:       coreutils
156 Requires:       diffutils
157 Requires:       gawk
158 Requires:       iptables
159 Requires:       losetup
160 Requires:       net-tools
161 Requires:       python-%{name} = %{version}-%{release}
162 Requires:       rc-scripts
163 Requires:       sed
164 Requires:       systemd-units >= 38
165 Requires:       util-linux
166 Requires:       which
167 Requires:       %{name}-guest = %{version}-%{release}
168 Obsoletes:      xen-doc
169 Obsoletes:      xen-udev
170 ExclusiveArch:  %{ix86} %{x8664}
171 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
172
173 # some PPC/SPARC boot images in ELF format
174 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
175
176 %description
177 This package contains the Xen hypervisor and Xen tools, needed to run
178 virtual machines on x86 systems, together with the kernel-xen*
179 packages. Information on how to use Xen can be found at the Xen
180 project pages.
181
182 Virtualisation can be used to run multiple versions or multiple Linux
183 distributions on one system, or to test untrusted applications in a
184 sandboxed environment. Note that the Xen technology is still in
185 development, and this RPM has received extremely little testing. Don't
186 be surprised if this RPM eats your data, drinks your coffee or makes
187 fun of you in front of your friends.
188
189 %description -l pl.UTF-8
190 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
191 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
192 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
193 projektu.
194
195 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
196 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
197 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
198 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
199 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
200 się wyśmiewał w obecności przyjaciół.
201
202 %package guest
203 Summary:        Xen tools for virtual machines
204 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
205 Group:          Applications/System
206 Requires:       %{name}-libs-guest = %{version}-%{release}
207
208 %description guest
209 Xen utilities for both dom0 and domU virtual domains.
210
211 %description guest -l pl.UTF-8
212 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
213
214 %package libs
215 Summary:        Xen libraries
216 Summary(pl.UTF-8):      Biblioteki Xena
217 Group:          Libraries
218 Requires:       %{name}-libs-guest = %{version}-%{release}
219
220 %description libs
221 Xen libraries.
222
223 %description libs -l pl.UTF-8
224 Biblioteki Xena.
225
226 %package libs-guest
227 Summary:        Xen libraries for virtual machines
228 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
229 Group:          Libraries
230
231 %description libs-guest
232 Xen libraries for both dom0 and domU virtual machines.
233
234 %description libs-guest -l pl.UTF-8
235 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
236
237 %package devel
238 Summary:        Header files for Xen
239 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
240 Group:          Development/Libraries
241 Requires:       %{name}-libs = %{version}-%{release}
242
243 %description devel
244 Header files for Xen.
245
246 %description devel -l pl.UTF-8
247 Pliki nagłówkowe Xena.
248
249 %package static
250 Summary:        Static Xen libraries
251 Summary(pl.UTF-8):      Statyczne biblioteki Xena
252 Group:          Development/Libraries
253 Requires:       %{name}-devel = %{version}-%{release}
254
255 %description static
256 Static Xen libraries.
257
258 %description static -l pl.UTF-8
259 Statyczne biblioteki Xena.
260
261 %package xend
262 Summary:        xend daemon
263 Summary(pl.UTF-8):      Demon xend
264 Group:          Daemons
265 Requires(post,preun,postun):    systemd-units >= 38
266 Requires:       systemd-units >= 38
267
268 %description xend
269 xend daemon.
270
271 %description xend -l pl.UTF-8
272 Demon xend.
273
274 %package -n ocaml-xen
275 Summary:        OCaml bindings for Xen
276 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
277 License:        LGPL v2.1 with linking exception
278 Group:          Libraries
279 Requires:       %{name}-libs = %{version}-%{release}
280 %if %{with ocaml}
281 %requires_eq    ocaml-runtime
282 %endif
283
284 %description -n ocaml-xen
285 OCaml bindings for Xen.
286
287 %description -n ocaml-xen -l pl.UTF-8
288 Wiązania OCamla dla Xena.
289
290 %package -n ocaml-xen-devel
291 Summary:        OCaml bindings for Xen - development files
292 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
293 License:        LGPL v2.1 with linking exception
294 Group:          Development/Libraries
295 Requires:       ocaml-xen = %{version}-%{release}
296 %if %{with ocaml}
297 %requires_eq    ocaml
298 %endif
299
300 %description -n ocaml-xen-devel
301 OCaml bindings for Xen - development files.
302
303 %description -n ocaml-xen-devel -l pl.UTF-8
304 Wiązania OCamla dla Xena - pliki programistyczne.
305
306 %package -n python-xen
307 Summary:        Xen Python modules
308 Summary(pl.UTF-8):      Moduły Pythona dla Xena
309 Group:          Libraries
310 Requires:       %{name}-libs = %{version}-%{release}
311 Conflicts:      xen < 3.2.1-0.3
312
313 %description -n python-xen
314 Xen Python modules.
315
316 %description -n python-xen -l pl.UTF-8
317 Moduły Pythona dla Xena.
318
319 %package -n python-xen-guest
320 Summary:        Xen Python modules for virtual machines
321 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
322 Group:          Libraries
323 Requires:       %{name}-libs-guest = %{version}-%{release}
324 Conflicts:      xen < 3.2.1-0.3
325
326 %description -n python-xen-guest
327 Xen Python modules for both dom0 and domU virtual machines.
328
329 %description -n python-xen-guest -l pl.UTF-8
330 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
331
332 %package -n bash-completion-%{name}
333 Summary:    bash-completion for Xen (xl)
334 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
335 Group:      Applications/Shells
336 Requires:   %{name} = %{version}-%{release}
337 Requires:   bash-completion
338
339 %description -n bash-completion-%{name}
340 This package provides bash-completion for Xen (xl).
341
342 %description -n bash-completion-%{name} -l pl.UTF-8
343 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
344
345 %package efi
346 Summary:        Xen hypervisor binary for EFI
347 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
348 Group:          Applications/System
349 Requires:       %{name}-libs-guest = %{version}-%{release}
350
351 %description efi
352 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
353 firmware without help from any additional bootloader.
354
355 %description efi -l pl.UTF-8
356 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
357 (U)EFI, bez potrzeby oddzielnego bootloadera.
358
359 %prep
360 %setup -q -a 16
361 %patch0 -p1
362 %patch1 -p1
363 %patch2 -p1
364 %patch3 -p1
365 %patch4 -p1
366 %patch5 -p1
367 %patch6 -p1
368 %patch7 -p1
369 %patch8 -p1
370 %patch9 -p1
371 %patch10 -p1
372 %patch11 -p1
373 %patch12 -p1
374
375 # stubdom sources
376 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
377 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
378
379 # do not allow fetching anything via git
380 echo GIT=/bin/false >> Config.mk
381
382 %build
383 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
384 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
385
386 # NOTE:
387 # - there is a quoting bug (in tools/driver/Makefile) that causes
388 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
389 #   anyway (see configure), gcrypt is optional
390 # - prevent libiconv from being detected (not needed with glibc)
391 cd tools
392 %configure \
393         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
394         ac_cv_lib_iconv_libiconv_open=no \
395         --disable-debug
396 cd ..
397
398 %{__make} dist-xen dist-tools dist-docs \
399         %{!?with_ocaml:OCAML_TOOLS=n} \
400         prefix=%{_prefix} \
401         CC="%{__cc}" \
402         CXX="%{__cxx}" \
403         V=1
404
405 unset CFLAGS
406 unset CXXFLAGS
407
408 %{__make} -j1 dist-stubdom \
409         %{!?with_ocaml:OCAML_TOOLS=n} \
410         CC="%{__cc}" \
411         CXX="%{__cxx}" \
412         V=1
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
417         $RPM_BUILD_ROOT{/usr/lib/tmpfiles.d,%{systemdunitdir},/var/log/xen/console}
418
419 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
420         %{!?with_ocaml:OCAML_TOOLS=n} \
421         prefix=%{_prefix} \
422         DESTDIR=$RPM_BUILD_ROOT \
423         HOTPLUGS=install-udev
424
425 %if "%{_lib}" == "lib64"
426 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
427 %endif
428
429 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
430 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
431 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
432 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
433 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
434 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
435 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
436 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
437 install %{SOURCE38} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/xenstored.conf
438 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
439 install %{SOURCE40} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/xend.conf
440 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
441 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
442 # sysvinit scripts
443 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
444 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
445 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
446 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
447 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
448 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
449 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
450
451 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
452
453 # for %%doc
454 install -d _doc
455 for tool in blktap blktap2 pygrub xenmon ; do
456         cp -p tools/$tool/README _doc/README.$tool
457 done
458 cp -al tools/qemu-xen/docs _doc/qemu-xen
459
460 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
461 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
462
463 %py_postclean
464
465 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
466 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
467 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
468 # seems not needed, the path is wrong anyway
469 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
470
471 # remove unneeded files
472 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
473 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
474 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
475 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
476 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
477
478 %clean
479 rm -rf $RPM_BUILD_ROOT
480
481 %post
482 /sbin/chkconfig --add xen-watchdog
483 /sbin/chkconfig --add xenconsoled
484 /sbin/chkconfig --add xenstored
485 /sbin/chkconfig --add xendomains
486 %systemd_post xen-watchdog.service xenconsoled.service
487
488 export NORESTART=1
489 %systemd_post xenstored.service
490 if [ $1 -ne 1 ] ; then
491         /bin/systemd_booted && echo "xenstored.service must not be restarted, ever!" || :
492 fi
493
494 %preun
495 if [ "$1" = "0" ]; then
496         %service xendomains stop
497         /sbin/chkconfig --del xendomains
498
499         %service xenconsoled stop
500         /sbin/chkconfig --del xenconsoled
501
502         %service xenstored stop
503         /sbin/chkconfig --del xenstored
504
505         %service xen-watchdog stop
506         /sbin/chkconfig --del xen-watchdog
507 fi
508 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
509
510 %postun
511 %systemd_reload
512
513 %post xend
514 /sbin/chkconfig --add xend
515 %systemd_post xend.service
516
517 %preun xend
518 if [ "$1" = "0" ]; then
519         %service xend stop
520         /sbin/chkconfig --del xend
521 fi
522 %systemd_preun xend.service
523
524 %postun xend
525 %systemd_reload
526
527 %post   libs -p /sbin/ldconfig
528 %postun libs -p /sbin/ldconfig
529
530 %post   libs-guest -p /sbin/ldconfig
531 %postun libs-guest -p /sbin/ldconfig
532
533 %files
534 %defattr(644,root,root,755)
535 %doc COPYING README* docs/misc/* 
536 %doc docs/html/*
537 %doc tools/qemu-xen-dir/*.html
538 %doc _doc/*
539 /boot/%{name}-syms-%{version}
540 /boot/%{name}-%{version}.gz
541 /boot/%{name}.gz
542 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
543 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
544 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
545 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
546 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
547 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
548 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
549 %attr(754,root,root) /etc/rc.d/init.d/xenstored
550 %attr(754,root,root) /etc/rc.d/init.d/xendomains
551 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
552 %{systemdunitdir}/proc-xen.mount
553 %{systemdunitdir}/var-lib-xenstored.mount
554 %{systemdunitdir}/xen-watchdog.service
555 %{systemdunitdir}/xenconsoled.service
556 %{systemdunitdir}/xenstored.service
557 %dir %{_sysconfdir}/xen
558 %dir %{_sysconfdir}/xen/auto
559 %dir %{_sysconfdir}/xen/examples
560 %dir %{_sysconfdir}/xen/scripts
561 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
563 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
564 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
565 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
566 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
567 %attr(755,root,root) %{_bindir}/pygrub
568 %attr(755,root,root) %{_bindir}/qemu-img-xen
569 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
570 %attr(755,root,root) %{_bindir}/remus
571 %attr(755,root,root) %{_bindir}/xencons
572 %attr(755,root,root) %{_bindir}/xentrace*
573 %attr(755,root,root) %{_sbindir}/blktapctrl
574 %attr(755,root,root) %{_sbindir}/flask-*
575 %attr(755,root,root) %{_sbindir}/gdbsx
576 %attr(755,root,root) %{_sbindir}/gtrace*
577 %attr(755,root,root) %{_sbindir}/img2qcow
578 %attr(755,root,root) %{_sbindir}/kdd
579 %attr(755,root,root) %{_sbindir}/lock-util
580 %attr(755,root,root) %{_sbindir}/qcow-create
581 %attr(755,root,root) %{_sbindir}/qcow2raw
582 %attr(755,root,root) %{_sbindir}/tap-ctl
583 %attr(755,root,root) %{_sbindir}/tapdisk*
584 %attr(755,root,root) %{_sbindir}/td-util
585 %attr(755,root,root) %{_sbindir}/vhd-*
586 %attr(755,root,root) %{_sbindir}/xen-*
587 %attr(755,root,root) %{_sbindir}/xenbaked
588 %attr(755,root,root) %{_sbindir}/xenconsoled
589 %attr(755,root,root) %{_sbindir}/xenlockprof
590 %attr(755,root,root) %{_sbindir}/xenmon.py
591 %attr(755,root,root) %{_sbindir}/xenperf
592 %attr(755,root,root) %{_sbindir}/xenpm
593 %attr(755,root,root) %{_sbindir}/xenpmd
594 %attr(755,root,root) %{_sbindir}/xenstored
595 %attr(755,root,root) %{_sbindir}/xentop
596 %attr(755,root,root) %{_sbindir}/xentrace_setmask
597 %attr(755,root,root) %{_sbindir}/xenwatchdogd
598 %attr(755,root,root) %{_sbindir}/xl
599 %attr(755,root,root) %{_sbindir}/xsview
600 %dir %{_libdir}/%{name}
601 %dir %{_libdir}/%{name}/bin
602 %attr(744,root,root) %{_libdir}/%{name}/bin/*
603 %if "%{_lib}" != "lib"
604 %dir %{_prefix}/lib/%{name}
605 %dir %{_prefix}/lib/%{name}/bin
606 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
607 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
608 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
609 %endif
610 %dir %{_prefix}/lib/%{name}/boot
611 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
612 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
613 %ifarch %{x8664}
614 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
615 %endif
616 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
617 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
618 %{_datadir}/xen
619 %{_mandir}/man1/qemu-img-xen.1*
620 %{_mandir}/man1/xentop.1*
621 %{_mandir}/man1/xentrace_format.1*
622 %{_mandir}/man1/xl.1*
623 %{_mandir}/man1/xm.1*
624 %{_mandir}/man5/xend-config.sxp.5*
625 %{_mandir}/man5/xl.cfg.5*
626 %{_mandir}/man5/xl.conf.5*
627 %{_mandir}/man5/xlcpupool.cfg.5*
628 %{_mandir}/man5/xmdomain.cfg.5*
629 %{_mandir}/man8/qemu-nbd-xen.8*
630 %{_mandir}/man8/xentrace.8*
631 %{_sharedstatedir}/xen
632 %{_sharedstatedir}/xenstored
633 %dir /var/run/xenstored
634 %{systemdtmpfilesdir}/xenstored.conf
635 %dir %attr(0700,root,root) /var/log/xen
636 %dir %attr(0700,root,root) /var/log/xen/console
637 %{_datadir}/qemu-xen
638
639 %files guest
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_bindir}/xen-detect
642 %attr(755,root,root) %{_bindir}/xenstore*
643
644 %files libs
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
648 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
650 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
652 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
654 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
656 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
657 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
658 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
659 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
660 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
661 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
662 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
663 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
664 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
665 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
666 %dir %{_libdir}/fs
667 %dir %{_libdir}/fs/ext2fs-lib
668 %dir %{_libdir}/fs/fat
669 %dir %{_libdir}/fs/iso9660
670 %dir %{_libdir}/fs/reiserfs
671 %dir %{_libdir}/fs/ufs
672 %dir %{_libdir}/fs/xfs
673 %dir %{_libdir}/fs/zfs
674 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
675
676 %files libs-guest
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
679 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
680
681 %files devel
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_libdir}/libblktap.so
684 %attr(755,root,root) %{_libdir}/libblktapctl.so
685 %attr(755,root,root) %{_libdir}/libfsimage.so
686 %attr(755,root,root) %{_libdir}/libvhd.so
687 %attr(755,root,root) %{_libdir}/libxenctrl.so
688 %attr(755,root,root) %{_libdir}/libxenguest.so
689 %attr(755,root,root) %{_libdir}/libxenlight.so
690 %attr(755,root,root) %{_libdir}/libxenstat.so
691 %attr(755,root,root) %{_libdir}/libxenstore.so
692 %attr(755,root,root) %{_libdir}/libxenvchan.so
693 %attr(755,root,root) %{_libdir}/libxlutil.so
694 %{_includedir}/_libxl_list.h
695 %{_includedir}/_libxl_types.h
696 %{_includedir}/_libxl_types_json.h
697 %{_includedir}/blktaplib.h
698 %{_includedir}/fsimage*.h
699 %{_includedir}/libxenvchan.h
700 %{_includedir}/libxl*.h
701 %{_includedir}/xen*.h
702 %{_includedir}/xs*.h
703 %{_includedir}/xen
704 %{_includedir}/xenstore-compat
705
706 %files static
707 %defattr(644,root,root,755)
708 %{_libdir}/libblktap.a
709 %{_libdir}/libblktapctl.a
710 %{_libdir}/libvhd.a
711 %{_libdir}/libxenctrl.a
712 %{_libdir}/libxenguest.a
713 %{_libdir}/libxenlight.a
714 %{_libdir}/libxenvchan.a
715 %{_libdir}/libxenstat.a
716 %{_libdir}/libxenstore.a
717 %{_libdir}/libxlutil.a
718
719 %files xend
720 %defattr(644,root,root,755)
721 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
722 %{systemdunitdir}/blktapctrl.service
723 %{systemdunitdir}/xend.service
724 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
725 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
726 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
727 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
728 %attr(755,root,root) %{_sbindir}/xend
729 %attr(755,root,root) %{_sbindir}/xm
730 %dir %attr(700,root,root) /var/run/xend
731 %{systemdtmpfilesdir}/xend.conf
732
733 %if %{with ocaml}
734 %files -n ocaml-xen
735 %defattr(644,root,root,755)
736 %doc tools/ocaml/LICENSE
737 %attr(755,root,root) %{_sbindir}/oxenstored
738 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
739 %dir %{_libdir}/ocaml/site-lib/xenbus
740 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
741 %dir %{_libdir}/ocaml/site-lib/xenctrl
742 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
743 %dir %{_libdir}/ocaml/site-lib/xeneventchn
744 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
745 %dir %{_libdir}/ocaml/site-lib/xenlight
746 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
747 %dir %{_libdir}/ocaml/site-lib/xenmmap
748 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
749
750 %files -n ocaml-xen-devel
751 %defattr(644,root,root,755)
752 %{_libdir}/ocaml/site-lib/xenbus/META
753 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
754 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
755 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
756 %{_libdir}/ocaml/site-lib/xenctrl/META
757 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
758 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
759 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
760 %{_libdir}/ocaml/site-lib/xeneventchn/META
761 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
762 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
763 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
764 %{_libdir}/ocaml/site-lib/xenmmap/META
765 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
766 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
767 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
768 %{_libdir}/ocaml/site-lib/xenlight/META
769 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
770 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
771 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
772 %dir %{_libdir}/ocaml/site-lib/xenstore
773 %{_libdir}/ocaml/site-lib/xenstore/META
774 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
775 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
776 %endif
777
778 %files -n python-xen
779 %defattr(644,root,root,755)
780 %attr(755,root,root) %{py_sitedir}/fsimage.so
781 %{py_sitedir}/grub
782 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
783 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
784 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
785 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
786 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
787 %{py_sitedir}/xen/remus
788 %{py_sitedir}/xen/sv
789 %{py_sitedir}/xen/util
790 %{py_sitedir}/xen/web
791 %{py_sitedir}/xen/xend
792 %{py_sitedir}/xen/xm
793 %{py_sitedir}/xen/xsview
794 %if "%{py_ver}" > "2.4"
795 %{py_sitedir}/pygrub-0.3-py*.egg-info
796 %{py_sitedir}/xen-3.0-py*.egg-info
797 %endif
798
799 %files -n python-xen-guest
800 %defattr(644,root,root,755)
801 %dir %{py_sitedir}/xen
802 %{py_sitedir}/xen/__init__.py*
803 %dir %{py_sitedir}/xen/lowlevel
804 %{py_sitedir}/xen/lowlevel/__init__.py*
805 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
806
807 %files -n bash-completion-%{name}
808 %defattr(644,root,root,755)
809 /etc/bash_completion.d/xl.sh
810
811 %if %{with efi}
812 %files efi
813 %defattr(644,root,root,755)
814 %dir %{_libdir}/efi
815 %{_libdir}/efi/*.efi
816 %endif
This page took 0.199361 seconds and 4 git commands to generate.