]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
run efi-boot-image in %%post of efi subpackage
[packages/xen.git] / xen.spec
1 #
2 # TODO:
3 #  - check if other tools/libs are not usable in domU, move them to -guest
4 #    packages if so
5 #  - pass bconds to qemu configure script (tricky, as the script is called from
6 #    Xen Makefiles)
7 #  - fix %doc - some files are installed in docdir both by make install and %d,
8 #    other are installed once
9 #  - now the build dependencies are insane (because of what qemu can use)
10 #    we should make them optional or get rid of them all properly
11 #
12 #
13 # Conditional build:
14 %bcond_without  opengl          # disable OpenGL support in Xen qemu
15 %bcond_without  sdl             # disable SDL support in Xen qemu
16 %bcond_without  bluetooth       # disable bluetooth support in Xen qemu
17 %bcond_without  brlapi          # disable brlapi support in Xen qemu
18 %bcond_without  ocaml           # build Ocaml libraries for Xen tools
19 %bcond_without  efi             # build the EFI hypervisor
20
21 %ifnarch %{x8664}
22 %undefine       with_efi
23 %endif
24
25 # from Config.mk:
26 %define seabios_version         1.6.3.2
27
28 %define xen_extfiles_url        http://xenbits.xensource.com/xen-extfiles
29 Summary:        Xen - a virtual machine monitor
30 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
31 Name:           xen
32 Version:        4.2.1
33 Release:        1
34 License:        GPL v2, interface parts on BSD-like
35 Group:          Applications/System
36 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
37 # Source0-md5:  0d48cbe1767b82aba12517898d4e0408
38 # used by stubdoms
39 Source10:       %{xen_extfiles_url}/lwip-1.3.0.tar.gz
40 # Source10-md5: 36cc57650cffda9a0269493be2a169bb
41 Source11:       %{xen_extfiles_url}/newlib-1.16.0.tar.gz
42 # Source11-md5: bf8f1f9e3ca83d732c00a79a6ef29bc4
43 Source12:       %{xen_extfiles_url}/zlib-1.2.3.tar.gz
44 # Source12-md5: debc62758716a169df9f62e6ab2bc634
45 Source13:       %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
46 # Source13-md5: cec05e7785497c5e19da2f114b934ffd
47 Source14:       %{xen_extfiles_url}/grub-0.97.tar.gz
48 # Source14-md5: cd3f3eb54446be6003156158d51f4884
49 Source15:       http://xenbits.xen.org/xen-extfiles/ipxe-git-9a93db3f0947484e30e753bbd61a10b17336e20e.tar.gz
50 # Source15-md5: 7496268cebf47d5c9ccb0696e3b26065
51 # http://xenbits.xen.org/git-http/seabios.git/
52 # git archive --prefix=tools/firmware/seabios/ --format=tar rel-%{seabios_version} | xz > seabios-%{seabios_version}.tar.xz
53 Source16:       seabios-%{seabios_version}.tar.xz
54 # Source16-md5: 145e07ff5618a3999f94f2e830d06b05
55 Source30:       proc-xen.mount
56 Source31:       var-lib-xenstored.mount
57 Source32:       blktapctrl.service
58 Source33:       blktapctrl.sysconfig
59 Source34:       xenconsoled.service
60 Source35:       xenconsoled.sysconfig
61 Source36:       xenstored.service
62 Source37:       xenstored.sysconfig
63 Source38:       xenstored.tmpfiles
64 Source39:       xend.service
65 Source40:       xend.tmpfiles
66 Source41:       xen-watchdog.service
67 Source42:       xen-dom0-modules-load.conf
68 # sysvinit scripts
69 Source50:       xend.init
70 Source51:       xenconsoled.init
71 Source52:       xenstored.init
72 Source53:       xen-watchdog.init
73 Source54:       xendomains.init
74 Source55:       xen.logrotate
75 Source56:       xen.tmpfiles
76 Source57:       xen.cfg
77 Source58:       xen.efi-boot-update
78 Patch0:         %{name}-python_scripts.patch
79 Patch1:         %{name}-symbols.patch
80 Patch2:         %{name}-curses.patch
81 Patch3:         pygrubfix.patch
82 Patch4:         xend.catchbt.patch
83 Patch5:         xend-pci-loop.patch
84 Patch6:         xen-dumpdir.patch
85 # Warning: this disables ingress filtering implemented in xen scripts!
86 Patch7:         xen-net-disable-iptables-on-bridge.patch
87 Patch8:         xen-configure-xend.patch
88 Patch9:         xen-initscript.patch
89 Patch10:        xen-quemu-softloat-c99.patch
90 Patch11:        xen-qemu.patch
91 Patch12:        xen-scripts-locking.patch
92 Patch13:        xen-close_lockfd_after_lock_attempt.patch
93 URL:            http://www.xen.org/products/xenhyp.html
94 %{?with_opengl:BuildRequires:   OpenGL-devel}
95 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
96 %ifarch %{ix86} %{x8664}
97 BuildRequires:  acpica
98 BuildRequires:  bcc
99 %endif
100 %{?with_bluetooth:BuildRequires:        bluez-libs-devel}
101 %{?with_brlapi:BuildRequires:   brlapi-devel}
102 %{?with_efi:BuildRequires:      binutils >= 3:2.23.51.0.3-2}
103 BuildRequires:  bzip2-devel
104 BuildRequires:  ceph-devel
105 BuildRequires:  curl-devel
106 BuildRequires:  cyrus-sasl-devel >= 2
107 BuildRequires:  e2fsprogs-devel
108 BuildRequires:  gcc >= 5:3.4
109 BuildRequires:  gettext-devel
110 BuildRequires:  glib2-devel >= 1:2.12
111 BuildRequires:  gnutls-devel
112 BuildRequires:  latex2html >= 2008
113 BuildRequires:  libaio-devel
114 BuildRequires:  libiscsi-devel
115 BuildRequires:  libjpeg-devel
116 BuildRequires:  libpng-devel
117 BuildRequires:  libuuid-devel
118 BuildRequires:  lzo-devel >= 2
119 BuildRequires:  ncurses-devel
120 %if %{with ocaml}
121 BuildRequires:  ocaml >= 3.04-7
122 BuildRequires:  ocaml-findlib
123 %endif
124 BuildRequires:  nss-devel >= 3.12.8
125 BuildRequires:  openssl-devel
126 BuildRequires:  pciutils-devel
127 BuildRequires:  perl-base
128 BuildRequires:  pkgconfig
129 BuildRequires:  python-devel
130 BuildRequires:  rpm-pythonprov
131 BuildRequires:  rpmbuild(macros) >= 1.647
132 BuildRequires:  spice-protocol >= 0.6.0
133 BuildRequires:  spice-server-devel >= 0.6.0
134 BuildRequires:  texi2html
135 BuildRequires:  texlive-dvips
136 BuildRequires:  texlive-latex-psnfss
137 BuildRequires:  texlive-xetex
138 BuildRequires:  usbredir-devel
139 BuildRequires:  vde2-devel
140 BuildRequires:  which
141 # for xfsctl (<xfs/xfs.h>)
142 BuildRequires:  xfsprogs-devel
143 BuildRequires:  xorg-lib-libX11-devel
144 BuildRequires:  xorg-lib-libXext-devel
145 BuildRequires:  xz-devel
146 BuildRequires:  yajl-devel
147 BuildRequires:  zlib-devel
148 # FIXME: see qemu configure comments on top of spec
149 %{!?with_opengl:BuildConflicts: OpenGL-devel}
150 %{!?with_sdl:BuildConflicts:    SDL-devel}
151 %{!?with_sdl:BuildConflicts:    SDL-devel}
152 %{!?with_bluetooth:BuildConflicts:      bluez-libs-devel}
153 %{!?with_brlapi:BuildConflicts: brlapi-devel}
154 Requires(post,preun):   /sbin/chkconfig
155 Requires(post,preun,postun):    systemd-units >= 38
156 Requires:       %{name}-libs = %{version}-%{release}
157 Requires:       ZopeInterface
158 Requires:       bridge-utils
159 Requires:       coreutils
160 Requires:       diffutils
161 Requires:       gawk
162 Requires:       iptables
163 Requires:       losetup
164 Requires:       net-tools
165 Requires:       python-%{name} = %{version}-%{release}
166 Requires:       rc-scripts
167 Requires:       sed
168 Requires:       systemd-units >= 38
169 Requires:       util-linux
170 Requires:       which
171 Requires:       %{name}-guest = %{version}-%{release}
172 Obsoletes:      xen-doc
173 Obsoletes:      xen-udev
174 ExclusiveArch:  %{ix86} %{x8664}
175 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
176
177 # some PPC/SPARC boot images in ELF format
178 %define         _noautostrip    .*%{_datadir}/\\(xen/qemu\\|qemu-xen\\)/\\(openbios-.*\\|palcode-clipper\\)
179
180 %description
181 This package contains the Xen hypervisor and Xen tools, needed to run
182 virtual machines on x86 systems, together with the kernel-xen*
183 packages. Information on how to use Xen can be found at the Xen
184 project pages.
185
186 Virtualisation can be used to run multiple versions or multiple Linux
187 distributions on one system, or to test untrusted applications in a
188 sandboxed environment. Note that the Xen technology is still in
189 development, and this RPM has received extremely little testing. Don't
190 be surprised if this RPM eats your data, drinks your coffee or makes
191 fun of you in front of your friends.
192
193 %description -l pl.UTF-8
194 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
195 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
196 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
197 projektu.
198
199 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
200 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
201 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
202 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
203 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
204 się wyśmiewał w obecności przyjaciół.
205
206 %package guest
207 Summary:        Xen tools for virtual machines
208 Summary(pl.UTF-8):      Narzędzia Xen dla maszyn virtualnych
209 Group:          Applications/System
210 Requires:       %{name}-libs-guest = %{version}-%{release}
211
212 %description guest
213 Xen utilities for both dom0 and domU virtual domains.
214
215 %description guest -l pl.UTF-8
216 Narzędzia Xena dla maszyn wirtualnych dom0 i domU.
217
218 %package libs
219 Summary:        Xen libraries
220 Summary(pl.UTF-8):      Biblioteki Xena
221 Group:          Libraries
222 Requires:       %{name}-libs-guest = %{version}-%{release}
223
224 %description libs
225 Xen libraries.
226
227 %description libs -l pl.UTF-8
228 Biblioteki Xena.
229
230 %package libs-guest
231 Summary:        Xen libraries for virtual machines
232 Summary(pl.UTF-8):      Biblioteki Xena dla maszyn wirtualnych
233 Group:          Libraries
234
235 %description libs-guest
236 Xen libraries for both dom0 and domU virtual machines.
237
238 %description libs-guest -l pl.UTF-8
239 Biblioteki Xena dla maszyn wirtualnych dom0 i domU.
240
241 %package devel
242 Summary:        Header files for Xen
243 Summary(pl.UTF-8):      Pliki nagłówkowe Xena
244 Group:          Development/Libraries
245 Requires:       %{name}-libs = %{version}-%{release}
246
247 %description devel
248 Header files for Xen.
249
250 %description devel -l pl.UTF-8
251 Pliki nagłówkowe Xena.
252
253 %package static
254 Summary:        Static Xen libraries
255 Summary(pl.UTF-8):      Statyczne biblioteki Xena
256 Group:          Development/Libraries
257 Requires:       %{name}-devel = %{version}-%{release}
258
259 %description static
260 Static Xen libraries.
261
262 %description static -l pl.UTF-8
263 Statyczne biblioteki Xena.
264
265 %package xend
266 Summary:        xend daemon
267 Summary(pl.UTF-8):      Demon xend
268 Group:          Daemons
269 Requires(post,preun,postun):    systemd-units >= 38
270 Requires:       systemd-units >= 38
271
272 %description xend
273 xend daemon.
274
275 %description xend -l pl.UTF-8
276 Demon xend.
277
278 %package -n ocaml-xen
279 Summary:        OCaml bindings for Xen
280 Summary(pl.UTF-8):      Wiązania OCamla dla Xena
281 License:        LGPL v2.1 with linking exception
282 Group:          Libraries
283 Requires:       %{name}-libs = %{version}-%{release}
284 %if %{with ocaml}
285 %requires_eq    ocaml-runtime
286 %endif
287
288 %description -n ocaml-xen
289 OCaml bindings for Xen.
290
291 %description -n ocaml-xen -l pl.UTF-8
292 Wiązania OCamla dla Xena.
293
294 %package -n ocaml-xen-devel
295 Summary:        OCaml bindings for Xen - development files
296 Summary(pl.UTF-8):      Wiązania OCamla dla Xena - pliki programistyczne
297 License:        LGPL v2.1 with linking exception
298 Group:          Development/Libraries
299 Requires:       ocaml-xen = %{version}-%{release}
300 %if %{with ocaml}
301 %requires_eq    ocaml
302 %endif
303
304 %description -n ocaml-xen-devel
305 OCaml bindings for Xen - development files.
306
307 %description -n ocaml-xen-devel -l pl.UTF-8
308 Wiązania OCamla dla Xena - pliki programistyczne.
309
310 %package -n python-xen
311 Summary:        Xen Python modules
312 Summary(pl.UTF-8):      Moduły Pythona dla Xena
313 Group:          Libraries
314 Requires:       %{name}-libs = %{version}-%{release}
315 Conflicts:      xen < 3.2.1-0.3
316
317 %description -n python-xen
318 Xen Python modules.
319
320 %description -n python-xen -l pl.UTF-8
321 Moduły Pythona dla Xena.
322
323 %package -n python-xen-guest
324 Summary:        Xen Python modules for virtual machines
325 Summary(pl.UTF-8):      Moduły Pythona dla maszyn wirtualnych Xena
326 Group:          Libraries
327 Requires:       %{name}-libs-guest = %{version}-%{release}
328 Conflicts:      xen < 3.2.1-0.3
329
330 %description -n python-xen-guest
331 Xen Python modules for both dom0 and domU virtual machines.
332
333 %description -n python-xen-guest -l pl.UTF-8
334 Moduły Pythona dla maszyn wirtualnych dom0 i domU.
335
336 %package -n bash-completion-%{name}
337 Summary:    bash-completion for Xen (xl)
338 Summary(pl.UTF-8):      Bashowe dopełnianie poleceń dla Xena (xl)
339 Group:      Applications/Shells
340 Requires:   %{name} = %{version}-%{release}
341 Requires:   bash-completion
342
343 %description -n bash-completion-%{name}
344 This package provides bash-completion for Xen (xl).
345
346 %description -n bash-completion-%{name} -l pl.UTF-8
347 Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
348
349 %package efi
350 Summary:        Xen hypervisor binary for EFI
351 Summary(pl.UTF-8):      Hipernadzorca Xen dla EFI
352 Group:          Applications/System
353 Requires:       %{name}-libs-guest = %{version}-%{release}
354
355 %description efi
356 Xen hypervisor EFI binary, which can be booted directly from (U)EFI
357 firmware without help from any additional bootloader.
358
359 %description efi -l pl.UTF-8
360 Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
361 (U)EFI, bez potrzeby oddzielnego bootloadera.
362
363 %prep
364 %setup -q -a 16
365 %patch0 -p1
366 %patch1 -p1
367 %patch2 -p1
368 %patch3 -p1
369 %patch4 -p1
370 %patch5 -p1
371 %patch6 -p1
372 %patch7 -p1
373 %patch8 -p1
374 %patch9 -p1
375 %patch10 -p1
376 %patch11 -p1
377 %patch12 -p1
378 %patch13 -p1
379
380 # stubdom sources
381 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
382 ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
383
384 # do not allow fetching anything via git
385 echo GIT=/bin/false >> Config.mk
386
387 %build
388 export CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
389 export CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
390
391 # NOTE:
392 # - there is a quoting bug (in tools/driver/Makefile) that causes
393 #   openssl is used instead of gcrypt; that's OK, openssl is obligatory
394 #   anyway (see configure), gcrypt is optional
395 # - prevent libiconv from being detected (not needed with glibc)
396 cd tools
397 %configure \
398         CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses" \
399         ac_cv_lib_iconv_libiconv_open=no \
400         --disable-debug
401 cd ..
402
403 %{__make} dist-xen dist-tools dist-docs \
404         %{!?with_ocaml:OCAML_TOOLS=n} \
405         prefix=%{_prefix} \
406         CC="%{__cc}" \
407         CXX="%{__cxx}" \
408         V=1
409
410 unset CFLAGS
411 unset CXXFLAGS
412
413 %{__make} -j1 dist-stubdom \
414         %{!?with_ocaml:OCAML_TOOLS=n} \
415         CC="%{__cc}" \
416         CXX="%{__cxx}" \
417         V=1
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
422         $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console} \
423         $RPM_BUILD_ROOT/etc/efi-boot/update.d
424
425 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
426         %{!?with_ocaml:OCAML_TOOLS=n} \
427         prefix=%{_prefix} \
428         DESTDIR=$RPM_BUILD_ROOT \
429         HOTPLUGS=install-udev
430
431 %if "%{_lib}" == "lib64"
432 ln -s %{_prefix}/lib/%{name}/bin/qemu-dm $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/qemu-dm
433 %endif
434
435 install %{SOURCE30} $RPM_BUILD_ROOT%{systemdunitdir}/proc-xen.mount
436 install %{SOURCE31} $RPM_BUILD_ROOT%{systemdunitdir}/var-lib-xenstored.mount
437 install %{SOURCE32} $RPM_BUILD_ROOT%{systemdunitdir}/blktapctrl.service
438 install %{SOURCE33} $RPM_BUILD_ROOT/etc/sysconfig/blktapctrl
439 install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
440 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
441 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
442 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
443 install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
444 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
445 install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
446 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
447 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
448 # sysvinit scripts
449 %{__rm} $RPM_BUILD_ROOT/etc/rc.d/init.d/*
450 install %{SOURCE50} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
451 install %{SOURCE51} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenconsoled
452 install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
453 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
454 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
455 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
456 install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
457
458 %if %{with efi}
459 install %{SOURCE57} $RPM_BUILD_ROOT/etc/efi-boot/xen.cfg
460 sed -e's;@libdir@;%{_libdir};g' -e's;@target_cpu@;%{_target_cpu};g' \
461                         %{SOURCE58} > $RPM_BUILD_ROOT/etc/efi-boot/update.d/xen.conf
462 %endif
463
464 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
465
466 # for %%doc
467 install -d _doc
468 for tool in blktap blktap2 pygrub xenmon ; do
469         cp -p tools/$tool/README _doc/README.$tool
470 done
471 cp -al tools/qemu-xen/docs _doc/qemu-xen
472
473 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
474 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
475
476 %py_postclean
477
478 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/qemu.1
479 mv $RPM_BUILD_ROOT%{_mandir}/man1/qemu-img{,-xen}.1
480 mv $RPM_BUILD_ROOT%{_mandir}/man8/qemu-nbd{,-xen}.8
481 # seems not needed, the path is wrong anyway
482 %{__rm} $RPM_BUILD_ROOT%{_prefix}/etc/qemu/target-x86_64.conf
483
484 # remove unneeded files
485 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.2.gz
486 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
487 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
488 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
489 %{__rm} $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post
495 /sbin/chkconfig --add xen-watchdog
496 /sbin/chkconfig --add xenconsoled
497 /sbin/chkconfig --add xenstored
498 /sbin/chkconfig --add xendomains
499 %systemd_post xen-watchdog.service xenconsoled.service xenstored.service
500
501 %preun
502 if [ "$1" = "0" ]; then
503         %service xendomains stop
504         /sbin/chkconfig --del xendomains
505
506         %service xenconsoled stop
507         /sbin/chkconfig --del xenconsoled
508
509         %service xenstored stop
510         /sbin/chkconfig --del xenstored
511
512         %service xen-watchdog stop
513         /sbin/chkconfig --del xen-watchdog
514 fi
515 %systemd_preun xen-watchdog.service xenconsoled.service xenstored.service
516
517 %postun
518 %systemd_reload
519
520 %post xend
521 /sbin/chkconfig --add xend
522 %systemd_post xend.service
523
524 %preun xend
525 if [ "$1" = "0" ]; then
526         %service xend stop
527         /sbin/chkconfig --del xend
528 fi
529 %systemd_preun xend.service
530
531 %postun xend
532 %systemd_reload
533
534 %post   libs -p /sbin/ldconfig
535 %postun libs -p /sbin/ldconfig
536
537 %post   libs-guest -p /sbin/ldconfig
538 %postun libs-guest -p /sbin/ldconfig
539
540 %post efi
541 [ -x /sbin/efi-boot-update ] && /sbin/efi-boot-update --auto || :
542
543 %files
544 %defattr(644,root,root,755)
545 %doc COPYING README* docs/misc/* 
546 %doc docs/html/*
547 %doc tools/qemu-xen-dir/*.html
548 %doc _doc/*
549 /boot/%{name}-syms-%{version}
550 /boot/%{name}-%{version}.gz
551 /boot/%{name}.gz
552 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenconsoled
553 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xenstored
554 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xendomains
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/xencommons
556 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/xen
557 %attr(754,root,root) /etc/rc.d/init.d/xen-watchdog
558 %attr(754,root,root) /etc/rc.d/init.d/xenconsoled
559 %attr(754,root,root) /etc/rc.d/init.d/xenstored
560 %attr(754,root,root) /etc/rc.d/init.d/xendomains
561 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/xen-dom0.conf
562 %{systemdunitdir}/proc-xen.mount
563 %{systemdunitdir}/var-lib-xenstored.mount
564 %{systemdunitdir}/xen-watchdog.service
565 %{systemdunitdir}/xenconsoled.service
566 %{systemdunitdir}/xenstored.service
567 %dir %{_sysconfdir}/xen
568 %dir %{_sysconfdir}/xen/auto
569 %dir %{_sysconfdir}/xen/examples
570 %dir %{_sysconfdir}/xen/scripts
571 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
572 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/examples/*
573 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/README*
574 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/cpupool
575 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xl.conf
576 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xen-backend.rules
577 %attr(755,root,root) %{_bindir}/pygrub
578 %attr(755,root,root) %{_bindir}/qemu-img-xen
579 %attr(755,root,root) %{_bindir}/qemu-nbd-xen
580 %attr(755,root,root) %{_bindir}/remus
581 %attr(755,root,root) %{_bindir}/xencons
582 %attr(755,root,root) %{_bindir}/xentrace*
583 %attr(755,root,root) %{_sbindir}/blktapctrl
584 %attr(755,root,root) %{_sbindir}/flask-*
585 %attr(755,root,root) %{_sbindir}/gdbsx
586 %attr(755,root,root) %{_sbindir}/gtrace*
587 %attr(755,root,root) %{_sbindir}/img2qcow
588 %attr(755,root,root) %{_sbindir}/kdd
589 %attr(755,root,root) %{_sbindir}/lock-util
590 %attr(755,root,root) %{_sbindir}/qcow-create
591 %attr(755,root,root) %{_sbindir}/qcow2raw
592 %attr(755,root,root) %{_sbindir}/tap-ctl
593 %attr(755,root,root) %{_sbindir}/tapdisk*
594 %attr(755,root,root) %{_sbindir}/td-util
595 %attr(755,root,root) %{_sbindir}/vhd-*
596 %attr(755,root,root) %{_sbindir}/xen-*
597 %attr(755,root,root) %{_sbindir}/xenbaked
598 %attr(755,root,root) %{_sbindir}/xenconsoled
599 %attr(755,root,root) %{_sbindir}/xenlockprof
600 %attr(755,root,root) %{_sbindir}/xenmon.py
601 %attr(755,root,root) %{_sbindir}/xenperf
602 %attr(755,root,root) %{_sbindir}/xenpm
603 %attr(755,root,root) %{_sbindir}/xenpmd
604 %attr(755,root,root) %{_sbindir}/xenstored
605 %attr(755,root,root) %{_sbindir}/xentop
606 %attr(755,root,root) %{_sbindir}/xentrace_setmask
607 %attr(755,root,root) %{_sbindir}/xenwatchdogd
608 %attr(755,root,root) %{_sbindir}/xl
609 %attr(755,root,root) %{_sbindir}/xsview
610 %dir %{_libdir}/%{name}
611 %dir %{_libdir}/%{name}/bin
612 %attr(744,root,root) %{_libdir}/%{name}/bin/*
613 %if "%{_lib}" != "lib"
614 %dir %{_prefix}/lib/%{name}
615 %dir %{_prefix}/lib/%{name}/bin
616 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/qemu-dm
617 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdom-dm
618 %attr(755,root,root) %{_prefix}/lib/%{name}/bin/stubdompath.sh
619 %endif
620 %dir %{_prefix}/lib/%{name}/boot
621 %{_prefix}/lib/%{name}/boot/ioemu-stubdom.gz
622 %{_prefix}/lib/%{name}/boot/pv-grub-x86_32.gz
623 %ifarch %{x8664}
624 %{_prefix}/lib/%{name}/boot/pv-grub-x86_64.gz
625 %endif
626 %{_prefix}/lib/%{name}/boot/xenstore-stubdom.gz
627 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
628 %{_datadir}/xen
629 %{_mandir}/man1/qemu-img-xen.1*
630 %{_mandir}/man1/xentop.1*
631 %{_mandir}/man1/xentrace_format.1*
632 %{_mandir}/man1/xl.1*
633 %{_mandir}/man1/xm.1*
634 %{_mandir}/man5/xend-config.sxp.5*
635 %{_mandir}/man5/xl.cfg.5*
636 %{_mandir}/man5/xl.conf.5*
637 %{_mandir}/man5/xlcpupool.cfg.5*
638 %{_mandir}/man5/xmdomain.cfg.5*
639 %{_mandir}/man8/qemu-nbd-xen.8*
640 %{_mandir}/man8/xentrace.8*
641 %{_sharedstatedir}/xen
642 %{_sharedstatedir}/xenstored
643 %dir /var/run/xenstored
644 %{systemdtmpfilesdir}/xenstored.conf
645 %{systemdtmpfilesdir}/xen.conf
646 %dir %attr(0700,root,root) /var/log/xen
647 %dir %attr(0700,root,root) /var/log/xen/console
648 %{_datadir}/qemu-xen
649
650 %files guest
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_bindir}/xen-detect
653 %attr(755,root,root) %{_bindir}/xenstore*
654
655 %files libs
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libblktap.so.*.*.*
658 %attr(755,root,root) %ghost %{_libdir}/libblktap.so.3.0
659 %attr(755,root,root) %{_libdir}/libblktapctl.so.*.*.*
660 %attr(755,root,root) %ghost %{_libdir}/libblktapctl.so.1.0
661 %attr(755,root,root) %{_libdir}/libfsimage.so.*.*.*
662 %attr(755,root,root) %ghost %{_libdir}/libfsimage.so.1.0
663 %attr(755,root,root) %{_libdir}/libvhd.so.*.*.*
664 %attr(755,root,root) %ghost %{_libdir}/libvhd.so.1.0
665 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
666 %attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.2
667 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
668 %attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.2
669 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
670 %attr(755,root,root) %ghost %{_libdir}/libxenlight.so.2.0
671 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*
672 %attr(755,root,root) %ghost %{_libdir}/libxenstat.so.0
673 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.1.0
675 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
676 %attr(755,root,root) %ghost %{_libdir}/libxlutil.so.1.0
677 %dir %{_libdir}/fs
678 %dir %{_libdir}/fs/ext2fs-lib
679 %dir %{_libdir}/fs/fat
680 %dir %{_libdir}/fs/iso9660
681 %dir %{_libdir}/fs/reiserfs
682 %dir %{_libdir}/fs/ufs
683 %dir %{_libdir}/fs/xfs
684 %dir %{_libdir}/fs/zfs
685 %attr(755,root,root) %{_libdir}/fs/*/fsimage.so
686
687 %files libs-guest
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
690 %attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
691
692 %files devel
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/libblktap.so
695 %attr(755,root,root) %{_libdir}/libblktapctl.so
696 %attr(755,root,root) %{_libdir}/libfsimage.so
697 %attr(755,root,root) %{_libdir}/libvhd.so
698 %attr(755,root,root) %{_libdir}/libxenctrl.so
699 %attr(755,root,root) %{_libdir}/libxenguest.so
700 %attr(755,root,root) %{_libdir}/libxenlight.so
701 %attr(755,root,root) %{_libdir}/libxenstat.so
702 %attr(755,root,root) %{_libdir}/libxenstore.so
703 %attr(755,root,root) %{_libdir}/libxenvchan.so
704 %attr(755,root,root) %{_libdir}/libxlutil.so
705 %{_includedir}/_libxl_list.h
706 %{_includedir}/_libxl_types.h
707 %{_includedir}/_libxl_types_json.h
708 %{_includedir}/blktaplib.h
709 %{_includedir}/fsimage*.h
710 %{_includedir}/libxenvchan.h
711 %{_includedir}/libxl*.h
712 %{_includedir}/xen*.h
713 %{_includedir}/xs*.h
714 %{_includedir}/xen
715 %{_includedir}/xenstore-compat
716
717 %files static
718 %defattr(644,root,root,755)
719 %{_libdir}/libblktap.a
720 %{_libdir}/libblktapctl.a
721 %{_libdir}/libvhd.a
722 %{_libdir}/libxenctrl.a
723 %{_libdir}/libxenguest.a
724 %{_libdir}/libxenlight.a
725 %{_libdir}/libxenvchan.a
726 %{_libdir}/libxenstat.a
727 %{_libdir}/libxenstore.a
728 %{_libdir}/libxlutil.a
729
730 %files xend
731 %defattr(644,root,root,755)
732 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/blktapctrl
733 %{systemdunitdir}/blktapctrl.service
734 %{systemdunitdir}/xend.service
735 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/xend
736 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xend.rules
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xm*
738 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xend*
739 %attr(755,root,root) %{_sbindir}/xend
740 %attr(755,root,root) %{_sbindir}/xm
741 %dir %attr(700,root,root) /var/run/xend
742 %{systemdtmpfilesdir}/xend.conf
743
744 %if %{with ocaml}
745 %files -n ocaml-xen
746 %defattr(644,root,root,755)
747 %doc tools/ocaml/LICENSE
748 %attr(755,root,root) %{_sbindir}/oxenstored
749 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/oxenstored.conf
750 %dir %{_libdir}/ocaml/site-lib/xenbus
751 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenbus/dllxenbus_stubs.so
752 %dir %{_libdir}/ocaml/site-lib/xenctrl
753 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenctrl/dllxenctrl_stubs.so
754 %dir %{_libdir}/ocaml/site-lib/xeneventchn
755 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xeneventchn/dllxeneventchn_stubs.so
756 %dir %{_libdir}/ocaml/site-lib/xenlight
757 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenlight/dllxenlight_stubs.so
758 %dir %{_libdir}/ocaml/site-lib/xenmmap
759 %attr(755,root,root) %{_libdir}/ocaml/site-lib/xenmmap/dllxenmmap_stubs.so
760
761 %files -n ocaml-xen-devel
762 %defattr(644,root,root,755)
763 %{_libdir}/ocaml/site-lib/xenbus/META
764 %{_libdir}/ocaml/site-lib/xenbus/libxenbus_stubs.a
765 %{_libdir}/ocaml/site-lib/xenbus/xenbus.a
766 %{_libdir}/ocaml/site-lib/xenbus/*.cm[aixo]*
767 %{_libdir}/ocaml/site-lib/xenctrl/META
768 %{_libdir}/ocaml/site-lib/xenctrl/libxenctrl_stubs.a
769 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.a
770 %{_libdir}/ocaml/site-lib/xenctrl/xenctrl.cm[aix]*
771 %{_libdir}/ocaml/site-lib/xeneventchn/META
772 %{_libdir}/ocaml/site-lib/xeneventchn/libxeneventchn_stubs.a
773 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.a
774 %{_libdir}/ocaml/site-lib/xeneventchn/xeneventchn.cm[aix]*
775 %{_libdir}/ocaml/site-lib/xenmmap/META
776 %{_libdir}/ocaml/site-lib/xenmmap/libxenmmap_stubs.a
777 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.a
778 %{_libdir}/ocaml/site-lib/xenmmap/xenmmap.cm[aix]*
779 %{_libdir}/ocaml/site-lib/xenlight/META
780 %{_libdir}/ocaml/site-lib/xenlight/libxenlight_stubs.a
781 %{_libdir}/ocaml/site-lib/xenlight/xenlight.a
782 %{_libdir}/ocaml/site-lib/xenlight/xenlight.cm[aix]*
783 %dir %{_libdir}/ocaml/site-lib/xenstore
784 %{_libdir}/ocaml/site-lib/xenstore/META
785 %{_libdir}/ocaml/site-lib/xenstore/xenstore.a
786 %{_libdir}/ocaml/site-lib/xenstore/*.cm[aixo]*
787 %endif
788
789 %files -n python-xen
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{py_sitedir}/fsimage.so
792 %{py_sitedir}/grub
793 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/checkpoint.so
794 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/flask.so
795 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/netlink.so
796 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/ptsname.so
797 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xc.so
798 %{py_sitedir}/xen/remus
799 %{py_sitedir}/xen/sv
800 %{py_sitedir}/xen/util
801 %{py_sitedir}/xen/web
802 %{py_sitedir}/xen/xend
803 %{py_sitedir}/xen/xm
804 %{py_sitedir}/xen/xsview
805 %if "%{py_ver}" > "2.4"
806 %{py_sitedir}/pygrub-0.3-py*.egg-info
807 %{py_sitedir}/xen-3.0-py*.egg-info
808 %endif
809
810 %files -n python-xen-guest
811 %defattr(644,root,root,755)
812 %dir %{py_sitedir}/xen
813 %{py_sitedir}/xen/__init__.py*
814 %dir %{py_sitedir}/xen/lowlevel
815 %{py_sitedir}/xen/lowlevel/__init__.py*
816 %attr(755,root,root) %{py_sitedir}/xen/lowlevel/xs.so
817
818 %files -n bash-completion-%{name}
819 %defattr(644,root,root,755)
820 /etc/bash_completion.d/xl.sh
821
822 %if %{with efi}
823 %files efi
824 %defattr(644,root,root,755)
825 %dir %{_libdir}/efi
826 %{_libdir}/efi/*.efi
827 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/xen.cfg
828 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/efi-boot/update.d/xen.conf
829 %endif
This page took 1.43498 seconds and 4 git commands to generate.