]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- more br
[packages/xen.git] / xen.spec
1 #
2 # NOTE:
3 # - this is userspace for xen-3.2.0 (provided by kernel-xen.spec)
4 #   if you are looking for xen-3.0.2 (kernel.spec:LINUX_2_6_16), checkout
5 #   this spec from XEN_3_0_2 branch
6 #
7 # TODO:
8 # - pldized init scripts
9 # - script for rc-boot
10 #
11 # Conditional build:
12 %bcond_with     pae             # build with PAE (HIGHMEM64G) support
13 %bcond_with     hvm             # build with hvm (full virtualization) support
14 #
15 Summary:        Xen - a virtual machine monitor
16 Summary(pl.UTF-8):      Xen - monitor maszyny wirtualnej
17 Name:           xen
18 %define _major  3.2
19 Version:        %{_major}.0
20 Release:        0.1
21 License:        GPL
22 Group:          Applications/System
23 Source0:        http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
24 # Source0-md5:  4aa57328d0802a063fa67dfc063da30e
25 Source1:        %{name}-xend.init
26 Source2:        %{name}-xendomains.init
27 Patch0:         %{name}-python_scripts.patch
28 Patch1:         %{name}-gcc.patch
29 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
30 BuildRequires:  curl-devel
31 BuildRequires:  e2fsprogs-devel
32 BuildRequires:  latex2html
33 BuildRequires:  libidn-devel
34 BuildRequires:  ncurses-devel
35 BuildRequires:  python-devel
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.268
38 BuildRequires:  tetex-dvips
39 BuildRequires:  tetex-format-latex
40 BuildRequires:  tetex-latex-psnfss
41 BuildRequires:  transfig
42 BuildRequires:  which
43 BuildRequires:  zlib-devel
44 %{?with_hvm:BuildRequires:      bcc}
45 Requires(post,preun):   /sbin/chkconfig
46 Requires:       ZopeInterface
47 Requires:       bridge-utils
48 Requires:       coreutils
49 Requires:       diffutils
50 Requires:       gawk
51 Requires:       iptables
52 Requires:       kernel(xen0) = %{_major}
53 Requires:       losetup
54 Requires:       net-tools
55 Requires:       rc-scripts
56 Requires:       sed
57 Requires:       util-linux-ng
58 Requires:       which
59 Obsoletes:      xen-doc
60 ExclusiveArch:  %{ix86} %{x8664}
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %ifnarch i686 athlon pentium3 pentium4
64 %undefine       with_pae
65 %endif
66
67 %description
68 This package contains the Xen hypervisor and Xen tools, needed to run
69 virtual machines on x86 systems, together with the kernel-xen*
70 packages. Information on how to use Xen can be found at the Xen
71 project pages.
72
73 Virtualisation can be used to run multiple versions or multiple Linux
74 distributions on one system, or to test untrusted applications in a
75 sandboxed environment. Note that the Xen technology is still in
76 development, and this RPM has received extremely little testing. Don't
77 be surprised if this RPM eats your data, drinks your coffee or makes
78 fun of you in front of your friends.
79
80 %description -l pl.UTF-8
81 Ten pakiet zawiera nadzorcę oraz narzędzia Xen, potrzebne do
82 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
83 kernel-xen*. Informacje jak używać Xena można znaleźć na stronach
84 projektu.
85
86 Wirtualizacja może być używana do uruchamiania wielu wersji lub wielu
87 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
88 aplikacji w odizolowanym środowisku. Należy zauważyć, że technologia
89 Xen jest ciągle rozwijana, a ten RPM był słabo testowany. Nie należy
90 być zdziwionym, jeśli ten pakiet zje dane, wypije całą kawę czy będzie
91 się wyśmiewał w obecności przyjaciół.
92
93 %package libs
94 Summary:        xen libraries
95 Summary(pl.UTF-8):      Biblioteki xena
96 Group:          Libraries
97
98 %description libs
99 xen libraries.
100
101 %description libs -l pl.UTF-8
102 Biblioteki xena.
103
104 %package hotplug
105 Summary:        xen hotplug
106 Group:          Application/System
107
108 %description hotplug
109 xen hotplug.
110
111 %package udev
112 Summary:        xen udev
113 Group:          Application/System
114
115 %description udev
116 xen udev.
117
118 %package devel
119 Summary:        Header files for xen
120 Summary(pl.UTF-8):      Pliki nagłówkowe xena
121 Group:          Development/Libraries
122 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
123
124 %description devel
125 Header files for xen.
126
127 %description devel -l pl.UTF-8
128 Pliki nagłówkowe xena.
129
130 %package static
131 Summary:        Static xen libraries
132 Summary(pl.UTF-8):      Statyczne biblioteki xena
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
135
136 %description static
137 Static xen libraries.
138
139 %description static -l pl.UTF-8
140 Statyczne biblioteki xena.
141
142 %prep
143 %setup -q
144 %patch0 -p1
145 %patch1 -p1
146
147 find . -iregex .*.orig -exec rm {} \;
148
149 chmod -R u+w .
150
151 %build
152 CFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
153 CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses" \
154 %{__make} -j1 xen tools \
155         %{?with_pae:XEN_TARGET_X86_PAE=y} \
156         CC="%{__cc}" \
157         CXX="%{__cxx}"
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT/var/run/{xen-hotplug,xend,xenstored}
162
163 %{__make} install-xen install-tools install-docs \
164         %{?with_pae:XEN_TARGET_X86_PAE=y} \
165         DESTDIR=$RPM_BUILD_ROOT \
166         XEN_PYTHON_NATIVE_INSTALL=1
167
168 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
169 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
170 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
171
172 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
173 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/save
174
175 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
176
177 %{py_comp} $RPM_BUILD_ROOT%{py_sitedir}
178 %{py_ocomp} $RPM_BUILD_ROOT%{py_sitedir}
179 %{py_comp} $RPM_BUILD_ROOT%{py_sitescriptdir}
180 %{py_ocomp} $RPM_BUILD_ROOT%{py_sitescriptdir}
181
182 cp -a dist/install/etc/udev $RPM_BUILD_ROOT%{_sysconfdir}
183
184 # remove unneeded files
185 #find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' -exec rm "{}" ";"
186 #find $RPM_BUILD_ROOT%{py_sitescriptdir} -name '*.py' -exec rm "{}" ";"
187 rm -rf $RPM_BUILD_ROOT%{_docdir}/xen
188 rm -rf $RPM_BUILD_ROOT/etc/init.d
189 rm -f $RPM_BUILD_ROOT/boot/xen-3.2.gz
190 rm -f $RPM_BUILD_ROOT/boot/xen-3.gz
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post
196 /sbin/chkconfig --add xend
197 /sbin/chkconfig --add xendomains
198
199 %preun
200 if [ "$1" = "0" ]; then
201         %service xend stop
202         /sbin/chkconfig --del xend
203
204         %service xendomains stop
205         /sbin/chkconfig --del xendomains
206 fi
207
208 %post   libs -p /sbin/ldconfig
209 %postun libs -p /sbin/ldconfig
210
211 %files
212 %defattr(644,root,root,755)
213 %doc COPYING README docs/misc/*
214 %doc docs/html/*
215 /boot/%{name}-syms-%{version}
216 /boot/%{name}-%{version}.gz
217 /boot/%{name}.gz
218 %attr(754,root,root) /etc/rc.d/init.d/*
219 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
220 %dir %{_sysconfdir}/xen
221 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/qemu-ifup
222 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
223 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
224 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
225 %dir %{_sysconfdir}/xen/auto
226 %dir %{_sysconfdir}/xen/scripts
227 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
228 %attr(755,root,root) %{_bindir}/*
229 %attr(755,root,root) %{_sbindir}/*
230 %dir %{_libdir}/%{name}
231 %dir %{_libdir}/%{name}/bin
232 %attr(744,root,root) %{_libdir}/%{name}/bin/*
233 %dir %{_prefix}/lib/%{name}
234 %dir %{_prefix}/lib/%{name}/boot
235 %attr(744,root,root) %{_prefix}/lib/%{name}/boot/hvmloader
236 %{_datadir}/xen
237 %{py_sitedir}/fsimage.so
238 %{py_sitedir}/grub
239 %dir %{py_sitedir}/%{name}
240 %dir %{py_sitedir}/%{name}/lowlevel
241 %{py_sitedir}/%{name}/lowlevel/*.py*
242 %attr(755,root,root) %{py_sitedir}/%{name}/lowlevel/*.so
243 %{py_sitedir}/%{name}/sv
244 %{py_sitedir}/%{name}/util
245 %{py_sitedir}/%{name}/web
246 %{py_sitedir}/%{name}/xend
247 %{py_sitedir}/%{name}/xm
248 %{py_sitedir}/%{name}/xsview
249 %{py_sitedir}/%{name}/*.py*
250 %{py_sitedir}/*.egg-info
251 #%{py_sitescriptdir}/*
252 %{_mandir}/man?/*
253 %{_sharedstatedir}/xen
254 %{_sharedstatedir}/xenstored
255 %dir /var/run/xen-hotplug
256 %dir %attr(700,root,root) /var/run/xend
257 %dir /var/run/xenstored
258
259 %files libs
260 %defattr(644,root,root,755)
261 %attr(755,root,root) %{_libdir}/lib*.so.*
262 %dir %{_libdir}/fs
263 %dir %{_libdir}/fs/ext2fs-lib
264 %dir %{_libdir}/fs/fat
265 %dir %{_libdir}/fs/iso9660
266 %dir %{_libdir}/fs/reiserfs
267 %dir %{_libdir}/fs/ufs
268 %attr(755,root,root) %{_libdir}/fs/*/*.so
269
270 %if ! %{with hvm}
271 %files hotplug
272 %defattr(644,root,root,755)
273 %attr(755,root,root) /etc/hotplug/*
274 %endif
275
276 %files udev
277 %defattr(644,root,root,755)
278 %config(noreplace) %verify(not md5 mtime size) /etc/udev/*
279
280 %files devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/lib*.so
283 %{_includedir}/*
284
285 %files static
286 %defattr(644,root,root,755)
287 %{_libdir}/lib*.a
This page took 0.105767 seconds and 4 git commands to generate.